Fresh 3.9.5 install won't run

This forum is for issues with installing Joomla! 3.x on IIS webservers.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
ianpro99
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue Apr 09, 2019 6:16 pm

Fresh 3.9.5 install won't run

Post by ianpro99 » Tue Apr 09, 2019 6:33 pm

I've installed Joomla 3.9.5 from scratch as a local setup for in-house development. After the installation completed successfully, the site won't run and I can't log in to the back-end. The only error message displayed in the browser is:

Error: Failed to start application: Error starting the session.

My environment particulars are:

OS = Windows 10 Pro
PHP = 7.3.1 (installed and managed via Web Platform Installer 5.1 in IIS)
Web server = IIS 10.0
DB = MS SQL Server 2016

There are no errors reported in the PHP log. I've reviewed the settings in configuration.php and they appear spot-on; the database table prefix is correct, login name, etc. are working (the database has all the tables created).

I can't find any error logs within the Joomla directories; PHP reports no errors and there's nothing relevant in the Windows application logs. Any ideas as to what could be causing the site to simply not run?

Thanks for any insight you can offer.
-- Ian

User avatar
mjparadac
Joomla! Ace
Joomla! Ace
Posts: 1881
Joined: Mon Oct 29, 2012 3:58 pm

Re: Fresh 3.9.5 install won't run

Post by mjparadac » Tue Apr 09, 2019 9:34 pm

Hello Ian, welcome to the forum.

Check the requirements

These links could help you.
https://docs.microsoft.com/en-us/iis/ap ... mla-on-iis
https://docs.joomla.org/IIS
https://docs.joomla.org/Installing_on_Microsoft

Regards,
Joomla Community Ambassador for A2 Hosting | A2 Hosting - Our speed, your success | https://www.a2hosting.com/joomla-hosting

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 37326
Joined: Sat Apr 05, 2008 9:58 pm

Re: Fresh 3.9.5 install won't run

Post by Webdongle » Tue Apr 09, 2019 10:21 pm

If it's on a PC try wamp
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

ianpro99
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue Apr 09, 2019 6:16 pm

Re: Fresh 3.9.5 install won't run

Post by ianpro99 » Tue Apr 09, 2019 11:59 pm

Thanks Webdongle and mjparadac for the replies. Some notes:

1. I can't use winamp; would love to. We're an MS shop, for better or for worse (little of both).
2. This config is fully supported, according to the current Joomla requirements. IIS and SQL not as common, but supported and should work.
3. I've followed the install instructions exactly, 3 times now, and each install is successful - the site just won't fire up.
4. One of the links mjparadac provided was useful, as far as correctly setting file and folder security within the site's directories, so that IIS can properly read and write there. Unfortunately, that still doesn't correct the problem.

Isn't there any type of log file that Joomla creates to log errors, messages, etc.? The only one I can find is under \administrator\logs and it's just an index.html container.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 37326
Joined: Sat Apr 05, 2008 9:58 pm

Re: Fresh 3.9.5 install won't run

Post by Webdongle » Wed Apr 10, 2019 8:39 am

http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

ianpro99
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue Apr 09, 2019 6:16 pm

Re: Fresh 3.9.5 install won't run

Post by ianpro99 » Wed Apr 10, 2019 8:54 pm

Thanks Webdongle, that FPA tool/script is great. It indicated a problem with the connection to MSSQL, which is odd, since the installer was able to connect and create all the necessary db items. At any rate, I re-ran the installation using MySQL and Joomla and the site work fine, so that points to an issue with MSSQL.

I'll test the install on an older version of SQLExpress and see if I get the same problem (I was using SQL 2017).

User avatar
AMurray
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4946
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Fresh 3.9.5 install won't run

Post by AMurray » Wed Apr 10, 2019 11:32 pm

Also important to note, MS-SQL DB will not be supported in the upcoming (end of 2019 it would seem at this stage) in Joomla 4.0
Regards,
--------------------------------------------------------------
A Murray
Millennium Falcon - it's the ship that made the Kessel run in less than 12 parsecs! The fastest hunk of junk in the galaxy.


Post Reply

Return to “Joomla! 3.x on IIS webserver”