Two identical sites that seem linked but shouldn't be :(

Need help with the Administration of your Joomla! 3.x site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
TikkiRo
Joomla! Explorer
Joomla! Explorer
Posts: 297
Joined: Wed Sep 26, 2007 6:42 pm
Location: BELFAST, N, Ireland UK
Contact:

Two identical sites that seem linked but shouldn't be :(

Post by TikkiRo » Mon Dec 02, 2019 3:07 pm

I routinely set up a test site in a subfolder alongside a main site to enable for component testing and also for newbies to learn how to admin a site without causing any damage to the live one.

So the test site will be a full copy of the main site on the server, and have a copy database of the main site,so for the most part the two sites will be pretty identical down to the user names etc. Previously this always worked fine without any hitches but after creating a new 'clean' test site (i.e. the old one fully deleted) this year I've got a new and somewhat frustrating issue that I've not figured out a reason for.

Basically I now can't have both sites open at the same time - if I do so and switch between them I'm bumped out of the other. So if I've been working on the main, and leave it open, then log in to the test site and do some work there, when I then return to the main site to do anything, it reverts to the login page (but the site is seemingly still 'active' as when I log in it's on the page I was working on so it hasn't closed the session out).

Anybody any ideas on the likely culprit for this as I'm at a loss to understand how 2 different databases could be 'speaking' to each other to provoke it?

 
User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 26804
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Two identical sites that seem linked but shouldn't be :(

Post by Per Yngve Berg » Mon Dec 02, 2019 4:04 pm

Alter configuration.php so they don't have the same secret hash. Php sessions are not stored in the database, but in the session save path folder of the server.

TikkiRo
Joomla! Explorer
Joomla! Explorer
Posts: 297
Joined: Wed Sep 26, 2007 6:42 pm
Location: BELFAST, N, Ireland UK
Contact:

Re: Two identical sites that seem linked but shouldn't be :(

Post by TikkiRo » Mon Dec 02, 2019 5:36 pm

Ahh suspected it had to be something like that but I'd no idea where to even start looking - another little gem that I'll hopefully remember in the future should it occur again! Thanks SO much!!

User avatar
sozzled
Joomla! Exemplar
Joomla! Exemplar
Posts: 8956
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: Two identical sites that seem linked but shouldn't be :(

Post by sozzled » Mon Dec 02, 2019 6:28 pm

Thank you, @Per. I agree with @TikkiRo: another little gem. I'm not sure if my development websites use the same secret hash as the production sites, but I'll keep this in mind. Further, I do all my development work on the same server where my production sites reside but I ensure the two types of sites are separated by using completely separate databases. Although, when I think about it, I don't often login to a dev't site at the same time as I login to a prod'n site. 8)
https://www.kuneze.com/blog
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

 

Post Reply

Return to “Administration Joomla! 3.x”