Help needed!!! Site Down after PHP upgrade

General questions relating to Joomla! 2.5. Note: All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5. There are other boards for more specific help on Joomla! features and extensions.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
Post Reply
dududu100
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu Apr 09, 2020 10:59 pm

Help needed!!! Site Down after PHP upgrade

Post by dududu100 » Thu Apr 09, 2020 11:21 pm

Hello everyone,

Hope you are doing well at this special time under Covid19.

This is my first post and I am looking for any help that could bring my site back. I am new to Joomla or any web design so I am still clueless after several hours of searches my self yesterday and today.

Recently, my webserver DreamHost upgraded php version to 7.2 from 5.6 I believe. All my site content is not showing except the main page. If I click on any of the link on the main page, I get an error message "Error You are not authorised to view this resource."

The same thing happens when I click on any of the articles under Administration, I get an error message "You are not permitted to use that link to directly access that page (#100)." When I click on Global Configuration, nothing is showing which scares me a lot.

When I click on the Joomla update, "You already have the latest Joomla! version, 2.5.28." it is showing I already have the latest version.

The site below is my website if someone doesn't mind taking a look at.

http://www.arthurtaichi.com/

I have emailed Dreamhost and no response. Does anyone have any suggestions or advice?

Any help would be much appreciated!!!

Brendan
Last edited by toivo on Thu Apr 09, 2020 11:59 pm, edited 1 time in total.
Reason: mod note: moved from 3.x General Questions

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 12933
Joined: Thu Feb 15, 2007 5:48 am
Location: Zagreb, Croatia

Re: Help needed!!! Site Down after PHP upgrade

Post by toivo » Fri Apr 10, 2020 12:05 am

Welcome to the forum!

Unfortunately Joomla 2.5 is not compatible with PHP 7. Only Joomla 3.5 and above can run on PHP 7. Your best option is to get your host to downgrade PHP back to 5.6 so that you have time to get someone to audit your website, including the template and third party extension, and advise you how to upgrade to a supported version of Joomla, which is currently 3.9.16.
Toivo Talikka, Global Moderator

dududu100
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu Apr 09, 2020 10:59 pm

Re: Help needed!!! Site Down after PHP upgrade

Post by dududu100 » Fri Apr 10, 2020 12:31 am

Thanks a lot for your response. DreamHost has not responded to my email from yesterday yet so I will see when I am able to contact them.

1. At the meantime, can I upgrade Joomla directly from 2.5 to 3.5 or above while running PHP 7?

2. How do I upgrade the Joomla if my Joomla admin page is showing "You already have the latest Joomla! version, 2.5.28." I saw some videos online that I need to click on the Joomla Update tab to update but mine is showing it is up to date already.

Thanks again!

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 12933
Joined: Thu Feb 15, 2007 5:48 am
Location: Zagreb, Croatia

Re: Help needed!!! Site Down after PHP upgrade

Post by toivo » Fri Apr 10, 2020 1:25 am

The forum Migrating and Upgrading to Joomla! 3.x has a sticky topic Practical Guide Upgrade Joomla 2.5 to Joomla 3.x, which gives the instructions how to get to Joomla 3.5.1 and beyond.

The Practical Guide instructs to change in the Options of the Joomla! Update component the settings from Long Term Release (LTS) to STS before the update, but in your particular case the results can be unpredictable because Joomla 2.5 does not run properly under PHP 7.

The best option could be to install on a Windows workstation the Wampserver bundle, which supports multiple versions of PHP, then use Akeeba Backup on your live 2.5 site, back up the website and restore it on the localhost using Akeeba's Kickstart utility. Install PHP 5.6 and PHP 7.4 as extensions. This setup would allow you to test all the third party extensions and update them to latest versions, compatible with Joomla 3.x, before running a trial upgrade to 3.5.1 and after that to the latest version, currently 3.9.16.

Remember to run backup at every stage, which will save time in case there are problems later on.
Toivo Talikka, Global Moderator

dududu100
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu Apr 09, 2020 10:59 pm

Re: Help needed!!! Site Down after PHP upgrade

Post by dududu100 » Fri Apr 10, 2020 8:34 pm

Thanks a lot for the detailed instructions!! I will be careful when doing this. Sorry about not responding to you eariler (I tried a couple of times this morning and for some reason I was blocked to send message eariler)

I followed the guide instruction and still not able to see the 3.x version update. After I disabled Remember Me plugin, switched from LTS to STS, the joomla Update button is showing Checking... then it is showing Jooma! is up-to-date. When I click on it, it is still 2.5 version.

Then, I found a link to download the new Joomla 3.9 package on this forum directly but I am not able to upload and install it. After I uploaded the zip Joomla 3.9 package under Extension Manager. I get an error message "JInstaller: :Install: Cannot find XML setup file".

I am new to the web design. The guide mentioned I need to " Use an FTP for this" to upload the package to Joomla. Could you let me know how I can use FTP to upload my new package or any steps I missed here?

Thanks again!

User avatar
AMurray
Joomla! Champion
Joomla! Champion
Posts: 6224
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Help needed!!! Site Down after PHP upgrade

Post by AMurray » Fri Apr 10, 2020 9:51 pm

. Could you let me know how I can use FTP to upload my new package or any steps I missed here?
I would refer to the Dreamhost Knowledgebase concerning FTP, e.g. https://help.dreamhost.com/hc/en-us/art ... DreamHost-
Regards,
--------------------------------------------------------------
A Murray
Help you I can, yes!. Post your question, you should. Keep it on topic you must!
Use the Forc....Forum Post Assistant my young Padawan!

User avatar
sozzled
Joomla! Exemplar
Joomla! Exemplar
Posts: 9886
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Help needed!!! Site Down after PHP upgrade

Post by sozzled » Fri Apr 10, 2020 9:53 pm

dududu100 wrote:
Fri Apr 10, 2020 12:31 am
Can I upgrade Joomla directly from 2.5 to 3.5 or above while running PHP 7?
Short answer: no

dududu100 wrote:
Fri Apr 10, 2020 12:31 am
My Joomla admin page is showing "You already have the latest Joomla! version, 2.5.28."
J! 2.5.28 was the last version released for J! 2.5 but that was five years ago. The first release of J! 3.x happened eight years ago.

dududu100 wrote:
Fri Apr 10, 2020 8:34 pm
I followed the guide ... then found a link to download the new Joomla 3.9 package on this forum directly but I am not able to upload and install it. After I uploaded the zip Joomla 3.9 package under Extension Manager. I get an error message "JInstaller: :Install: Cannot find XML setup file".
That is not how you "update" from J! 2.5.28 to J! 3.9.16. The short answer is that it will probably take you a few hours, possibly a day or two, to migrate your website from J! 2.5.28 to J! 3.9.16.

You may be able to do this yourself or you could organise someone to do the job for you. The job will take less time if you have a reliable backup of your website (files and database).

We know that you are not the first person who will be caught in this situation. Toivo's advice (about reverting to PHP 5.6 or to perform the migration on a locally-hosted device with Wampserver) is good advice. Just know that it's not a task that is done quickly—in five or ten minutes—and it will take you a few hours.
https://www.kuneze.com/blog
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)


Post Reply

Return to “General Questions/New to Joomla! 2.5”