Styling an image in an article causes internal error Topic is solved

Everything to do with Joomla! 3.x templates and templating.
Post Reply
CyborgPrime
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Wed May 09, 2007 7:50 am

Styling an image in an article causes internal error

Post by CyborgPrime » Tue Aug 25, 2020 4:55 pm

Hello!

This started happening across all my joomla sites.

If I make a new article and insert an image it saves ok.

If I center the image and save, I get an Internal server error.

This happens if I put ANY style on the image.

things I've tried:
- reloading the joomla core
- checked other joomla sites (happening on ALL of them)
- I checked some older sites I haven't updated in a while and its happening on them too, but I don't know when it started...

Any ideas what's going on?

THanks in advance for any help you can provide.
Last edited by imanickam on Wed Aug 26, 2020 2:48 am, edited 2 times in total.
Reason: Moved the topic from the forum General Questions/New to Joomla! 3.x to the forum Templates for Joomla! 3.x

CyborgPrime
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Wed May 09, 2007 7:50 am

Joomshaper site is down?

Post by CyborgPrime » Tue Aug 25, 2020 9:47 pm

I went to Joomshaper to see if I could get some help with this issue where I get an internal server errer if I try to style an image and save the article.

Got 404 for all Joomshaper pages.

??
Last edited by toivo on Tue Aug 25, 2020 11:16 pm, edited 2 times in total.
Reason: mod note: moved from 3.x Administration, merged with the current topic - cross posting is against the forum rules!

User avatar
sozzled
Joomla! Exemplar
Joomla! Exemplar
Posts: 9999
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Joomshaper site is down?

Post by sozzled » Tue Aug 25, 2020 9:56 pm

I received an email from Joomshaper today which says that "We are moving to a new support system". This may explain why their website has problems, perhaps?
https://www.kuneze.com/blog
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

CyborgPrime
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Wed May 09, 2007 7:50 am

Re: Joomshaper site is down?

Post by CyborgPrime » Tue Aug 25, 2020 10:03 pm

Do you think that might have something to do with why every site I have one of their tamplates on crashes if I apply a style to an image in an article?

That doesnt make sense to mee- unless the template is making callbacks to the joomshaper site?

I'm grasping at straws here.

User avatar
sozzled
Joomla! Exemplar
Joomla! Exemplar
Posts: 9999
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Joomshaper site is down?

Post by sozzled » Tue Aug 25, 2020 10:09 pm

I have no idea, mate. I'm only telling you that I received an email about five hours ago. I did not go to the developer's website until I saw this topic on the forum. I've used something from Joomshaper, once upon a time, and I subscribe to their news 'blogs but I don't have much to do with them, sorry. I can't help you. Suggest you wait and try again later.

And, to get to the point, I wouldn't imagine that "every site" you own that uses "one of their templates" would crash (for any reason) because the developer's site has currently gone walkabout.
https://www.kuneze.com/blog
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

CyborgPrime
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Wed May 09, 2007 7:50 am

Re: Joomshaper site is down?

Post by CyborgPrime » Tue Aug 25, 2020 10:18 pm

well, it just happened out of the blue, coincidentally on the day they ar emoving their site...

User avatar
sozzled
Joomla! Exemplar
Joomla! Exemplar
Posts: 9999
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Joomshaper site is down?

Post by sozzled » Tue Aug 25, 2020 10:23 pm

Tell you what: for the time being just wait until the developer's website has been restored. If, after that, you don't have any issues applying a style to an image then it's not just a coincidence. I would be interested to know if the two things are connected. If your website requires their website to be running whenever you want to "apply a style to an image" then you should probably report that to the developers. :)
https://www.kuneze.com/blog
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

User avatar
ranwilli
Joomla! Master
Joomla! Master
Posts: 19186
Joined: Sun Feb 19, 2006 6:47 pm
Location: Toledo, OH
Contact:

Re: Styling an image in an article causes internal error

Post by ranwilli » Tue Aug 25, 2020 10:58 pm

What server error are you getting? Have you asked your host about it? Doesn't seem like a Joomla issue, since other sites, and especially outdated sites, have the same issue.
Don't HACK the Joomla! core, Instead "Extend" and/or "Override."
Stay ON the update path.
https://harpervance.com

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 13263
Joined: Thu Feb 15, 2007 5:48 am
Location: Zagreb, Croatia

Re: Joomshaper site is down?

Post by toivo » Tue Aug 25, 2020 11:09 pm

Interesting. It is possible that some paid extensions have to "phone home" before you can use them.

At the moment the JoomShaper website is online and the last posts in their support forum were submitted four hours ago.
Toivo Talikka, Global Moderator

User avatar
sozzled
Joomla! Exemplar
Joomla! Exemplar
Posts: 9999
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Styling an image in an article causes internal error

Post by sozzled » Tue Aug 25, 2020 11:20 pm

Yes, I can confirm that the developer's website is operating now.
https://www.kuneze.com/blog
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 13263
Joined: Thu Feb 15, 2007 5:48 am
Location: Zagreb, Croatia

Re: Styling an image in an article causes internal error

Post by toivo » Tue Aug 25, 2020 11:21 pm

The two topics have now been merged because cross posting, creating more than one topic about the same issue, is against the forum rules.

If you get an internal server error, there are several things that can be done. Change the level of error reporting in the Global Configuration from 'Default' to 'Maximum'. Enable also the Debug option in Global Configuration and enable and configure the plugin System - Debug to record debug entries for your usergroup, Super User, and 'Log almost everything'. The PHP error log can then be downloaded from administrator/logs/everything.php. Post the relevant lines here for advice.
Toivo Talikka, Global Moderator

CyborgPrime
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Wed May 09, 2007 7:50 am

Re: Styling an image in an article causes internal error

Post by CyborgPrime » Tue Aug 25, 2020 11:30 pm

ok sorry- I didnt see them as the same issue...

I am working with the hosting company to see if they can figure it out.

User avatar
sozzled
Joomla! Exemplar
Joomla! Exemplar
Posts: 9999
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Styling an image in an article causes internal error

Post by sozzled » Tue Aug 25, 2020 11:32 pm

This issue seems to be directly related to the template (and, for that reason, it would be better if the topic was relocated in the Templates for Joomla! 3.x forum category). I've experienced a similar kind of happening with another template framework that uses SCSS or LESS and requires changes to customised CSS to be compiled.

If you don't get it right, a change in the custom.scss file fails to compile and causes an HTTP 500 Internal Server error when you try top compile it. It's fairly straightforward to overcome the error; you just have to be more careful when you make changes (e.g. match the open/close curly braces).

Those kinds of things, independently of whether there's some kind of callback to the developer's website (perhaps), can happen. Double-check the syntax of the custom.scss (if that's what you're doing). I could be mistaken; I don't know much about the template you're using.
https://www.kuneze.com/blog
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

CyborgPrime
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Wed May 09, 2007 7:50 am

Re: Styling an image in an article causes internal error

Post by CyborgPrime » Tue Aug 25, 2020 11:37 pm

I might have css compressing on - maybe that mangled it - I'll check - thanks for the idea

CyborgPrime
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Wed May 09, 2007 7:50 am

Re: Styling an image in an article causes internal error

Post by CyborgPrime » Wed Aug 26, 2020 12:17 am

Now when I try to update the template through the joomla updater, I get errors that jooshaper's manifest cant be found - maybe paths have changed... I'll try again tomorrow.

anybody else using Helix Ultimate?

User avatar
AMurray
Joomla! Champion
Joomla! Champion
Posts: 6467
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Styling an image in an article causes internal error

Post by AMurray » Wed Aug 26, 2020 9:25 am

Yes, using Helix.

Haven't been into my sites so not aware of this issue....but joomshaper.com is currently showing "down for maintenance" with a login form (similar to Joomla's offline mode)...and no longer a 404 error as was the case earlier.
Regards,
--------------------------------------------------------------
A Murray
Help you I can, yes!. Post your question, you should. Keep it on topic you must!
Use the Forc....Forum Post Assistant my young Padawan!

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 13263
Joined: Thu Feb 15, 2007 5:48 am
Location: Zagreb, Croatia

Re: Styling an image in an article causes internal error

Post by toivo » Wed Aug 26, 2020 9:49 am

AMurray wrote:
Wed Aug 26, 2020 9:25 am
....but joomshaper.com is currently showing "down for maintenance" with a login form (similar to Joomla's offline mode)...and no longer a 404 error as was the case earlier.
Maybe their CDN is down in some regions, because I just downloaded Helix Ultimate, installed it and it worked (as an aside, had to change the level of error reporting to 'Simple' because of numerous PHP notices in PHP 7.4.8).
Last edited by toivo on Wed Aug 26, 2020 12:10 pm, edited 1 time in total.
Reason: smiley
Toivo Talikka, Global Moderator

CyborgPrime
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Wed May 09, 2007 7:50 am

Re: Styling an image in an article causes internal error

Post by CyborgPrime » Wed Aug 26, 2020 5:55 pm

were you able to insert an image in an article save it, then center it and save again with no troubles?

CyborgPrime
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Wed May 09, 2007 7:50 am

Re: Styling an image in an article causes internal error

Post by CyborgPrime » Wed Aug 26, 2020 6:53 pm

SOLUTION

mod_security was suddenly interfering

i turned it off and everything went back to normal.

THanks everybody!

User avatar
sozzled
Joomla! Exemplar
Joomla! Exemplar
Posts: 9999
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Styling an image in an article causes internal error

Post by sozzled » Wed Aug 26, 2020 7:16 pm

Excellent news. Thanks. :)
https://www.kuneze.com/blog
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)


Post Reply

Return to “Templates for Joomla! 3.x”