PHP 8: Failed to load Xenon template: Please install Gantry 5 Framework!

Need help with the Administration of your Joomla! 3.x site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
Forsh
Joomla! Explorer
Joomla! Explorer
Posts: 351
Joined: Sat Aug 20, 2005 3:05 pm
Location: 1135 N Broadway #213 Denver, CO 80203
Contact:

PHP 8: Failed to load Xenon template: Please install Gantry 5 Framework!

Post by Forsh » Sun Dec 17, 2023 3:48 pm

I am trying to change my PHP version from 7.4 to 8 but I always get this error and I can't figure out why this is happening.
The Xenon template is the template that the website uses, but I still get this error when I change to the default Beez template as well.

I have downloaded and installed the latest Gantry 5 version, checked and everything published.

I don't understand why I would get a template error about the Xenon template when I switch my default template over to Beez and then change my PHP to 8.0.

This one thing is not allowing me to change over to PHP 8

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 30880
Joined: Mon Oct 27, 2008 9:27 pm
Location: Romerike, Norway

Re: PHP 8: Failed to load Xenon template: Please install Gantry 5 Framework!

Post by Per Yngve Berg » Sun Dec 17, 2023 3:57 pm

There is also Plugins that have to be disabled.

User avatar
AMurray
Joomla! Exemplar
Joomla! Exemplar
Posts: 9702
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: PHP 8: Failed to load Xenon template: Please install Gantry 5 Framework!

Post by AMurray » Sun Dec 17, 2023 10:14 pm

What is the actual error (not mentioned in your OP)?

I have my doubts about Beez3 template working on PHP 8 since it was shipped with J3 in its early days, years before PHP 8...but I could be wrong. Perhaps try the Protostar template instead to see if you get the same error. What version of Joomla 3 are you running - assume 3.10.x (the latest, and last version in the J3 series)?

You say you use the latest Gantry framework, but what about the latest Xeon template version (v 1.5 Nov 11, 2021)?

Just noting that PHP 8.0 is EOL (November 2023). Joomla 3.x is EOL (September 2023). Suggest updating to 4.4.x.

Even using PHP 8.1 with Joomla 3.10 may be possible but you will more than likely run into issues with any extensions used that are not going to work with PHP 8.1

But I'm also thinking Xeon may be too old for PHP 8.x Rocket Theme site says Xeon min requirement is PHP 7.1 but nothing in the template's change log about PHP 8.x compatibility.

For reference: Xeon template is not mentioned here: https://rockettheme.com/product-updates nor https://rockettheme.com/joomla-template ... ity-matrix

Also Gantry website (documentation) says "Always use the latest stable Joomla" - so again, suggest Joomla 4.4 at least.
Regards - A Murray
General Support Moderator

Forsh
Joomla! Explorer
Joomla! Explorer
Posts: 351
Joined: Sat Aug 20, 2005 3:05 pm
Location: 1135 N Broadway #213 Denver, CO 80203
Contact:

Re: PHP 8: Failed to load Xenon template: Please install Gantry 5 Framework!

Post by Forsh » Sun Dec 17, 2023 10:41 pm

AMurray wrote:
Sun Dec 17, 2023 10:14 pm
What is the actual error (not mentioned in your OP)?

I have my doubts about Beez3 template working on PHP 8 since it was shipped with J3 in its early days, years before PHP 8...but I could be wrong. Perhaps try the Protostar template instead to see if you get the same error. What version of Joomla 3 are you running - assume 3.10.x (the latest, and last version in the J3 series)?

You say you use the latest Gantry framework, but what about the latest Xeon template version (v 1.5 Nov 11, 2021)?

Just noting that PHP 8.0 is EOL (November 2023). Joomla 3.x is EOL (September 2023). Suggest updating to 4.4.x.

Even using PHP 8.1 with Joomla 3.10 may be possible but you will more than likely run into issues with any extensions used that are not going to work with PHP 8.1

But I'm also thinking Xeon may be too old for PHP 8.x Rocket Theme site says Xeon min requirement is PHP 7.1 but nothing in the template's change log about PHP 8.x compatibility.

For reference: Xeon template is not mentioned here: https://rockettheme.com/product-updates nor https://rockettheme.com/joomla-template ... ity-matrix

Also Gantry website (documentation) says "Always use the latest stable Joomla" - so again, suggest Joomla 4.4 at least.
I have Xenon installed on my Joomla 4 install on my website's subdomain just to test and it works fine on Joomla 4 with php 8 set.

Yes, my Joomla 3 install is 3.10.

I just set Prostar as my template to test, enabled php 8, and the website gives the same following error "Failed to load 'rt_xenon' template: Please install Gantry 5 Framework!" The website this is happening to is in my signature. I can't upgrade it past php 7.4 or I get that error no matter what template I try to use.

Thinking about just moving the content over to the subdomain where Xenon/J4/and PHP8+ will run fine and doing a 301 redirect from the main domain over to the subdomain. I'm just not skilled enough to be able to upgrade and troubleshoot the Joomla 3.10 install to get it upgraded so it can run Joomla4/Xenon/Php8+

Xenon runs on both J3 and J4 so I wouldn't think that the problem. My subdomain is https://guide.denverdonate.com/ where J4 is installed and where I tested Xenon, temporarily enabling the template and PhP8+, everything worked fine. The problem is that I can't enable php8+ at all permanently because both websites are on the same host. If I enable php8+ then the main domain gives that Xenon/Gantry error.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 44068
Joined: Sat Apr 05, 2008 9:58 pm

Re: PHP 8: Failed to load Xenon template: Please install Gantry 5 Framework!

Post by Webdongle » Mon Dec 18, 2023 1:01 am

What have you downloaded from https://gantry.org/downloads ?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

Forsh
Joomla! Explorer
Joomla! Explorer
Posts: 351
Joined: Sat Aug 20, 2005 3:05 pm
Location: 1135 N Broadway #213 Denver, CO 80203
Contact:

Re: PHP 8: Failed to load Xenon template: Please install Gantry 5 Framework!

Post by Forsh » Mon Dec 18, 2023 2:59 am

Webdongle wrote:
Mon Dec 18, 2023 1:01 am
What have you downloaded from https://gantry.org/downloads ?
joomla-pkg_gantry5_v5.5.17.zip

Here's a screenshot showing it's installed (Joomla 3.10)
Screenshot 2023-12-17 195830.png
Latest version of Xenon is installed
Screenshot 2023-12-17 200158.png
You do not have the required permissions to view the files attached to this post.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 44068
Joined: Sat Apr 05, 2008 9:58 pm

Re: PHP 8: Failed to load Xenon template: Please install Gantry 5 Framework!

Post by Webdongle » Mon Dec 18, 2023 3:28 am

That's a dev package. Perhaps they can better answer your question?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

User avatar
AMurray
Joomla! Exemplar
Joomla! Exemplar
Posts: 9702
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: PHP 8: Failed to load Xenon template: Please install Gantry 5 Framework!

Post by AMurray » Mon Dec 18, 2023 10:15 am

Yes, RT site says it runs on "Joomla 4" but not necessarily on PHP 8......

Other thing to try, uninstall the Gantry 5 framework completely and reinstall it. I don't know why Protostar is complaining since it doesn't use Gantry 5.
Regards - A Murray
General Support Moderator

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 44068
Joined: Sat Apr 05, 2008 9:58 pm

Re: PHP 8: Failed to load Xenon template: Please install Gantry 5 Framework!

Post by Webdongle » Mon Dec 18, 2023 11:27 am

AMurray wrote:
Mon Dec 18, 2023 10:15 am
... I don't know why Protostar is complaining since it doesn't use Gantry 5.
Probably because the op installed a gantry quickstart package and it was a development one at that.

If the op had installed the Joomla full package and installed gantry into that then they would not have the problem.

Clearly the problem is the gantry quickstart development package. The op needs to contact them.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

User avatar
AMurray
Joomla! Exemplar
Joomla! Exemplar
Posts: 9702
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: PHP 8: Failed to load Xenon template: Please install Gantry 5 Framework!

Post by AMurray » Mon Dec 18, 2023 9:59 pm

Yes, perhaps the OP can do a secondary test, on a subdomain (or localhost - Wampserver would be my choice) and install the quickstart again and see if the problem can be replicated.

And as you have mentioned, additionally, a third test, this time a clean install of Joomla, then install only the framework plugin and the standalone template and see if the problem can be replicated
Regards - A Murray
General Support Moderator

nacc
I've been banned!
Posts: 347
Joined: Mon Jul 03, 2023 7:08 pm

Re: PHP 8: Failed to load Xenon template: Please install Gantry 5 Framework!

Post by nacc » Mon Dec 18, 2023 11:12 pm

1) Gantry 5.5.17 is the latest version available (released on 31-Oct-2023). It runs fine on J! 3.10 and J! 4.4. It runs on PHP 7.4 and PHP 8.1.11. I know this because I use the Helium template on a couple of my websites.

2) Gantry 5.5.17 is not a "development" version.

3) I see no indication here that the OP has installed a "quickstart" package.

4) Xenon 1.5.0 was released by Rockettheme on 30-Nov-2021. It is the latest version available. I do not know if this template is compatible with J! 4.x; the OP asks about whether their J! 3.10 website will run with PHP 8.x and Xenon.

Forsh wrote:
Sun Dec 17, 2023 10:41 pm
I just set [protostar] as my template to test, enabled php 8, and the website gives the same following error "Failed to load 'rt_xenon' template: Please install Gantry 5 Framework!"
Yes, as @AMurray observed, it is strange that using Protostar as the default template would raise error messages about Xenon but it's not unheard of. It's possible that the website in question is missing some vital part of Gantry 5 and re-installing the Gantry 5 package may fix that problem. I've has similar problems with incompletely installed extensions that were remedied by re-installing them.

Slightly off-topic: Maintenance on Beez3 ceased around the time when J! 3.8 happened. The only default template for J! 3.10 that has any moderate chance of success is Protostar.


Post Reply

Return to “Administration Joomla! 3.x”