eMail Not Working

Need help with the Administration of your Joomla! site? Pop your questions in here.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
coreygallon
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Tue Oct 24, 2006 4:58 pm

eMail Not Working

Post by coreygallon » Thu Oct 26, 2006 7:47 pm

Hello,

I have searched the forums but I cannot seem to find a solution to the problem I am experiencing.  My Joomla site will not send emails at all.  I run other sites from the same hosting account, and they are able to send email using PHP without any problems.  Can someone please help me get the PHP mailing feature working?

Thanks!

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 22799
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, Netherlands
Contact:

Re: eMail Not Working

Post by pe7er » Thu Oct 26, 2006 8:10 pm

Could you compare the server settings and the e-mail settings in Joomla's Global Configuration of your various sites?
If there are any differences maybe that's why it is not working on one site....
Kind Regards,
Peter Martin, Global Moderator
https://db8.nl - Joomla specialist, Nijmegen, Nederland
Co-developer of d2 Content https://data2site.com/joomla-extensions/d2-content

coreygallon
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Tue Oct 24, 2006 4:58 pm

Re: eMail Not Working

Post by coreygallon » Thu Oct 26, 2006 8:58 pm

Please elaborate.  I am unclear on what you mean.

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 22799
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, Netherlands
Contact:

Re: eMail Not Working

Post by pe7er » Thu Oct 26, 2006 10:03 pm

coreygallon wrote:Please elaborate.  I am unclear on what you mean.
You have a couple of sites that work correctly and one that does not. So by comparing the server settings (especially php.ini) and the mail settings in Joomla's Global Config from the working sites with the non-working site, you might find some differences in the settings. Those differences are the reason why the other sites work ok, but one does not.
Kind Regards,
Peter Martin, Global Moderator
https://db8.nl - Joomla specialist, Nijmegen, Nederland
Co-developer of d2 Content https://data2site.com/joomla-extensions/d2-content

coreygallon
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Tue Oct 24, 2006 4:58 pm

Re: eMail Not Working

Post by coreygallon » Thu Oct 26, 2006 11:00 pm

Thanks for the suggestion.  I have found that my site is able to send me the automated emails -- such as when someone registers for an account -- but it is unable to send anyone else emails -- e.g. the validation email that they are supposed to receive when they register.

Does this help pinpoint the problem for anyone?

coreygallon
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Tue Oct 24, 2006 4:58 pm

Re: eMail Not Working

Post by coreygallon » Tue Oct 31, 2006 4:30 pm

^^bump^^

Please, someone help with this!  I will have to abandon Joomla if I can't get this issue resolved, and I would prefer not to!

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 22799
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, Netherlands
Contact:

Re: eMail Not Working

Post by pe7er » Tue Oct 31, 2006 4:52 pm

coreygallon wrote:Please, someone help with this!  I will have to abandon Joomla if I can't get this issue resolved, and I would prefer not to!
Threaten to abandon Joomla doesn't stimulate other people to help you with Joomla...

What might help to get the issue solved is to give more information about your configuration:
What OS?  (Linux/Windows) + version.
What hosting company?
What PHP version?
What Joomla version?
What's the URL of your site/
Kind Regards,
Peter Martin, Global Moderator
https://db8.nl - Joomla specialist, Nijmegen, Nederland
Co-developer of d2 Content https://data2site.com/joomla-extensions/d2-content

coreygallon
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Tue Oct 24, 2006 4:58 pm

Re: eMail Not Working

Post by coreygallon » Tue Oct 31, 2006 5:25 pm

My site is hosted by GoDaddy, on their Linux hosting platform.  (I am not sure which distribution they are running.)  I am running (what I believe to be) the most current stable version of Joomla -- 1.0.11.  I will happily provide you with a URL to the output of the phpinfo() function run on my site: http://www.theemhproject.com/phpinfo.php.  That should answer your remaining questions. 
Threaten to abandon Joomla doesn't stimulate other people to help you with Joomla...
I was not threatening anything.  I will have to find another CMS if I can't get this problem resolved -- that is an unfortunate fact!  You missed the last part of my statement: "I would prefer not to!"  I like Joomla, and I'm rather impressed by it.  This email issue is, however, debilitating to my site and I can't possibly continue to use Joomla if I can't find a solution to the problem.  My statement was made to illustrate the dire nature of the situation!  You'd hardly scold a drowning person for claiming that they will die if someone doesn't assist them!  It was in that vein that I made my remark -- I desperately need the help of a Joomla expert!  I appreciate your willingness to volunteer as such! 
;D

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 22799
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, Netherlands
Contact:

Re: eMail Not Working

Post by pe7er » Tue Oct 31, 2006 5:39 pm

coreygallon wrote:My site is hosted by GoDaddy, on their Linux hosting platform.
Ok, that's valueable information to solve your problem.
A search on this forum for Godaddy + SMTP found:
http://forum.joomla.org/index.php/topic,108299.0.html
http://forum.joomla.org/index.php/topic,97878.0.html
Hopefully it gives you some info to solve your problem.

PS: the registration e-mail that is send to you, is it your e-mail account at your godaddy server?
Could you change that into some external e-mail account?
Just to test if the Godaddy server maybe permist only "internal" e-mail messages and not to any external e-mail address?
(then register and see if you still receive the automated emails for someone that registers for an account).
I was not threatening anything.  I will have to find another CMS if I can't get this problem resolved -- that is an unfortunate fact!  You missed the last part of my statement: "I would prefer not to!"  I like Joomla, and I'm rather impressed by it.  This email issue is, however, debilitating to my site and I can't possibly continue to use Joomla if I can't find a solution to the problem.  My statement was made to illustrate the dire nature of the situation!  You'd hardly scold a drowning person for claiming that they will die if someone doesn't assist them!  It was in that vein that I made my remark -- I desperately need the help of a Joomla expert!  I appreciate your willingness to volunteer as such!
No prob.
Kind Regards,
Peter Martin, Global Moderator
https://db8.nl - Joomla specialist, Nijmegen, Nederland
Co-developer of d2 Content https://data2site.com/joomla-extensions/d2-content

wilsonpro
Joomla! Intern
Joomla! Intern
Posts: 51
Joined: Sun Nov 13, 2005 4:10 pm
Location: London, England
Contact:

Re: eMail Not Working

Post by wilsonpro » Tue Oct 31, 2006 7:16 pm

Before I converted from #ambo to joomla whenever a user posted an article on the website it automatically sent me a notification email. It doesn't do that any more and I can't see why not. It does send a private message but that's not really what I need.

Is there any info on setting this up please?
Thanks,

Andy Wilson

coreygallon
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Tue Oct 24, 2006 4:58 pm

Re: eMail Not Working

Post by coreygallon » Wed Nov 01, 2006 11:46 pm

To those who have offered their assistance,

It seems that the problem has resolved itself.  Unfortunately, I have tried so many things to remedy the issues in the past week that I cannot say precisely what the solution was!  Still, I appreciate the help you have rendered on my behalf!

Thanks!


Locked

Return to “Administration - 1.0.x”