access level not working?

Need help with the Administration of your Joomla! site? Pop your questions in here.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
gennaroz
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Sun Dec 31, 2006 5:54 pm

access level not working?

Post by gennaroz » Tue Jan 02, 2007 11:38 am

I am relatively new to Joomla!
I followed the manual to set up a menu which should be accessible only to Special users. I set the module access level for the menu to Special, all menu items are set to Special, and all content pages accessible from the menu are set to Special.
The menu is invisible to unregistered users. However, when I log in using any registered account (say as Publisher) Joomla lets the user access the menu (and modify contents).
I am using Joomla! version 1.0.12.

Any ideas?
Gennaro Zezza, Napoli, Italy

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 22235
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, The Netherlands
Contact:

Re: access level not working?

Post by pe7er » Tue Jan 02, 2007 12:24 pm

"special" should not be visible for registered only visitors. Could you try another login that is "registered" and not publisher or anything.
The access levels:
public -> every visitor
registered -> only registered visitors
special -> only registered visitors that have level author or higher.
Kind Regards,
Peter Martin, Global Moderator
https://db8.nl - Joomla specialist, Nijmegen, Nederland
Co-developer of d2 Content https://data2site.com/joomla-extensions/d2-content

gennaroz
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Sun Dec 31, 2006 5:54 pm

Re: access level not working?

Post by gennaroz » Tue Jan 02, 2007 1:50 pm

Thank you for your reply!
The menu is invisible to Registered users. But in the latest Joomla manual, on page 44, it says
"Special:  Determines that the article will only be available to users with Manager, Administrator, or Super Administrator permissions."
I guess this is not true any longer?

pe7er wrote: "special" should not be visible for registered only visitors. Could you try another login that is "registered" and not publisher or anything.
The access levels:
public -> every visitor
registered -> only registered visitors
special -> only registered visitors that have level author or higher.
Gennaro Zezza, Napoli, Italy

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 22235
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, The Netherlands
Contact:

Re: access level not working?

Post by pe7er » Tue Jan 02, 2007 2:19 pm

gennaroz wrote:The menu is invisible to Registered users. But in the latest Joomla manual, on page 44, it says
"Special:  Determines that the article will only be available to users with Manager, Administrator, or Super Administrator permissions."
I guess this is not true any longer?
Or maybe I am wrong... I always thought that "special" was every level higher then registered....
Kind Regards,
Peter Martin, Global Moderator
https://db8.nl - Joomla specialist, Nijmegen, Nederland
Co-developer of d2 Content https://data2site.com/joomla-extensions/d2-content

gennaroz
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Sun Dec 31, 2006 5:54 pm

Re: access level not working?

Post by gennaroz » Tue Jan 02, 2007 3:20 pm

pe7er wrote:
gennaroz wrote:The menu is invisible to Registered users. But in the latest Joomla manual, on page 44, it says
"Special:  Determines that the article will only be available to users with Manager, Administrator, or Super Administrator permissions."
I guess this is not true any longer?
Or maybe I am wrong... I always thought that "special" was every level higher then registered....
I am afraid you are right: "registered" does not include Authors etc.
But since the Manual has it differently I guess this has been changed in one of the releases?
Any ideas on how to change the code so that Joomla behaves as described in the manual?  ;)
Gennaro Zezza, Napoli, Italy

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: access level not working?

Post by humvee » Wed Jan 24, 2007 1:28 am

Hi Guys,

This is an error in the User Manual that I had already picked up and is marked for correction in the 2nd edition.

The correct levels are identified in the Help Screen available http://help.joomla.org/content/view/228/153/ on page 3

If anyone should find discrepancies like this please let us know in the User Manual 1.0.x Feedback forum.

Thanks

Andy

User avatar
xprdq
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Sun Aug 24, 2008 8:41 pm
Location: Shady Point, Oklahoma
Contact:

Re: access level not working?

Post by xprdq » Mon Sep 15, 2008 2:50 am

Has anyone found a way to set menus so that ...

1.) Public users see one or two menu items

2.) Registered users see a few more

3.) 'Authors' see a few more
and
4.) Admins & higher see all of these plus some?

I would REALLY like to be able to do that.

mariam81
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sat Sep 20, 2008 5:29 am

Re: access level not working?

Post by mariam81 » Sat Sep 20, 2008 5:31 am

I am having the same problem. When I set things to "special" access, all registered users are able to see it. Is there any way to correct this? Thanks in advance for the help :)

mariam81
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sat Sep 20, 2008 5:29 am

Re: access level not working?

Post by mariam81 » Sat Sep 20, 2008 10:46 pm

Now I have realized that my access level is working everywhere except for the User Menu and Main Menu. It does work in the top menu. Please help if you can :)

Justizia
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Tue Oct 07, 2008 4:39 pm

Re: access level not working?

Post by Justizia » Tue Oct 07, 2008 5:02 pm

I am having an issue with access levels which I hope someone can advise me on. My website uses a pre-built Joomla template with the Fireboard Forum component. It has integrated well with the Joomla access levels, but I have had one problem...

Once someone has been given Editor status to access our officer forums, if I demote their status back to Author status, for some reason they still seem to be able to see the forums which require Editor status. I have not found any way to reset it and several people who stopped being officers had to create new accounts on our site since I could not modify their old ones appropriately. Any advice about how to fix this would be welcome!

charkrunge
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Mon Oct 20, 2008 3:21 pm

Re: access level not working?

Post by charkrunge » Mon Oct 20, 2008 5:04 pm

mariam81 wrote:Now I have realized that my access level is working everywhere except for the User Menu and Main Menu. It does work in the top menu. Please help if you can :)
If this issue is still persistent, you might try changing the display of the menu from List to Legacy - Vertical or vice versa (from within the module properties). I found that mine did the same thing with a prebuilt template from another designer and once I changed the list style, it was fixed.


Locked

Return to “Administration - 1.0.x”