dublicate search results on static content items - wrong syndication links

General questions relating to Joomla! There are other boards for more specific help on Joomla! features and extensions.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
libo
Joomla! Apprentice
Joomla! Apprentice
Posts: 19
Joined: Sun Oct 08, 2006 11:18 pm

dublicate search results on static content items - wrong syndication links

Post by libo » Tue Apr 24, 2007 7:12 pm

Hello there.
I am totally newbie and try to set up a joomla 1.0.12/VM site.
I face foll problems:
1)i get duplicate search results on static content pages (see attached jpg). Non-static content ,which may contain the word on search, appears only once on search results
2)though syndication RSS2.0 on FF and IE7 shows article links of home page, clicking on any of links it results to "You are not authorised to view this resource.You need to login.".  The link of this warning page is "http://www.mysite.com/subroot/content/view/2/"  instead of the correct link cerresponding to the specific article "http://www.mysite.com/subroot/content/view/2/1/". Same respectively with all syndicated articles.

Really appreciate any assistance
You do not have the required permissions to view the files attached to this post.
Last edited by libo on Sat Apr 28, 2007 5:57 am, edited 1 time in total.

 
User avatar
Wizzie
Joomla! Hero
Joomla! Hero
Posts: 2703
Joined: Tue Sep 06, 2005 4:37 am
Location: Australia
Contact:

Re: dublicate search results on static content pages - wrong syndication links

Post by Wizzie » Wed Apr 25, 2007 5:42 am

With regard to the error message you are seeing, you might want to read through the FAQ (if you haven't already done so) FAQ: You are not authorized to view this resource. You need to login. http://forum.joomla.org/index.php/topic,19443.0.html

In relation to the search issues, do all of the duplicate search results have exactly the same URL or different URLs?

libo
Joomla! Apprentice
Joomla! Apprentice
Posts: 19
Joined: Sun Oct 08, 2006 11:18 pm

Re: dublicate search results on static content items - wrong syndication links

Post by libo » Wed Apr 25, 2007 8:21 am

Thanks Wizzie for your attention.

Regarding my first problem, the reply to your question is as foll:
a. search result no.3 URL is http://www.mysite.com/subroot/content/view//30/64/ and when clicking it gets you to the actual article, whereas its duplicate result no.6 URL is http://www.mysite.com/subroot/content/view/30/ and when clicking, the loaded page shows "You are not authorised to view this resource. You need to login."
b. search result no.4 URL is http://www.mysite.com/subroot/content/view/29/73/ and duplicate result no.7 URL http://www.mysite.com/subroot/content/view/29/ with exactly same behaviour as the above pair of duplicated search results.
c. The same again with result no.5 and no.8 respectively.

I have gone through your suggested link once before your suggestion, regarding the 2nd problem, but i admit i did not understand much. I must go through again and check if can get through something.

I feel that both problems, i.e. duplicate search results, with incomplete URL on half results, aswell as the incomplete URLs of the RSS syndication links, may have the same cause?


Any advice appreciated.

Thanks
Last edited by libo on Sat Apr 28, 2007 5:58 am, edited 1 time in total.

libo
Joomla! Apprentice
Joomla! Apprentice
Posts: 19
Joined: Sun Oct 08, 2006 11:18 pm

Re: dublicate search results on static content items - wrong syndication links

Post by libo » Sat Apr 28, 2007 6:34 am

@Wizzie:

reg the issue with duplicate search results returned on static content items, i was experimenting and found that by setting the "search content" mambot parameter "static content nonmenu" to "no" , i/o default "yes", i got 5 results with no duplicates, compared to 8 initially (out of which, 3 were duplicates with wrong links).
See attached jpg
You do not have the required permissions to view the files attached to this post.

 

Locked

Return to “General Questions - 1.0.x”