[FIXED:TRACKER: #6091] - Login module published breaks default/home page link

Locked
User avatar
jonflgiles
Joomla! Intern
Joomla! Intern
Posts: 92
Joined: Fri Mar 24, 2006 4:58 pm
Location: Derby, UK

[FIXED:TRACKER: #6091] - Login module published breaks default/home page link

Post by jonflgiles » Tue Jul 17, 2007 11:10 am

When login module published the default menu item in mainmenu module breaks (would often be Home for most people sites I guess)

Checked this by changing default menu item. The default menu item then takes on the same link as the current page linked to. This only happens when login module published! The behaviour is the same whether logged in or not.

Regards,

Jon.

Wamp5 1.7.2 on XP Pro SP2
Apache 2.24
PHP 5.2.3
MySQL 5.0.41
Firefox 2.0.0.4
Build 8013

edit: make topic name more descriptive.
Last edited by Jinx on Mon Aug 27, 2007 4:32 pm, edited 1 time in total.

User avatar
aravot
Joomla! Ace
Joomla! Ace
Posts: 1015
Joined: Thu Aug 18, 2005 1:16 am
Location: Glendale, CA, USA
Contact:

Re: [8013] Login module published breaks default/home page link

Post by aravot » Tue Jul 17, 2007 10:31 pm

Sorry don't understand, I have login module and main menu published, the link for Home stays the same, can you give step by step info, thanks.

User avatar
mikekist
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Thu Jul 05, 2007 4:16 pm

Re: [INFO REQUESTED] [8013] Login module published breaks default/home page link

Post by mikekist » Wed Jul 18, 2007 3:32 am

I have the same issue as detailed here: http://forum.joomla.org/index.php?topic ... icseen#new

This seems to be an issue only on the nightly builds and not with Beta2.

After further investigation it seems the error occurs only when the login module is moved to another column (ie right) but things work OK when  the login module remains in the left column.

When publishing the login module to a page other than the home page, the installation will return to the home page with the error when trying to log in or off (again only when moved out of the left column).

The error I am receiving is: http://localhost/joomla/http://localhos ... e&Itemid=1 in the address bar and "HTTP Error 404.0 - Not Found" on the page.

If I disable or delete the module and then reenable or reinstall the module in the left column the site will return to normal.

Even when the login function is working from the left column on a page other than the home page, it will still return to the home page instead of keeping the module's page open when logging in or out.

Thanks,

Mike

Windows Vista with IIS7
PHP 5.2.3
MySQL 5.0.41
Firefox 2.0.0.4
IE 7
Current nightly build

User avatar
aravot
Joomla! Ace
Joomla! Ace
Posts: 1015
Joined: Thu Aug 18, 2005 1:16 am
Location: Glendale, CA, USA
Contact:

Re: [CONFIRMED] [8013] Login module published breaks default/home page link

Post by aravot » Wed Jul 18, 2007 6:48 am

Revision 8032, Confirmed.

Q&T Note; Tracker URL -> http://joomlacode.org/gf/project/joomla ... em_id=6091

User avatar
Robin
Joomla! Master
Joomla! Master
Posts: 15753
Joined: Thu Aug 18, 2005 10:41 am

Re: [TRACKER: #6091] r8013 - Login module published breaks default/home page lin

Post by Robin » Wed Jul 18, 2007 8:04 am

Q&T; artifact assigned to Jinx, could be another router issue

User avatar
jonflgiles
Joomla! Intern
Joomla! Intern
Posts: 92
Joined: Fri Mar 24, 2006 4:58 pm
Location: Derby, UK

Re: [TRACKER: #6091] r8013 - Login module published breaks default/home page lin

Post by jonflgiles » Wed Jul 18, 2007 8:30 am

The issue I reported differs subtly from that of Mike's.

@aravot: More detailed steps:

In an installation that was blank and has been populated with my own test data, with SEF and mod_rewrite both ON and working:
Create a login module and assigned to template position footer (this is in keeping with above description)
Menu module is published (there is only one at present)
Publish login module.

Problem described appears: Default menu item link is modified to the last menu item url I just clicked. E.g. clicked on an item with url: "about", default item takes on same url.

What is different from Mike's case is that I do not get a 404 at any point. If I turn off SEF and mod_rewrite in config all works as normal with mod_login published in a position other than left.

Trying this also on a fresh default install with build 8035 and all works when mod_login is in left position. Moving module to right posiiton breaks it except without 404.

Hope this helps,

Jon.

Edit: typo.
Last edited by jonflgiles on Wed Jul 18, 2007 9:47 am, edited 1 time in total.

User avatar
aravot
Joomla! Ace
Joomla! Ace
Posts: 1015
Joined: Thu Aug 18, 2005 1:16 am
Location: Glendale, CA, USA
Contact:

Re: [TRACKER: #6091] r8013 - Login module published breaks default/home page lin

Post by aravot » Wed Jul 18, 2007 3:48 pm

I am not working with SEF, could someone with SEF check this please.

leadict
Joomla! Guru
Joomla! Guru
Posts: 809
Joined: Thu Oct 05, 2006 12:13 am

Re: [TRACKER: #6091] r8013 - Login module published breaks default/home page link

Post by leadict » Thu Jul 19, 2007 10:41 pm

I have tested it:

1) With SEF URLs disabled:

Links on Login module work as expected.

2) With SEF URLs enabled (mod_rewrite disabled):

Links on Login module redirect to the Home Page (default menu item).

3) Issue with Default Menu Item:

With Login module and SEF URLs enabled, if you click in a menu item and then in the Home menu item, you will remain in the same page (in this case the Home menu item redirects to the last page visited).

This happens both in a blank installation and in an installation with sample data. The unique difference is that, in an installation with sample data, you can return to the Home Page (default menu item) by clicking Home in the breadcrumbs module.

Note: The behaviour is the same for any module position and i get no error.
Last edited by leadict on Thu Jul 19, 2007 10:45 pm, edited 1 time in total.
"The skill of writing is to create a context in which other people can think" - Edwin Schlossberg.

Lottario
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 207
Joined: Wed Jul 04, 2007 2:42 pm

Re: [TRACKER: #6091] r8013 - Login module published breaks default/home page lin

Post by Lottario » Fri Jul 20, 2007 2:22 am

leadict wrote: 2) With SEF URLs enabled (mod_rewrite disabled):

Links on Login module redirect to the Home Page (default menu item).
I would just like to add to this, as it is not always the case.  If you are already on a registration page (through a link in a menu or otherwise), then the login module links will take you to the homepage.

As well, if you access a login page from the menu, the forgotten username/password links will take you to the home page (IIRC, sorry, don't have Joomla! active right now to test, I'll confirm in the morning), and the registration link will do the same, unless you have a registration link in a menu, in which case, the registration link will work.

User avatar
swiftly
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 125
Joined: Thu Jul 12, 2007 10:59 pm
Location: Netherlands
Contact:

Re: [TRACKER: #6091] r8013 - Login module published breaks default/home page lin

Post by swiftly » Sat Jul 21, 2007 11:11 pm

Lottario wrote:
leadict wrote: 2) With SEF URLs enabled (mod_rewrite disabled):

Links on Login module redirect to the Home Page (default menu item).
I would just like to add to this, as it is not always the case.  If you are already on a registration page (through a link in a menu or otherwise), then the login module links will take you to the homepage.

As well, if you access a login page from the menu, the forgotten username/password links will take you to the home page (IIRC, sorry, don't have Joomla! active right now to test, I'll confirm in the morning), and the registration link will do the same, unless you have a registration link in a menu, in which case, the registration link will work.
I can confirm this, (nightly 20/7)
Jack

http://www.tradingmate.com
It's running from 2004, i restarted it at july 15th 2007, and again restarted it at 30 august 2009

User avatar
H13
Joomla! Ace
Joomla! Ace
Posts: 1472
Joined: Sun Dec 10, 2006 6:39 pm
Location: Czech Republic
Contact:

J1.5 RC1 - Registration page is not shown if SEF is enabled

Post by H13 » Wed Jul 25, 2007 9:00 am

Hi, If I want to register as a new user (No Account Yet?  Register) and I click on 'Register', Joomla displays frontpage but not register form if SEF is enabled.  ??? (in com_user folder there is no router.php file ???)

without SEF: http://xxxx/?option=com_user&task=register&Itemid=1
with SEF: http://xxx/index.php/component/user?task=register


Info:
Browsers : Firefox 2, IE 6, Opera 9
localhost - Windows XP, Apache/2.2.4 (Win32), PHP Version 5.1.6, MYSQL 5.0.22
server -    FreeBSD 6.2-STABLE, Apache/2.2.0 (Unix), PHP Version 5.1.2, MYSQL 5.0.18
Last edited by H13 on Wed Jul 25, 2007 9:18 am, edited 1 time in total.
- Phoca Gallery - powerful image gallery - http://www.phoca.cz/phocagallery/
- Phoca Restaurant Menu - http://www.phoca.cz/restaurantmenudemo/
- Phoca Cart - e-commerce platform for Joomla!
- Phoca Download - download manager for Joomla!

Lottario
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 207
Joined: Wed Jul 04, 2007 2:42 pm

Re: J1.5 RC1 - Registration page is not shown if SEF is enabled

Post by Lottario » Wed Jul 25, 2007 1:32 pm

This bug has already been found/confirmed http://forum.joomla.org/index.php/topic,191479.0.html.

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 22105
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, The Netherlands
Contact:

Re: [TRACKER: #6091] r8013 - Login module published breaks default/home page lin

Post by pe7er » Wed Jul 25, 2007 1:50 pm

[MOD note: thread J1.5 RC1 - Registration page is not shown if SEF is enabled merged into this one]
Kind Regards,
Peter Martin, Global Moderator
https://db8.nl - Joomla specialist, Nijmegen, Nederland
Co-developer of d2 Content https://data2site.com/joomla-extensions/d2-content

mcanedo
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Wed Jul 25, 2007 5:59 pm

Re: [TRACKER: #6091] r8013 - Login module published breaks default/home page lin

Post by mcanedo » Fri Jul 27, 2007 2:04 am

Is there any quick work around for this?
BBnuke.com :: Your BlackBerry Experience
http://www.bbnuke.com

User avatar
Robin
Joomla! Master
Joomla! Master
Posts: 15753
Joined: Thu Aug 18, 2005 10:41 am

Re: [TRACKER: #6091] r8013 - Login module published breaks default/home page lin

Post by Robin » Fri Jul 27, 2007 9:45 am

mcanedo wrote: Is there any quick work around for this?
Not that I know of, there are some important changes going on (JRoute) and it would be best to wait until thats fixed as well.

Lottario
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 207
Joined: Wed Jul 04, 2007 2:42 pm

Re: [TRACKER: #6091] r8013 - Login module published breaks default/home page lin

Post by Lottario » Fri Jul 27, 2007 1:29 pm

mcanedo wrote: Is there any quick work around for this?
Putting register in as a menu item will allow registration, but still doesn't fix the links in the login module.

mcanedo
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Wed Jul 25, 2007 5:59 pm

Re: [TRACKER: #6091] r8013 - Login module published breaks default/home page lin

Post by mcanedo » Sun Jul 29, 2007 3:56 am

I'm experience the same problme with the links that appear at the bottom por pagination, those ones of:
« Start  Prev 1  2  3 Next  End »
They are also not working with SEF enabled.
BBnuke.com :: Your BlackBerry Experience
http://www.bbnuke.com

User avatar
Jinx
Joomla! Champion
Joomla! Champion
Posts: 6569
Joined: Fri Aug 12, 2005 12:47 am
Contact:

Re: [TRACKER: #6091] r8013 - Login module published breaks default/home page lin

Post by Jinx » Sat Aug 25, 2007 3:44 pm

Changes have been made on SVN in the last days concering login redirects, I have tried to replicate the issue reported with the login module both with and wihtout SEF and was unable too. Can you guys please check again and report back ? Thnx.
Johan Janssens - Joomla Co-Founder, Lead Developer of Joomla 1.5

http://www.joomlatools.com - Joomla extensions that just work

User avatar
aravot
Joomla! Ace
Joomla! Ace
Posts: 1015
Joined: Thu Aug 18, 2005 1:16 am
Location: Glendale, CA, USA
Contact:

Re: [TRACKER: #6091] r8013 - Login module published breaks default/home page lin

Post by aravot » Sat Aug 25, 2007 11:01 pm

Checked with r8567 without SEF, it is fixed.

holister
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sun Aug 26, 2007 3:59 am

Re: [TRACKER: #6091] r8013 - Login module published breaks default/home page lin

Post by holister » Sun Aug 26, 2007 5:33 am

Jinx wrote: Changes have been made on SVN in the last days concering login redirects, I have tried to replicate the issue reported with the login module both with and wihtout SEF and was unable too. Can you guys please check again and report back ? Thnx.
I am using RC1 and experiencing the problem of register, forgot user, forgot password links all not working... They all display the frontpage.
Last edited by holister on Sun Aug 26, 2007 6:01 pm, edited 1 time in total.

User avatar
aravot
Joomla! Ace
Joomla! Ace
Posts: 1015
Joined: Thu Aug 18, 2005 1:16 am
Location: Glendale, CA, USA
Contact:

Re: [TRACKER: #6091] r8013 - Login module published breaks default/home page lin

Post by aravot » Sun Aug 26, 2007 6:53 am


User avatar
Jinx
Joomla! Champion
Joomla! Champion
Posts: 6569
Joined: Fri Aug 12, 2005 12:47 am
Contact:

Re: [TRACKER: #6091] r8013 - Login module published breaks default/home page lin

Post by Jinx » Mon Aug 27, 2007 4:28 pm

Closing down.
Johan Janssens - Joomla Co-Founder, Lead Developer of Joomla 1.5

http://www.joomlatools.com - Joomla extensions that just work


Locked

Return to “Q&T 1.5.x Resolved”