List of extensions needing upgrading for 1.0.13 compatibility

Joomla version 1.0 is end-of-life and are no longer supported. Please use Joomla 3.x instead.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18873
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

List of extensions needing upgrading for 1.0.13 compatibility

Post by infograf768 » Wed Jul 25, 2007 6:42 am

To developers & users

Please list here the extensions you experience problems with in 1.0.13.
Please 3pd devs post here when available upgrades (and also in your JED description)

It is suggested to all to subscribe to this thread to be kept informed.

EDIT (August 12, 2007): An official fix is available for 1.0.13
http://forum.joomla.org/index.php/topic ... #msg944268

It should fix a number of issues with admin session.
It may not fix all specific extension problems.
Last edited by infograf768 on Sun Aug 12, 2007 5:35 am, edited 1 time in total.
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18873
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

1.0.13 compatibility- CB 1.0.2•JCE 1.1.5

Post by infograf768 » Wed Jul 25, 2007 6:44 am

The 2 I am sure of for now.

Community Builder 1.0.2

JCE 1.1.5
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 19693
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: List of extensions needing upgrading for 1.0.13 compatibility

Post by leolam » Wed Jul 25, 2007 7:00 am

Comprehensive overview for clarity If solution or hotfix please post in this thread (with Link!)  so i update the list

See this post by Infograf  regarding official patch for Joomla-core 1.0.13 Also note it fixes Joomla and most extensions but some will need fixing by 3rd party developers!

Community Builder please see new release fixing all issues as posted and more COOL! Kudos Team Joomlapolis!!!
Joomlahack Bridge
X SMF-Bridge  >> discontinued
Virtuemart >> Fixed
JCE 1.1.5 >> Fixed
Joomfish 1.7
JoomlaXplorer 2.0.0 beta5
eLearningforce Components + Bridges:
  • Synch users  + CB
  • Bridges (SMF, PhpBB, JvB)
  • Subscription Pro/Deluxe
  • SingleSign-On, both components.
  • Multisites site manager – can’t synchronize users
  • LMS forum mambot.
PollXT>> Fixed
astatsPRO 1.0.0 component >> patch
Last edited by leolam on Mon Aug 13, 2007 11:26 am, edited 1 time in total.
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
-> Joomla Webmaster Services: gws-webmaster.services

User avatar
Geraint
Joomla! Guru
Joomla! Guru
Posts: 561
Joined: Fri Aug 19, 2005 5:23 pm
Location: Gogledd Cymru

Re: List of extensions needing upgrading for 1.0.13 compatibility

Post by Geraint » Wed Jul 25, 2007 7:24 am

Joomfish 1.7 will be subject to autologouts in the backend.

User avatar
Gerlof
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 206
Joined: Wed Nov 02, 2005 9:20 am
Location: Putten, The Netherlands
Contact:

Re: List of extensions needing upgrading for 1.0.13 compatibility

Post by Gerlof » Wed Jul 25, 2007 10:02 am

eXtplorer 2.0.0 beta5 (formerly known as joomlaXplorer 2.0.0) has the same auto logout problem  :(
joomlaXplorer 1.6.1 works normally  :)

Gerlof
Last edited by Gerlof on Wed Jul 25, 2007 10:21 am, edited 1 time in total.

User avatar
lavsteph
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Thu Sep 14, 2006 8:57 pm
Location: France
Contact:

Re: List of extensions needing upgrading for 1.0.13 compatibility

Post by lavsteph » Wed Jul 25, 2007 11:57 am

Hello

for the SMF bridge see this topics : http://www.simplemachines.org/community ... pic=184557  :-\

User avatar
happy_noodle_boy
Joomla! Guru
Joomla! Guru
Posts: 692
Joined: Thu Aug 18, 2005 10:32 am
Location: United Kingdom
Contact:

Re: List of extensions needing upgrading for 1.0.13 compatibility

Post by happy_noodle_boy » Wed Jul 25, 2007 12:02 pm

Does anyone have any idea where and why this is occuring?

Seems to affect JCE in the Admin backend only.
just because you're not paranoid, doesn't mean everybody isn't out to get you.
http://www.maketradefair.org

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 19693
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: List of extensions needing upgrading for 1.0.13 compatibility

Post by leolam » Wed Jul 25, 2007 12:06 pm

lavsteph wrote: for the SMF bridge see this topics :
please lets keep this a list.... this was already posted on the forum here
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
-> Joomla Webmaster Services: gws-webmaster.services

User avatar
Rolf
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 121
Joined: Mon Oct 31, 2005 10:00 pm
Location: vienna
Contact:

Re: List of extensions needing upgrading for 1.0.13 compatibility

Post by Rolf » Wed Jul 25, 2007 12:09 pm

Joomfish @version 1.7 - $Revision: 14 $
Frontend:
Fatal error: Cannot instantiate non-existent class: mldatabase in /home/httpd/hosts/srv05192/html/mambots/system/jfdatabase.systembot.php on line 53
i solved that on line 53 with replacing the // (comment) with @
@require_once( $mosConfig_absolute_path '/components/com_joomfish/includes/joomfish.class.php' );

then came:
Fatal error: Call to a member function on a non-object in /home/httpd/hosts/srv05192/html/modules/mod_jflanguageselection.php on line 52
//$langActive = $_JOOMFISH_MANAGER->getActiveLanguages();
i just uncommented this line and the page could load complete in the defaultlanguage at least.

Backend:
none of the administrationsscreens works.
index2.php cant load any of joomfishcomponents.
index2.php?option=com_joomfish  brings me back to "home"

best regards
rolf
... it´s only a mouseklick away!

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 19693
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: List of extensions needing upgrading for 1.0.13 compatibility

Post by leolam » Wed Jul 25, 2007 12:17 pm

Rolf wrote: best regards
rolf
Did you read the Text of the thread? Why you dump here a lot of code?
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
-> Joomla Webmaster Services: gws-webmaster.services

ziissi
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed Aug 30, 2006 4:53 pm

Re: List of extensions needing upgrading for 1.0.13 compatibility

Post by ziissi » Wed Jul 25, 2007 12:36 pm

astatsPRO 1.0.0 component

User avatar
Rolf
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 121
Joined: Mon Oct 31, 2005 10:00 pm
Location: vienna
Contact:

Re: List of extensions needing upgrading for 1.0.13 compatibility

Post by Rolf » Wed Jul 25, 2007 12:45 pm

infograf768 wrote: To developers & users
Please list here the extensions you experience problems with in 1.0.13.
It is suggested to all to subscribe to this thread to be kept informed.
of course I did!
Or did I miss the line were stands not to give a bit information about what happens in detail?
or the line: don´t tell the others how to quickfix a known problem?
... it´s only a mouseklick away!

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 19693
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: List of extensions needing upgrading for 1.0.13 compatibility

Post by leolam » Wed Jul 25, 2007 1:09 pm

happy_noodle_boy wrote: Does anyone have any idea where and why this is occuring?
Ryan I think this will help you to find something for JCE ?

;)
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
-> Joomla Webmaster Services: gws-webmaster.services

jhoov
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Wed Mar 01, 2006 5:39 pm

phpBB Component 1.2.4 RC4

Post by jhoov » Wed Jul 25, 2007 4:02 pm

phpBB Component 1.2.4 RC4

can not login anymore

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 19693
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: List of extensions needing upgrading for 1.0.13 compatibility

Post by leolam » Wed Jul 25, 2007 4:51 pm

jhoov wrote: phpBB Component 1.2.4 RC4
can not login anymore
is that the Bridge and which one?
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
-> Joomla Webmaster Services: gws-webmaster.services

jhoov
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Wed Mar 01, 2006 5:39 pm

Re: List of extensions needing upgrading for 1.0.13 compatibility

Post by jhoov » Wed Jul 25, 2007 5:52 pm

leolam wrote: is that the Bridge and which one?
It is more than the bridge, it is the modified phpBB that installs into the com_forum directory.  It originally came from http://www.tim-online.nl, but I can't find it there anymore.  Perhaps I need to find a more recent solution. 

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 19693
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: List of extensions needing upgrading for 1.0.13 compatibility

Post by leolam » Thu Jul 26, 2007 1:22 am

jhoov wrote: It is more than the bridge, it is the modified phpBB that installs into the com_forum directory.  It originally came from http://www.tim-online.nl, but I can't find it there anymore.  Perhaps I need to find a more recent solution. 
That was the one developed by Adam v. Dongen aka websmurf. He has left that company and started for himself http://joomla-addons.org /

I think he has stopped development but you can drop him a line at his site. He is very responsive....(normally ;) )

cheers
Leo
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
-> Joomla Webmaster Services: gws-webmaster.services

ISchier
Joomla! Intern
Joomla! Intern
Posts: 81
Joined: Sun Nov 12, 2006 8:44 pm

Re: List of extensions needing upgrading for 1.0.13 compatibility

Post by ISchier » Thu Jul 26, 2007 4:11 am

Looks like AEC Subscription Manager is incompatible with 1.0.13.

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 19693
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: List of extensions needing upgrading for 1.0.13 compatibility

Post by leolam » Thu Jul 26, 2007 5:53 am

ISchier wrote: Looks like AEC Subscription Manager is incompatible with 1.0.13.
no its not AEC it's the admin backend from Joomla as far as we see now.
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
-> Joomla Webmaster Services: gws-webmaster.services

User avatar
happy_noodle_boy
Joomla! Guru
Joomla! Guru
Posts: 692
Joined: Thu Aug 18, 2005 10:32 am
Location: United Kingdom
Contact:

Re: List of extensions needing upgrading for 1.0.13 compatibility

Post by happy_noodle_boy » Thu Jul 26, 2007 8:53 am

just because you're not paranoid, doesn't mean everybody isn't out to get you.
http://www.maketradefair.org

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 19693
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: List of extensions needing upgrading for 1.0.13 compatibility

Post by leolam » Thu Jul 26, 2007 8:56 am

happy_noodle_boy wrote: Fix for JCE 1.1.5 - http://forum.joomla.org/index.php/topic ... #msg920232
Kudos Ryan ;) wow fast as usual!
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
-> Joomla Webmaster Services: gws-webmaster.services

Pmoney
Joomla! Apprentice
Joomla! Apprentice
Posts: 29
Joined: Tue Sep 05, 2006 6:49 pm

Re: List of extensions needing upgrading for 1.0.13 compatibility

Post by Pmoney » Thu Jul 26, 2007 5:41 pm

PollXT 1.22.13
If "cookies enabled" is used in the configuration, when voting, message shows "cookies must be enabled", even if they are enabled.
Short term solution was to disable cookies in the component.
Not sure if this happens in never version (paid) of component either.

Joomlageek2.0
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Fri Jun 01, 2007 7:04 pm

Re: List of extensions needing upgrading for 1.0.13 compatibility

Post by Joomlageek2.0 » Thu Jul 26, 2007 8:01 pm

Is there a downgrade patch to go back to 1.0.12 or do I need to restore from a backup? My backup is a little stale. I hate to lose this much information.

Geas
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Mon Sep 12, 2005 3:06 am
Location: ARG, BA
Contact:

Re: List of extensions needing upgrading for 1.0.13 compatibility

Post by Geas » Thu Jul 26, 2007 10:12 pm

JACLPlus v1.0.8

Edited: JCAPlus v1.0.12 - there's an update for chartered members to JACPlus v1.0.13 <- this one claims to work on J! .13 - didn't test it. Thanks leolam for the reply (a few msgs down)
Last edited by Geas on Fri Jul 27, 2007 3:14 pm, edited 1 time in total.
Gastón Alegre Stotzer

sableholic
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Fri May 05, 2006 4:13 am

Re: List of extensions needing upgrading for 1.0.13 compatibility

Post by sableholic » Fri Jul 27, 2007 2:33 am

Pmoney wrote: PollXT 1.22.13
If "cookies enabled" is used in the configuration, when voting, message shows "cookies must be enabled", even if they are enabled.
Short term solution was to disable cookies in the component.
Not sure if this happens in never version (paid) of component either.
I haven't tested this but I saw on their site this fix:
http://www.joomlaxt.com/forum/view-5978.html#2843

xavierpayne
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Jul 27, 2007 2:34 am

Event Calendar 1.6.4 Looses Login

Post by xavierpayne » Fri Jul 27, 2007 2:45 am

After upgrading to Joomla 1.0.13 (from 1.0.12). When in the control panel (back end) for the Event Calendar component if I add or update an Event after saving the event *any* further action in the joomla control panel results in being forwarded to the login screen.

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 19693
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: List of extensions needing upgrading for 1.0.13 compatibility

Post by leolam » Fri Jul 27, 2007 4:51 am

Geas wrote: JACLPlus v1.0.8
you need to upgrade :
JACLPlus Pro v1.0.13 Component for Joomla! 1.0.13 Stable
Last edited by leolam on Fri Jul 27, 2007 4:59 am, edited 1 time in total.
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
-> Joomla Webmaster Services: gws-webmaster.services

User avatar
Raffù
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Fri Sep 22, 2006 12:15 am

Re: 1.0.13 compatibility- CB 1.0.2•JCE 1.1.5

Post by Raffù » Fri Jul 27, 2007 9:34 am

infograf768 wrote: The 2 I am sure of for now.

Community Builder 1.0.2

JCE 1.1.5
JCE 1.1.6 now available (and working)
--
Raffù

ziissi
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed Aug 30, 2006 4:53 pm

Re: List of extensions needing upgrading for 1.0.13 compatibility

Post by ziissi » Fri Jul 27, 2007 9:59 am

astatsPRO 1.0.0 component (backend authentication problem) fix can be downloaded from
http://www.joomlaportal.de/joomla-kompo ... post473205

However, the forum is in German language and you need to register to obtain the patch.

Patch fixes the following file
administrator/components/com_astatspro/includes/functions.inc.php

eboy
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Thu Jul 12, 2007 8:40 am

Re: List of extensions needing upgrading for 1.0.13 compatibility

Post by eboy » Fri Jul 27, 2007 5:08 pm

Hot property

When i have upgraded to version 1.0.13 registration of hot property brokers have been incorrectly


Locked

Return to “Upgrading - 1.0.x”