Template Contest Entry - [Speedlate] 1.4

This forum is for the Joomla! 1.5 template contest, where people can post their templates.
User avatar
zammbi
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 112
Joined: Fri Jun 15, 2007 8:07 am
Contact:

Template Contest Entry - [Speedlate] 1.4

Post by zammbi » Mon Sep 17, 2007 11:59 am

Speedlate

Speedlate template is a simple, great looking template which is a tableless, elastic layout, with zoom function and easy to use backend options.  It's a 3 column layout with header and footer. Compressed as much as possible (images and the css files) for those 56k users.The template supports I.E5, opera5+, firefox .8+, Netscape 6+, safari 3.
I've have tried to make it stable as possible on all browsers I could test, so it's friendly to 95+% of the visitors.
Valid xhtml 1.0, CSS 3 (when -moz-opacity is turned off), its also passes section 508, Priority 1 and 2 (Tested by hermish.com).

Some features:
  • Typography - Has notice, code, quote styles and more.
  • Built in picture popup using css.
  • Rounded corners, using only one image. Which you can choose the colour in the backend
  • 3 different site colours to choose from.
  • Custom top menu
  • No editing a image for your site title
  • And more...
Image

Backend:

Image

Any feedback will be great, and same with any bugs found.

Version 1.4:
www.speedingpc.com/files/speedlate.zip
Need RC3 to run.

Demo:
No demo sorry.

1.4 update:
-More icons for the top menu.
-New icon images.
-Top menu options in backend.
-Able to choose between strict or transitional.
-Cleaner code.
-Able to choose either a em or px layout.
-Layout is now 100% max width.
-New Love theme
-Background images for the middle and left bars.
-Sorted backend.
-Added footer module.
-Now works with RC3.
-Other tweaks and bug fixes...

1.1.2 update:
-Support the latest SVN.
1.1.1 update:
-Updated the zoom images.
-Able to choose the placement of user1&2.
Last edited by zammbi on Sat Oct 13, 2007 1:41 pm, edited 1 time in total.
http://www.speedingpc.com – Repair/speed up/secure/save space/pimp your computer

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18766
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Template Contest Entry - [Speedlate]

Post by infograf768 » Mon Sep 17, 2007 2:39 pm

Your zip file is corrupted, at least seen by Joomla!
I could uncompress it locally and rezip it to install.
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

User avatar
zammbi
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 112
Joined: Fri Jun 15, 2007 8:07 am
Contact:

Re: Template Contest Entry - [Speedlate]

Post by zammbi » Mon Sep 17, 2007 2:43 pm

I just downloaded it then, and installed it on my test server and it worked well. Could you try downloading it again?
http://www.speedingpc.com – Repair/speed up/secure/save space/pimp your computer

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18766
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Template Contest Entry - [Speedlate]

Post by infograf768 » Mon Sep 17, 2007 2:58 pm

Same... strange.
Error I get with your zip.
        * Unable to write entry


Notice: Undefined index: name in /Library/WebServer/Documents/joomla11new/libraries/joomla/filesystem/archive/zip.php on line 198

Notice: Undefined index: name in /Library/WebServer/Documents/joomla11new/libraries/joomla/filesystem/archive/zip.php on line 198

Notice: Undefined index: _method in /Library/WebServer/Documents/joomla11new/libraries/joomla/filesystem/archive/zip.php on line 336

Notice: Undefined index: _method in /Library/WebServer/Documents/joomla11new/libraries/joomla/filesystem/archive/zip.php on line 342

Notice: Undefined index: csize in /Library/WebServer/Documents/joomla11new/libraries/joomla/filesystem/archive/zip.php on line 344

Notice: Undefined index: name in /Library/WebServer/Documents/joomla11new/libraries/joomla/filesystem/archive/zip.php on line 200

Warning: file_put_contents(/Library/WebServer/Documents/joomla11new/tmp/install_46ee937f7480d/) [function.file-put-contents]: failed to open stream: Is a directory in /Library/WebServer/Documents/joomla11new/libraries/joomla/filesystem/file.php on line 285
??•Unable to find install package•??
What application are you using to zip the package? And on what type of server do you succeed?
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

User avatar
Wendy
Joomla! Hero
Joomla! Hero
Posts: 2008
Joined: Tue Nov 22, 2005 5:20 pm
Location: British Columbia, Canada

Re: Template Contest Entry - [Speedlate]

Post by Wendy » Mon Sep 17, 2007 3:03 pm

zammbi, I had the same problem as infograf768.  When I try to install your .zip I get an error.  If I unzip and rezip on my machine, it installs fine. 
Wendy Robinson
Joomla! Community Leadership Team member

User avatar
zammbi
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 112
Joined: Fri Jun 15, 2007 8:07 am
Contact:

Re: Template Contest Entry - [Speedlate]

Post by zammbi » Mon Sep 17, 2007 3:04 pm

Thats really weird, I'm using IZArc for my zipping. I could try winrar in a sec. I'm running a WAMP5 server.
http://www.speedingpc.com – Repair/speed up/secure/save space/pimp your computer

User avatar
zammbi
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 112
Joined: Fri Jun 15, 2007 8:07 am
Contact:

Re: Template Contest Entry - [Speedlate]

Post by zammbi » Mon Sep 17, 2007 3:14 pm

There I uploaded a new zip file using winrar. Sorry about that. Can someone report back that if this one is working fine?
http://www.speedingpc.com – Repair/speed up/secure/save space/pimp your computer

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18766
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Template Contest Entry - [Speedlate]

Post by infograf768 » Mon Sep 17, 2007 3:31 pm

Works now.
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

User avatar
newart
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3177
Joined: Fri Sep 02, 2005 10:06 am
Location: Solar system - Earth - European Union

Re: Template Contest Entry - [Speedlate]

Post by newart » Tue Sep 18, 2007 9:34 am

sorry but in my IE6 your template is too wide, with big fonts...
former Q&T WorkGroup Joomla member - Italian Translation Team Member

User avatar
zammbi
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 112
Joined: Fri Jun 15, 2007 8:07 am
Contact:

Re: Template Contest Entry - [Speedlate]

Post by zammbi » Tue Sep 18, 2007 11:37 am

Its fine in my mine, I think the problem is that the zoom script I'm using doesn't use the default size and can zoom in on the first load. Report back if setting the default size with the zoom fixes that problem.
Though I found a small bug in the header that I'll fix soon.
Last edited by zammbi on Tue Sep 18, 2007 11:39 am, edited 1 time in total.
http://www.speedingpc.com – Repair/speed up/secure/save space/pimp your computer

User avatar
zammbi
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 112
Joined: Fri Jun 15, 2007 8:07 am
Contact:

Re: Template Contest Entry - [Speedlate]

Post by zammbi » Tue Sep 18, 2007 2:09 pm

Small update:
-Fixed the small header problem in the older IE's when the width was 100em.
-Add a backend option to turn the zoom off/on.
http://www.speedingpc.com – Repair/speed up/secure/save space/pimp your computer

User avatar
MindTooth
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 135
Joined: Mon Sep 05, 2005 11:58 am
Location: Norway
Contact:

Re: Template Contest Entry - [Speedlate]

Post by MindTooth » Tue Sep 18, 2007 2:43 pm

I think you need to fix your images files. They are all at a low res.

User avatar
zammbi
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 112
Joined: Fri Jun 15, 2007 8:07 am
Contact:

Re: Template Contest Entry - [Speedlate]

Post by zammbi » Tue Sep 18, 2007 3:00 pm

Well all images have been compressed to help out 56k users. I have tried to not compress them too much so its noticeable on default zoom.
Which images are you talking about?
I could always add higher res pictures for people who want to use them instead...
http://www.speedingpc.com – Repair/speed up/secure/save space/pimp your computer

User avatar
zammbi
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 112
Joined: Fri Jun 15, 2007 8:07 am
Contact:

Re: Template Contest Entry - [Speedlate]

Post by zammbi » Wed Sep 19, 2007 12:25 pm

1.1 Update:
-Fixed a few problems with modules not collapsing.
-Able to place syndication in the footer or in the left bar or just turn it off.
-Able to turn breadcrumbs off/on.
-Able to change the template width to any size.
-Able to turn the copyright on/off.
-Able to choose your own title or use the default.
-Updated the code to support the latest nightly which fixed a poll bug and the read more.
-Small other updates like spelling errors...
http://www.speedingpc.com – Repair/speed up/secure/save space/pimp your computer

User avatar
newart
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3177
Joined: Fri Sep 02, 2005 10:06 am
Location: Solar system - Earth - European Union

Re: Template Contest Entry - [Speedlate] 1.1

Post by newart » Wed Sep 19, 2007 6:16 pm

good work in progess done, in IE7 is ok maybe you can check another level of zoom, when you enter for the first time in your site, it seems to me a little wider than I'd like to see...  :-\ about your images layout I have only one idea to say:
a layout a little more accessible... for people with eye problems is slightly difficult.

Dont' worry please about my post, it's only for a better (already it is) template! :)
former Q&T WorkGroup Joomla member - Italian Translation Team Member

Woodhead
Joomla! Intern
Joomla! Intern
Posts: 54
Joined: Tue Jul 24, 2007 2:45 pm
Location: Denmark

Re: Template Contest Entry - [Speedlate] 1.1

Post by Woodhead » Wed Sep 19, 2007 7:35 pm

I have a weird problem with this template. Tried to install it and it said: sucessfully installed. Went to the Templat Manager but couln't find it in the list. Thought ... ok maybee I didn't hit the right button so tried to install it again and then it said that the temlate already had been installed ???? Still can't find it in the list.
Im running RC2.

User avatar
zammbi
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 112
Joined: Fri Jun 15, 2007 8:07 am
Contact:

Re: Template Contest Entry - [Speedlate] 1.1

Post by zammbi » Thu Sep 20, 2007 12:14 am

Woodhead wrote: I have a weird problem with this template. Tried to install it and it said: sucessfully installed. Went to the Templat Manager but couln't find it in the list. Thought ... ok maybee I didn't hit the right button so tried to install it again and then it said that the temlate already had been installed ???? Still can't find it in the list.
Im running RC2.
Bah I was afraid of something going wrong if I update to support the latest nightly. I'll see what I can do.
IE7 is ok maybe you can check another level of zoom
I thought it was the script at first, but even when its off the site, it still does it. I don't know why its doing that, I think its a IE7 bug in the way it handles em sizes. Maybe I could make a special case to make IE 7 smaller.
a layout a little more accessible... for people with eye problems is slightly difficult.
Can you expand in what you mean?

Ty for the feedback.
http://www.speedingpc.com – Repair/speed up/secure/save space/pimp your computer

User avatar
zammbi
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 112
Joined: Fri Jun 15, 2007 8:07 am
Contact:

Re: Template Contest Entry - [Speedlate] 1.1

Post by zammbi » Thu Sep 20, 2007 12:39 am

Quote from: Woodhead on Today at 03:35:01 PM
I have a weird problem with this template. Tried to install it and it said: sucessfully installed. Went to the Templat Manager but couln't find it in the list. Thought ... ok maybee I didn't hit the right button so tried to install it again and then it said that the temlate already had been installed Huh? Still can't find it in the list.
Im running RC2.
Bah I was afraid of something going wrong if I update to support the latest nightly. I'll see what I can do.
I just reinstalled RC2 on my comp, and the template is fine... Maybe a Joomla bug? can you uninstall it? Can you report back if its just my template?
Last edited by zammbi on Thu Sep 20, 2007 4:00 am, edited 1 time in total.
http://www.speedingpc.com – Repair/speed up/secure/save space/pimp your computer

User avatar
newart
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3177
Joined: Fri Sep 02, 2005 10:06 am
Location: Solar system - Earth - European Union

Re: Template Contest Entry - [Speedlate] 1.1

Post by newart » Thu Sep 20, 2007 6:59 am

zammbi wrote:
a layout a little more accessible... for people with eye problems is slightly difficult.
some ideas:

Choose a better contrast of colours
Adjust a bit the space pad when starting a text in order to see a right separation between lines and text
Zoom icons more intuitive image
Better images for 56k users
former Q&T WorkGroup Joomla member - Italian Translation Team Member

Woodhead
Joomla! Intern
Joomla! Intern
Posts: 54
Joined: Tue Jul 24, 2007 2:45 pm
Location: Denmark

Re: Template Contest Entry - [Speedlate] 1.1

Post by Woodhead » Thu Sep 20, 2007 9:18 am

Just tried on another RC2 installation and the problem still there. I can see the template in the uninstall list but not in the Template Manager.
I have no problems with all the other 1.5 Templates here. I have both installed and uninstalled a lot of them so it's only this one that have the problem.

User avatar
zammbi
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 112
Joined: Fri Jun 15, 2007 8:07 am
Contact:

Re: Template Contest Entry - [Speedlate] 1.1

Post by zammbi » Thu Sep 20, 2007 10:42 am

Choose a better contrast of colours
Adjust a bit the space pad when starting a text in order to see a right separation between lines and text
Zoom icons more intuitive image
Better images for 56k users
So redo my template? :-\ well I'll see what I can do to improve... Though I am working on another template which I think is totally better then this one,  so depends on how much time I have.
Just tried on another RC2 installation and the problem still there. I can see the template in the uninstall list but not in the Template Manager.
I have no problems with all the other 1.5 Templates here. I have both installed and uninstalled a lot of them so it's only this one that have the problem.
Weird... I'll look into it and see if I can get the same problem... I wonder if anyone else has the same problem?

Edit: I found my demo server is doing the same thing. It's something wrong with the XML file I think. I hopefully have a fix soon.
Last edited by zammbi on Thu Sep 20, 2007 12:05 pm, edited 1 time in total.
http://www.speedingpc.com – Repair/speed up/secure/save space/pimp your computer

User avatar
newart
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3177
Joined: Fri Sep 02, 2005 10:06 am
Location: Solar system - Earth - European Union

Re: Template Contest Entry - [Speedlate] 1.1

Post by newart » Thu Sep 20, 2007 12:38 pm

working in another template better than this one is very exciting... have a good work!  ;)
former Q&T WorkGroup Joomla member - Italian Translation Team Member

User avatar
zammbi
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 112
Joined: Fri Jun 15, 2007 8:07 am
Contact:

Re: Template Contest Entry - [Speedlate] 1.1a

Post by zammbi » Thu Sep 20, 2007 1:17 pm

Ok I solved the error, I just about cried :'( when I found out what was wrong.... The "templateDetails.xml" file was called "templatedetails.xml" After a hour or so editing files trying to find out...
Ah well at least I got my demo server using ftp and its now displaying the language files fine.
working in another template better than this one is very exciting... have a good work!
Thx, yea I knew this one wouldn't match visually to the ones posted. My skills in Photoshop are not the best. But my new template looks great, without being heavy in images still and has most of the advantages of this one. Hopefully this will be my trump card  ;)
Last edited by zammbi on Thu Sep 20, 2007 1:31 pm, edited 1 time in total.
http://www.speedingpc.com – Repair/speed up/secure/save space/pimp your computer

Woodhead
Joomla! Intern
Joomla! Intern
Posts: 54
Joined: Tue Jul 24, 2007 2:45 pm
Location: Denmark

Re: Template Contest Entry - [Speedlate] 1.1a

Post by Woodhead » Thu Sep 20, 2007 1:32 pm

Get this error when trying to install 1.1a after uninstalling 1.1:
JInstaller::install: File '/home/virtual/xxxxxx.xx/public_html/test/tmp/install_46f275d30eb4f/speedlate/templatedetails.xml' does not exist

User avatar
zammbi
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 112
Joined: Fri Jun 15, 2007 8:07 am
Contact:

Re: Template Contest Entry - [Speedlate] 1.1a

Post by zammbi » Thu Sep 20, 2007 1:37 pm

Woodhead wrote: Get this error when trying to install 1.1a after uninstalling 1.1:
JInstaller::install: File '/home/virtual/xxxxxx.xx/public_html/test/tmp/install_46f275d30eb4f/speedlate/templatedetails.xml' does not exist
Woops try now, and ty for the quick report.
Dam case sensitive...
Edit: bah also fixed the print button and email button to use the right case.
Last edited by zammbi on Thu Sep 20, 2007 1:54 pm, edited 1 time in total.
http://www.speedingpc.com – Repair/speed up/secure/save space/pimp your computer

Woodhead
Joomla! Intern
Joomla! Intern
Posts: 54
Joined: Tue Jul 24, 2007 2:45 pm
Location: Denmark

Re: Template Contest Entry - [Speedlate] 1.1b

Post by Woodhead » Thu Sep 20, 2007 1:56 pm

Works - nice work!

User avatar
zammbi
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 112
Joined: Fri Jun 15, 2007 8:07 am
Contact:

Re: Template Contest Entry - [Speedlate] 1.1b

Post by zammbi » Thu Sep 20, 2007 2:01 pm

Woodhead wrote: Works - nice work!
:) And thank you for the report!
http://www.speedingpc.com – Repair/speed up/secure/save space/pimp your computer

Woodhead
Joomla! Intern
Joomla! Intern
Posts: 54
Joined: Tue Jul 24, 2007 2:45 pm
Location: Denmark

Re: Template Contest Entry - [Speedlate] 1.1b

Post by Woodhead » Thu Sep 20, 2007 7:18 pm

No problem. You did the hard work  ;)

web.valuable
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Sat Oct 06, 2007 12:36 pm

Re: Template Contest Entry - [Speedlate] 1.1.2

Post by web.valuable » Fri Oct 12, 2007 7:57 pm

I use xamp on Windows and a subfolder for Joomla! (see below).

There are some problems:

1) When I navigate "Home" via breadcumbs, I come to the root folder (htdocs), not in the htdocs\newera. When I navigate "Home" via main menu, everything is O'k.

2) I receive a warning when error reporting is switched on:

Notice: Undefined property: stdClass::$readmore_text in C:\xampp\htdocs\newera\templates\speedlate\html\com_content\category\blog_item.php on line 102

3) CSS works only in the "Home" location, and doesn't work for any other.

It seems to me all these problems come for the same reason (use of server root path instead of relative links). When I use other templates, everything is O'k.


Best regards

User avatar
zammbi
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 112
Joined: Fri Jun 15, 2007 8:07 am
Contact:

Re: Template Contest Entry - [Speedlate] 1.1.2

Post by zammbi » Sat Oct 13, 2007 2:10 am

Yea this is a old version, I'm working on a 1.4 version. Many many changes will upload it soon.
http://www.speedingpc.com – Repair/speed up/secure/save space/pimp your computer


Locked

Return to “Joomla! 1.5 Template Contest”