TinyMCE Styles Broken?

Need help with a WYSIWYG-editor in Joomla! 1.0.x? This is the place to be.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
QuakerOatz
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Tue Nov 29, 2005 5:52 pm

TinyMCE Styles Broken?

Post by QuakerOatz » Tue Nov 29, 2005 7:11 pm

I can't get TinyMCE to display any styles in the drop down menu. I'm using the latest version of Joomla (1.0.4). I searched the forums and tried various fixes with no effect.

Even explicitly stating the CSS in the mambot settings for TinyMCE, specifically setting "Custom CSS Classes" to /templates/rhuk_solarflare_ii/css/template_css.css had not effect.

I'm also running joomla using MSAS (msas_45_107), which I don't think would make a difference...

I've heard of a hack by referencing your stylesheet in one of the index.php files, but I don't know which one to change. If I can't get this going I guess I can do everything in HTML and lose TinyMCE... but I like the simplicity an ease of use of TinyMCE.

Thanks

gmarques
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Sep 02, 2005 9:15 am

Re: TinyMCE Styles Broken?

Post by gmarques » Wed Dec 14, 2005 11:52 am

I've got the same problem and I don't know how to solve it!

Plesase help us!!  ???

chipw
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 119
Joined: Fri Dec 16, 2005 9:43 pm

Re: TinyMCE Styles Broken?

Post by chipw » Mon Dec 19, 2005 6:43 pm

I've got the same problem as well. :'(

QuakerOatz
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Tue Nov 29, 2005 5:52 pm

Re: TinyMCE Styles Broken?

Post by QuakerOatz » Mon Dec 19, 2005 10:12 pm

WoW how is everyone creating content in Joomla without styles?

I can't say I'm that confident with using Joomla over Mambo with the lack of support for major bugs. This problem would have been fixed quickly with Mambo...

dvance
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Fri Dec 23, 2005 3:16 am

Re: TinyMCE Styles Broken?

Post by dvance » Fri Dec 23, 2005 3:31 am

Could someone please suggest to us brand new Joomla! users another editor  in which styles work correctly?  Styles are absolutely essential.

By the way, I just did a fresh Joomla! v.1.0.4 install today, and the "format" drop-down doesn't work either (although for come reason, that does work on opensourcecms's 1.0.4 demo)...

If the method for defining new styles has changed from Mambo, would someone point to the documentation?  I can't find any.  Thanks!

spacebass5000
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 110
Joined: Sun Nov 20, 2005 7:00 pm

Re: TinyMCE Styles Broken?

Post by spacebass5000 » Fri Jan 13, 2006 7:12 pm

I noticed this only happens when using tinymce from the backend. Frontend use seems fine.

[me=spacebass5000]shrugs[/me]

edit: wait, I take that back, my 1.0.5 install is working whereas my 1.0.4 is not.
Because Joomla ROCKS!!! It f*@cking ROCKS I say!!!

dvance
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Fri Dec 23, 2005 3:16 am

Re: TinyMCE Styles Broken?

Post by dvance » Fri Jan 13, 2006 7:30 pm

This topic was moved to the "Quality and Testing" forum, where the problem was identified and a temporary solution offered...

http://forum.joomla.org/index.php/topic,26290.0.html


Locked

Return to “WYSIWYG Editors - 1.0.x”