Error: Expire date set to 1970 by default

General questions relating to Joomla! 1.5 There are other boards for more specific help on Joomla! features and extensions.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
Locked
User avatar
tresan
Joomla! Ace
Joomla! Ace
Posts: 1010
Joined: Thu Feb 09, 2006 3:00 pm
Location: Odense - DK
Contact:

Error: Expire date set to 1970 by default

Post by tresan » Tue Jan 22, 2008 11:53 pm

On new fresh install of 1.5 Stable.

Have to remove the expire date on all creations of articles or its expired on creation.
Ronni K. G. Christiansen (@redwebdk)
http://www.redcomponent.com/ - One big family of Joomla extentions & templates
http://redweb.dk - Joomla Webdesign & Development
redHOST.dk - 100% Joomla Webhotel - Dansk support med Joomla viden!

 
User avatar
mcsmom
Joomla! Exemplar
Joomla! Exemplar
Posts: 7985
Joined: Thu Aug 18, 2005 8:43 pm
Location: New York
Contact:

Re: Error: Expire date set to 1970 by default

Post by mcsmom » Tue Jan 22, 2008 11:58 pm

Please explain step by step how you created the article.

Frontend or backend?
Did you try to change the expiration date or use the default?
Etc.
So we must fix our vision not merely on the negative expulsion of war, but upon the positive affirmation of peace. MLK 1964.
http://officialjoomlabook.com Get it at http://www.joomla.org/joomla-press-official-books.html Buy a book, support Joomla!.

User avatar
tresan
Joomla! Ace
Joomla! Ace
Posts: 1010
Joined: Thu Feb 09, 2006 3:00 pm
Location: Odense - DK
Contact:

Re: Error: Expire date set to 1970 by default

Post by tresan » Wed Jan 23, 2008 12:23 am

Using backend and it happens on all articles i create.

I have a hunch it might be due to some server variable perhaps - but it didnt happen before Joomla 1.5 stable.

After creation its expired (without me having even touched the field) i then edit the article again and remove the date so it changes to never expire - which i was quite sure its supposed to do from start.
Ronni K. G. Christiansen (@redwebdk)
http://www.redcomponent.com/ - One big family of Joomla extentions & templates
http://redweb.dk - Joomla Webdesign & Development
redHOST.dk - 100% Joomla Webhotel - Dansk support med Joomla viden!

StarShaper
Joomla! Explorer
Joomla! Explorer
Posts: 347
Joined: Wed Sep 27, 2006 11:55 pm

Re: Error: Expire date set to 1970 by default

Post by StarShaper » Wed Jan 23, 2008 12:31 am

tresan wrote: After creation its expired (without me having even touched the field) i then edit the article again and remove the date so it changes to never expire - which i was quite sure its supposed to do from start.
Could you please provide more data?

What about your system settings? Admin->Help

User avatar
tresan
Joomla! Ace
Joomla! Ace
Posts: 1010
Joined: Thu Feb 09, 2006 3:00 pm
Location: Odense - DK
Contact:

Re: Error: Expire date set to 1970 by default

Post by tresan » Wed Jan 23, 2008 12:33 am

PHP bygger aktiveret:  Linux web1 2.6.18-5-vserver-k7 #1 SMP Wed Oct 3 03:04:00 UTC 2007 i686 
Databaseversion:  5.0.32-Debian_7etch4-log 
Databasesammenkøring:  utf8_general_ci 
PHP version:  4.4.7-0.dotdeb.1 
Webserver:  Apache/2.2.3 (Debian) 
Webserver til PHP-grænseflade:  cgi-fcgi 
Joomla!-version:  Joomla! 1.5.0 Production/Stable [ Khepri ] 21-January-2008 23:55 GMT 
Ronni K. G. Christiansen (@redwebdk)
http://www.redcomponent.com/ - One big family of Joomla extentions & templates
http://redweb.dk - Joomla Webdesign & Development
redHOST.dk - 100% Joomla Webhotel - Dansk support med Joomla viden!

StarShaper
Joomla! Explorer
Joomla! Explorer
Posts: 347
Joined: Wed Sep 27, 2006 11:55 pm

Re: Error: Expire date set to 1970 by default

Post by StarShaper » Wed Jan 23, 2008 12:35 am

tresan wrote: PHP bygger aktiveret:  Linux web1 2.6.18-5-vserver-k7 #1 SMP Wed Oct 3 03:04:00 UTC 2007 i686 
Databaseversion:  5.0.32-Debian_7etch4-log 
Databasesammenkøring:  utf8_general_ci 
PHP version:  4.4.7-0.dotdeb.1 
Webserver:  Apache/2.2.3 (Debian) 
Webserver til PHP-grænseflade:  cgi-fcgi 
Joomla!-version:  Joomla! 1.5.0 Production/Stable [ Khepri ] 21-January-2008 23:55 GMT 
This is the 4 message I read about this problem. And it seems that all users are running PHP 4.

I think this belongs to the development bug forum.

User avatar
mcsmom
Joomla! Exemplar
Joomla! Exemplar
Posts: 7985
Joined: Thu Aug 18, 2005 8:43 pm
Location: New York
Contact:

Re: Error: Expire date set to 1970 by default

Post by mcsmom » Wed Jan 23, 2008 1:32 am

I think it is giving you the  beginning of the unix epoch date (1/1/70).

I tried but I could not reproduce.

If you want it never to expire (which is the default) you should have the word Never in the expiration date field.

This worked fine for me. If the field said never, I saved, and when I reopened it still said never.

I then tried clearing the field and saving. On reopening Never was in the field.


Then I tried clearing all of the date fields and saving.
On reopening all of the date fields had returned to the default.



I am running php 4.4.7.
So we must fix our vision not merely on the negative expulsion of war, but upon the positive affirmation of peace. MLK 1964.
http://officialjoomlabook.com Get it at http://www.joomla.org/joomla-press-official-books.html Buy a book, support Joomla!.

theTRON
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Jan 23, 2008 4:25 am

Re: Error: Expire date set to 1970 by default

Post by theTRON » Wed Jan 23, 2008 4:30 am

Hey everyone,

I'm experiencing the same issue on a fresh install of 1.5 Stable and stumbled upon this thread. It's not a huge issue for us, but would be great if it defaulted to 'Never'.

Heres my system-info:

PHP Built on:  Linux ws-13 2.6.16-27-lustre-1.4.10.1.netregistry #3 SMP Wed Nov 7 16:31:25 EST 2007 i686
Database Version: 4.1.22-standard
Database Collation: utf8_general_ci
PHP Version: 4.4.7
Web Server: Zeus/4.3
Web Server to PHP interface: cgi-fcgi
Joomla! Version: Joomla! 1.5.0 Production/Stable [ Khepri ] 21-January-2008 23:55 GMT

StarShaper
Joomla! Explorer
Joomla! Explorer
Posts: 347
Joined: Wed Sep 27, 2006 11:55 pm

Re: Error: Expire date set to 1970 by default

Post by StarShaper » Wed Jan 23, 2008 4:47 am

Now I'm aware of six people who encountered this problem. I don't see any system related connections between this people, except that they all are running PHP 4.  ???

This is pretty strange...
Last edited by StarShaper on Wed Jan 23, 2008 4:50 am, edited 1 time in total.

coolhva
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Wed Jan 23, 2008 7:35 am

Re: Error: Expire date set to 1970 by default

Post by coolhva » Wed Jan 23, 2008 7:37 am

I think that on some systems the default date is set to 1970 instead of 1900.

I found this:

Code: Select all

administrator\components\com_content\controller.php(559):   if (JHTML::_('date', $row->publish_down, '%Y') <= 1969 || $row->publish_down == $db->getNullDate()) {
If you change 1969 to 1970 it works as it is supposed to.

StarShaper
Joomla! Explorer
Joomla! Explorer
Posts: 347
Joined: Wed Sep 27, 2006 11:55 pm

Re: Error: Expire date set to 1970 by default

Post by StarShaper » Wed Jan 23, 2008 2:06 pm

I think this is not the problem. 1970 is just the minimum unix date. The date sould not be below 1970.

I will check this.
Last edited by StarShaper on Wed Jan 23, 2008 6:57 pm, edited 1 time in total.

User avatar
mcsmom
Joomla! Exemplar
Joomla! Exemplar
Posts: 7985
Joined: Thu Aug 18, 2005 8:43 pm
Location: New York
Contact:

Re: Error: Expire date set to 1970 by default

Post by mcsmom » Thu Jan 24, 2008 6:19 am

I'm running php 4.4.7 and I can't reproduce, so I don't think that is the issue.

Can you turn on debug and paste your memory and queries on savign an article here?
So we must fix our vision not merely on the negative expulsion of war, but upon the positive affirmation of peace. MLK 1964.
http://officialjoomlabook.com Get it at http://www.joomla.org/joomla-press-official-books.html Buy a book, support Joomla!.

User avatar
Peter Clements
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 172
Joined: Tue Nov 08, 2005 12:58 pm
Location: Kent, England, UK
Contact:

Re: Error: Expire date set to 1970 by default

Post by Peter Clements » Thu Jan 24, 2008 3:28 pm

I'm also experiencing this problem and have posted my system information in this other thread relating to the issue.

User avatar
mcsmom
Joomla! Exemplar
Joomla! Exemplar
Posts: 7985
Joined: Thu Aug 18, 2005 8:43 pm
Location: New York
Contact:

Re: Error: Expire date set to 1970 by default

Post by mcsmom » Thu Jan 24, 2008 4:11 pm

Can you do the same, turn on debug and post results on saving an article?

Also put error reporting to maximum.
So we must fix our vision not merely on the negative expulsion of war, but upon the positive affirmation of peace. MLK 1964.
http://officialjoomlabook.com Get it at http://www.joomla.org/joomla-press-official-books.html Buy a book, support Joomla!.

User avatar
Peter Clements
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 172
Joined: Tue Nov 08, 2005 12:58 pm
Location: Kent, England, UK
Contact:

Re: Error: Expire date set to 1970 by default

Post by Peter Clements » Thu Jan 24, 2008 4:59 pm

mcsmom wrote: Can you do the same, turn on debug and post results on saving an article?

Also put error reporting to maximum.
Here you go, I'd set error reporting to maximum anyway while the site was being developed, this is the debug output from saving an article:
Profile Information
Application afterLoad: 0.003 seconds, 0.34 MB
Application afterInitialise: 0.079 seconds, 2.70 MB
Application afterRoute: 0.079 seconds, 2.70 MB
Application afterDispatch: 0.165 seconds, 5.75 MB
Application afterRender: 0.226 seconds, 6.49 MB
Memory Usage
6849408
18 queries logged

  1.
      SELECT *
        FROM bcsp_session
        WHERE session_id = '99e3a9549ef2d1c8058f7b4331f0111a'
  2.
      DELETE
        FROM bcsp_session
        WHERE ( time = 1
        AND access -1
        AND c.state -2
        GROUP BY u.name
        ORDER BY u.name
  12.
      SELECT template
        FROM bcsp_templates_menu
        WHERE client_id = 1
        AND menuid = 0
  13.
      SELECT id, title, module, position, content, showtitle, control, params
        FROM bcsp_modules AS m
        LEFT JOIN bcsp_modules_menu AS mm
        ON mm.moduleid = m.id
        WHERE m.published = 1
        AND m.access "com_frontpage"
        AND `option` "com_media"
        AND enabled = 1
        ORDER BY ordering, name
  17.
      SELECT COUNT(*)
        FROM bcsp_messages
        WHERE state = 0
        AND user_id_to = 63
  18.
      SELECT COUNT( session_id )
        FROM bcsp_session
        WHERE guest 1

Language Files Loaded

    * /var/www/vhosts/[DOMAIN NAME]/httpdocs/administrator/language/en-GB/en-GB.ini 1
    * /var/www/vhosts/[DOMAIN NAME]/httpdocs/administrator/language/en-GB/en-GB.plg_system_debug.ini 1
    * /var/www/vhosts/[DOMAIN NAME]/httpdocs/administrator/language/en-GB/en-GB.com_content.ini 1
    * /var/www/vhosts/[DOMAIN NAME]/httpdocs/administrator/language/en-GB/en-GB.tpl_khepri.ini 1
    * /var/www/vhosts/[DOMAIN NAME]/httpdocs/administrator/language/en-GB/en-GB.mod_submenu.ini 1
    * /var/www/vhosts/[DOMAIN NAME]/httpdocs/administrator/language/en-GB/en-GB.com_content.menu.ini
    * /var/www/vhosts/[DOMAIN NAME]/httpdocs/administrator/language/en-GB/en-GB.mod_title.ini 1
    * /var/www/vhosts/[DOMAIN NAME]/httpdocs/administrator/language/en-GB/en-GB.mod_toolbar.ini 1
    * /var/www/vhosts/[DOMAIN NAME]/httpdocs/administrator/language/en-GB/en-GB.mod_menu.ini 1
    * /var/www/vhosts/[DOMAIN NAME]/httpdocs/administrator/language/en-GB/en-GB.com_contact.menu.ini 1
    * /var/www/vhosts/[DOMAIN NAME]/httpdocs/administrator/language/en-GB/en-GB.com_poll.menu.ini 1
    * /var/www/vhosts/[DOMAIN NAME]/httpdocs/administrator/language/en-GB/en-GB.com_search.menu.ini 1
    * /var/www/vhosts/[DOMAIN NAME]/httpdocs/administrator/language/en-GB/en-GB.com_banners.menu.ini 1
    * /var/www/vhosts/[DOMAIN NAME]/httpdocs/administrator/language/en-GB/en-GB.com_newsfeeds.menu.ini 1
    * /var/www/vhosts/[DOMAIN NAME]/httpdocs/administrator/language/en-GB/en-GB.com_weblinks.menu.ini 1
    * /var/www/vhosts/[DOMAIN NAME]/httpdocs/administrator/language/en-GB/en-GB.mod_status.ini 1

Untranslated strings

None
I've replaced a few bits of data with [SQUARE BRACKETS].

User avatar
ianmac
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4784
Joined: Sat Sep 24, 2005 11:01 pm
Location: Toronto, Canada

Re: Error: Expire date set to 1970 by default

Post by ianmac » Thu Jan 24, 2008 6:22 pm

Can you try the patch attached to this email?

Index: administrator/components/com_content/controller.php
===================================================================
--- administrator/components/com_content/controller.php (revision 9954)
+++ administrator/components/com_content/controller.php (working copy)
@@ -440,7 +440,7 @@
$row->ordering = 0;
$row->images = array ();
$row->publish_up = $createdate->toUnix();
- $row->publish_down = JText::_('Never');
+ $row->publish_down = $nullDate;
$row->creator = '';
$row->created = $createdate->toUnix();
$row->modified = $nullDate;

Ian
You do not have the required permissions to view the files attached to this post.

User avatar
Peter Clements
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 172
Joined: Tue Nov 08, 2005 12:58 pm
Location: Kent, England, UK
Contact:

Re: Error: Expire date set to 1970 by default

Post by Peter Clements » Fri Jan 25, 2008 9:15 am

OK, how do I apply that patch?  I guess I need some sort of application capable of understanding what it's saying?

Is it as simple as swapping the line "$row->publish_down = JText::_('Never');" for the line "$row->publish_down = $nullDate;"?  Which might not the the 'proper' way of doing it but if it will provide a result that might help then I'll do that.

(I've already sorted it using the 'fix' listed in this post but can easily revert back to the original.)

 

Locked

Return to “General Questions/New to Joomla! 1.5”