Problems with Arabic language on Multilingual site.

How to support more than one language on your site.

Moderator: General Support Moderators

Locked
Gizzy
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Sat Sep 10, 2005 8:50 pm
Location: Belgium

Problems with Arabic language on Multilingual site.

Post by Gizzy » Mon Jan 28, 2008 12:38 am

Hi Guys,

I am facing some major problem wulie trying to setup a Multilingual website using joomfish. There are 2 languages on the site, English and Arabic. English is the main langauge.

Now I have tested the site using wamp on the lolcahost. So then I transfered the same site on the server and also imported the database, but after the tranfer the Arabic language is still not showing up properly. It shows stange charachters.

I followed the different thread regarding making a joomla site completely utf8 compliant, etc. And it works fine on the PC's locahost.
If anyone know what this could be causing or what I am doing wrong then please do share your thoughts and experience.

I can read the arabic language but don't understand what is written/said, this is why I am posting this in the egnlish section.

the url to the site is: http://www.nsba.nl


Thnaks,
Gizzy.
Last edited by Gizzy on Mon Jan 28, 2008 12:44 am, edited 1 time in total.

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18869
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Problems with Arabic language on Multilingual site.

Post by infograf768 » Wed Jan 30, 2008 4:43 pm

Arabic displays OK here for this url.
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

Gizzy
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Sat Sep 10, 2005 8:50 pm
Location: Belgium

Re: Problems with Arabic language on Multilingual site.

Post by Gizzy » Thu Jan 31, 2008 10:42 am

Thanks.

I managed to fix it myself in the mean time. Though I see that the titles are still aligned to the left instead of being on the right side.

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18869
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Problems with Arabic language on Multilingual site.

Post by infograf768 » Thu Jan 31, 2008 11:19 am

To align them to right, you have to modifiy your CSS to use rtl
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

mmg_16
Joomla! Apprentice
Joomla! Apprentice
Posts: 39
Joined: Wed Mar 16, 2011 6:32 am

Re: Problems with Arabic language on Multilingual site.

Post by mmg_16 » Sun Jun 05, 2011 1:37 pm

Hey can you guide me how to translate my site fromenglish to arabic using a link in the front page? I installed joom!fish,arabic language pack but on activating the arabic link page simply moves RTL direction.Text is not translated to arabic at all


Locked

Return to “Joom!Fish and Multilingual Sites”