mod_xxxx problems with CentOS 5.1

Need help installing Joomla! 1.5? For all Joomla! 1.5 installation issues please use this forum.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Tue Jun 17, 2008 3:29 am

mod_xxxx problems with CentOS 5.1

Postby wireless_tom » Tue Jun 17, 2008 4:03 am

Greetings - Newbie... please bear with me. I'm trying to configure a server for a new installation. Its a CentOS host running on a dell rackmount. I'm using the latest builds of Apache, MySQL and PHP. I've got all the obvious packages installed for each (using the package management tool).

It seems like the 3 extension pre-requisites for for Joomla are depreciated in the lastest builds of PHP (mod_mysql /mod_xml / mod_zlib), that is they don't install anything in the extensions area now in the php.ini. In the same ini I noted the extensions folder, so I looked there and I see .so files. There is one called, but its not linked in the ini/called out with the older model of calling an extension, i.e., further research on an RH 4 host shows the same behavior. I've read online in PHP that the ZLIB is now integrated into the core PHP but not sure if thats confirmed anywhere.

.... so I'm both not sure if this is even the area/thing I should be using to get that particular pre-req installed. Am I on the write track?

Anyone have any recent experience installing this on a new Redhat 5 system (please note, CentoS is the redistribution of Redhat, so its ensentially the same OS as the payware, just without the RH logos).

Here's the basics:
Linux host1 2.6.18-53.1.21.el5 #1 SMP Tue May 20 09:35:07 EDT 2008 x86_64 x86_64 x86_64 GNU/Linux
Apache version 2.2.3
MySQL version 5.0.22
PHP version 5.1.6

Thanks for any help/sorry for the book. I just didn't see anyone in the forums with the same issues with newer versions of PHP.


User avatar
Joomla! Apprentice
Joomla! Apprentice
Posts: 31
Joined: Mon Aug 22, 2005 4:06 am

Re: mod_xxxx problems with CentOS 5.1

Postby cdbragg » Thu Jul 24, 2008 5:41 am

Hi Tom,

I've just installed Joomla on a fresh CentOS 5 installation... and was having trouble with the pre-installation check telling me that MySQL wasn't supported.

Tried lots of things... but eventually found a post somewhere that told me the following:

    Check /etc/php.ini to determine the extension_dir where php modules are located. It was ‘/usr/lib/php/modules’ on my machine.
    Check if was present in the modules directory.
    Add a ‘’ entry in php.ini

That’s it. MySQL works from PHP now. phpinfo() still shows that the configuration is –without-mysql. However there is now a mysql section in the output of phpinfo().
Hope this helps.

I got this snippet from ... -centos-41 and even though I was in CentOS 5 it has worked for me and the installation went ahead with no further troubles.

Perhaps there is something similar with the other bits? Good luck.


Return to “Installation 1.5”

Who is online

Users browsing this forum: No registered users and 8 guests