# JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Need help with the Administration of your Joomla! 1.5 site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
User avatar
kmk
Joomla! Apprentice
Joomla! Apprentice
Posts: 28
Joined: Sat Aug 18, 2007 4:17 am
Location: Abbotsford, BC, Canada
Contact:

# JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by kmk » Wed Aug 06, 2008 11:03 pm

# JFTP::mkdir: Bad response
# JFTP::chmod: Bad response
# JFTP::store: Bad response
# Warning! Failed to move file

Can someone from the Joomla core team please step up to the plate and offer a viable solution to the above noted problem encountered by myself and many others which occurs when attempting to install modules, plugins, etc. in Joomla 1.5.5? To date, no remedy offered in any other post that I have seen on the subject has worked for me. My site, http://kennethmontgomerykeillor.com, is hosted by http://ixwebhosting.com. Any request for more information to pinpoint and resolve this problem once and for all is welcome.
Thank you.

User avatar
ooffick
Joomla! Master
Joomla! Master
Posts: 11405
Joined: Thu Jul 17, 2008 3:10 pm
Location: Ireland
Contact:

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by ooffick » Thu Aug 07, 2008 10:45 am

Do you have the Joomla FTP Layer enabled? (Global Configuration > Server > FTP Settings)?
Does that FTP user have permission to create a file or folder?

Olaf
Olaf Offick - Global Moderator
learnskills.org

User avatar
kmk
Joomla! Apprentice
Joomla! Apprentice
Posts: 28
Joined: Sat Aug 18, 2007 4:17 am
Location: Abbotsford, BC, Canada
Contact:

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by kmk » Thu Aug 07, 2008 6:21 pm

Currently, the FTP layer is enabled. (Global Configuration > Server > FTP Settings)
Attempting to install a module produces the following message:

JFTP::mkdir: Bad response
JFTP::chmod: Bad response
JFTP::store: Bad response
Warning! Failed to move file

When the FTP layer is disabled, the message reads as follows:

# JFolder::create: Could not create directory
# Warning! Failed to move file

I have precisely the same FTP settings in 'Global Configuration > Server > FTP Settings' as I do in my 'FireFTP' client which is an addon integrated into the Firefox 3 browser. With FireFTP I can freely create files and folders on the server. Permissions for all directories and files are set to 755.

User avatar
ooffick
Joomla! Master
Joomla! Master
Posts: 11405
Joined: Thu Jul 17, 2008 3:10 pm
Location: Ireland
Contact:

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by ooffick » Thu Aug 07, 2008 6:42 pm

Hmm, well, how do you install a module by uploading it, or by installing it using the URL?
If you only tried one of them could you try the other method as well?

Could you try to set the permission for the "modules" directory to 777, so that it is accessible by the web-server.
You might need to set some other directories as well.

Olaf
Olaf Offick - Global Moderator
learnskills.org

User avatar
kmk
Joomla! Apprentice
Joomla! Apprentice
Posts: 28
Joined: Sat Aug 18, 2007 4:17 am
Location: Abbotsford, BC, Canada
Contact:

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by kmk » Thu Aug 07, 2008 7:59 pm

I have only ever used the 'Upload Package File' installation method before. Following your instruction, I set both the 'plugins' and 'modules' directories to 777 and tried to install a plugin and then a module using both the 'Upload Package File' and 'Install from URL' methods with each. Here are the results:

Install plugin - 'Upload Package File' installation method:

# JFTP::mkdir: Bad response
# JFTP::chmod: Bad response
# JFTP::store: Bad response
# Warning! Failed to move file

'Install from URL' method:

* JFTP::mkdir: Bad response
* JFTP::chmod: Bad response
* JFTP::write: Bad response

Notice: Array to string conversion in /****/****/****/****/kennethmontgomerykeillor.com/libraries/joomla/installer/helper.php on line 65 (path replaced by asterisks by me)
Unable to find install package

Install module - 'Upload Package File' installation method:

# JFTP::mkdir: Bad response
# JFTP::chmod: Bad response
# JFTP::store: Bad response
# Warning! Failed to move file

'Install from URL' method:

* JFTP::mkdir: Bad response
* JFTP::chmod: Bad response
* JFTP::write: Bad response

Notice: Array to string conversion in /****/****/****/****/kennethmontgomerykeillor.com/libraries/joomla/installer/helper.php on line 65
Unable to find install package

Pertinent to:

"You might need to set some other directories as well."

Kindly elaborate upon and clarify this instruction using detailed specifics including the naming of any and all said "other directories". Thank you.

User avatar
kmk
Joomla! Apprentice
Joomla! Apprentice
Posts: 28
Joined: Sat Aug 18, 2007 4:17 am
Location: Abbotsford, BC, Canada
Contact:

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by kmk » Fri Aug 08, 2008 1:42 am

I sincerely appreciate the efforts of Olaf to help resolve this problem, albeit unsuccessfully, so far. I am left no option but to repeat my original appeal.

# JFTP::mkdir: Bad response
# JFTP::chmod: Bad response
# JFTP::store: Bad response
# Warning! Failed to move file

Can someone from the Joomla core team please step up to the plate and offer a viable solution to the above noted problem encountered by myself and many others which occurs when attempting to install modules, plugins, etc. in Joomla 1.5.5? To date, no remedy offered in any other post that I have seen on the subject has worked for me. My site, http://kennethmontgomerykeillor.com, is hosted by http://ixwebhosting.com. Any request for more information to pinpoint and resolve this problem, once and for all, is welcome.
Thank you.

User avatar
ooffick
Joomla! Master
Joomla! Master
Posts: 11405
Joined: Thu Jul 17, 2008 3:10 pm
Location: Ireland
Contact:

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by ooffick » Fri Aug 08, 2008 8:54 am

Can you try the following:
  1. Login to the admin interface
  2. Click on Help
  3. Click on System Info
  4. Click on Directory Permissions
  5. You will see a list of Directories which are writable/unwritable
  6. Can you check each one which is unwritable and set it's permission to 777
Or you can follow the steps here:
http://docs.joomla.org/How_to_solve_Ins ... on_Manager

Olaf
Olaf Offick - Global Moderator
learnskills.org

User avatar
kmk
Joomla! Apprentice
Joomla! Apprentice
Posts: 28
Joined: Sat Aug 18, 2007 4:17 am
Location: Abbotsford, BC, Canada
Contact:

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by kmk » Fri Aug 08, 2008 5:11 pm

"Can you try the following:

1. Login to the admin interface
2. Click on Help
3. Click on System Info
4. Click on Directory Permissions
5. You will see a list of Directories which are writable/unwritable
6. Can you check each one which is unwritable and set it's permission to 777".

Following your above instruction, I have confirmed that all directories are "Writable".
It is not the first time I have checked this.

I will now move on to:

"Or you can follow the steps here:
http://docs.joomla.org/How_to_solve_Ins ... on_Manager"

johnnybgoodwin
Joomla! Intern
Joomla! Intern
Posts: 65
Joined: Fri Apr 27, 2007 3:18 pm

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by johnnybgoodwin » Mon Aug 11, 2008 3:26 am

I have exactly the same problem, and it just started. A couple of days ago I could install anything, now I can't install anything. I tried the url install too, and also got an error with that.
Since I have php 5 directory permissions is not the issue (plus nothing changed in two days, that I know about). Directory ownerships also look right.
Mystery?
Appreciate any help.

John

User avatar
kmk
Joomla! Apprentice
Joomla! Apprentice
Posts: 28
Joined: Sat Aug 18, 2007 4:17 am
Location: Abbotsford, BC, Canada
Contact:

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by kmk » Mon Aug 11, 2008 3:41 am

I'm not an expert on this subject, but for a start I suggest you follow the steps here:

http://docs.joomla.org/How_to_solve_Ins ... on_Manager

pertaining to 'path.php' and let me know what happens.

Degira
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Sat Aug 16, 2008 1:02 am

Solved

Post by Degira » Sat Aug 16, 2008 1:35 am

I try to explain how to solve that problem..

First Step: Go to Admin Panel and Chose System Info under Help Section and check directory permisions..
--Help--Sytem info--Directory Permissions
And make all directories writable which is unwritable.

in example, this is our ftp server: ftp.example.com and your webserver is http://www.example.com
Connect to your ftp server and Open your configuration file..
When you connected ftp server,your files stored under www or public_html folder,so you must chance:

var $ftp_root = 'www'; or var $ftp_root = 'public_html';

It cant be blank,if you dont fill this so everything goes wrong,you cant install anything.

If you installed joomla under subdomain then you should do it like this:

var $ftp_root = 'www/subdomainfolder'; or var $ftp_root = 'public_html/subdomainfolder'; No trailing slash!


for http://www.example.com

var $ftp_host = 'ftp.example.com';
var $ftp_port = '21';
var $ftp_user = 'ftpuser';
var $ftp_pass = 'ftppass';
var $ftp_root = 'www';
var $ftp_enable = '1';


for http://subdomain.example.com

var $ftp_host = 'ftp.example.com';
var $ftp_port = '21';
var $ftp_user = 'ftpuser';
var $ftp_pass = 'ftppass';
var $ftp_root = 'www/subdomainfolder';
var $ftp_enable = '1';


After this problem has been fixed:) Its not only for modules plugins or components.
You will never see error message for anything again.

Salam from Turkey..
Last edited by Degira on Thu Aug 21, 2008 10:59 pm, edited 1 time in total.

mythrii123
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu Aug 21, 2008 9:41 am

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by mythrii123 » Thu Aug 21, 2008 9:53 am

Can any body help me out to install a component in 1.5

I am getting this error while installation


* JFTP::mkdir: Bad response
* JFTP::chmod: Bad response
* JFTP::store: Bad response
* Warning! - Failed to move file

i had searched many forums.

enabled FTP
GAVE 777 PERMISSIONS TO ALMOST ALL FOLDERS
CHECKED TEH CONFIGURATION FILE


Please help me to install the component

jamesls
Joomla! Intern
Joomla! Intern
Posts: 74
Joined: Wed Oct 03, 2007 11:02 am
Location: Castleblayney
Contact:

Re: Solved

Post by jamesls » Fri Aug 22, 2008 1:42 pm

I followed this and all works fine now. thanks Degira
Degira wrote:I try to explain how to solve that problem..

First Step: Go to Admin Panel and Chose System Info under Help Section and check directory permisions..
--Help--Sytem info--Directory Permissions
And make all directories writable which is unwritable.

in example, this is our ftp server: ftp.example.com and your webserver is http://www.example.com
Connect to your ftp server and Open your configuration file..
When you connected ftp server,your files stored under www or public_html folder,so you must chance:

var $ftp_root = 'www'; or var $ftp_root = 'public_html';

It cant be blank,if you dont fill this so everything goes wrong,you cant install anything.

If you installed joomla under subdomain then you should do it like this:

var $ftp_root = 'www/subdomainfolder'; or var $ftp_root = 'public_html/subdomainfolder'; No trailing slash!


for http://www.example.com

var $ftp_host = 'ftp.example.com';
var $ftp_port = '21';
var $ftp_user = 'ftpuser';
var $ftp_pass = 'ftppass';
var $ftp_root = 'www';
var $ftp_enable = '1';


for http://subdomain.example.com

var $ftp_host = 'ftp.example.com';
var $ftp_port = '21';
var $ftp_user = 'ftpuser';
var $ftp_pass = 'ftppass';
var $ftp_root = 'www/subdomainfolder';
var $ftp_enable = '1';


After this problem has been fixed:) Its not only for modules plugins or components.
You will never see error message for anything again.

Salam from Turkey..

rodrigth
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Sat Aug 23, 2008 2:20 am

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by rodrigth » Sat Aug 23, 2008 2:23 am

i have followed all of the tips and ideas on this thread and have exhausted everything i can find on the internet... here is my present config file:

var $log_path = '/home/jorod/public_html/public_html/crest-resort/logs';
var $tmp_path = '/home/jorod/public_html/public_html/tmp';

var $ftp_enable = '1';
var $ftp_host = 'ftp.crest-resort.com';
var $ftp_port = '21';
var $ftp_user = 'ftp-user';
var $ftp_pass = 'ftp-userpass';
var $ftp_root = '/home/jorod/public_html/public_html/crest-resort/';

var $MetaAuthor = '1';
var $MetaTitle = '1';
var $lifetime = '15';
var $session_handler = 'database';
var $password = 'my password is in here'
}
?>

Degira
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Sat Aug 16, 2008 1:02 am

This is sample correct configuration file..

Post by Degira » Sat Aug 23, 2008 3:45 am

To configure log and tmp path,use this script: open notepad and paste code and save it as path php or something else,and upload it into your joomla installation and run..

<?php
//Gets the document root
$root = getenv("DOCUMENT_ROOT") ;
Echo $root;
?>


when i ran this script i got this reply from server:

/home/jorod/public_html/crest-resort/

so ,log_path and tmp path is:

var $log_path = '/home/jorod/public_html/crest-resort/logs';
var $tmp_path = '/home/jorod/public_html/crest-resort/tmp';







Finally:

var $log_path = '/home/jorod/public_html/crest-resort/logs';
var $tmp_path = '/home/jorod/public_html/crest-resort/tmp';
var $live_site = 'http://www.crest-resort.com';
var $offset = '0';
var $caching = '0';
var $cachetime = '15';
var $cache_handler = 'file';
var $memcache_settings = array();
var $ftp_enable = '1';
var $ftp_host = 'ftp.crest-resort.com';
var $ftp_port = '21';
var $ftp_user = 'ftp-user';
var $ftp_pass = 'ftp-password';
var $ftp_root = '/public_html/crest-resort';


You can figure out how i edited config file..Good luck..

rodrigth
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Sat Aug 23, 2008 2:20 am

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by rodrigth » Sat Aug 23, 2008 7:04 am

thank you very much! it worked! idk what setting i had wrong...

festim
Joomla! Apprentice
Joomla! Apprentice
Posts: 16
Joined: Thu Apr 12, 2007 10:21 pm

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by festim » Tue Sep 23, 2008 2:52 pm

I had the same problem with the above errors and following Degira's instructions everything worked out well. These problems seem to happen when you trying to restore your site to another host as it will keep the same settings as the old one.
If you have FTP layer enabled you'll need to dissable it after you follow the instructions coz it wont work otherwise.

Festim

Degira
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Sat Aug 16, 2008 1:02 am

SOLVED : # JFTP::ERRORS

Post by Degira » Tue Sep 23, 2008 8:46 pm

Dear friends..Its not complicate.Just simple.If you are using php then you should know that the diffrence between document root and ftp server root.Only that is the point.I give you example using my configuration file..

Recommended:
1.Go to Admin Panel
2.--Help--Sytem info--Directory Permissions
Give right permissions to directories (if marked red,it means you must change permissions to CHMOD 777)
3.After its done,check directory permissions again.If all lines marked green,then everything ok.
4.Do not try to enabl ftp layer in admin panel,because configuration file is unwritable,so you must change it manually,connect via ftp and do it,
var $ftp_enable = '1';
You dont need to chmod to configuration file because you editing manually.

5.How you can see that where is your document root on the server?..
Open notepad and paste this code :

<?php
//Gets the document root
$root = getenv("DOCUMENT_ROOT") ;
Echo $root;
?>

And save this file as root.php or something you want as *.php

Upload it to your joomla installation directory and run on your website..
When i run it,i get this code

/home/yuroecom/public_html/v2 Its document root,not ftp server root!!
So its my document root ,then i can edit lines like this,
var $log_path = '/home/yuroecom/public_html/v2/logs';
var $tmp_path = '/home/yuroecom/public_html/v2/tmp';

6. Now i connect to my ftp server(im using flashfxp)
When i connected im here ''/'' means im in ftp server root.
Then i enter public_html,and after v2 directory to access my joomla installation.
And my joomla installation in the flash..

I checking ftp software adress bar and see this path:
''/public_html/v2/''

So lets see that the difrence:
/home/yuroecom/public_html/v2 document root
/public_html/v2/ ftp server root for joomla installation

So im using this line ( /home/yuroecom/public_html/v2 )only for tmp and cache directory setting in configuration file.Because its asking me what is document root of tmp and cache directories..
You dont us this part for ftp server settings /home/yuroecom

7. lets edit ftp server root lines in configuration file..
Then we use that ''/public_html/v2/'' ftp server root for joomla installation

See that joomla doesnt ask ftp server root,asking ftp server root for joomla installation which means where is our joomla installation on ftp server!!

var $ftp_host = 'ftp.host.com';
var $ftp_port = '21';
var $ftp_user = 'ftpuser';
var $ftp_pass = 'ftppass';
var $ftp_root = ' public_html/v2 ';
var $ftp_enable = '1';


Its done..
Do not forget CHMOD 644 configuration.php
I dont know how to explain it more detailed.Because its very simple..Its not a problem about joomla.Its problem with our php knowledge..I hope it helps you.
All other solutiouns posibly melt your mind. Only use this.

lelando
Joomla! Apprentice
Joomla! Apprentice
Posts: 31
Joined: Mon Dec 17, 2007 8:33 am

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by lelando » Mon Oct 20, 2008 7:27 am

after following one of the links earlier in this string, I found a solution that took care of my problem. Go to your Global Configuration > Server > Server Settings > Path to Temp Folder. For some reason, mine didn't match the current server, but the development server. That was f'ing everything up. As soon as I altered the path to reflect the correct path, then everything worked perfectly!

How do you get the correct path, you ask? Make a text file, and put this code into it:

Code: Select all

<?php
  echo getcwd();
?>
and save the file as path.php. Upload it to the root folder of your joomla install.

Now navigate your browser to http://path.to.joomla/path.php. Copy the path that shows up in your browser. Paste it into the 'path to temp folder' field mentioned above, and add "/tmp" (without the quotes) after the path. Click "Save".

If your problem was like mine, that should solve it.

If your problem is due to a different source, then I wish you luck. Good luck.

Cheers.

diskj
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Nov 20, 2008 12:05 am

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by diskj » Mon Dec 22, 2008 10:05 pm

PosternB you are a God Send.. I have spent over a week, many hours, Hundreds of posts and a lot of money buying Dreamweaver and Ipswitch ftp so I can upload the files, once changed or updated, all to no avail. And now I find your post and all my problems are solved.

Thank you very much indeed.

User avatar
verticalgrain
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 105
Joined: Mon Dec 01, 2008 4:16 am
Contact:

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by verticalgrain » Sat Dec 27, 2008 7:24 pm

I encountered this same problem, and the solution was also in the path to the tmp folder.

I developed the site on a linux server, on which the path to the tmp folder was ./tmp . I then transferred the site to my clients server, which was a windows IIS server. This is when I encountered the problem, as ./tmp no longer worked.

Eventually I found the right path, which was E:/*****/***********/tmp . I found this path through the Joomla backend, by going to help, system info, PHP information, and looking for the PATH_TRANSLATED variable. The path here was E:/*****/***********/index.php, so I just modified it to be E:/*****/***********/tmp and that worked like a charm.

Thanks to all the posters in this topic for pointing me in the right direction.

User avatar
shanDB
Joomla! Intern
Joomla! Intern
Posts: 70
Joined: Tue Nov 11, 2008 9:31 am

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by shanDB » Thu Feb 12, 2009 1:49 pm

posternb wrote:after following one of the links earlier in this string, I found a solution...
You are a champion!!
After spending the last 24 hours trying to solve this problem, I finally came accross your solution - and it worked!!

:D

User avatar
verticalgrain
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 105
Joined: Mon Dec 01, 2008 4:16 am
Contact:

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by verticalgrain » Thu Feb 12, 2009 5:13 pm

A few couple of very experienced Joomla users told me the path to the tmp directory often causes issues like this and is usually the first thing they look at.

Degira
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Sat Aug 16, 2008 1:02 am

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by Degira » Fri Feb 13, 2009 6:39 am

Already solved..

johnsten
Joomla! Intern
Joomla! Intern
Posts: 54
Joined: Thu Nov 22, 2007 9:55 pm

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by johnsten » Fri Feb 20, 2009 11:53 am

verticalgrain wrote:I encountered this same problem, and the solution was also in the path to the tmp folder.

I developed the site on a linux server, on which the path to the tmp folder was ./tmp . I then transferred the site to my clients server, which was a windows IIS server. This is when I encountered the problem, as ./tmp no longer worked.

Eventually I found the right path, which was E:/*****/***********/tmp . I found this path through the Joomla backend, by going to help, system info, PHP information, and looking for the PATH_TRANSLATED variable. The path here was E:/*****/***********/index.php, so I just modified it to be E:/*****/***********/tmp and that worked like a charm.

Thanks to all the posters in this topic for pointing me in the right direction.
I can't find the PATH_TRANSLATED php information.

User avatar
verticalgrain
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 105
Joined: Mon Dec 01, 2008 4:16 am
Contact:

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by verticalgrain » Fri Feb 20, 2009 4:44 pm

Do you see any paths at all in the PHP information page under the help tab and system info?

joeker
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Mon Feb 16, 2009 5:27 pm

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by joeker » Tue Mar 10, 2009 7:46 pm

Another quick note, instead of changing write permissions to 777, which is a security risk on a shared webserver, you can try and changing the owner of all your directories and files to the webserver user, this will allow the webserver to create and write files and directories without opening up your site to other users on the server

User avatar
verticalgrain
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 105
Joined: Mon Dec 01, 2008 4:16 am
Contact:

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by verticalgrain » Tue Mar 10, 2009 10:11 pm

Good point - and I've always been curious and never figured this out, but would my webserver username be the same as my ftp login?

Also what would the "group" generally be?

riccardosl
Joomla! Apprentice
Joomla! Apprentice
Posts: 43
Joined: Tue Jan 06, 2009 7:28 pm

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by riccardosl » Wed Mar 25, 2009 4:05 pm

I'm running joomla version 1.5.9 on PHP 5 but FTP Layer to install modules works only with FTP disabled.

It' also for you?

User avatar
verticalgrain
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 105
Joined: Mon Dec 01, 2008 4:16 am
Contact:

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by verticalgrain » Thu Mar 26, 2009 12:56 pm

I was having that problem as well for awhile, until I got the tmp directory correct. Then the ftp file layer worked I believe.


Locked

Return to “Administration 1.5”