Error loading feed data - JF2.0 -SOLVED

General questions regarding the use of languages in Joomla! 1.5.

Moderator: General Support Moderators

Locked
hrga
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Mon Sep 01, 2008 4:39 pm

Error loading feed data - JF2.0 -SOLVED

Post by hrga » Mon Sep 01, 2008 4:46 pm

Hy everyone!

Is it possible that someone will know how to solve my problem? I get in Control panel of Joomfish mesage Error loading feed data.Joomfish 2.0 on Joomla 1.5

Also in state info I have: jfdatabase two times and this info:

jfdatabase Published
jfdatabase Order not correct
jfalternative not installed!
Joom!Fish language selection Published
JoomFish Direct Translation not installed!

Thx to all those reading this to help me solve problem.
Last edited by hrga on Wed Sep 03, 2008 12:11 pm, edited 3 times in total.

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 21971
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, The Netherlands
Contact:

Re: Error loading feed data - JF2.0

Post by pe7er » Mon Sep 01, 2008 9:24 pm

Kind Regards,
Peter Martin, Global Moderator
https://db8.nl - Joomla specialist, Nijmegen, Nederland
Co-founder of data2.eu GDPR Tool https://data2.eu/en/gdpr-tool

AbyssLLC
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Tue Jun 03, 2008 1:09 pm

Re: Error loading feed data - JF2.0

Post by AbyssLLC » Tue Sep 02, 2008 7:05 pm

Did you install JCE? I had the pink Error loading feed data banner message with the installation of JCE.

With Extensions --> Module Manager --> Administrator --> JCE Latest News Module --> Delete. The pink Error loading feed data banner message was gone.

hrga
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Mon Sep 01, 2008 4:39 pm

Re: Error loading feed data - JF2.0

Post by hrga » Wed Sep 03, 2008 11:33 am

Nope don't have it. ( JC )

Alos I tried Joomfish Beta2, also same thing happening. :'( :'(

hrga
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Mon Sep 01, 2008 4:39 pm

Re: Error loading feed data - JF2.0

Post by hrga » Wed Sep 03, 2008 12:02 pm

Solved ! Thx man

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 21971
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, The Netherlands
Contact:

Re: Error loading feed data - JF2.0 -SOLVED

Post by pe7er » Wed Sep 03, 2008 3:06 pm

Good to see that you've solved it!
Could you please post your solution so that other users can benefit from it?
Thanks!
Kind Regards,
Peter Martin, Global Moderator
https://db8.nl - Joomla specialist, Nijmegen, Nederland
Co-founder of data2.eu GDPR Tool https://data2.eu/en/gdpr-tool

hrga
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Mon Sep 01, 2008 4:39 pm

Re: Error loading feed data - JF2.0 -SOLVED

Post by hrga » Wed Sep 03, 2008 3:23 pm

Yes I forgot, sory.

Well the problem was that in the: Joomfish/Settings you have to turn the radio button News to "No". Then the Error goes away.

But I need to mention that the JF 2 stil has many bugs so on my test site it is not working well or I can say it is not working. Cant wait until the working version comes out!

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 21971
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, The Netherlands
Contact:

Re: Error loading feed data - JF2.0 -SOLVED

Post by pe7er » Thu Sep 04, 2008 8:22 am

Thanks for sharing your solution!

I tested the Beta (which I was available in different files in the JoomFish forum) on some systems and did not experience much bugs.
Joom!Fish 2.0 RC1 was recently released to the donors of the system,
and in about 5 days a public release is expected.
Kind Regards,
Peter Martin, Global Moderator
https://db8.nl - Joomla specialist, Nijmegen, Nederland
Co-founder of data2.eu GDPR Tool https://data2.eu/en/gdpr-tool

ghost1227
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu Dec 04, 2008 9:02 pm

Re: Error loading feed data - JF2.0 -SOLVED

Post by ghost1227 » Tue Jan 20, 2009 2:34 pm

Instead of just deleting the module, you can retain the new updates by editing the module and changing the RSS feed URL to http://www.joomlacontenteditor.net/inde ... d&type=rss.

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18685
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Error loading feed data - JF2.0 -SOLVED

Post by infograf768 » Wed Jan 21, 2009 6:18 am

ghost1227 wrote:Instead of just deleting the module, you can retain the new updates by editing the module and changing the RSS feed URL to http://www.joomlacontenteditor.net/inde ... d&type=rss.
THis concerns JCE and not Joomfish.
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

ghost1227
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu Dec 04, 2008 9:02 pm

Re: Error loading feed data - JF2.0 -SOLVED

Post by ghost1227 » Wed Jan 21, 2009 7:27 am

crap good point :P my bad

foxone
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Fri Aug 22, 2008 1:36 am

Re: Error loading feed data - JF2.0 -SOLVED

Post by foxone » Fri Jan 23, 2009 5:08 pm

that fixed my DocMan issue! Thanks!

Ufavrite4nmovie
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Fri Feb 20, 2009 5:27 pm

Re: Error loading feed data - JF2.0 -SOLVED

Post by Ufavrite4nmovie » Fri Feb 20, 2009 5:31 pm

Extension, Module Manager, Administrator then disable Joomla! security newsfeed.

User avatar
gjrweb
Joomla! Intern
Joomla! Intern
Posts: 67
Joined: Wed Aug 27, 2008 12:03 pm
Location: Tilburg, The Netherlands
Contact:

Re: Error loading feed data - JF2.0 -SOLVED

Post by gjrweb » Wed Apr 22, 2009 1:47 pm

Indeed applies to the general joomla rss feed, the joomfish feed and the docman update feeds.

Turning of is a solution, however most feeds provide usefull information. How to keep the RSS feeds alive without errors?
GJ-R Webdevelopment & E-Commerce Expert # Webshops - http://www.gj-r.nl/

aKosmAn
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Tue Jun 09, 2009 7:51 am
Contact:

Re: Error loading feed data - JF2.0 -SOLVED

Post by aKosmAn » Tue Jun 09, 2009 9:50 am

The problem is ongoing, please help me

sanjaydebnath
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Jun 12, 2009 12:47 pm

Re: Error loading feed data - JF2.0 -SOLVED

Post by sanjaydebnath » Fri Jun 12, 2009 12:56 pm

Editing the module and changing the RSS feed URL do not help. It still shows the error "Error loading feed data". It goes off only when I disable the module "Joomla! security newsfeed" from Extension>>Module Manager>>Administrator.

Any help?

Thanks in advance!!! :)

User avatar
jeff-j
Joomla! Apprentice
Joomla! Apprentice
Posts: 27
Joined: Fri Feb 22, 2008 4:16 am
Location: Los Angeles

Re: Error loading feed data - JF2.0 -SOLVED

Post by jeff-j » Wed Jun 17, 2009 4:58 am

The problem is still ongoing for me, too!

My sites need RSS feeds via the mod_feed feature, so I can't just disable it. I've turned on system-cache and disabled the Joomla Security Newseed (which only turns off the back-end problem), but the front-end problem still persists in my Joomla 1.5.11, ever since upgrading from 1.5.7 > 1.5.8 > 1.5.9 > 1.5.10.

I do not have JoomFish or JCE or any of the other components/extensions installed.

I cannot get this resolved. Can anyone please help those of us still experiencing this problem?

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18685
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Error loading feed data - JF2.0 -SOLVED

Post by infograf768 » Wed Jun 17, 2009 6:18 am

jeff-j wrote:The problem is still ongoing for me, too!

My sites need RSS feeds via the mod_feed feature, so I can't just disable it. I've turned on system-cache and disabled the Joomla Security Newseed (which only turns off the back-end problem), but the front-end problem still persists in my Joomla 1.5.11, ever since upgrading from 1.5.7 > 1.5.8 > 1.5.9 > 1.5.10.

I do not have JoomFish or JCE or any of the other components/extensions installed.

I cannot get this resolved. Can anyone please help those of us still experiencing this problem?
That is a different issue as it does not apparently deals with a wrong url for the feeds/

My guess is that it is related to your host's settings.
Check the php settings in Help->System Info-> Php settings tabs

If I remeber well allow_url_fopen should be on
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

User avatar
jeff-j
Joomla! Apprentice
Joomla! Apprentice
Posts: 27
Joined: Fri Feb 22, 2008 4:16 am
Location: Los Angeles

Re: Error loading feed data - JF2.0 -SOLVED

Post by jeff-j » Wed Jun 17, 2009 7:06 am

@infograf768: Thanks for your quick response.
I checked the PHP settings tab, but didn't find anything like what you mentioned. (See screenshot.) Perhaps I'm looking in the wrong place. Can you please advise?

- jeff
You do not have the required permissions to view the files attached to this post.

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18685
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Error loading feed data - JF2.0 -SOLVED

Post by infograf768 » Wed Jun 17, 2009 7:11 am

oops, other tab
PHP information
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

User avatar
jeff-j
Joomla! Apprentice
Joomla! Apprentice
Posts: 27
Joined: Fri Feb 22, 2008 4:16 am
Location: Los Angeles

Re: Error loading feed data - JF2.0 -SOLVED

Post by jeff-j » Wed Jun 17, 2009 7:33 am

Ok, here's what I've got:
Configuration
PHP Core
Directive........................................Local Value.............Master Value
allow_call_time_pass_reference......On..........................On
allow_url_fopen..............................On.........................On
allow_url_include............................On.........................On
always_populate_raw_post_data.....Off.........................Off
Feeds coming from different domains on the same server load fine; the problem seems to be confined to feeds coming from all external servers.

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18685
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Error loading feed data - JF2.0 -SOLVED

Post by infograf768 » Wed Jun 17, 2009 10:08 am

Must be some kind of setup of your host.
Ask them.
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

User avatar
jeff-j
Joomla! Apprentice
Joomla! Apprentice
Posts: 27
Joined: Fri Feb 22, 2008 4:16 am
Location: Los Angeles

Re: Error loading feed data - JF2.0 -SOLVED

Post by jeff-j » Wed Jun 17, 2009 12:14 pm

Thank you. Actually, I have been asking my host about it. The trouble is that my webhost says it's a problem with Joomla and the Joomla forums say it's a setting with my host.

My webhost told me to turn off the Joomla Security Newsfeed and/or reinstall the mod_feed module. But I have a problem with com_newsfeeds, as well, which leads me to believe it's not just a corrupted module. Besides, other users in the Joomla forums are having problems, too.

Sorry to bother you with this, but it's been 4 months since it's worked, and I have no idea what to do. Both com_newsfeeds and mod_feed used to work, but the errors started happening as soon as I updated from J1.5.7 and hasn't worked since.

joe_eastern
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sat Jul 11, 2009 6:43 am

Re: Error loading feed data - JF2.0

Post by joe_eastern » Thu Jul 16, 2009 4:24 am

pe7er wrote:Welcome to Joomla forum!

Please see:
http://forum.joomla.org/viewtopic.php?f=430&t=279064
and on the forum of JoomFish: http://www.joomfish.net/forum/viewtopic.php?f=28&t=1247
I have some problem with joomla too when first install, but after i online to the internet and start joomla, wew... "error loading feed" is gone... Thanks for all information, it's really usefull :D

eddiesays
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Fri Jul 09, 2010 10:44 am

Re: Error loading feed data - JF2.0 -SOLVED

Post by eddiesays » Fri Jul 30, 2010 5:06 pm

After much ado looking into the functioning of the module, I figured that there is nothing innately wrong with any of the modules. It is simply some security measure whether host server or browser that prevents php or any script from accessing feeds. I think that it is a cross-browser security measure to prevent hacking.

So, because my client browser still accesses feeds directly I created a simple module called TabFeed mod_tabfeed (basically a cut-down mod_feed) to solve the problem. Take a look at:
http://extensions.joomla.org/extensions ... JmZWVkIjt9

If you download the file follow the README.pdf for administrator fix.

It might be enough for one or two people.

Regards,
Ed.

Rasulo
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Mon Nov 19, 2007 5:30 pm
Location: UK

Re: Error loading feed data - JF2.0 -SOLVED

Post by Rasulo » Sat Apr 21, 2012 11:57 am

Well in my case - it seems it is not a host thing, but a Joomla issue.

I have an SMF site that reads RSS feeds faultlessly, can also do structured js RSS feeds in custom boxes etc, yet on the same domain / same host, Joomla (2 sites, 1 dev, 1 live) refuses to allow any sort of RSS usage at all.

All I can get is the error : ' Error loading feed data./Error. Feed not retrieved. '

I imagine it is meaningless, but when I wrap the SMF site in a Joomla wrapper, the SMF feeds are still fine - just an observation, as I am pulling my hair out here.

My Joomla sites are v1.5.25 / v1.5.26

I have been following this issue closely, and have tried every solution from these discussions that I have come across, to no avail ...

EDIT : I just installed Slick RSS, and ran a test : ' Error(s): * cURL error 7: couldn't connect to host '

Seems odd that Joomla throws this up, and as I said earlier, SMF on the same domain is OK - still seems like Joomla, but I am usually wrong :p
Last edited by Rasulo on Sat Apr 21, 2012 1:11 pm, edited 2 times in total.

Rasulo
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Mon Nov 19, 2007 5:30 pm
Location: UK

Re: Error loading feed data - JF2.0 -SOLVED

Post by Rasulo » Sat Apr 21, 2012 12:45 pm

I just learned the following from my hosts:

'The outgoing connections are disabled by default on all accounts, however they can be enabled for paid accounts upon request. So all you need to do is raise a ticket from your Hosting Control Panel -> Support Center -> Trouble Tickets and we will enable them for you.'

OK, so I will do that, and also ask them why my SMF site handles cURL, and RSS on the same domain with no issues.

Anyway, it seems maybe I could have solved at least my problem here :p

Rasulo
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Mon Nov 19, 2007 5:30 pm
Location: UK

Re: Error loading feed data - JF2.0 -SOLVED

Post by Rasulo » Sat Apr 21, 2012 1:05 pm

OK - apologies to all for 3 consecutive posts, and apologies for doubting Joomla ...

Within 10 minutes of submitting a trouble ticket to my hosts, I have full RSS functionality once more. :eek:

I only hope that my posts help some one else with the RSS issue.

Thanks

:D

aliciabrand
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Tue Jun 19, 2012 8:26 am

Re: Error loading feed data - JF2.0 -SOLVED

Post by aliciabrand » Tue Jun 19, 2012 6:29 pm

I thinks you use Joomfish 2.0 and Joomla 1.5 not compatibility .


Locked

Return to “Language - Joomla! 1.5”