window.parent.jInsertEditorText is not a function

General questions relating to Joomla! 1.5 There are other boards for more specific help on Joomla! features and extensions.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
Locked
snipered
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Thu Apr 24, 2008 3:13 pm

window.parent.jInsertEditorText is not a function

Post by snipered » Tue Oct 28, 2008 9:02 pm

Everytime i try to add an image or create a pagebreak using the buttons at the bottom of the text editor i get the error message (in firefox error console).

window.parent.jInsertEditorText is not a function

And i cannot obviously add any image or pagebreak.
This is the same for TinyMCE or xStandard text editor.

I am running 1.5.2 with legacy mode. (everytime i turn off legacy i get direct access not allowed so can't check if legacy the problem)

Can anyone help me out please?

xrum
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 105
Joined: Tue Jan 15, 2008 7:07 pm

Re: window.parent.jInsertEditorText is not a function

Post by xrum » Fri Jan 09, 2009 4:48 pm

same here, is there a solution to this?

Pantanowitz
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Wed Mar 11, 2009 11:55 pm

Re: window.parent.jInsertEditorText is not a function

Post by Pantanowitz » Thu Mar 12, 2009 12:02 am

Insert the script line tag in your template's index.php file within the <head></head> tags:
<script type="text/javascript" src="/media/system/js/mootools.js"></script>

That is the jInsertEditorText functiion is defined in the mootools.js file.
Good luck ;)

User avatar
xoundboy
Joomla! Apprentice
Joomla! Apprentice
Posts: 31
Joined: Fri Nov 23, 2007 2:18 pm

Re: window.parent.jInsertEditorText is not a function

Post by xoundboy » Sun Dec 05, 2010 11:44 pm

Me too - I'm getting this after trying to insert an image into an article from the front-end editor.
I have Joomla 1.5.22 with joomfish installed and JCE editor.

The problem would appear to be that the image uploader is opening in a completely new page and not a pop-up where it belongs, thereby losing the refernece to the editor. When the insert button is clicked and it tries to insert the image back to the editor it can't because the editor is no longer there.


Locked

Return to “General Questions/New to Joomla! 1.5”