Fatal Error: Allowed memory size

Joomla version 1.5 is end-of-life and are no longer supported. Please use Joomla 3.x instead.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
adamklawonn
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Sat Nov 29, 2008 9:26 pm

Fatal Error: Allowed memory size

Post by adamklawonn » Sat Nov 29, 2008 10:58 pm

Hi all:

I have read other posts with upload issues on PHP file sizes. Here is my error message:


Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 67 bytes) in /home/content/d/a/i/dailyphx/html/libraries/joomla/error/exception.php on line 117


I contacted my host, GoDaddy, and found that the upload limit is 8 MB. I do not know why this error message is appearing.

Regardless, other posts have shown that the php.ini must be re-written to account for this upload issue. Here was my original php.ini file:

register_globals = off
allow_url_fopen = off

expose_php = Off
max_input_time = 60
variables_order = "EGPCS"
extension_dir = ./
upload_tmp_dir = /tmp
precision = 12
SMTP = relay-hosting.secureserver.net
url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=,fieldset="

[Zend]
zend_extension=/usr/local/zo/ZendExtensionManager.so
zend_extension=/usr/local/zo/4_3/ZendOptimizer.so


...and here is the new version with a few lines I added (in bold):

register_globals = off
allow_url_fopen = off

expose_php = Off
max_input_time = 60
memory_limit = 50M
post_max_size = 10M
file_uploads = On
upload_max_filesize = 192M

variables_order = "EGPCS"
extension_dir = ./
upload_tmp_dir = /tmp
precision = 12
SMTP = relay-hosting.secureserver.net
url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=,fieldset="

[Zend]
zend_extension=/usr/local/zo/ZendExtensionManager.so
zend_extension=/usr/local/zo/4_3/ZendOptimizer.so


Did I do this correctly? Or is there a line of code I must include in my .htaccess file?

My Background:
Shared Host: GoDaddy.com, PHP 5.x
Joomla v1.5
Mac OS X

All help is appreciated. Thanks!

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 10665
Joined: Thu Feb 15, 2007 5:48 am
Location: Oxford, UK
Contact:

Re: Fatal Error: Allowed memory size

Post by toivo » Sun Nov 30, 2008 9:48 am

The error message complains about not enough memory being available to the PHP session, obviously because of the size of the uploaded file.

You have to increase both the memory_limit and the post_max_size to accommodate your largest file upload.

Regards,
Toivo Talikka, Global Moderator
troubleshooting smtp and other articles https://talikka.com/joomla

afbt
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Sat Jan 22, 2011 11:59 am

Re: Fatal Error: Allowed memory size

Post by afbt » Sat Jan 22, 2011 12:02 pm

Hello,

May i ask where are these files are locate,
new in joomla, i just running wampserver
so the site is local.

Thanks for advance

Af

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 10665
Joined: Thu Feb 15, 2007 5:48 am
Location: Oxford, UK
Contact:

Re: Fatal Error: Allowed memory size

Post by toivo » Sat Jan 22, 2011 12:17 pm

The php.ini file is in the bin subfolder in the Apache folder, for example c:\wamp\bin\apache\Apache2.2.17\bin\php.ini
Toivo Talikka, Global Moderator
troubleshooting smtp and other articles https://talikka.com/joomla

afbt
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Sat Jan 22, 2011 11:59 am

Re: Fatal Error: Allowed memory size

Post by afbt » Sat Jan 22, 2011 12:22 pm

Thank for the quick reply,
i have to change the memory_limit ?
Current is now: memory_limit = 128M at line 458

Thanks for advance :)

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 10665
Joined: Thu Feb 15, 2007 5:48 am
Location: Oxford, UK
Contact:

Re: Fatal Error: Allowed memory size

Post by toivo » Sat Jan 22, 2011 1:18 pm

If you run on a localhost, it obviously is not that critical and 128MB is quite a lot. If you get error messages about PHP running out of memory, you should increase it.
Toivo Talikka, Global Moderator
troubleshooting smtp and other articles https://talikka.com/joomla

afbt
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Sat Jan 22, 2011 11:59 am

Re: Fatal Error: Allowed memory size

Post by afbt » Sat Jan 22, 2011 1:32 pm

Yes i am running on a localhost,
by increase memory you mean
increase memory on my pc or change the value
at php.ini ?

Thanks and sorry for the suffering.

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 10665
Joined: Thu Feb 15, 2007 5:48 am
Location: Oxford, UK
Contact:

Re: Fatal Error: Allowed memory size

Post by toivo » Sat Jan 22, 2011 2:26 pm

No trouble at all. You can just change the value in php.ini if required.
Toivo Talikka, Global Moderator
troubleshooting smtp and other articles https://talikka.com/joomla

afbt
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Sat Jan 22, 2011 11:59 am

Re: Fatal Error: Allowed memory size

Post by afbt » Sat Jan 22, 2011 7:24 pm

Nothing changed if i change the value in php.ini :)

But I did Repair the Database via PhpMyadmin and it works !!

Thank you so much Mr. Toivo for your time and your help.

Best regards

Af

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 10665
Joined: Thu Feb 15, 2007 5:48 am
Location: Oxford, UK
Contact:

Re: Fatal Error: Allowed memory size

Post by toivo » Sat Jan 22, 2011 7:36 pm

Remember to restart Apache after modifying the php.ini file.
Toivo Talikka, Global Moderator
troubleshooting smtp and other articles https://talikka.com/joomla

afbt
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Sat Jan 22, 2011 11:59 am

Re: Fatal Error: Allowed memory size

Post by afbt » Mon Jan 24, 2011 9:33 am

You are right on this !

Thank you again :)

dani71508
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Mon Apr 18, 2011 7:05 pm

Re: Fatal Error: Allowed memory size

Post by dani71508 » Thu Jul 14, 2011 6:58 pm

Hi afbt,
I have seen you repaired the fatal error message you had.
I have exactly the same config you have. I have godaddy and same joomla version and I get
Fatal error: Out of memory (allocated 176685056) (tried to allocate 40 bytes) in /home/content/l/j/b/ljbi5524/html/joomla/libraries/joomla/error/exception.php on line 117

How did you repair the DB with PHPmyAdmin?
Any help would be greatly appreciated.
Thank you,
Danilo

endritjahaj1
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Wed Jun 22, 2011 10:30 am

Re: Fatal Error: Allowed memory size

Post by endritjahaj1 » Wed Jul 20, 2011 2:27 pm

dani71508 wrote:Hi afbt,
I have seen you repaired the fatal error message you had.
I have exactly the same config you have. I have godaddy and same joomla version and I get
Fatal error: Out of memory (allocated 176685056) (tried to allocate 40 bytes) in /home/content/l/j/b/ljbi5524/html/joomla/libraries/joomla/error/exception.php on line 117

How did you repair the DB with PHPmyAdmin?
Any help would be greatly appreciated.
Thank you,
Danilo
i have the same question
thanks for your help

User avatar
Rowby
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 193
Joined: Sun Dec 11, 2005 9:13 pm
Location: California
Contact:

Re: Fatal Error: Allowed memory size

Post by Rowby » Mon Aug 15, 2011 4:19 pm

Be aware that even if you modify the php.ini file to increase memory allocation, some hosting companies will ignore it.

For example, at Hostgator, in a shared account, you are limited to 64MG, no matter what you put in the php.ini file. With Hostgator you need to have at least a VPS (Virtual Private Server) or a dedicated server to increase memory size.

For Joomla users, using google search to find a solution on this subject, I am adding the following keywords and phrases to help others with this issue.

Fatal error: Out of memory (allocated 68943872) (tried to allocate 9114002 bytes)

libraries/joomla/cache/storage/file.php on line 133

Joomla 1.7 Joomla cache progressive conservative

Rowby

dunio
Joomla! Apprentice
Joomla! Apprentice
Posts: 39
Joined: Wed Dec 14, 2011 3:59 pm

Re: Fatal Error: Allowed memory size

Post by dunio » Sat Dec 31, 2011 2:16 am

I have this error, too. I have memory_limit 2GB! What gives!? Also, my server cpu freaks out - about 96% most of the time. I have migrated to another server then the problems started. Besides, everything seems pretty fast and just fine in front end.

Hm.. and index.php of joomla takes 0.36 - 0.41 to load. Optimized script should take 0.03 - 0.05 to load. What gives!?

dunio
Joomla! Apprentice
Joomla! Apprentice
Posts: 39
Joined: Wed Dec 14, 2011 3:59 pm

Re: Fatal Error: Allowed memory size

Post by dunio » Mon Jan 16, 2012 2:59 am

ideas, please
repairing the table or increasing memory does not help me :(

bradley568
Joomla! Intern
Joomla! Intern
Posts: 66
Joined: Sat Nov 29, 2008 6:50 am

Re: Fatal Error: Allowed memory size

Post by bradley568 » Fri Feb 03, 2012 7:31 pm

I have this error using Joomla 1.7.4 and CB 1.7.1.
I get the error sometimes when a user tries to register but regularly when we try to Login.

Any clues?

dunio
Joomla! Apprentice
Joomla! Apprentice
Posts: 39
Joined: Wed Dec 14, 2011 3:59 pm

Re: Fatal Error: Allowed memory size

Post by dunio » Fri Feb 03, 2012 8:15 pm

Maybe in your case it really is memory. Contact your hosting provider and let them know to increase memory_limit. Also refer to the manuals of this joomla version and this cb version. Also ask the CB support to let them know. They might have better suggestions, if that is not really memory related.

bradley568
Joomla! Intern
Joomla! Intern
Posts: 66
Joined: Sat Nov 29, 2008 6:50 am

Re: Fatal Error: Allowed memory size

Post by bradley568 » Fri Feb 03, 2012 8:26 pm

I checked CB and found a useful script to test my memory and found that it was only using 30M instead of the 90M reported.
I also disabled the facebook connect module that I have installed and that seems to have fixed it.

dunio
Joomla! Apprentice
Joomla! Apprentice
Posts: 39
Joined: Wed Dec 14, 2011 3:59 pm

Re: Fatal Error: Allowed memory size

Post by dunio » Fri Feb 03, 2012 8:35 pm

Try to contact cb support and figure out what sets the limitation or use another method for fb connect.


Locked

Return to “Installation 1.5”