Fatal error: Call to a member function get() on a non-object

Joomla version 1.5 is end-of-life and are no longer supported. Please use Joomla 3.x instead.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
ergun_ozkan
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sat May 23, 2009 9:38 am

Fatal error: Call to a member function get() on a non-object

Post by ergun_ozkan » Tue Jan 12, 2010 12:38 am

Hi
I installed Joomla_1.5.15-Stable-Full_Package.

I did not experience a problem during installation.
After installation, I deleted the installation folder.
I have to enter the site click on site.
But the site did not open!

Gave the following error:

Code: Select all

Fatal error: Call to a member function get() on a non-object in /home/akmtekni/public_html/templates/rhuk_milkyway/index.php on line 23
I deleted all the files in my server.
I reinstalled and Joomla_1.5.15-Stable-Full_Package.
I did not experience a problem during installation.
After installation, I deleted the installation folder.
I clicked to enter the admin area management.
Management area, but did not open!

Gave the following error:

Code: Select all

Fatal error: Call to a member function get() on a non-object in /home/akmtekni/public_html/administrator/templates/khepri/login.php on line 35
Why these problems are caused?

Please help

paulgreco
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 106
Joined: Mon Jan 29, 2007 8:28 pm

Re: Fatal error: Call to a member function get() on a non-object

Post by paulgreco » Thu Jan 28, 2010 12:26 am

I'm having the same problem...wth?

http://test.northwestlittleleague.org/administrator/

digiweb
Joomla! Apprentice
Joomla! Apprentice
Posts: 41
Joined: Tue Sep 12, 2006 12:54 pm

Re: Fatal error: Call to a member function get() on a non-object

Post by digiweb » Fri Jan 29, 2010 1:21 am

Check your template directory against the install. This will occur if params.ini is missing.

User avatar
Llewellyn
Joomla! Apprentice
Joomla! Apprentice
Posts: 31
Joined: Sat Jun 14, 2008 10:45 am
Location: Windhoek, Namibia
Contact:

Re: Fatal error: Call to a member function get() on a non-object

Post by Llewellyn » Tue Feb 16, 2010 10:27 pm

Thanks it worked for me, I just uploaded the params.ini again and it worked......
<<ewe>>yn :geek:

Joomla Component Builder - Lead Developer

seointexas
Joomla! Intern
Joomla! Intern
Posts: 65
Joined: Tue Mar 30, 2010 3:44 am
Location: Dallas Texas United States
Contact:

Re: Fatal error: Call to a member function get() on a non-ob

Post by seointexas » Sun May 30, 2010 6:08 am

Thanks! I am not sure where all of y params.ini files went in my default install, but I pulled them from another and it worked like a charm.

leonghoward
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sat Apr 16, 2011 11:10 pm

Re: Fatal error: Call to a member function get() on a non-ob

Post by leonghoward » Sun Apr 17, 2011 12:02 am

Fatal error: Call to a member function login() on a non-object in /home/millsbor/public_html/administrator/components/com_login/admin.login.php on line 64

How do you update param ini

erictomlee
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 110
Joined: Fri Feb 27, 2009 12:11 am
Location: Silicon Valley
Contact:

Re: Fatal error: Call to a member function get() on a non-ob

Post by erictomlee » Thu May 12, 2011 6:02 pm

leonghoward wrote:Fatal error: Call to a member function login() on a non-object in /home/millsbor/public_html/administrator/components/com_login/admin.login.php on line 64

How do you update param ini

I have a similar thing while trying to rebuild my site. I idiotically uploaded Joomla 1.6.3 instead of Joomla 1.5.23... FML!!!
Fatal error: Call to a member function login() on a non-object in /homepages/44/d90092464/htdocs/remixculture.com/administrator/components/com_login/admin.login.php on line 64

JackRT
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Sat May 14, 2011 10:52 am

Re: Fatal error: Call to a member function get() on a non-ob

Post by JackRT » Sat May 14, 2011 10:58 am

you just need to re-upload the params.ini file..
Transitioning these from Flash... be kind to me...
car insurance companies
vehicle insurance

erictomlee
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 110
Joined: Fri Feb 27, 2009 12:11 am
Location: Silicon Valley
Contact:

Re: Fatal error: Call to a member function get() on a non-ob

Post by erictomlee » Sat May 14, 2011 5:40 pm

JackRT wrote:you just need to re-upload the params.ini file..
oh... I'll look for that. thanks

jmdziba
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Wed May 25, 2011 3:16 pm

Re: Fatal error: Call to a member function get() on a non-ob

Post by jmdziba » Wed May 25, 2011 3:18 pm

Where do I get the files?

erictomlee
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 110
Joined: Fri Feb 27, 2009 12:11 am
Location: Silicon Valley
Contact:

Re: Fatal error: Call to a member function get() on a non-ob

Post by erictomlee » Wed May 25, 2011 3:40 pm

jmdziba wrote:Where do I get the files?
they are in each template

tannwander
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Mon Jul 06, 2009 3:12 pm

Re: Fatal error: Call to a member function get() on a non-ob

Post by tannwander » Sat Jul 02, 2011 12:38 pm

I take a look in my templates folders and all them has params.ini
But I'm gotting the same error.
Could someone give a new hint?
Thanks

transco
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Sun Sep 21, 2008 10:21 am

Re: Fatal error: Call to a member function get() on a non-ob

Post by transco » Sat Jul 02, 2011 6:41 pm

I am installing 1.6' Site works OK, except when I go to administratorr I have this same error. I have read forums I have checked param ini file for my template and it is empty.. so how does one proceed should I start over with clean install or ?

Any help would be appreciated.

Thanks

mrmcq
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Wed Jul 06, 2011 6:54 pm

Re: Fatal error: Call to a member function get() on a non-ob

Post by mrmcq » Fri Jul 08, 2011 3:55 pm

I too have tried uploading each and every template's param ini file and still the "Fatal error: Call to a member function login() on a non-object" error. I have gone through the install both through automatically (GoDaddy Applications, Joomla 1.6.3), and manually (Joomla 1.6.4) MANY TIMES, successfully...because I can see the front-end just FINE!

Yet each time I have hit this same error directly after trying to log into the /administrator/ page!

What the heck is going on? I have no CLUE what to do :-\

jurajvt
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Apr 28, 2010 6:50 am

Re: Fatal error: Call to a member function get() on a non-ob

Post by jurajvt » Thu Jul 14, 2011 5:22 pm

I too have tried uploading each and every template's param ini file and still the "Fatal error: Call to a member function login() on a non-object" error. I have gone through the install both through automatically (GoDaddy Applications, Joomla 1.6.3), and manually (Joomla 1.6.4) MANY TIMES, successfully...because I can see the front-end just FINE!

Yet each time I have hit this same error directly after trying to log into the /administrator/ page!

What the heck is going on? I have no CLUE what to do :-\
Hello.

You must put params.ini to your admin template, e.g. yoursite\administrator\templates\khepri

You can get this file from same location in another existing installation. Or you can download new installation package of Joomla, unzip it and go to the directory, what I have wroted above.

It must work for you!

kylagogg
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sun Sep 25, 2011 12:47 am

Re: Fatal error: Call to a member function get() on a non-ob

Post by kylagogg » Sun Sep 25, 2011 1:25 am

Call to a member function getMessageQueue() on a non-object in /home/gater/public_html/templates/project1/functions.php on line 230


I tried installing the params.ini in the new template directory in the admin folder and in the template folder. Over and over? Even took it from another template? Haven't had this challenge before in earlier versions on Joomla. Using 1.7 this time around. Thank-you for you time!

willean
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Wed Nov 09, 2011 11:06 am

Re: Fatal error: Call to a member function get() on a non-ob

Post by willean » Wed Nov 09, 2011 11:26 am

i have the same error, but have not seen a single person here who really makes you understand he say, please explain things, i many not know where param.ini is, i request a simple direction like go to a> b> c etc
Fatal error: Call to a member function getTemplate() on a non-object in C:\xampplite\htdocs\joomla\modules\mod_exmenu-j15\exmenu\util\sitehelper.class.php on line 30

thanks alot

lintably
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Tue Nov 15, 2011 2:08 pm

Re: Fatal error: Call to a member function get() on a non-ob

Post by lintably » Tue Nov 15, 2011 2:34 pm

I'm soooooooooooo confused! Please help! Installed Joomla 1.7 without any problem but then decided to use Joomla 1.5 as there were loads more templates. After dithering, decided that it was not worth goig backwards to 1.5 and reinstalled 1.7. All installs were done via one click install on Softalicious. Hosting is on UK2net. Even though the database for 1.5 was deleted before the install, legacy files were detected when I reinstalled 1.7.

The install did not detect any problem. I can't however log in ot the admin pane. due to the fatal error. Hence I can't adjust the template as I can't access it. the front end of the site appears fine www.neemco.co.uk

It seems clear that the legacy files caused the problem since the first instal via softalicious went fine and I was able to log in to the admin panel. I have reinstalles several times now with the same result.

I am a newbie. I do not understand the instructions given earlier in this topic to "put params.ini to your admin template, e.g. yoursite\administrator\templates\khepri You can get this file from same location in another existing installation. Or you can download new installation package of Joomla, unzip it and go to the directory, what I have wroted above."

This would seem not to apply to a one click install. I don't have access to www.neemco\administrator\templates\ because I can't login to the admin panel. also I have no idea what the name of the default template in 1.7 is so I am totally confused.

I have requested UK2net help by reboot or clearing the database cache...(not sure if this is a viable request).

Any suggestions would be appreciated. This is an urgent problem as clients are expected to be viewing the site in a few days and I can't modify the site!

lintably
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Tue Nov 15, 2011 2:08 pm

Re: Fatal error: Call to a member function get() on a non-ob

Post by lintably » Tue Nov 15, 2011 3:17 pm

I have managed to sort out a solution to this error when using one click installation. It is indeed the legacy files causing the problem! In C Panel go to the legacy files management. Delete all the files from previous intstallations. If you attempt an install of Joomla and still get a message stating that a duplicate file is still there DO NOT click to overwrite. Go back to the legacy management and remove all files listed manually. Once all legacy files are removed I was able to get a clean install and Voila...no more error message! *claps hands*

iamjlw
Joomla! Apprentice
Joomla! Apprentice
Posts: 28
Joined: Fri May 29, 2009 11:43 pm

Re: Fatal error: Call to a member function get() on a non-ob

Post by iamjlw » Wed Dec 07, 2011 1:10 pm

Hi Everyone,

I had this exact same problem when upgrading from 1.5.25 to 1.7.3 and lintably is totally right on. Before copying your jupgrade folder to your root, make sure that you have copied all of your 1.5 files to a holding folder (ie. old_site) and then delete all of the 1.5 joomla files from your root. After all the 1.5 files are deleted, then copy all the files in jupgrade to you root and as lintably says, "Voila"
everything works ; )

versionupdate
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Mon Jun 20, 2011 6:55 am
Location: Bangkok Thailand
Contact:

Re: Fatal error: Call to a member function get() on a non-ob

Post by versionupdate » Thu Dec 08, 2011 2:25 am

Newbie here. I am currently trying that app too.. will keep you posted if I can do something

charleyhankins
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 221
Joined: Fri Oct 12, 2007 7:07 pm

Re: Fatal error: Call to a member function get() on a non-ob

Post by charleyhankins » Tue Feb 05, 2013 11:50 pm

be sure to check administrator/components/com_login for the presence of admin.login.php. This is an old 1.5 file that you don't need but will kill you admin login.

Thanks to TFuller
http://forum.joomla.org/memberlist.php? ... ile&u=6092

leonxn
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Wed Feb 06, 2013 10:12 pm
Location: fanlols.com
Contact:

Re: Fatal error: Call to a member function get() on a non-ob

Post by leonxn » Wed Feb 06, 2013 10:27 pm

Check your template directory against the install. This will occur if params.ini is missing.

leonxn
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Wed Feb 06, 2013 10:12 pm
Location: fanlols.com
Contact:

Re: Fatal error: Call to a member function get() on a non-ob

Post by leonxn » Mon Aug 19, 2013 5:35 pm

Check your template directory against the install. This will occur if params.ini is missing.

Alveen
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Wed Dec 04, 2013 1:56 am

Re: Fatal error: Call to a member function get() on a non-ob

Post by Alveen » Wed Dec 04, 2013 2:01 am

Hi

I am getting the same problem with my site.


Warning: require_once(/home/rjreid/public_html/administrator) [function.require-once]: failed to open stream: No such file or directory in /home/rjreid/public_html/administrator/index.php on line 22

Fatal error: require_once() [function.require]: Failed opening required '/home/rjreid/public_html/administrator' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/rjreid/public_html/administrator/index.php on line 22

I cant even log in the backend of the site . It comes up when i type my url/administrator

Need a solution please :)

JunieG
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Wed Dec 04, 2013 6:05 pm

Re: Fatal error: Call to a member function get() on a non-ob

Post by JunieG » Thu Dec 19, 2013 9:19 pm

I get this error when I try to make changes to a Section or Category in Joomla 1.5.7, this is NOT a new install. Don't have a clue what to do. I did recently have my hosting site do a reinstall of the website because of issues I had after installing Prestashop. Uninstalled Prestashop, then reinstalled website from a backup done just before I tried uploading Prestashop.

Fatal error: Call to a member function get() on a non-object in /home2/weaverco/public_html/plugins/editors/jce.php on line 340

Suggestions? Newbie so need detailed help, please.

ADvanceref
Joomla! Apprentice
Joomla! Apprentice
Posts: 47
Joined: Sat Jun 08, 2013 8:25 am

Re: Fatal error: Call to a member function get() on a non-ob

Post by ADvanceref » Tue Feb 04, 2014 10:15 am

Up. I have the same problem
Toutes les informations sur le rachat de crédit, 1RachatCredit.fr : www.1RachatCredit.fr. Pour le referencement de votre site internet, faites appel à une agence web.

User avatar
dpacadmin
Joomla! Champion
Joomla! Champion
Posts: 6029
Joined: Sat Aug 16, 2008 1:46 pm
Location: the Bat Cave
Contact:

Re: Fatal error: Call to a member function get() on a non-ob

Post by dpacadmin » Thu Feb 06, 2014 12:49 am

Try re-installing or updating the JCE editor.

ADvanceref
Joomla! Apprentice
Joomla! Apprentice
Posts: 47
Joined: Sat Jun 08, 2013 8:25 am

Re: Fatal error: Call to a member function get() on a non-ob

Post by ADvanceref » Sun Feb 09, 2014 12:54 pm

Great! it succeed. Thanks.
Toutes les informations sur le rachat de crédit, 1RachatCredit.fr : www.1RachatCredit.fr. Pour le referencement de votre site internet, faites appel à une agence web.


Locked

Return to “Installation 1.5”