Joomla web page problem - Too many redirects

Discussion regarding Joomla! 2.5 Performance issues.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
tualisa
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Tue Mar 06, 2012 8:05 am

Joomla web page problem - Too many redirects

Post by tualisa » Tue Apr 10, 2012 10:05 am

I am running a Joomla (2.5.1) homepage locally on my computer while developing the site. When I try to open the page in different browsers I get this message (Google Chrome): This webpage has a redirect loop.Clearing your cookies for this site or allowing third-party cookies may fix the problem.
Error 310 (net::ERR_TOO_MANY_REDIRECTS): There were too many redirects.

I get the same problem in Safari and Firefox, and none of the suggested solutions tend to help. Why do I get this problem and what can be done to solve it? Has i something to do with the language filter plug-in? My site is bilingual.

The strange thing is that the redirect problem doesn't occur every time I try to open the web site.

Thankful for any help!

vidurb
Joomla! Explorer
Joomla! Explorer
Posts: 295
Joined: Tue Feb 08, 2011 8:46 am

Re: Joomla web page problem - Too many redirects

Post by vidurb » Tue Apr 10, 2012 12:33 pm

Which template are you using?
Vidur Bharany :geek:
Adwiz Digital
http://www.adwiz.in

tualisa
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Tue Mar 06, 2012 8:05 am

Re: Joomla web page problem - Too many redirects

Post by tualisa » Tue Apr 10, 2012 1:02 pm

I use the Beez 5 template.

tualisa
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Tue Mar 06, 2012 8:05 am

Re: Joomla web page problem - Too many redirects

Post by tualisa » Wed Apr 11, 2012 8:03 am

I noticed that if I write the full address in the address bar, localhost:8888/mypage/index.php/se, I get the redirection problem and a loop at the end of the address like this:
localhost:8888/mypage/index.php/se/index.php/se/index.php/se/index.php/se/index.php/se/index.php/se/index.php/se/index.php/se/index.php/se/index.php/se/index.php/se/index.php/se/index.php/se/index.php/se/index.php/se

Then again, if I leave out the file name from the address and stop at the folder name like this, localhost:8888/mypage/, no redirection problem occur and the browser finds the site.

It doesn't completely solve the problem however, since some links at the page still generate the loop.

Daz2007
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Thu Nov 17, 2011 8:23 am

Re: Joomla web page problem - Too many redirects

Post by Daz2007 » Wed Apr 11, 2012 1:32 pm

It sounds like an issue with .htaccess and rewrite.

If you find the following in the .htaccess:
RewriteBase /

Change it to show your sites install directory, so probably something like this:
RewriteBase /mypage/

aaanativearts
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 203
Joined: Fri Aug 04, 2006 12:38 pm

Re: Joomla web page problem - Too many redirects

Post by aaanativearts » Thu Apr 12, 2012 4:34 am

I'm having this problem in Joomla 2.5.4 and my install is in the root directory. It wasn't an issue until I upgraded from 2.5.3.

tualisa
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Tue Mar 06, 2012 8:05 am

Re: Joomla web page problem - Too many redirects

Post by tualisa » Fri Apr 13, 2012 7:36 am

Daz2007 wrote:It sounds like an issue with .htaccess and rewrite.

If you find the following in the .htaccess:
RewriteBase /

Change it to show your sites install directory, so probably something like this:
RewriteBase /mypage/
I tried to change the suggested code (and clear all browser history) but it didn't help, unfortunately.

vidurb
Joomla! Explorer
Joomla! Explorer
Posts: 295
Joined: Tue Feb 08, 2011 8:46 am

Re: Joomla web page problem - Too many redirects

Post by vidurb » Fri Apr 13, 2012 2:51 pm

Can you knock off everything in Components > Redirect >

Empty the trash of this component too.
Vidur Bharany :geek:
Adwiz Digital
http://www.adwiz.in

Daz2007
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Thu Nov 17, 2011 8:23 am

Re: Joomla web page problem - Too many redirects

Post by Daz2007 » Fri Apr 13, 2012 3:02 pm

I'd also try making sure joomla caching is disabled and cleared, and also try with another browser.
When I had the problem clearing the browser history didnt work, but the problem was sorted when I tried another one.

vsevolod
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Mon Jul 25, 2011 4:23 pm

Re: Joomla web page problem - Too many redirects

Post by vsevolod » Wed Dec 05, 2012 10:48 am

In my case, it was hoster environment configuration problem, which occurred only for SSL-related stuff. Any time I tried to switch Joomla core ssl support on, or if any 3-rd party ssl redirection plugins were active, I got error 310 TOO_MANY_REDIRECTS.
The requests were processed by ngnix->apache chain, internal local ngnix->apache traffic always was plain http, so the latter did not get any standard environment vars which could trigger SSL redirection in Joomla. So, it tries to redirect to https, got plain http, and redirects again and again, in an endless loop.
The ngnix proxy added custom HTTP header field though, X-SSL-Connect, which is set to "yes" when https was requested. So, in root .htaccess I used

Code: Select all

SetEnvIfNoCase X-SSL-Connect (^yes) HTTPS=on
to set-up standard environment var for Apache.
That was an end to error 310 in my case.

PS. The following symptoms followed this SSL config problem. When I only started to work around it, I tried using just administrator requests rewrite in .htaccess, based on X-SSL-Connect flag:

Code: Select all

RewriteCond %{REQUEST_URI} ^/administrator
RewriteCond %{HTTP:X-SSL-Connect} !(^yes)
RewriteRule ^(.*)$ https://my-site.ru%{REQUEST_URI} [R=301,L]
which at first seems to work, but apparently redirected only part of the resources, that were linked under administrator/, so other stuff were not requested via https and it implicitly broke Joomla autoucheck and autoupdate scripts.

neo314
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Sat Mar 13, 2010 4:22 am

Re: Joomla web page problem - Too many redirects

Post by neo314 » Sat Dec 15, 2012 10:06 pm

Any idea what is the cause of this problem? I'm experiencing the same thing, sort of...

On my live server, everything is fine, but on my WAMP development server, I started getting this too many redirect problem on SOME ssl pages.

For example, https://mysite.home (test server) or https://mysite.home/mypage works fine, but https://mysite.home/my-cart (VirtueMart) has the redirect problem, and https://mysite.home/administrator has the redirect problem. On the live server (mysite.com) they work fine.

I had to disable forced SSL on my test server in order to access the admin side. I tried vsevolod's SetEnvIfNoCase solution and that didn't help.

I think it may be a plugin problem, but I am not sure. If I find it is, I'll post back. What I do know is that I built most of this site on the test server using SSL without any problem, and somewhere along the way, this problem cropped up.

For my situation, it isn't a crisis, just a nuisance, but it would be nice to know what the problem is.

jankman
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sun Nov 06, 2016 5:30 am

Re: Joomla web page problem - Too many redirects

Post by jankman » Sun Nov 06, 2016 12:32 pm

Hi everyone.. Sorry to interrupt you guys but can i get you attention? I'm newbie here in joomla and i just want to make my first site.. I don't have a domain yet. so my url as of now is "localhost/mysite/index.php". I have a problem in redirecting issue. When i load my browser (Google chrome) it says that "Localhost page isn't responding", "localhost redirect you too many times." also google suggest to clear all cookies. I did that in my browser but nothing changes. I don't know about the codes in my installation.. It said that i can use this program and make a website by putting stuffs (i don't know what exact words can i use for that).. i don't know also how to code. Please help me to fix this.

my "localhost/mysite/administrator" is working fine.. but when it comes to the site, the message appears.

my joomla version is the latest one.
my server is MAMP.. port: 80 / 3306 (something like that)
i'm using joom! template (http://web-komp.eu/documentation/joom/i ... #!/welcome)
other modules: sp portfolio, roksprocket strip module, widgetkit lite (for slideshow)

please help me to do the exact way how to fix this. This is my first website. i don't want to give up this project i started. Thank you very much. I will appreciate if someone respond.


Post Reply

Return to “Performance - Joomla! 2.5”