Joomla 2.5.4 Contact Form Not Sending Mail

For Joomla! 2.5 Coding related discussions, please use: http://groups.google.com/group/joomla-dev-general
Note: All 1.6, 1.7 and 3.5 releases have reached end of life and should be updated to 3.x.

Moderator: ooffick

Forum rules
Please use the mailing list here: http://groups.google.com/group/joomla-dev-general rather than this forum.
tfuller0943
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Mon Apr 16, 2012 6:22 pm

Joomla 2.5.4 Contact Form Not Sending Mail

Post by tfuller0943 » Tue Apr 17, 2012 7:47 pm

I'm using an out of the box joomla contact form and Mail doesn't make it from the form to the receiving mail server. I have no idea of where to check for the source of the problem.

Can someone give me some direction here?

Here are some settings from the Control Panel > Configuration File

mailer mail
mailfrom XXXXXXXXXX
fromname stay-in-your-home.org
sendmail /usr/sbin/sendmail
smtpauth 0
smtpuser xxxxxx
smtppass xxxxxx
smtphost localhost
smtpsecure none
smtpport 25

User avatar
pxforti
Joomla! Hero
Joomla! Hero
Posts: 2755
Joined: Wed Apr 04, 2007 8:54 pm
Location: Driggs, Idaho

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by pxforti » Wed Apr 18, 2012 1:05 pm

In global settings, make sure that the from email address is from the same domain as the website. eg, is you site is mysite.com, then the from email needs to be somebody@mysite.com.
Joomla Website Design / CS-Cart Website Design
http://writenowdesign.com

User avatar
Angola
Joomla! Intern
Joomla! Intern
Posts: 54
Joined: Tue Aug 22, 2006 10:30 am
Location: Oslo, Norway
Contact:

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by Angola » Sun Apr 22, 2012 4:49 pm

pxforti wrote:In global settings, make sure that the from email address is from the same domain as the website. eg, is you site is mysite.com, then the from email needs to be somebody@mysite.com.
In my case it still does not work. It seems like this is a serious problem that many of us are experiencing but no concrete solution has been found yet!

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 24805
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by Per Yngve Berg » Sun Apr 22, 2012 6:10 pm

Do you have mail included in the hosting account?

Set Joomla to use the php mailer.
If it's not working them, call your host providers support.

If you use mail from another provider, use smtp in Joomla and your smtp credentials.

User avatar
Angola
Joomla! Intern
Joomla! Intern
Posts: 54
Joined: Tue Aug 22, 2006 10:30 am
Location: Oslo, Norway
Contact:

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by Angola » Sun Apr 22, 2012 6:35 pm

Per Yngve Berg wrote:Do you have mail included in the hosting account?

Set Joomla to use the php mailer.
If it's not working them, call your host providers support.

If you use mail from another provider, use smtp in Joomla and your smtp credentials.
Hi Per, thanks for your reply. Yes I did input an email from my hosting account and I checked the php mailer option in the Global Config. but it did not help. Strange thing is that I have another site running on J! 1. 5.26 with almost exactly the same configuration that is working perfectly.

I have read many other threads from desperate users who seem to have the same problem that I have and I am beginning to wonder whether this is a Joomla issue!

Anyway, I will also check with the hosting provider.

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 24805
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by Per Yngve Berg » Sun Apr 22, 2012 6:42 pm

What does the php info say about smtp set-up?

User avatar
Angola
Joomla! Intern
Joomla! Intern
Posts: 54
Joined: Tue Aug 22, 2006 10:30 am
Location: Oslo, Norway
Contact:

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by Angola » Sun Apr 22, 2012 7:06 pm

Per Yngve Berg wrote:What does the php info say about smtp set-up?
on PHP Core I see this column among many others

sendmail_from no value no value (this is despite having this value input on the backend!)
sendmail_path /usr/sbin/sendmail -t -i

Could the culprit be hiding somewhere here?

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 24805
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by Per Yngve Berg » Sun Apr 22, 2012 8:34 pm

I was thinking about the SMTP and SMTP Port.

User avatar
Angola
Joomla! Intern
Joomla! Intern
Posts: 54
Joined: Tue Aug 22, 2006 10:30 am
Location: Oslo, Norway
Contact:

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by Angola » Sun Apr 22, 2012 8:47 pm

Per Yngve Berg wrote:I was thinking about the SMTP and SMTP Port.
SMTP = localhost
SMTP port = 25

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 24805
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by Per Yngve Berg » Mon Apr 23, 2012 6:14 am

Is there a SMTP server running on the server?

User avatar
Angola
Joomla! Intern
Joomla! Intern
Posts: 54
Joined: Tue Aug 22, 2006 10:30 am
Location: Oslo, Norway
Contact:

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by Angola » Mon Apr 23, 2012 7:09 am

Per Yngve Berg wrote:Is there a SMTP server running on the server?
Yes Per, as I said I am having other Joomla sites J!1.5.26 all hosted on the same server and they are sending mail. Unfortunately, the J!2.5 is not sending mail, neither from the admin nor the contact form. I have checked and rechecked. Even tried different contact components but without success. It is kind of weird!

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 24805
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by Per Yngve Berg » Mon Apr 23, 2012 5:24 pm

I have tested both on a server using the SMTP and one with PHP-mailer. Both send out mail.
Joomla 2.5.4

Is there anything in the server logs?

User avatar
Angola
Joomla! Intern
Joomla! Intern
Posts: 54
Joined: Tue Aug 22, 2006 10:30 am
Location: Oslo, Norway
Contact:

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by Angola » Mon Apr 23, 2012 7:06 pm

Thanks for taking your time. I have checked the server logs but nothing seems to be abnormal (I did not get any wiser). I do not know why this is happening and right now it feels like I am groping in the dark!

User avatar
Angola
Joomla! Intern
Joomla! Intern
Posts: 54
Joined: Tue Aug 22, 2006 10:30 am
Location: Oslo, Norway
Contact:

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by Angola » Wed Apr 25, 2012 7:26 pm

Per Yngve Berg wrote:I have tested both on a server using the SMTP and one with PHP-mailer. Both send out mail.
Joomla 2.5.4

Is there anything in the server logs?
Hi Per, it seems like setting up a gmail smtp host does the trick. The problem is most probably with my host provider, and not a J! one.

Here is my server configuration:

Mailer: SMTP Server
Mail from: ….@gmail.com
From Name: Mysite name
Sendmail Path: /usr/sbin/sendmail
SMTP Authentication: Yes
SMTP Security: SSL

SMTP Port: 465
SMTP: Username: my gmail username
SMTP Password: my gmail password
SMTP Host: smtp.gmail.com

I hope this might help others who might experience the same problem as I was having.

Thanks for your patience!

User avatar
corrado444
Joomla! Guru
Joomla! Guru
Posts: 856
Joined: Thu Jul 06, 2006 8:30 am
Location: Sacramento
Contact:

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by corrado444 » Fri May 04, 2012 12:39 am

I have tried every suggestion I found here, but mine still doesn't work. I am about to ditch the whole thing and try a form component.

I have tried sendmail
SMTP mail with a native email address
Gmail

None worked. What I get is the page simply refreshes and no email is sent. The one thing I have always trusted about Joomla was the contact form.
Watch the 10 Minute Joomla! Tips Video Podcast
Itunes: [url]itpc://10minutejoomlatips.blip.tv/rss/itunes[/url]
Feedburner http://feeds.feedburner.com/10MinutesJoomlaTips

Davey72
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Fri Apr 06, 2012 2:45 pm

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by Davey72 » Tue May 08, 2012 5:25 pm

corrado444 wrote:I have tried every suggestion I found here, but mine still doesn't work. I am about to ditch the whole thing and try a form component.

I have tried sendmail
SMTP mail with a native email address
Gmail

None worked. What I get is the page simply refreshes and no email is sent. The one thing I have always trusted about Joomla was the contact form.

Same here. And ALL my joomla 1.5x sites work no problem.

Does anyone have any solid info? Unlike the TS, I do not believe it's a problem with my hosting.

I am hoping for a solution to this very soon because I am waiting to deliver the site to a client and the only thing left to do is resolve this form issue.

All help is welcome.

Thanks!

nicnic
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 115
Joined: Thu Jul 20, 2006 9:07 am
Contact:

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by nicnic » Wed May 09, 2012 11:26 pm

Same here, nothing seems to work. When I hit send (Php mailer or SMTP) the page just quickly refresh (no thank you message or anything.)

Oh well, I'll contact my host.

Davey72
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Fri Apr 06, 2012 2:45 pm

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by Davey72 » Wed May 09, 2012 11:39 pm

Come on guys (developers, support, gurus...), please shed some light on this. If this issue will be fixed on a future release, or if you are working on a solution, this is all very important info for us devoted users to know.

There are way too many users experiencing this issue for it to be passed over. Please help.

feesh
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Thu Aug 05, 2010 8:33 pm

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by feesh » Tue May 29, 2012 11:56 pm

YES! this is the exact same problem i am having.
email worked fine in 1.5, but not now.
my webhost has no idea.
i have tried PHP mail, SMTP with my own ISP's settings (as i do for home use, they insist) and even my host SMTP settings.
i have tried every port i can, i have tried SSL/no SSL.... pretty much EVERYTHING.

ANYONE????????????

this is a MAJOR drag. i was hacked last month and had to tear the entire site down and rebuild from scratch in a new template. i do not want that to happen again, and leaving my email addy as a naked link on the site is not what i want to do anymore.

help?

Davey72
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Fri Apr 06, 2012 2:45 pm

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by Davey72 » Wed May 30, 2012 12:20 am

I installed another instance of joomla in a subfolder of my domain, and the contact form works there.

I checked all my settings and lots of code, and they are exactly the same.

It's frustrating that no one can shed any light on this issue.

So maybe try that. If it works, maybe there are still some bugs in the 2.5 install that we dont know about.

feesh
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Thu Aug 05, 2010 8:33 pm

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by feesh » Wed May 30, 2012 12:57 am

hmmm. interesting for sure. thing is, every time i try to mess with Joomla, i get even more headaches. i'm really not a web guy... just broke, so i'm doing it myself, you know?
are you saying you're pointing the form from your existing site to look at the newer joomla install? not sure what you mean EXACTLY.
thanks for the tip!

feesh
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Thu Aug 05, 2010 8:33 pm

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by feesh » Wed May 30, 2012 1:00 am

my site got hacked last month, so i wouldn't even be on 2.5 if that hadn't happened.
everything worked great in 1.5.
once i upgraded (recommended for security as 1.5 has a lot of "holes" they said) all kinds of stuff that used to work beautifully now DON'T.
i find 2.5 clunky and frustrating. but here we are now, so....

simz
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Wed Jun 17, 2009 1:06 pm
Location: france
Contact:

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by simz » Sat Jun 02, 2012 12:16 am

hello
for me that it's working:
for smtphost: mail.skiscool.com
for smtpport: 26

yes 25 didn't work and i passed a lot of time in the cpanel manual to find the port


localhost dont work for some host
maybe try like me : mail.yourhost.com
or ask at your providor

feesh
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Thu Aug 05, 2010 8:33 pm

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by feesh » Sat Jun 02, 2012 5:32 am

hey simz. thanks, but i tried EVERYTHING so far, including what you suggested.

simz
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Wed Jun 17, 2009 1:06 pm
Location: france
Contact:

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by simz » Sat Jun 02, 2012 12:33 pm

if your joomla is not a fresh install.. maybe some update failed... or something
try to rewrite the folder phpmailer in librairies with the last one in joomla 2.5.4 package.

the best is to use a little code to check your smtp parameters.
go in this site take the script and execute it with your parameter and check if it's working!

http://www.rackspace.com/knowledge_cent ... ctionality

to test be sure you have PEAR installed in your providor (phpinfo) else the script won t work

to install PEAR it s easy just download pear put it in the same folder level than your script and in your script
add these line at the beginning:

Code: Select all

if (strpos(__FILE__, ':') !== false) {
	$path_delimiter = ';';
} else {
	$path_delimiter = ':';
}
ini_set('include_path', ini_get('include_path') . $path_delimiter . dirname(__FILE__) . '/PEAR');
Test smtp and when you will be sure about the port and the host just put them in the configuration.php file in joomla.

Maybe as well desactivate all spam protection in your providor in your cpanel.. sometime it's just because the door is closed!

Simon

feesh
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Thu Aug 05, 2010 8:33 pm

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by feesh » Sun Jun 03, 2012 5:02 am

okay simz!! wow. many thanks for all that. basically, my site was hacked and i wiped the server of all my stuff. Joomla 2.5 was installed by my webhost (they have "one click installs") but it probably over the 1.7 install from the previous incarnation of the site. will have to try this info you have given me, though i will admit it is at the moment WAY over my head. i will forge forth though!
MANY thanks!

User avatar
matt_nz
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 168
Joined: Sat Jun 21, 2008 12:43 am

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by matt_nz » Wed Jun 13, 2012 12:55 am

I had a similar issue, J15 email sent ok, upgraded to J25, same settings, same server, email would not send, no error messages.

I tried installing a fresh 2.5.4 into a sub folder on the server and the email sent ok, so it seemed like an issue with that one Joomla install that had been upgraded.

As Joomla's email functions are in the libraries folder, I downloaded a fresh J25 zip, and uploaded the libraries folder to my site (overwriting), the email works now.

I'm not sure why this would happen, as I done my Joomla 2.5 upgrade with a fresh J25, and just migrated the database with spupgrade, obviously something went wrong with the libraries folder somewhere.

feesh
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Thu Aug 05, 2010 8:33 pm

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by feesh » Thu Jun 14, 2012 12:20 am

thanks matt! will try it out when i get a chance.
cheers!
fish

chanderjeet
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Wed Jun 27, 2012 8:25 pm

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by chanderjeet » Wed Jun 27, 2012 8:34 pm

I am using Joomla 2.5.6 with XAMPP and this is how I fixed it :

Step 1 :

Mailer = smtp
From email = xxx@gmail.com (actual email address that works)
From Name = This can be anything.
Sendmail Path = /usr/sbin/sendmail
SMTP Authentication = Yes
SMTP Security = SSL
SMTP Port = 465
SMTP Username = xxx@gmail.com (your gmail address that works)
SMTP Password = **** (password for your gmail account)
SMTP Host = smtp.gmail.com

Step 2 :

- Open C:\xampp\php (or wherever your xampp is installed)
- Open php.ini in notepad and search for [PECL]
- This will take you to a section with lot of extensions listed.
- Add the following line just above the [PECL]
extension=php_openssl.dll
- Save the file
- Restart the apache service and you should be good :D

nicnic
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 115
Joined: Thu Jul 20, 2006 9:07 am
Contact:

Re: Joomla 2.5.4 Contact Form Not Sending Mail

Post by nicnic » Fri Jun 29, 2012 12:48 pm

Can't really understand Simz explaination. Tried all other options and my site still dosen't send anything.

Host hasn't found any solution so far.

This is getting anoying. :-\


Post Reply

Return to “Joomla! 2.5 Coding”