Automated check for Joomla! & Mambo Versions script

Joomla version 1.0 is end-of-life and are no longer supported. Please use Joomla 3.x instead.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
User avatar
Wizzie
Joomla! Hero
Joomla! Hero
Posts: 2703
Joined: Tue Sep 06, 2005 4:37 am
Location: Australia
Contact:

Automated check for Joomla! & Mambo Versions script

Post by Wizzie » Mon Jun 26, 2006 7:17 am

As a design and hosting firm, we got sick of always trying to remember which client was on which version of Joomla! (and Mambo....we discovered we had forgotten to convert some!). So we wrote a perl script. Below is what the coder provided.

It is provided to everyone but there are no guarantees, support and you use at your own risk.

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------

A quick and (very) dirty perl script to find and report all your Joomla/Mambo and some Component versions and details,
either to STDOUT or via an email alert. Refer to the notes below for limitations.

STDOUT/Email Output Example:

    -----------------------------------------------------------------------------------
    Mambo Version: 4.5.2.2 Stable
    Build:  Released: 02-June-2005  Codename: Titan Recoiled
    /home/user1/domains/user1.com.au/public_html/
    ===================================================================================

    -----------------------------------------------------------------------------------
    Joomla! Version: 1.0.9 Stable
    Build: 3876  Released: 05 June 2006  Codename: Sunshine
    /home/user2/domains/user2.com.au/public_html/j109/
    ===================================================================================
Run via cron, once a week or so, keep track of out-of-date versions reducing the risk of older vulnerable instances being
left on servers accidentally or just to version manage your servers instances.

Notes:
  1. Older versions of Mambo will not report all variables, namely "Build" as this was not published in the older revisions.
  2. Only components that publish a "version.php" and conform to a similar format to Joomla! will report.
      (IE: VirtueMart/mambo-phpShop)
  3. There is always a chance that other applications that use "version.php" in a similar format maybe picked up also.

  ------------------------------------------------------------------------------------------------------------------------------------------
  This program is free software; you can redistribute it and/or modify it under the terms of the 
  GNU General Public License as published by the Free Software Foundation; either version 2
  of the License, or (at your option) any later version.                                                           
                                                                                                                                     
  This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY;
  without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
  PURPOSE. See the GNU General Public License for more details.
  =====================================================================
You do not have the required permissions to view the files attached to this post.
Last edited by Tonie on Wed Jun 28, 2006 6:18 pm, edited 1 time in total.

charlottezweb
Joomla! Apprentice
Joomla! Apprentice
Posts: 19
Joined: Mon Dec 05, 2005 8:10 pm

Re: Automated check for Joomla! & Mambo Versions script

Post by charlottezweb » Tue Jun 27, 2006 12:02 am

Any reason this wouldn't work on a server running Perl 5.8.7? 
Can't locate File/Find/Rule.pm in @INC (@INC contains: /usr/lib/perl5/5.8.7/i686-linux /usr/lib/perl5/5.8.7 /usr/lib/perl5/site_perl/5.8.7/i686-linux /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.1/i686-linux /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl/5.6.0 /usr/lib/perl5/site_perl .) at check.pl line 30.

BEGIN failed--compilation aborted at check.pl line 30.
Cheers,
Jason

User avatar
Wizzie
Joomla! Hero
Joomla! Hero
Posts: 2703
Joined: Tue Sep 06, 2005 4:37 am
Location: Australia
Contact:

Re: Automated check for Joomla! & Mambo Versions script

Post by Wizzie » Tue Jun 27, 2006 7:43 am

Hi Jason

I just asked the developer, he said the script should run under Perl 5.8.7 but you need to ensure Perl Modules File::Find::Rule is installed and possibly MIME::Lite.

The developer just looked at the error message you quoted and he said that it looks like the File::Find::Rule Perl Module hasn't been installed.

You probably already now this, but for those that don't, to install this Perl Module using Cpan (Command cpan install File::Find::Rule).

Hope this fixes your problem.

Cheers
Robyn

gjj
Joomla! Apprentice
Joomla! Apprentice
Posts: 29
Joined: Fri Sep 02, 2005 2:04 pm
Location: Reading, UK
Contact:

Re: Automated check for Joomla! & Mambo Versions script

Post by gjj » Tue Jun 27, 2006 11:03 am

I get the same error. Unfortunatly, on a shared hosting service I can't add the perl module (though I guess I could install my own perl - but that sounds like hard work!

Great idea though!!

Gareth
Gareth

User avatar
Wizzie
Joomla! Hero
Joomla! Hero
Posts: 2703
Joined: Tue Sep 06, 2005 4:37 am
Location: Australia
Contact:

Re: Automated check for Joomla! & Mambo Versions script

Post by Wizzie » Tue Jun 27, 2006 11:30 am

Approach your hosting provider, they maybe willing to install the Perl Module for you. It is worth a try.

charlottezweb
Joomla! Apprentice
Joomla! Apprentice
Posts: 19
Joined: Mon Dec 05, 2005 8:10 pm

Re: Automated check for Joomla! & Mambo Versions script

Post by charlottezweb » Tue Jun 27, 2006 12:19 pm

Wizzie wrote: I just asked the developer, he said the script should run under Perl 5.8.7 but you need to ensure Perl Modules File::Find::Rule is installed and possibly MIME::Lite.

The developer just looked at the error message you quoted and he said that it looks like the File::Find::Rule Perl Module hasn't been installed.
Thanks!  I'll give that a shot.

Cheers,
Jason

charlottezweb
Joomla! Apprentice
Joomla! Apprentice
Posts: 19
Joined: Mon Dec 05, 2005 8:10 pm

Re: Automated check for Joomla! & Mambo Versions script

Post by charlottezweb » Tue Jun 27, 2006 1:16 pm

Your instructions worked perfectly.  GREAT OUTPUT, you just saved me a LOT of time.  Thank you so much for sharing this.

Regards,
Jason

jraff
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Thu Jan 19, 2006 10:19 pm
Location: Northern New Jersey, USA

Re: Automated check for Joomla! & Mambo Versions script

Post by jraff » Tue Jul 11, 2006 8:23 pm

Wizzie wrote: Approach your hosting provider, they maybe willing to install the Perl Module for you. It is worth a try.
As long as the moldule is PURE PERL... (No "C")
I've had luck installing the module on my local machine then FTPing the files to the web server in some local directory.
Just make sure you add the local directory/files to the INC path.

uncobeth
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Tue Jun 27, 2006 1:20 am
Location: SP, NC US
Contact:

Re: Automated check for Joomla! & Mambo Versions script

Post by uncobeth » Sun Dec 31, 2006 1:29 am

Thanks very much for posting your script.  It's been very helpful!

jraff
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Thu Jan 19, 2006 10:19 pm
Location: Northern New Jersey, USA

Re: Automated check for Joomla! & Mambo Versions script

Post by jraff » Fri Dec 28, 2007 4:30 pm

gjj wrote: I get the same error. Unfortunatly, on a shared hosting service I can't add the perl module (though I guess I could install my own perl - but that sounds like hard work!

Great idea though!!

Gareth
One can install a pure perl module in one's own virtual include area and then reference it directly in the application.

berteh
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Feb 14, 2008 9:05 am

Re: Automated check for Joomla! & Mambo Versions script

Post by berteh » Mon Mar 17, 2008 10:16 am

hello.

the txt attachement can't be accessed anylonger, would you mind copying the script content in the post?

thanks.
B.

User avatar
dam-man
Joomla! Exemplar
Joomla! Exemplar
Posts: 7961
Joined: Fri Sep 09, 2005 2:13 pm
Location: The Netherlands
Contact:

Re: Automated check for Joomla! & Mambo Versions script

Post by dam-man » Mon Mar 17, 2008 11:25 am

berteh wrote:hello.

the txt attachement can't be accessed anylonger, would you mind copying the script content in the post?

thanks.
B.
Would be nice indeed :geek:
Robert Dam - Joomla Forum Moderator
Dutch Boards | Joomla Coding Boards | English Support Boards

ptomter
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Wed Jun 25, 2008 9:48 am

Re: Automated check for Joomla! & Mambo Versions script

Post by ptomter » Sun Mar 22, 2009 4:36 pm

I want to add an excludepath in the script can someone please help me?

webuserdan
Joomla! Apprentice
Joomla! Apprentice
Posts: 24
Joined: Tue Jun 16, 2009 11:42 pm

Re: Automated check for Joomla! & Mambo Versions script

Post by webuserdan » Wed Jul 28, 2010 6:58 am

Sorry if this is a stupid question but is there a way to tell if a site is running the current version? i.e. I can see this script will tell me the version but it won't tell me if its current right? Is there some way we can retrieve something from Joomla.org that tells us the current version then we can compare with that?
Web Circle

http://www.webcircle.com.au Gold Coast Web Design - http://awebsitedesigner.com.au Website Design Blog


Locked

Return to “Upgrading - 1.0.x”