RTMP Bitrate streaming problem with ALLVideo Reloaded & AWS

This forum is for general questions about extensions for Joomla! version 1.5.x.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Mon Jul 23, 2012 7:34 pm

RTMP Bitrate streaming problem with ALLVideo Reloaded & AWS

Postby dnharris » Mon Jul 23, 2012 8:20 pm


I have successfully implemented the RTMP code using the custom tag with a single file (tested both flv and mp4) using AVR v1.2.7.1054 w/ JW Player using Joomla 1.5 and a rocket theme. However, I am having trouble with bitrate dynamic switching though.

I have tried referring to a rss xml file containing the links to the videos {rtmp...}video.xml{/rtmp} as well as copying the hard code from a working single video file and replacing {file...} with {Levels: [ {bitrate='3500' width='1920' file='video1920.flv'} ] }

see below..

This works: {rtmp...}video.mp4{rtmp}
This does not work: {rtmp...}videobitrate.xml{rtmp}

videobitrate.xml file contains:
<rss version="2.0" xmlns:media="http://search.yahoo.com/mrss/"
<title>Playlist with RTMP Dynamic Streaming</title>
<media:content bitrate="3500" url="video720.flv" width="1280" />
<media:content bitrate="1800" url="video576.flv" width="1024"/>
<media:content bitrate="900" url="video432.flv" width="768" />
<media:content bitrate="600" url="video288.flv" width="512" />
<media:content bitrate="300" url="video144.flv" width="256" />

This script in an article does not work either:

<script type="text/javascript">
image:'image works fine ',
levels: [
{ bitrate: 3500, width: 1280, file: 'video720.flv' },
{ bitrate: 1800, width: 1024, file: 'video576.flv' },
{ bitrate: 900, width: 768, file: 'video432.flv' },
{ bitrate: 600, width: 512, file: 'video288.flv' },
{ bitrate: 300, width: 256, file: 'video144.flv' }

note I took out the file as I was anticipating levels: would work in its place..


User avatar
Joomla! Champion
Joomla! Champion
Posts: 5672
Joined: Thu Aug 18, 2005 2:09 am
Location: California

Re: RTMP Bitrate streaming problem with ALLVideo Reloaded &

Postby kenmcd » Wed Jul 25, 2012 12:10 am

Looks like you have a mix of newer embed code and an older player, incorrect XML file, etc., etc.
Quite a mess.

I am guessing you found how to add an RTMP tag to AVR from one of my older posts.

If I remember correctly the v4.3.132 player does not support multi-bitrate.
The v4.7 player does support it (IIRC).
So the AVR embed code could be adjusted to use the newer player.

I can attach the v4.7 player SWF here.
With a correct XML file it should work.

If you would like help to get it working, please provide real media links for me to test.

██ LibreTraining

Return to “Extensions for Joomla! 1.5”

Who is online

Users browsing this forum: No registered users and 7 guests