Upgrade from 2.5.27 to 3.3.3 fatal error(s)

Need help upgrading your Joomla! website or converting to Joomla! 3.x? Please consider the availability of third-party templates and extensions when deciding which Joomla version to use.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
tokenring
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 240
Joined: Sun Mar 22, 2009 11:42 pm

Upgrade from 2.5.27 to 3.3.3 fatal error(s)

Post by tokenring » Thu Nov 06, 2014 10:16 pm

Hey everyone!

Well I experienced that same error that lots of users have seen when upgrading to 3.3.3. I've been preparing for the upgrade over the last month:

prep:
  • uninstalling any module, component and/or plugin that was not in use
    make sure all component,modules and/or plugins are both J2.5 and J3.x (compatible)
    perform a backup
    and execute this on the test site
this is what I thought I did successfully. I did the upgrade and immediately the admin control panel broke and I saw that dreaded error:

Table '<tableName>_postinstall_messages' doesn't exist SQL=SHOW FULL COLUMNS FROM `<tableName>_postinstall_messages`" tabindex="0">1146 - Table '<tableName>_postinstall_messages' doesn't exist SQL=SHOW FULL COLUMNS FROM `<tableName_messages>

that was in the back end. I opened the front end and I saw an error that said something like:
easy_calc_plus J2.5 isn't the correct version, please install the version for 3.x

Since I couldn't get the cpanel (at this time) I went into MySQL and I disabled the plugin. I refreshed the front end and the error was still there.

I Googled around on what to do and I saw some tricks to get to specific parts of the admin control panel by using:
administrator/index.php?option=com_config
administrator/index.php?option=com_installer&view=database
administrator/index.php?option=com_installer


but when I do I get errors like this:
Fatal error: Call to a member function get() on a non-object in <http://path/administrator/components/co ... roller.php on line 39

Fatal error: Call to a member function get() on a non-object in
<http://path/administrator/components/co ... roller.php on line 36


and in the front end I see errors like this now:
1146 - Table '<tableName>_contentitem_tag_map' doesn't exist SQL=SELECT `m`.`tag_id`,`t`.* FROM `<tableName>_contentitem_tag_map` AS m INNER JOIN `<tableName>_tags` AS t ON `m`.`tag_id` = `t`.`id` WHERE `m`.`type_alias` = 'com_content.article' AND `m`.`content_item_id` = 107 AND `t`.`published` = 1 AND t.access IN (1,1)

1146 - Table '<tableName>_contentitem_tag_map' doesn't exist SQL=SELECT `m`.`tag_id`,`t`.* FROM `<tableName>_contentitem_tag_map` AS m INNER JOIN `<tableNane>_tags` AS t ON `m`.`tag_id` = `t`.`id` WHERE `m`.`type_alias` = 'com_content.article' AND `m`.`content_item_id` = 107 AND `t`.`published` = 1 AND t.access IN (1,1)

These are my environment details:
PHP Built On Linux info 3.0 #1337 SMP Tue Jan 01 00:00:00 CEST 2000 all GNU/Linux
Database Version 5.1.73-log
Database Collation utf8_general_ci
PHP Version 5.5.18
Web Server Apache
WebServer to PHP Interface cgi-fcgi
Joomla! Version Joomla! 2.5.27 Stable [ Ember ] 30-September-2014 14:00 GMT
Joomla! Platform Version Joomla Platform 11.4.0 Stable [ Brian Kernighan ] 03-Jan-2012 00:00 GMT
User Agent Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/38.0.2125.111 Safari/537.36

So I don't know what to do now? I can't access the front or the back.


Thanks!

coding1
I've been banned!
Posts: 340
Joined: Mon Oct 20, 2014 10:42 am

Re: Upgrade from 2.5.27 to 3.3.3 fatal error(s)

Post by coding1 » Sat Nov 08, 2014 4:27 am

- click Fix database button in extension manager
- you can copy update package in your folder if it failed when update

sovainfo
Joomla! Exemplar
Joomla! Exemplar
Posts: 8818
Joined: Sat Oct 01, 2011 7:06 pm

Re: Upgrade from 2.5.27 to 3.3.3 fatal error(s)

Post by sovainfo » Sat Nov 08, 2014 11:44 am

Restore backup, disable plugin "Remember me", increase max_execution_time in php.ini, restart apache, update to 3.3.6, update easy_calc.
Issue with migrating? Include logs/joomla_update.php in your report!
Blank screen? Verify pagesource for HTML code (javascript error)
Installation failing on populating database? Install with set_time_limit(0)
Document your customizations!

tokenring
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 240
Joined: Sun Mar 22, 2009 11:42 pm

Re: Upgrade from 2.5.27 to 3.3.3 fatal error(s)

Post by tokenring » Sat Nov 08, 2014 5:08 pm

The problem is that I can't get to the admin control panel.

- I can't click fix db - admin control panel is not available
- I can't do a restore, admin control panel is not available

tokenring
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 240
Joined: Sun Mar 22, 2009 11:42 pm

Re: Upgrade from 2.5.27 to 3.3.3 fatal error(s)

Post by tokenring » Sat Nov 08, 2014 5:22 pm

If I go to the control panel now, I see this

Fatal error: Call to a member function set() on a non-object in <URL>/administrator/components/com_login/controller.php on line 38

tokenring
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 240
Joined: Sun Mar 22, 2009 11:42 pm

Re: Upgrade from 2.5.27 to 3.3.3 fatal error(s)

Post by tokenring » Sat Nov 08, 2014 5:35 pm

I've done this now:

rename :

/libraries/cms/controller

to

/libraries/cms/controller_

and now I can get to parts of the admin control panel. I'll do some more work and investigation and try to get to a state where I can perform the steps you guys have suggested above.

sovainfo
Joomla! Exemplar
Joomla! Exemplar
Posts: 8818
Joined: Sat Oct 01, 2011 7:06 pm

Re: Upgrade from 2.5.27 to 3.3.3 fatal error(s)

Post by sovainfo » Sat Nov 08, 2014 6:28 pm

Restoring doesn't require access to Joomla Control Panel. It is something you do on the filesystem!
Issue with migrating? Include logs/joomla_update.php in your report!
Blank screen? Verify pagesource for HTML code (javascript error)
Installation failing on populating database? Install with set_time_limit(0)
Document your customizations!

tokenring
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 240
Joined: Sun Mar 22, 2009 11:42 pm

Re: Upgrade from 2.5.27 to 3.3.3 fatal error(s)

Post by tokenring » Sat Nov 08, 2014 9:47 pm

sovainfo wrote:Restoring doesn't require access to Joomla Control Panel. It is something you do on the filesystem!
could be true! :-)

Thanks!

tokenring
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 240
Joined: Sun Mar 22, 2009 11:42 pm

Re: Upgrade from 2.5.27 to 3.3.3 fatal error(s)

Post by tokenring » Sat Nov 08, 2014 9:56 pm

I'm in now, but when I go to the repair option, I see this:
1146 - An error has occurred.
Table 'db.table_postinstall_messages' doesn't exist SQL=SHOW FULL COLUMNS FROM `table_postinstall_messages`

or this if I try to go to the installer by URL:
Table 'db.table_weblinks' doesn't exist SQL=SHOW COLUMNS IN `db_weblinks` WHERE field = 'alias' AND type = 'VARCHAR(255)'


going to try the options suggested above with some caution!
Last edited by tokenring on Sun Nov 09, 2014 11:52 am, edited 1 time in total.

tokenring
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 240
Joined: Sun Mar 22, 2009 11:42 pm

Re: Upgrade from 2.5.27 to 3.3.3 fatal error(s)

Post by tokenring » Sat Nov 08, 2014 10:06 pm

I was able to get to the "Discover" area in the Cpanel. I ran the tool and the list is about 20 deep that I have to update. I'm not sure about the accuracy of the entire list.

tokenring
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 240
Joined: Sun Mar 22, 2009 11:42 pm

Re: Upgrade from 2.5.27 to 3.3.3 fatal error(s)

Post by tokenring » Sun Nov 09, 2014 12:42 am

Update!

Can't get any of the front end content to load. I can get to most of the admin area except for the most important areas.

System -> Control Panel:
1146 - An error has occurred.
Table 'db.table_postinstall_messages' doesn't exist SQL=SHOW FULL COLUMNS FROM `table_postinstall_messages`


Extensions -> Extension Manager -> Database:
1146 - An error has occurred.
Table 'db.table_content_types' doesn't exist SQL=SHOW COLUMNS IN `table_content_types` WHERE field = 'content_history_options'


Components -> Joomla Update -> Update Server -> Save and Close:
1054 - An error has occurred.
Unknown column 'a.extra_query' in 'field list' SQL=SELECT DISTINCT a.update_site_id, a.type, a.location, a.last_check_timestamp, a.extra_query FROM table_update_sites AS a INNER JOIN table_update_sites_extensions AS b ON a.update_site_id = b.update_site_id WHERE a.enabled = 1 AND b.extension_id = 700

I ran the discover and installed all of the updates. I Uninstalled Component -> "Content History", but I still get the Content_History error

Can I get that package anywhere (Content_History)???

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 35497
Joined: Sat Apr 05, 2008 9:58 pm

Re: Upgrade from 2.5.27 to 3.3.3 fatal error(s)

Post by Webdongle » Sun Nov 09, 2014 1:33 am

If you use xampp on your PC (mamp on mac) http://forum.joomla.org/viewtopic.php?f ... 4#p3233724 gives links to some alternative methods of updating.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

tokenring
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 240
Joined: Sun Mar 22, 2009 11:42 pm

Re: Upgrade from 2.5.27 to 3.3.3 fatal error(s)

Post by tokenring » Sun Nov 09, 2014 11:29 am

I forgot to say, that when logging in to the admin control panel, I see this error:
Fatal error: Call to a member function checkSession() on a non-object in /URL.path/plugins/user/joomla/joomla.php on line 209

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 35497
Joined: Sat Apr 05, 2008 9:58 pm

Re: Upgrade from 2.5.27 to 3.3.3 fatal error(s)

Post by Webdongle » Sun Nov 09, 2014 11:47 am

You will keep getting errors until you reinstate your backup like Sovainfo suggested. In my previous post you will find a link that gives more information about recovering from a failed update.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

tokenring
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 240
Joined: Sun Mar 22, 2009 11:42 pm

Re: Upgrade from 2.5.27 to 3.3.3 fatal error(s)

Post by tokenring » Sun Nov 09, 2014 11:55 am

I wasn't completely clear on what I said. I only did an akeeba backup. Without quickly looking into it, I'm sure this won't work. Is it impossible to work through this?

tokenring
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 240
Joined: Sun Mar 22, 2009 11:42 pm

Re: Upgrade from 2.5.27 to 3.3.3 fatal error(s)

Post by tokenring » Sun Nov 09, 2014 11:55 am

I already have SP upgrade installed on this instance. Is that the part of your link you are referring to?

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 35497
Joined: Sat Apr 05, 2008 9:58 pm

Re: Upgrade from 2.5.27 to 3.3.3 fatal error(s)

Post by Webdongle » Sun Nov 09, 2014 12:36 pm

http://forum.joomla.org/viewtopic.php?f ... 4#p3233724 may help if you want to upgrade manually.

If you are having Problems with SP upgrade then perhaps contact them http://cyend.com/extensions/contact-us
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

tokenring
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 240
Joined: Sun Mar 22, 2009 11:42 pm

Re: Upgrade from 2.5.27 to 3.3.3 fatal error(s)

Post by tokenring » Sun Nov 09, 2014 12:42 pm

My system is showing version 3.3.3

tokenring
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 240
Joined: Sun Mar 22, 2009 11:42 pm

Re: Upgrade from 2.5.27 to 3.3.3 fatal error(s)

Post by tokenring » Sun Nov 09, 2014 2:30 pm

A very interesting update and possibly a premature "It's fixed" statement.

I did something probably no one would recommend in any situation, but I just did this and my control panel is fully available and so is all the content on the front end.:
  • Current version 3.3.6 - broken with all errors above in last 2-3 posts
    Installed joomla_2.5.26_to_2.5.27 package, version shows 2.5.27 in control panel
    Now able to get to Extension -> Database and Extension -> Database -> Fix without errors
    DB errors shows about 46 errors, but they don't fix upon running fix (Joomla is 2.5, DB is 3.0.1 errors)
    Deleted the contents of folder /administrator/components/com_admin/sql/updates/mysql
    DB errors shows 1 error, but it doesn't fix (3.0.1 CMS db mismatch)
    Install 3.0.1 to 3.0.2, no errors in DB
    No errors anywhere in control panel
    All content on Front end accessible
going to step through each update and continue. Who knows, maybe it works. If it does, I'll mark the thread appropriately.

For the live site (new migration)

I'll do an Akeeba back
An independent file system and db backup (CML, phpMyadmin)
Uninstall easy_calc
Disable RememberMe plugin
Double make sure all 3rd party extensions are compatible
Do not use the Joomla update option to go from 2.5.27 to 3.3.6 (manually update 2.5.27 to 3.0.1)

thanks everyone! wish me luck!

tokenring
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 240
Joined: Sun Mar 22, 2009 11:42 pm

Re: Upgrade from 2.5.27 to 3.3.3 fatal error(s)

Post by tokenring » Sun Nov 09, 2014 2:38 pm

These were the DB errors I saw at step #4 when I installed the 2.5.26 to 2.5.27 patch

42 Database Problems Found 42
Other Information

Database schema version (2.5.27) does not match CMS version (3.0.3).
Table 'table_content' does not have column 'title_alias' with type 'VARCHAR(255)'. (From file 1.7.3-2011-10-15.sql.)
Table 'keycd_content' does not have column 'title_alias' with type 'VARCHAR(255)'. (From file 1.7.4-2011-11-23.sql.)
Table 'table_weblinks' should not have column 'sid'. (From file 3.0.0.sql.)
Table 'table_weblinks' should not have column 'date'. (From file 3.0.0.sql.)
Table 'table_weblinks' should not have column 'archived'. (From file 3.0.0.sql.)
Table 'table_weblinks' should not have column 'approved'. (From file 3.0.0.sql.)
Table 'table_menu' should not have column 'ordering'. (From file 3.0.0.sql.)
Table 'table_session' should not have column 'usertype'. (From file 3.0.0.sql.)
Table 'table_users' should not have column 'usertype'. (From file 3.0.0.sql.)
Table 'table_updates' should not have column 'categoryid'. (From file 3.0.0.sql.)
Table 'table_weblinks' does not have column 'version'. (From file 3.0.0.sql.)
Table 'table_weblinks' does not have column 'images'. (From file 3.0.0.sql.)
Table 'table_newsfeeds' does not have column 'description'. (From file 3.0.0.sql.)
Table 'table_newsfeeds' does not have column 'version'. (From file 3.0.0.sql.)
Table 'table_newsfeeds' does not have column 'hits'. (From file 3.0.0.sql.)
Table 'table_newsfeeds' does not have column 'images'. (From file 3.0.0.sql.)
Table 'table_contact_details' does not have column 'version'. (From file 3.0.0.sql.)
Table 'table_contact_details' does not have column 'hits'. (From file 3.0.0.sql.)
Table 'table_banners' does not have column 'created_by'. (From file 3.0.0.sql.)
Table 'table_banners' does not have column 'created_by_alias'. (From file 3.0.0.sql.)
Table 'table_banners' does not have column 'modified'. (From file 3.0.0.sql.)
Table 'table_banners' does not have column 'modified_by'. (From file 3.0.0.sql.)
Table 'table_banners' does not have column 'version'. (From file 3.0.0.sql.)
Table 'table_categories' does not have column 'version'. (From file 3.0.0.sql.)
Table 'table_finder_terms' does not have column 'language'. (From file 3.0.0.sql.)
Table 'table_finder_tokens' does not have column 'language'. (From file 3.0.0.sql.)
Table 'table_finder_tokens_aggregate' does not have column 'language'. (From file 3.0.0.sql.)
Table 'table_associations' does not have column 'id' with type 'INT(11)'. (From file 3.0.3.sql.)
Table 'table_contentitem_tag_map' does not exist. (From file 3.1.0.sql.)
Table 'table_tags' does not exist. (From file 3.1.0.sql.)
Table 'table_ucm_content' does not exist. (From file 3.1.0.sql.)
Table 'table_modules' does not have column 'asset_id'. (From file 3.2.0.sql.)
Table 'table_postinstall_messages' does not exist. (From file 3.2.0.sql.)
Table 'table_ucm_history' does not exist. (From file 3.2.0.sql.)
Table 'table_users' does not have column 'otpKey'. (From file 3.2.0.sql.)
Table 'table_users' does not have column 'otep'. (From file 3.2.0.sql.)
Table 'table_user_keys' does not exist. (From file 3.2.0.sql.)
Table 'table_update_sites' does not have column 'extra_query'. (From file 3.2.2-2013-12-22.sql.)
Table 'table_updates' does not have column 'extra_query'. (From file 3.2.2-2013-12-22.sql.)
Table 'table_users' does not have column 'requireReset'. (From file 3.3.0-2014-02-16.sql.)
Table 'table_user_profiles' does not have column 'profile_value' with type 'TEXT'. (From file 3.3.4-2014-08-03.sql.)

Database schema version (in #__schemas): 2.5.27.
Update version (in #__extensions): 3.0.3.
Database driver: mysql.
69 database changes were checked successfully.
176 database changes did not alter table structure and were skipped.

tokenring
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 240
Joined: Sun Mar 22, 2009 11:42 pm

Re: Upgrade from 2.5.27 to 3.3.3 fatal error(s)

Post by tokenring » Sun Nov 09, 2014 2:53 pm

The next updates and fixes.

3.1.0 database after fix
Database schema version (in #__schemas): 3.1.0.
Update version (in #__extensions): 3.1.0.
Database driver: mysql.
70 database changes were checked successfully.
103 database changes did not alter table structure and were skipped.


3.1.0 to 3.1.1
Database schema version (in #__schemas): 3.1.1.
Update version (in #__extensions): 3.1.1.
Database driver: mysql.
70 database changes were checked successfully.
104 database changes did not alter table structure and were skipped.


3.1.1 to 3.1.4
Database schema version (in #__schemas): 3.1.4.
Update version (in #__extensions): 3.1.4.
Database driver: mysql.
72 database changes were checked successfully.
117 database changes did not alter table structure and were skipped.


3.1.4 to 3.1.5
Database schema version (in #__schemas): 3.1.5.
Update version (in #__extensions): 3.1.5.
Database driver: mysql.
72 database changes were checked successfully.
117 database changes did not alter table structure and were skipped.


***
I have come across a new issue.
When I attempt to upgrade from 3.1.5 to 3.2.0, the site just refreshes after the upload is complete.

tokenring
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 240
Joined: Sun Mar 22, 2009 11:42 pm

Re: Upgrade from 2.5.27 to 3.3.3 fatal error(s)

Post by tokenring » Sun Nov 09, 2014 3:37 pm

90% percent done!

3.1.5 to 3.2.0
didn't work (just refreshed and stayed at 3.1.5)


3.1.5 to 3.3.0
Database schema version (in #__schemas): 3.3.0-2014-04-02.
Update version (in #__extensions): 3.3.0.
Database driver: mysql.
83 database changes were checked successfully.
137 database changes did not alter table structure and were skipped.

...

3.3.1 - 3.3.2 - 3.3.3 - 3.3.4 - 3.3.5 - all worked with no errors.

3.3.5 to 3.3.6
Database schema version (in #__schemas): 3.3.6-2014-09-30.
Update version (in #__extensions): 3.3.6.
Database driver: mysql.
84 database changes were checked successfully.
139 database changes did not alter table structure and were skipped.

The only thing now is that the admin control panel looks funny. I couldn't change the default template as that column couldn't be clicked. I went into the DB and disabled (1 -> 0) for the "Home" column on the only admin template that had it enabled (bluestork)

Now the backend looks perfect. No admin template is defaulted though and I see this error:

Error
The template for this display is not available.

Changed the default to "isis" and looks like all is well.

... I'm sure there are some underlying errors, but nevertheless everything seems okay functionality.

Finally 3.3.6 Lives!

sovainfo
Joomla! Exemplar
Joomla! Exemplar
Posts: 8818
Joined: Sat Oct 01, 2011 7:06 pm

Re: Upgrade from 2.5.27 to 3.3.3 fatal error(s)

Post by sovainfo » Sun Nov 09, 2014 3:47 pm

Try reading the release notes! You should have skipped J335. Since you are on J336 now don't think anything is wrong.
Issue with migrating? Include logs/joomla_update.php in your report!
Blank screen? Verify pagesource for HTML code (javascript error)
Installation failing on populating database? Install with set_time_limit(0)
Document your customizations!

tokenring
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 240
Joined: Sun Mar 22, 2009 11:42 pm

Upgrade from 2.5.27 to 3.3.6 - Some content errors

Post by tokenring » Wed Nov 12, 2014 11:44 am

This is in relation to thread : http://forum.joomla.org/viewtopic.php?f=710&t=864798

After I did the upgrade on the test side as in the above thread, I did it properly on the live site. This time I didn't have all of the errors. I only had to do the DB fixes along the way.

However, there are many spots in the front end now where the content is not available. These are the errors I get when accessing menus that linked to "registered user" content (articles).

front end - Menu #1
1054 - Unknown column 'c.version' in 'field list' SQL=SELECT c.id, c.asset_id, c.access, c.alias, c.checked_out, c.checked_out_time, c.created_time, c.created_user_id, c.description, c.extension, c.hits, c.language, c.level, c.lft, c.metadata, c.metadesc, c.metakey, c.modified_time, c.note, c.params, c.parent_id, c.path, c.published, c.rgt, c.title, c.modified_user_id, c.version, CASE WHEN CHAR_LENGTH(c.alias) != 0 THEN CONCAT_WS(':', c.id, c.alias) ELSE c.id END as slug,COUNT(i.`id`) AS numitems FROM table_categories as c LEFT JOIN table_categories AS s ON (s.lft <= c.lft AND s.rgt >= c.rgt) OR (s.lft > c.lft AND s.rgt < c.rgt) LEFT JOIN (SELECT cat.id as id FROM table_categories AS cat JOIN table_categories AS parent ON cat.lft BETWEEN parent.lft AND parent.rgt WHERE parent.extension = 'com_content' AND parent.published != 1 GROUP BY cat.id) AS badcats ON badcats.id = c.id LEFT JOIN `table_content` AS i ON i.`catid` = c.id AND i.state = 1 WHERE (c.extension='com_content' OR c.extension='system') AND c.access IN (1,1,2) AND c.published = 1 AND s.id=44 AND badcats.id is null GROUP BY c.id, c.asset_id, c.access, c.alias, c.checked_out, c.checked_out_time, c.created_time, c.created_user_id, c.description, c.extension, c.hits, c.language, c.level, c.lft, c.metadata, c.metadesc, c.metakey, c.modified_time, c.note, c.params, c.parent_id, c.path, c.published, c.rgt, c.title, c.modified_user_id, c.version ORDER BY c.lft

All errors are the same when clicking a menu that points to articles. If I access front end menus that point to components and modules, they are okay and show up, it just errors out for articles.

If I access those same menu's to articles in the admin control panel, I get the same error when I try and change the menu type. See screen shot.
You do not have the required permissions to view the files attached to this post.

sovainfo
Joomla! Exemplar
Joomla! Exemplar
Posts: 8818
Joined: Sat Oct 01, 2011 7:06 pm

Re: Upgrade from 2.5.27 to 3.3.6 - Some content errors

Post by sovainfo » Wed Nov 12, 2014 12:12 pm

What does logs/joomla)update.php say?
Issue with migrating? Include logs/joomla_update.php in your report!
Blank screen? Verify pagesource for HTML code (javascript error)
Installation failing on populating database? Install with set_time_limit(0)
Document your customizations!

tokenring
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 240
Joined: Sun Mar 22, 2009 11:42 pm

Re: Upgrade from 2.5.27 to 3.3.6 - Some content errors

Post by tokenring » Wed Nov 12, 2014 9:46 pm

Not too much actually. This is what I have.

#
#<?php die('Forbidden.'); ?>
#Date: 2014-11-09 21:54:08 UTC
#Software: Joomla Platform 12.2.0 Stable [ Neil Armstrong ] 21-September-2012 00:00 GMT

#Fields: datetime priority category message
2014-11-09T21:54:08+00:00 INFO update COM_JOOMLAUPDATE_UPDATE_LOG_DELETE_FILES
2014-11-09T21:55:49+00:00 INFO update COM_JOOMLAUPDATE_UPDATE_LOG_DELETE_FILES
2014-11-09T21:57:42+00:00 INFO 24.36.216.189 update COM_JOOMLAUPDATE_UPDATE_LOG_DELETE_FILES
2014-11-09T22:41:37+00:00 INFO update Update started by user admin (683). Old version is 3.3.3.
2014-11-09T22:41:37+00:00 INFO update Downloading update file from .
2014-11-09T22:41:38+00:00 INFO update File Joomla_3.3.x_to_3.3.6-Stable-Patch_Package.zip successfully downloaded.
2014-11-09T22:41:39+00:00 INFO update Starting installation of new version.
2014-11-09T22:41:42+00:00 INFO 24.36.216.189 update Finalising installation.

tokenring
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 240
Joined: Sun Mar 22, 2009 11:42 pm

Re: Upgrade from 2.5.27 to 3.3.6 - Some content errors

Post by tokenring » Wed Nov 12, 2014 10:00 pm

I was just thinking... looking at it now, it doesn't really sound like it completed. Are there other lines after mine in a log file after a successful update?

sovainfo
Joomla! Exemplar
Joomla! Exemplar
Posts: 8818
Joined: Sat Oct 01, 2011 7:06 pm

Re: Upgrade from 2.5.27 to 3.3.6 - Some content errors

Post by sovainfo » Wed Nov 12, 2014 10:12 pm

This is what it should be:
2014-10-08T20:17:00+00:00 INFO update Update started by user Super User (864). Old version is 3.3.3.
2014-10-08T20:17:00+00:00 INFO update Downloading update file from .
2014-10-08T20:17:05+00:00 INFO update File Joomla_3.3.x_to_3.3.6-Stable-Patch_Package.zip successfully downloaded.
2014-10-08T20:17:06+00:00 INFO update Starting installation of new version.
2014-10-08T20:17:26+00:00 INFO ::1 update Finalising installation.
2014-10-08T20:17:26+00:00 INFO ::1 update Ran query from file 3.3.4-2014-08-03. Query text: ALTER TABLE `#__user_profiles` CHANGE `profile_value` `profile_value` TEXT NOT N.
2014-10-08T20:17:26+00:00 INFO ::1 update Ran query from file 3.3.6-2014-09-30. Query text: INSERT INTO `#__update_sites` (`name`, `type`, `location`, `enabled`) VALUES ('J.
2014-10-08T20:17:26+00:00 INFO ::1 update Ran query from file 3.3.6-2014-09-30. Query text: INSERT INTO `#__update_sites_extensions` (`update_site_id`, `extension_id`) VALU.
2014-10-08T20:17:26+00:00 INFO ::1 update Deleting removed files and folders.
2014-10-08T20:17:30+00:00 INFO ::1 update Cleaning up after installation.
2014-10-08T20:17:30+00:00 INFO ::1 update Update to version 3.3.6 is complete.
Issue with migrating? Include logs/joomla_update.php in your report!
Blank screen? Verify pagesource for HTML code (javascript error)
Installation failing on populating database? Install with set_time_limit(0)
Document your customizations!

tokenring
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 240
Joined: Sun Mar 22, 2009 11:42 pm

Re: Upgrade from 2.5.27 to 3.3.6 - Some content errors

Post by tokenring » Wed Nov 12, 2014 10:58 pm

Can I run those queries/scripts manually for a fix? It looks like you went from 3.3.3 to 3.3.6

sovainfo
Joomla! Exemplar
Joomla! Exemplar
Posts: 8818
Joined: Sat Oct 01, 2011 7:06 pm

Re: Upgrade from 2.5.27 to 3.3.6 - Some content errors

Post by sovainfo » Thu Nov 13, 2014 2:07 am

Sure, you can find them in administrator/components/com_admin/sql/updates/mysql.
You would need to replace #__ with your prefix_.

The cli/deletefiles.php is the equivalent for the function mentioned in the log deleting the files/folders.

The updates of the manifest can be done in the backend.

Unfortunately there a few things in administrator/components/com_admin/script.php that you need to do manually. Sofar I haven't found any documentation mentioning that. You would need to verify whether you need to do something and then figure out how to do it or ask here!

Looks like your infra is having problems, you might want to check system logfiles or use the Forum Post Assistant mentioned above in the header of the forum.
Issue with migrating? Include logs/joomla_update.php in your report!
Blank screen? Verify pagesource for HTML code (javascript error)
Installation failing on populating database? Install with set_time_limit(0)
Document your customizations!


Locked

Return to “Migrating and Upgrading to Joomla! 3.x”