Forvirring med Canonical URL

Spørsmål om administrasjon og installering

Moderators: Per Yngve Berg, sone12

Locked
Liibre
Joomla! Apprentice
Joomla! Apprentice
Posts: 16
Joined: Mon Apr 22, 2013 11:47 am

Forvirring med Canonical URL

Post by Liibre » Wed Feb 04, 2015 4:17 pm

Hei, jeg er forholdsvis fersk med joomla og har noen spørsmål. Jeg forvirres av dette med canonical url. Tidligere var websiden vår (http://adventuresbarcelona.com) satt opp tospråklig. Etter en tid valgte vi to seperate domener .no og .com, med henholdsvis norsk og engelsk språk. Når jeg sjekker Google webmaster tools får jeg ofte feil på .com siden, såkalte "crawl errors".

URL'ene som mangler innholder /en/. Det er merkelig, ettersom engelsk nå er eneste språk, og hovedspråket på .com domenet, og derfor brukes ikke /en/ mer. Når jeg forsøkte å legge ut link til en av våre nyhetsartikler på facebook, kom ikke bildet opp. Jeg brukte facebook debug tool for å finne feilen, og får beskjed om at min link http://adventuresbarcelona.com har en canonical url som er http://adventuresbarcelona.com/en/ Jeg antar dette kan forklare feilene i Google Webmaster Tools, og det er vel kanskje grunnen til at bilder til linkene ikke vises på facebook. I tillegg får jeg en del advarsler i Facebook debug tool (se vedlegg).

Saken er at jeg aner ikke hvorfor vår canonical url er satt til http://adventuresbarcelon.com/en/ istedetfor http://adventuresbarcelona.com. For å være ærlig er jeg usikker på hva en canonical url er. Hvor i Joomla kan jeg endre denne? Jeg gjetter at dette kan fordi siden en gang var tospråklig, men vet ikke sikkert. Det hele er ganske forvirrende, så hvis noen har tips om hvordan jeg kan løse dette ville det vært til fantastisk god hjelp! Takk!
You do not have the required permissions to view the files attached to this post.

User avatar
rued
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4790
Joined: Fri Sep 16, 2005 10:23 pm
Location: Finland / Norway
Contact:

Re: Forvirring med Canonical URL

Post by rued » Thu Feb 05, 2015 4:29 pm

Todelt sak,

Gamle lenker vil fortsatt finnes rundt i systemene på nett, de må bare omdirigeres. Noe som du har fått noe innspill på her, i din nesten identiske engelske tråd: http://forum.joomla.org/viewtopic.php?f=708&t=870354 I forhold til Google har du vel sikkert opprettet og sendt inn oppdaterte sidekart?

Utover det burde du jo nesten vite hva du har satt opp i konfigurasjon og av programtillegg, men ellers er det nok bare å begynne å lete med lys og forstørrelsesglass, rundt i alle kriker og kroker. ;)

Se på 'Konfigurasjonen', og også direkte i configuration.php-fila, samt .htaccess-fila.

Se over alle programtillegg, spesielt de av system-typen som har med domene og flerspråklig funksjonalitet å gjøre, se også på om du har installert noe ekstra.

Finner du ikke noe andre steder får du også sjekke om noe er lagt inn direkte i designet.

PS! Med et tillegg som 'Language Domains' hadde dere kanskje ikke behøvd å dele opp siden i flere installasjoner. Og ellers er den utrolig treg å laste, One er billig - men ikke bra ...
Rune Rasmussen - http://www.syntaxerror.no
Norske nettløsninger og integrasjoner, CONSIGNOR EDI, Mamut ordreimport og produkteksport, kortbetaling og faktura m.m.

Norsk Joomla! - Norwegian Translation Team - http://www.norskjoomla.no

User avatar
rued
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4790
Joined: Fri Sep 16, 2005 10:23 pm
Location: Finland / Norway
Contact:

Re: Forvirring med Canonical URL

Post by rued » Thu Feb 05, 2015 4:37 pm

Påse forresten at Facebook laster oppdatert side, og ikke en eldre mellomlagret.

Kildekode vist her viser ingen /en/ i canonical-adressen, så jeg tror siden er i orden, og at det er Facebook som kødder med deg. :)
adventuresbarcelona.png
adventuresbarcelona_news.png
You do not have the required permissions to view the files attached to this post.
Rune Rasmussen - http://www.syntaxerror.no
Norske nettløsninger og integrasjoner, CONSIGNOR EDI, Mamut ordreimport og produkteksport, kortbetaling og faktura m.m.

Norsk Joomla! - Norwegian Translation Team - http://www.norskjoomla.no

Liibre
Joomla! Apprentice
Joomla! Apprentice
Posts: 16
Joined: Mon Apr 22, 2013 11:47 am

Re: Forvirring med Canonical URL

Post by Liibre » Tue Feb 10, 2015 10:37 am

Hei Per Yngve, takk for svar og gode tips!
rued wrote: Gamle lenker vil fortsatt finnes rundt i systemene på nett, de må bare omdirigeres. Noe som du har fått noe innspill på her, i din nesten identiske engelske tråd: http://forum.joomla.org/viewtopic.php?f=708&t=870354 I forhold til Google har du vel sikkert opprettet og sendt inn oppdaterte sidekart?
Jeg forsøkte å endre .htaccess fila som ble forslått i den andre tråden, men det gav meg enda verre feilmeldinger, så jeg endret den tilbake. I forhold til Google, så er sitemap oppdatert og riktig ja.
rued wrote: Utover det burde du jo nesten vite hva du har satt opp i konfigurasjon og av programtillegg, men ellers er det nok bare å begynne å lete med lys og forstørrelsesglass, rundt i alle kriker og kroker. ;)
Det er veldig begrenset, jeg har bare et par programtillegg, bruker i veldig liten grad plugins utover standardinstallasjonen av joomla + noen fra templateutvikleren, og konfigurasjonen er stort sett standard. Har i stor grad holdt meg til å endre innhold og utseende, ikke scriptet noe selv eller gjort store konfigurasjonsendringer. .htaccess fila er standard, eneste endringer der er fra joomla, med SEO friendly url. I configuration.php finner jeg heller ikke spor etter noe som kan ha satt canonical url til /en/.
rued wrote: PS! Med et tillegg som 'Language Domains' hadde dere kanskje ikke behøvd å dele opp siden i flere installasjoner. Og ellers er den utrolig treg å laste, One er billig - men ikke bra ...
Egentlig ganske fornøyd med delingen slik den er nå, ettersom det gjør sidene mindre sårbare. Siden er forholdsvis treg ja, jobber med å forbedre det. Vi benytter One.com for den norske og Bluehost for den engelske. Faktisk har vi så langt hatt bedre erfaring med one.com som host, enn Bluehost. Både i forhold til hastighet, og i forhold til Bluehosts mailservere.

Det du skriver til slutt om facebook er interessant. For det er dette som virkelig forvirrer meg. Jeg har ikke gjort endringer (ihvertfall ikke bevisst) som skulle tilsi at at canonical url skal inneholde /en/, likevel er det det facebook viser. Jeg har forsøkt på nytt igjen og forsikret meg om at det ikke er en mellomlagret versjon, men får samme resultat hver gang jeg linker artikler fra Facebook.

Når du sjekker kildekoden så viser den akkurat som du sier, ikke canonical med /en/. Men, når jeg tester på http://www.seoreviewtools.com/canonical ... n-checker/ så får jeg også beskjed om at canonical er: http://adventuresbarcelona.com/en/ Noe som tyder på at det ikke bare er Facebook som kødder.

Så, forvirringen er fortsatt total :eek: Det merkelige er at det samme skjer ikke med .no domenet, der er canonical riktig. Det til tross for at versjonen på .no domenet har utspring i eksakt samme versjon og konfigurasjon som .com siden....

Har du noen andre tips på hva som kan forårsake dette, og hvordan jeg kan få fikset det?

Takk for hjelpen så langt!


Locked

Return to “Administrasjon/installasjon”