PHP 5.6 och Joomla 1.5?

Diskutera allmänna frågor rörande Joomla! 1.5!

Moderators: Zello, chrille

Forum rules
Forumregler
Locked
magnusd
Joomla! Explorer
Joomla! Explorer
Posts: 421
Joined: Sat Dec 08, 2007 4:36 pm

PHP 5.6 och Joomla 1.5?

Post by magnusd » Mon Feb 09, 2015 10:25 pm

Hej
Administrerar en webbutik gjord I 1.5
Tyvärr inte helt enkel att uppgradera.

Nu säjer One.com att de kommer att uppgradera till PHP 5.6. Kör 5.3 idag.

Kommer det att fungera?

Hälsningar
Magnus

User avatar
maxa
Joomla! Guru
Joomla! Guru
Posts: 557
Joined: Sat Aug 27, 2005 11:07 am
Location: Sweden
Contact:

Re: PHP 5.6 och Joomla 1.5?

Post by maxa » Mon Feb 09, 2015 10:56 pm

Hej Magnus!

Nej Joomla 1.5 fungerar inte på php 5.6. Men du bör uppdatera din Joomla snarast ändå. Surfade häromdan in på en webbyrå som kör Joomla 1.5 och fick röd varningsskärm från webbläsaren att det fanns skadlig kod på sajten. Det är inte en kul signal till besökarna. Joomla 1.5 går inte hålla säkert idag. Visst, det är lite jobb att uppdatera, men trösten är att det är väldigt enkelt att uppdatera dagens versioner. Ungefär som i WordPress.

Så fatta mod och skrid till verket! Lycka till!

magnusd
Joomla! Explorer
Joomla! Explorer
Posts: 421
Joined: Sat Dec 08, 2007 4:36 pm

Re: PHP 5.6 och Joomla 1.5?

Post by magnusd » Mon Feb 09, 2015 11:11 pm

Vilken är den senaste versionen 1.5 fungerar med? Körs som sagt på 5.3 idag, utan problem.

Magnus

magnusd
Joomla! Explorer
Joomla! Explorer
Posts: 421
Joined: Sat Dec 08, 2007 4:36 pm

Re: PHP 5.6 och Joomla 1.5?

Post by magnusd » Tue Feb 10, 2015 9:50 am

Om man ska migrera vilket är att rekomendera? till 2.5 först eller direct till 3.0? Misstänker att det finns en del komponenter som inte har stöd för 3.0

Finns det något alternative tillo Jupgrade. Har använt detta tidigare och har flera ganger råkat ut för att den stökar till en del I database och sabbar framförallt alla kategorier.

Hälsningar
Magnus

EE Photo
Joomla! Ace
Joomla! Ace
Posts: 1858
Joined: Mon Dec 14, 2009 4:17 pm

Re: PHP 5.6 och Joomla 1.5?

Post by EE Photo » Wed Feb 11, 2015 7:34 pm

Skulle tro att högre än PHP 5.3 så kommer du få problem, på Joomlas hemsida rekommenderar dom PHP 5.2: http://www.joomla.org/technical-requirements.html

Jag använde JUpgrade när jag migrerade och det gick bra även under den tiden när komponenten hade en del problem. Vad jag har förstått ska dom ha fixat dom problemen nu. Skrev en guide om det här: http://1drv.ms/1rCgRoy

Du ska kunna gå direkt till Joomla 3 nu. Men se till så att alla dina tillägg fungerar med Joomla 3.
Besök gärna min webbplats: http://www.fotoforalla.se/

magnusd
Joomla! Explorer
Joomla! Explorer
Posts: 421
Joined: Sat Dec 08, 2007 4:36 pm

Re: PHP 5.6 och Joomla 1.5?

Post by magnusd » Wed Feb 11, 2015 7:56 pm

Ja, jag testade. 5.3 funkar. 5.4 gör det inte. har för gammalt av allt. Webbshopen kör Virtumart 1. Massa manuellt ändrat I filerna, mallar och VM-teman som inte funkar, så får I princip göra om allt ändå. Så väljer att bygga nytt med Joomla 3 och Virtuemart 3. Går det att importera alla produkter från den gamla butiken så är det bra, annars bara att lägga in på nytt.

Kommer troligen flytta siten till Binero också och då är det inte lika akut eftersom de fortfarande erbjuder både PHP 5.2 och 5.3.

EE Photo
Joomla! Ace
Joomla! Ace
Posts: 1858
Joined: Mon Dec 14, 2009 4:17 pm

Re: PHP 5.6 och Joomla 1.5?

Post by EE Photo » Wed Feb 11, 2015 8:07 pm

Tror nog det bästa alternativet faktiskt är att bygga om. Då börjar du helt rent också och kan vara säker på att du inte har blivit infekterad med något. Skulle säga att risken är rätt hög att du är infekterad nu om du kör Joomla 1.5 och Virtuemart 1.
Besök gärna min webbplats: http://www.fotoforalla.se/


Locked

Return to “Allmänna frågor”