Admin Login Loop

Need help with the Administration of your Joomla! 3.x site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
waynejb
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Wed Feb 13, 2008 4:34 pm

Admin Login Loop

Post by waynejb » Tue May 30, 2017 2:53 pm

After Updating to Joomla 3.7.2 cannot login using admin login page. Looked at the log file, just says failure. Using IIS 8.5 and PHP 7. Reset password via database, same result. Note: all other admins cannot login either. Turned on debug and maximum error reporting, nothing showing. Login from front also ends in loop failure.

Looking for other things to try.

User avatar
JAVesey
Joomla! Hero
Joomla! Hero
Posts: 2048
Joined: Tue May 14, 2013 1:21 pm
Location: Cardiff, Wales, UK
Contact:

Re: Admin Login Loop

Post by JAVesey » Tue May 30, 2017 3:50 pm

Have you tried clearing both your site and browser caches? Make sure that your site cookie is deleted from your browser ;)

Do you have any caching services/CSN in place?
John V
Cardiff, Wales, UK
Uses Joomla 3.9.11 and PHP7.3

waynejb
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Wed Feb 13, 2008 4:34 pm

Re: Admin Login Loop

Post by waynejb » Tue May 30, 2017 5:37 pm

Yes, cleared both site and browser caches and not currently using any other services. :(
Also did a full install of J3.72 in case any files were corrupt.

waynejb
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Wed Feb 13, 2008 4:34 pm

Re: Admin Login Loop

Post by waynejb » Wed May 31, 2017 8:13 pm

After several days of working on this issue, this is what I found.

Somehow plg_authentication_joomla and plug_user_joomla setting were all set to 0 withing the database.

Step 1: Log in to db management

Step 2: BACK UP!!

Step 3: go to joomla_sessions and delete all lines.

Step 4: go to joomla_extensions>plg_user_joomla

Step 5: Set client_id, enabled, access & Protected to 1

Step 3: Repeate this for plg_authentication_joomla

You might want to insure that plg_authentication_joomla (nder joomla_extensions) is also set to 1 on client_id, enabled, access & protected.

I was then allowed access!

potvor
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Fri Jun 02, 2017 1:01 pm

Re: Admin Login Loop

Post by potvor » Mon Dec 18, 2017 1:39 pm

Hi, thanks for info
I did all you said but I am still in the loop.
Any suggestions?

dunbarr
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Thu Apr 24, 2014 6:59 pm

Re: Admin Login Loop

Post by dunbarr » Thu Feb 28, 2019 4:06 pm

I have tried this solution, but I still have the same issue of a looping admin login.


Post Reply

Return to “Administration Joomla! 3.x”