Update 3.8.10 - iframes no longer work?

Need help upgrading your Joomla! website or converting to Joomla! 3.x? Please consider the availability of third-party templates and extensions when deciding which Joomla version to use.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
ahawthorne
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Wed Aug 30, 2017 7:38 pm

Update 3.8.10 - iframes no longer work?

Post by ahawthorne » Fri Jul 13, 2018 6:41 pm

All of my iframes with [youtube] videos embedded that have worked for years, since 2.5 through 3.8.7 and 3.8.8 no longer work after upgrading to 3.8.10. Recopied embed code from [youtube] - same. Tried <object data tag, as well as iframe. Example embed code:
<iframe width="560" height="315" src="https://www.[youtube].com/embed/AViKKehE2is?rel=0" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe>
Cannot find any other changes that might have broken these.
Thanks for any help.
Amy

ahawthorne
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Wed Aug 30, 2017 7:38 pm

Re: Update 3.8.10 - iframes no longer work?

Post by ahawthorne » Fri Jul 13, 2018 7:26 pm

This forum automatically added those brackets around [youtube]. They are NOT in the code. Thanks.

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 24869
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Update 3.8.10 - iframes no longer work?

Post by Per Yngve Berg » Fri Jul 13, 2018 9:17 pm


User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 19105
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Update 3.8.10 - iframes no longer work?

Post by leolam » Sat Jul 14, 2018 5:37 am

JCE-editor has a media manager which allows to embed any type of video from most providers in an article/module/etc https://joomlacontenteditor.net

Leo 8)
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
Member Joomla Bug Squad & Joomla CMS Release Team

Dtorr1981
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Wed May 06, 2015 8:37 am

Re: Update 3.8.10 - iframes no longer work?

Post by Dtorr1981 » Sat Jul 14, 2018 10:21 am

I can confirm this bug, I have managed to work around it by removing the https: from the src url. i.e.

Code: Select all

<iframe width="560" height="315" src="//www.[youtube].com/embed/G9kN3mHBXh0?rel=0&showinfo=0" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe>
I hope this helps.

Regards
D

ahawthorne
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Wed Aug 30, 2017 7:38 pm

Re: Update 3.8.10 - iframes no longer work?

Post by ahawthorne » Mon Jul 16, 2018 5:55 pm

Thanks for the replies. Am using <object data="https://www.[youtube].com/v/AViKKehE2is?rel=0" width="100%" height="400"></object> for now, but will try this iframe change as well.


Post Reply

Return to “Migrating and Upgrading to Joomla! 3.x”