Cant access articles in administration, page works

Need help with the Administration of your Joomla! 3.x site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
praf123
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Sat Sep 15, 2018 1:07 pm

Cant access articles in administration, page works

Post by praf123 » Sat Sep 15, 2018 1:20 pm

I have a page avtogeni-trening.si

I updated articles at least 1 year ago.

Last week I noticed my google position was dropping rapidly, so I entered to htaccess the in order to have a certificate SSL.

I also set php to 7.2 since joomla reminded me it is too old. I had 7.0?!

As you can see I am a rookie:) I, however, do not make enough money to pay extra.

Then I updated to joomla 3.8.12 from 3.8.3. I thought now I am set.

I tried to update my articles and got http 500 errror.

Ok, then I switched back to php 7.0 and restored my last backup. From before these changes.

OK, and now if I try to access articles I do not get http error 500, but a blank page.

Please help! The site works still.

Another question since I have https now, do I need redirects for google hits?

Thank you all and sorry if things are too basic.

User avatar
AMurray
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3838
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Cant access articles in administration, page works

Post by AMurray » Sun Sep 16, 2018 12:04 am

Last week I noticed my google position was dropping rapidly, so I entered to htaccess the in order to have a certificate SSL.
The SSL seems to be working, although on the front-end when I click the green padlock, it says something about insecure content being blocked by my browser (Firefox). I suspect this might be more my own system, as I have an ad-blocker plugin for Firefox, and it might be blocking Google ads or something like that.

Also I guess, in time, your site will be re-indexed by Google and regain its ranking - otherwise you can resubmit it through Google Webmaster tools. You don't have to do anything else as far as I know.

I don't know why you're getting the Error 500 in the administrator while trying to edit articles. Since we don't have your back-end access, it's not something we can troubleshoot easily.

You would be advised to use the Forum Post Assistant - viewtopic.php?f=714&t=793531- so we can see the detailed system information that might help us track any other issues.

Otherwise, can you advise if the issue is resolved?
Regards,
--------------------------------------------------------------
A Murray
Millennium Falcon - it's the ship that made the Kessel run in less than 12 parsecs! The fastest hunk of junk in the galaxy.

deleawo
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Tue Jun 05, 2012 8:56 pm

Re: Cant access articles in administration, page works

Post by deleawo » Sun Sep 16, 2018 6:14 am

Hi praf123

I had an issue similar to this. It got resolved when I changed the php version on the cpanel of my live site to the version on the testing site of my back up(I normally test my back up's in a live environment to make sure everything works before making the changes on the live site). I then deleted the live site and upload the last back up that I tested. This resolved the issue.

User avatar
toivo
Joomla! Exemplar
Joomla! Exemplar
Posts: 9697
Joined: Thu Feb 15, 2007 5:48 am
Location: Oxford, UK
Contact:

Re: Cant access articles in administration, page works

Post by toivo » Sun Sep 16, 2018 6:54 am

Google Chrome usually reports the site as insecure because of links starting with 'http' instead of 'https'. The home page has four links to stylesheets from fonts.googleapis.com and one in the footer in the t3- copyright section.

There is no need to change the .htaccess file to enable the SSL protocol, just select the SSL option in the Global Configuration.

The 500 error, 'internal server error', may have occurred because of a third party extension, which has coding issues in PHP 7.2, maybe a deprecated function or a strict standards error.

A blank page usually indicates that a PHP fatal error has occurred. Change the level of error reporting in Global Configuration to 'Maximum' to get more information displayed and written to the PHP error log, which will help identifying the root cause of the problem.

You could troubleshoot the error and test first both the extensions and the full upgrade process in PHP 7.0 and 7.2 by installing a localhost bundle like XAMPP or Wampserver in your workstation. The Wampserver product allows you to install several version of PHP and swap between them. The documentation in the sticky topics of the forum at http://forum.wampserver.com/list.php?2 contains detailed installation instructions and tutorials how to set up virtual hosts in Apache, to support more than one development and testing site.
Toivo Talikka, Global Moderator
my first programs were assembled and run in 16KB :)
troubleshooting smtp and other articles https://talikka.com/joomla

praf123
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Sat Sep 15, 2018 1:07 pm

Re: Cant access articles in administration, page works

Post by praf123 » Sun Sep 16, 2018 7:15 am

Thanks,

I will try to get this done. I will report the result in order if someone will have use of that. I appreciate the help!

praf123
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Sat Sep 15, 2018 1:07 pm

Re: Cant access articles in administration, page works

Post by praf123 » Sun Sep 16, 2018 7:10 pm

The article 500 error was caused because the content database table was not updated.

Regards,

User avatar
toivo
Joomla! Exemplar
Joomla! Exemplar
Posts: 9697
Joined: Thu Feb 15, 2007 5:48 am
Location: Oxford, UK
Contact:

Re: Cant access articles in administration, page works

Post by toivo » Sun Sep 16, 2018 7:15 pm

It could actually be the other way around. Does that mean that articles were not updated because of a PHP fatal error? If you can post the full error message here, others may be able to give you tell you what is wrong and what to do.
Toivo Talikka, Global Moderator
my first programs were assembled and run in 16KB :)
troubleshooting smtp and other articles https://talikka.com/joomla


Post Reply

Return to “Administration Joomla! 3.x”