Joomla 3 generates Invalid Referral error with external weblink

This forum is for issues with installing Joomla! 3.x on IIS webservers.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
APSchnabel
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Thu Oct 04, 2018 9:08 pm

Joomla 3 generates Invalid Referral error with external weblink

Post by APSchnabel » Thu Oct 04, 2018 9:16 pm

Hello, we are running Joomla! 3.8.12 Stable on IIS 10 on Server 2016 and we've just run in to a very strange problem. We use BMC Track-It! as our helpdesk ticketing software and we recently upgraded from version 11.4 to version 2018.02 which is entirely web based.

I put links to the Track-It! self-service portal on our joomla intranet site both as an external url menu item and as a weblink on the front page. For some reason, clicking the links from Joomla leads to an issue where the Track-It! website doesn't pass through the windows credentials automatically like it should. Our users actually can't login because it is stuck trying to authenticate them.

If you type in the url manually or click it from another program like Outlook or Word, the Track-It! site works just fine.

As part of trying to trouble shoot this, I turned on Windows Authentication in IIS and at that point, when clicking the link from our intranet site I started getting an Unhandled Exception, Invalid Referrer error in the Track-It! web app. This only occurs when clicking the link from our Joomla site.

If anyone has any suggestions on how to troubleshoot this, I would appreciate it. I'm not saying it's Joomla's fault instead of Track-It's, since every other external link we have works just fine (including some using Windows Authentication) but it is strange that the problem only occurs when the traffic is coming from Joomla.

I've opened a ticket with BMC's support on their end, but I thought I would reach out here to see if anyone had any ideas on what I could do to resolve this.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 37323
Joined: Sat Apr 05, 2008 9:58 pm

Re: Joomla 3 generates Invalid Referral error with external weblink

Post by Webdongle » Thu Oct 04, 2018 10:03 pm

http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein


Post Reply

Return to “Joomla! 3.x on IIS webserver”