Issue in old version of JCE Editor after upgrading to Joomla 3.9.0 Topic is solved

This forum is for general questions about extensions for Joomla! 3.x.

Moderators: pe7er, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Locked
wutting
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Nov 02, 2018 11:59 pm

Issue in old version of JCE Editor after upgrading to Joomla 3.9.0

Post by wutting » Sat Nov 03, 2018 12:18 am

Hello...
Hope I am in the correct place for my question on how to fix the following error.
I am using wamp64, php vers. 7.2.10 , windows 7.
The following errors occur when I try to do some things in the control panel.

Clicking new article, shows these errors...
Clicking Articles to go to next menu does not produce the errors.
But from this new page, clicking to edit an article or create an article or create a new category produces this error...
I am not really sure what to do except ask does anyone here know what is the problem.
Thanks in advance...

Warning: Illegal string offset 'icon' in D:\wamp64\www\library\components\com_jce\editor\libraries\classes\browser.php on line 615

Warning: Cannot assign an empty string to a string offset in D:\wamp64\www\library\components\com_jce\editor\libraries\classes\browser.php on line 615

Warning: Illegal string offset 'action' in D:\wamp64\www\library\components\com_jce\editor\libraries\classes\browser.php on line 616

Warning: Cannot assign an empty string to a string offset in D:\wamp64\www\library\components\com_jce\editor\libraries\classes\browser.php on line 616

Warning: Illegal string offset 'title' in D:\wamp64\www\library\components\com_jce\editor\libraries\classes\browser.php on line 617

Warning: array_merge(): Argument #2 is not an array in D:\wamp64\www\library\components\com_jce\editor\libraries\classes\browser.php on line 620

Warning: array_key_exists() expects parameter 2 to be array, null given in D:\wamp64\www\library\components\com_jce\editor\libraries\classes\browser.php on line 623
Last edited by toivo on Sat Nov 03, 2018 7:01 am, edited 1 time in total.
Reason: mod note: moved to 3.x Extensions, retitled

User avatar
AMurray
Joomla! Champion
Joomla! Champion
Posts: 7263
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Error In Joomla 3.9.0

Post by AMurray » Sat Nov 03, 2018 12:48 am

The errors seems related to JCE editor. Have you updated it to the latest version? Maybe they haven't released a compatible 3.9.0 version yet. Suggest reporting the errors on the JCE forum.

JCE (Core) is currently v 2.6.3 released in October 2018.
https://www.joomlacontenteditor.net/support/forum

That's the only thing I can think of as it would appear to be an error with JCE, not Joomla.

Given you're using WAMPServer, try other various PHP versions e.g. 5.6.x, 7.1.x etc You can install those in WAMPServer without reinstalling the entire server software. Just download the modules and install them, and restart WAMP.

While I haven't seen these errors myself, this is the second question on the same issue I've seen on this forum.
viewtopic.php?f=706&t=966890
Regards - A Murray

wutting
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Nov 02, 2018 11:59 pm

Re: Error In Joomla 3.9.0

Post by wutting » Sat Nov 03, 2018 5:08 am

I updated Joomla to 3.9 today so that has probably something to do with it... thanks for your input... also cannot get to JCE control panel as that is broken as well... will try the other link you sent to me... thanks..

wutting
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Nov 02, 2018 11:59 pm

Re: Error In Joomla 3.9.0

Post by wutting » Sat Nov 03, 2018 5:37 am

Okay.... I got the newest version of JCE and figured out how to upgrade manually... now all is well...

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 28323
Joined: Mon Oct 27, 2008 9:27 pm
Location: Romerike, Norway

Re: Error In Joomla 3.9.0

Post by Per Yngve Berg » Sat Nov 03, 2018 8:24 am

AMurray wrote:
Sat Nov 03, 2018 12:48 am
JCE (Core) is currently v 2.6.3 released in October 2018.
You have missed 30 releases as I have 2.6.33

wutting
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Nov 02, 2018 11:59 pm

Re: Issue in old version of JCE Editor after upgrading to Joomla 3.9.0

Post by wutting » Sat Nov 03, 2018 9:22 pm

Thanks for updates... it is all working now.... Thanks

User avatar
AMurray
Joomla! Champion
Joomla! Champion
Posts: 7263
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Issue in old version of JCE Editor after upgrading to Joomla 3.9.0

Post by AMurray » Sat Nov 03, 2018 11:06 pm

yes, just a typo, should have been 2.6.33.
Regards - A Murray


Locked

Return to “Extensions for Joomla! 3.x”