Module loadin .ini not .sys.ini language file

Did you find a bug in Joomla! 3.x but aren't sure? This forum is the place to help figure out if the problem is a bug and how to report it. If you are an experienced Joomla! user and are certain that you have found a bug please use the Bug Tracker to submit your issue.
This forum is for discussion about bugs and to get help with reporting them to the Bug Tracker: https://issues.joomla.org

Moderator: ooffick

Forum rules
Please use the official Bug Tracker to report a bug: https://issues.joomla.org
Post Reply
jmoelholt
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Tue Dec 25, 2018 5:41 pm

Module loadin .ini not .sys.ini language file

Post by jmoelholt » Tue Dec 25, 2018 6:05 pm

Hi

I did try to develop a module. When adding language files, the system does not load the .sys.ini language file but only the .ini language file. I use the methode of storing the language files under the module in the language folder.

When i did place the language strings in the .sys.ini file they did not "translate" in the backend, but when i did place the same strings in the .ini file, they did "translate" i.e show in the backend.

It seems that in the backend Joomla does not load the .sys.ini file but uses the .ini file only.

My example:

My language files is under module folder "language/en-GB"

en-GB.mod_hotodcf.sys.ini and en-GB.mod_hotodcf.ini:
MOD_HOTODCF_XML_DESCRIPTION="hotoDCF - Hometoll Display Custom Field"
MOD_HOTODCF_CUSTOMFIELD_LABEL="Custom field"
MOD_HOTODCF_CUSTOMFIELD_DESC="What custom fields should be displayed"
MOD_HOTODCF_OUTPUTEMPTY_LABEL="Display empty field"
MOD_HOTODCF_OUTPUTEMPTY_DESC="No (default)=Do not display the field - Yes=Display the field even if empty"


mod_hotodcf.xml (cut version):
<description>MOD_HOTODCF_XML_DESCRIPTION</description>
<files>
<filename>mod_hotodcf.xml</filename>
<filename module="mod_hotodcf">mod_hotodcf.php</filename>
<filename>index.html</filename>
<filename>helper.php</filename>
<folder>tmpl</folder>
<folder>language</folder>
</files>
<config>
<fields name="params">
<fieldset name="basic">

<field name="hotodcf_customfield" type="text"
default=""
label="MOD_HOTODCF_CUSTOMFIELD_LABEL"
description="MOD_HOTODCF_CUSTOMFIELD_DESC"
size="40"
/>


Best regards
John

Post Reply

Return to “Joomla! 3.x Bug Reporting”