Created my firstbasic module but install throws error 0 Call to a member function.. Topic is solved

For Joomla! 3.x Coding related discussions, please use: http://groups.google.com/group/joomla-dev-general

Moderator: ooffick

Forum rules
Please use the mailing list here: http://groups.google.com/group/joomla-dev-general rather than this forum.
Post Reply
User avatar
DV-admin
Joomla! Apprentice
Joomla! Apprentice
Posts: 35
Joined: Wed Sep 20, 2017 7:24 am
Location: Genova
Contact:

Created my firstbasic module but install throws error 0 Call to a member function..

Post by DV-admin » Thu Jan 03, 2019 2:46 pm

Hi there, I hope someone can explain this error to me and help me solve it.

I followed the tutorial to create my first basic Joomla module.

I actually think I followed the instructions pretty much to the letter. I checked my code several times.
Here : https://docs.joomla.org/J3.x:Creating_a ... sic_Module

Everything fine except it doesnt install. :(

When I use 'discover' the module is present, I selected it and clicked on install and it shows me the following error.
'0 Call to a member function children() on null'

Any of you :geek: gurus out there can tell me what I could be doing wrong?
Thanks,
Liz
Last edited by toivo on Thu Jan 03, 2019 5:40 pm, edited 1 time in total.
Reason: mod note: moved to 3.x Coding

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 19530
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Created my firstbasic module but install throws error 0 Call to a member function..

Post by leolam » Thu Jan 03, 2019 2:54 pm

I think I found a very good link that will guide you to resolve your issue

http://lmgtfy.com/?q=%270%20Call%20to%2 ... %20null%27

Leo 8)
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
-> Joomla Webmaster Services: gws-webmaster.services

User avatar
DV-admin
Joomla! Apprentice
Joomla! Apprentice
Posts: 35
Joined: Wed Sep 20, 2017 7:24 am
Location: Genova
Contact:

Re: Created my firstbasic module but install throws error 0 Call to a member function..

Post by DV-admin » Thu Jan 03, 2019 4:43 pm

Yeah thanks Leo :-) but besides a PHP version change (which I don't want to do because I am on 7.2 and I should be) Google isn't exactly throwing up anything that helps in my case.

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 19530
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Created my firstbasic module but install throws error 0 Call to a member function..

Post by leolam » Thu Jan 03, 2019 5:03 pm

So in 2 hours you have gone through 5 pages of Googles results and none work? I am quick but you re a rocket!

come-on

Leo 8)
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
-> Joomla Webmaster Services: gws-webmaster.services

User avatar
DV-admin
Joomla! Apprentice
Joomla! Apprentice
Posts: 35
Joined: Wed Sep 20, 2017 7:24 am
Location: Genova
Contact:

Re: Created my firstbasic module but install throws error 0 Call to a member function..

Post by DV-admin » Thu Jan 03, 2019 5:10 pm

I usually do not post on the Forum if I havn't done at least 2 hours of searching myself. Obviously.

User avatar
DV-admin
Joomla! Apprentice
Joomla! Apprentice
Posts: 35
Joined: Wed Sep 20, 2017 7:24 am
Location: Genova
Contact:

Re: Created my firstbasic module but install throws error 0 Call to a member function..

Post by DV-admin » Fri Jan 04, 2019 9:51 am

Ok, it's been fixed.


Post Reply

Return to “Joomla! 3.x Coding”