in 3.9.1 user request to login link in email is not private

Need help with the Administration of your Joomla! 3.x site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
veranatura
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Sun Jul 29, 2012 3:24 pm

in 3.9.1 user request to login link in email is not private

Post by veranatura » Fri Jan 11, 2019 4:01 pm

hello
in 3.9.1 when user requests their privacy details the site sends email to user with a link back to website to log in but the link thats sent is http and not https and when the user sees a login page a message is also displayed saying your information is not private.
How do I get the system to email the link to the https address so users information on page is private

User avatar
sozzled
Joomla! Champion
Joomla! Champion
Posts: 6375
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: in 3.9.1 user request to login link in email is not private

Post by sozzled » Fri Jan 11, 2019 6:48 pm

Would need to see Forum Post Assistant report before making any other comment. See viewtopic.php?f=7&t=966324#p3550995 for instructions.
https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?

veranatura
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Sun Jul 29, 2012 3:24 pm

Re: in 3.9.1 user request to login link in email is not private

Post by veranatura » Mon Jan 14, 2019 6:04 pm

Ihave have to post the information created by the script I think I will just to have to live with issue because im concerned about what infomaion will be posted when I read "Due to the highly sensitive nature of the information displayed by the FPA script, it should be removed from the server immediately after use".
So I wont be running the FPA script.

Thanks anyway.

User avatar
sozzled
Joomla! Champion
Joomla! Champion
Posts: 6375
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: in 3.9.1 user request to login link in email is not private

Post by sozzled » Mon Jan 14, 2019 6:53 pm

Fair enough. In that case, you should also read Section 11 of https://tm.joomla.org/gnu-general-publi ... se-v2.html. It's your problem.

Good luck. 8)
https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?

User avatar
AMurray
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4177
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: in 3.9.1 user request to login link in email is not private

Post by AMurray » Tue Jan 15, 2019 8:46 am

just a comment/question on this matter (don't know it will resolve anything or is indeed applicable to the OP's question).

I would have thought, if you had SSL on your site, any email containing hyperlinks that lead back to the site e.g. account activation or those where you have to enter verification codes etc, should link back on the site page which should load as https://.

If the links are somehow hard-coded as http:// then that deserves the attention of the developers and an issue logged on https://issues.joomla.org
Regards,
--------------------------------------------------------------
A Murray
Millennium Falcon - it's the ship that made the Kessel run in less than 12 parsecs! The fastest hunk of junk in the galaxy.

veranatura
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Sun Jul 29, 2012 3:24 pm

Re: in 3.9.1 user request to login link in email is not private

Post by veranatura » Tue Jan 22, 2019 4:59 pm

Thank you A Murray that is my problem the link are somehow hard-coded as http://
I will post the issue as you helpfully suggested at https://issues.joomla.org.


Post Reply

Return to “Administration Joomla! 3.x”