After upgrade from 2.5 to 3.6.5 menu items return "500 JHtml Image not found" Topic is solved

Need help upgrading your Joomla! website or converting to Joomla! 3.x? Please consider the availability of third-party templates and extensions when deciding which Joomla version to use.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
JonDePoe
Joomla! Apprentice
Joomla! Apprentice
Posts: 29
Joined: Wed Jun 08, 2011 5:10 pm
Contact:

After upgrade from 2.5 to 3.6.5 menu items return "500 JHtml Image not found"

Post by JonDePoe » Sat Jan 12, 2019 2:59 pm

Not sure if this the right place to post this, but here goes:
I have been running a 2.5.28 site for quite some time and decided to upgrade.
My template is a 2.5X.. no upgrades available for it.
No 3rd party extensions installed that I am aware of... just straight Joomla core items
Site running fine for about 7 years.
Upgraded to 3.4.0 then to 3.6.5
The front (home) page looks fine, the backend works fine, no errors. I can edit/create pages no problem. I can log in as a registered user from the front end ( I have 50 or so users)… everything seems to work fine on the backend. One error that I do remember seeing is "can't find XML setup file" when I just updated Akeeba Backup to 6.3.3.

My problem is all but one menu link from the front page goes to a "500 JHtml Image not found" error. One link still works but sub links from it are also broken. I can still access image files from a browser by entering the path ie: pdf and docs.

The whole site seems to be running on the backend smoothly. Front end not so much.
Any ideas tips or help would be greatly appreciated.
Last edited by toivo on Sun Jan 13, 2019 7:23 am, edited 1 time in total.
Reason: mod note: split from someone else's topic - please create your own topics in the future

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 19300
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: After upgrade from 2.5 to 3.6.5 menu items return "500 JHtml Image not found"

Post by leolam » Sun Jan 13, 2019 2:53 pm

Please post the full error message. It is caused by an extension that is not compliant with Joomla 3.x

Leo 8)
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
Member Joomla Bug Squad & Joomla CMS Release Team

JonDePoe
Joomla! Apprentice
Joomla! Apprentice
Posts: 29
Joined: Wed Jun 08, 2011 5:10 pm
Contact:

Re: After upgrade from 2.5 to 3.6.5 menu items return "500 JHtml Image not found"

Post by JonDePoe » Sun Jan 13, 2019 5:06 pm

I'll do one better than that... here is the site URL you can peruse for yourself and see what happens from the front end menu: www.washingtonflyersclub.org. The only one working is the "WFC info" but its sub menus are broken.

By the way I was wrong on the template version. It is actually a 1.7 not a 2.5. I now remember creating the site before 2.x came out and have been upgrading core since but not the template.

I thought the module editing stopped working but now seems to be ok as I was just able to change the Next Meeting module on the front page. I do this website for free and I'm more and more wondering why? Sigh.

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 25104
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: After upgrade from 2.5 to 3.6.5 menu items return "500 JHtml Image not found"

Post by Per Yngve Berg » Sun Jan 13, 2019 7:34 pm

Turn off SEF URLs as a start, so we can see what is going on.

I can access the president page with the Protostar template.

http://www.washingtonflyersclub.org/ind ... =protostar

Enable Debug and error reporting to get the full error messages.

JonDePoe
Joomla! Apprentice
Joomla! Apprentice
Posts: 29
Joined: Wed Jun 08, 2011 5:10 pm
Contact:

Re: After upgrade from 2.5 to 3.6.5 menu items return "500 JHtml Image not found"

Post by JonDePoe » Sun Jan 13, 2019 10:41 pm

OK. Turned off SEF URLs and enabled Debug. Does show a lot more information for sure.

annahersh
Joomla! Explorer
Joomla! Explorer
Posts: 357
Joined: Wed Aug 15, 2018 8:23 pm

Re: After upgrade from 2.5 to 3.6.5 menu items return "500 JHtml Image not found"

Post by annahersh » Sun Jan 13, 2019 11:01 pm

Check your template's article override file at the line 33 indicated in the error report
/templates/itcompany/html/com_content/article/default.php:33

There is image being called but it is missing. You need a conditional statement. Are you using the same template from your 2.5 site? The article file for 3.6.5 is different so you may need to recreate that override.

JonDePoe
Joomla! Apprentice
Joomla! Apprentice
Posts: 29
Joined: Wed Jun 08, 2011 5:10 pm
Contact:

Re: After upgrade from 2.5 to 3.6.5 menu items return "500 JHtml Image not found"

Post by JonDePoe » Mon Jan 14, 2019 4:50 am

Sorry, you're way over my head now. I have no idea how to do this.
I am using the same template from 2.5 site.... it is a 1.7 template which worked ok with the 2.5 site. I'm 75 yrs old and my brain cells are slowing down a tad. If there is no easier way around this issue should I consider just redo-ing the site with the 3.9.1 version and a current version template? Your advice?

annahersh
Joomla! Explorer
Joomla! Explorer
Posts: 357
Joined: Wed Aug 15, 2018 8:23 pm

Re: After upgrade from 2.5 to 3.6.5 menu items return "500 JHtml Image not found"

Post by annahersh » Mon Jan 14, 2019 5:30 am

You don't need to recreate the site, just update to 3.9.1 and switch the template to the included Protostar. You may need to reassign modules though.

JonDePoe
Joomla! Apprentice
Joomla! Apprentice
Posts: 29
Joined: Wed Jun 08, 2011 5:10 pm
Contact:

Re: After upgrade from 2.5 to 3.6.5 menu items return "500 JHtml Image not found"

Post by JonDePoe » Mon Jan 14, 2019 6:20 pm

OK, upgraded to 3.9.1 with no problems reported. Set Protostar as default template. Site still behaving the same as before. Reenabled Debugger. Any ideas?

User avatar
sozzled
Joomla! Champion
Joomla! Champion
Posts: 6320
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: After upgrade from 2.5 to 3.6.5 menu items return "500 JHtml Image not found"

Post by sozzled » Mon Jan 14, 2019 7:03 pm

Would need to see Forum Post Assistant report before making any other comment. See viewtopic.php?f=7&t=966324#p3550995 for instructions.
https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 25104
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: After upgrade from 2.5 to 3.6.5 menu items return "500 JHtml Image not found"

Post by Per Yngve Berg » Mon Jan 14, 2019 7:32 pm

Rename the folder ROOT/templates/itcompany/html/ to html.sav. That will disable the overrides.

annahersh
Joomla! Explorer
Joomla! Explorer
Posts: 357
Joined: Wed Aug 15, 2018 8:23 pm

Re: After upgrade from 2.5 to 3.6.5 menu items return "500 JHtml Image not found"

Post by annahersh » Mon Jan 14, 2019 9:41 pm

Did you set protostar as default via the template manager? The site is still using the old template hence the reason you still get the error.
Set default template
set-template.jpg
protostar.jpg
wfc-no-error.jpg
Check the page using protostar in the url query at http://www.washingtonflyersclub.org/ind ... =protostar
You do not have the required permissions to view the files attached to this post.

User avatar
sozzled
Joomla! Champion
Joomla! Champion
Posts: 6320
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: After upgrade from 2.5 to 3.6.5 menu items return "500 JHtml Image not found"

Post by sozzled » Mon Jan 14, 2019 10:15 pm

JonDePoe wrote:
Mon Jan 14, 2019 4:50 am
I am using the same template from 2.5 site.... it is a 1.7 template which worked ok with the 2.5 site.
Well, of course your "J! 1.7" template—atomic, Beez5, etc.—will work with J! 2.5 because J! 2.5 is just J! 1.7 under another name. However, you cannot use [J! 1.6/1.7 or] J! 2.5 templates with J! 3.x because they just don't work. Templates designed for [J! 1.6/1.7 or] J! 2.5 can be made to work, with some effort or if you want to pay someone to do the work for you, but as a general rule, J! 2.5 templates will not operate with J! 3.x.

As far as the HTTP 500 Internal Server Error is concerned, that's something else again. The HTTP 500 error has nothing to do with "broken menus" or missing modules.

If you want us to continue to guess what's wrong, then we can play that game. ;) If you want real help, I repeat what I wrote earlier:
sozzled wrote:
Mon Jan 14, 2019 7:03 pm
Would need to see Forum Post Assistant report before making any other comment. See viewtopic.php?f=7&t=966324#p3550995 for instructions.
https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?

JonDePoe
Joomla! Apprentice
Joomla! Apprentice
Posts: 29
Joined: Wed Jun 08, 2011 5:10 pm
Contact:

Re: After upgrade from 2.5 to 3.6.5 menu items return "500 JHtml Image not found"

Post by JonDePoe » Mon Jan 14, 2019 10:29 pm

OK, protostar is set as the default template and I went into the ROOT for itcompany and renamed the itcompany/html to html.sav as sozzled suggested. Site now works minus the colored menu bar and the colored top menu bar... but it works. I am assuming that if I acquire a new current dated template (3.x) I can re-assemble the site with that and it should work? Just asking, because I have no real clue if it will.

User avatar
sozzled
Joomla! Champion
Joomla! Champion
Posts: 6320
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: After upgrade from 2.5 to 3.6.5 menu items return "500 JHtml Image not found"

Post by sozzled » Mon Jan 14, 2019 10:47 pm

JonDePoe wrote:
Mon Jan 14, 2019 10:29 pm
OK, protostar is set as the default template and I went into the ROOT for itcompany and renamed the itcompany/html to html.sav as sozzled suggested.
Actually, @Per suggested that.

JonDePoe wrote:
Mon Jan 14, 2019 10:29 pm
Site now works ...
... meaning that the HTTP 500 Internal Server Error(s) has/have disappeared, yes?

JonDePoe wrote:
Mon Jan 14, 2019 10:29 pm
... minus the colored menu bar and the colored top menu bar.
Different issue. Please start a new topic for this matter. In your new topic, please include the Forum Post Assistant report:Image
https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?

JonDePoe
Joomla! Apprentice
Joomla! Apprentice
Posts: 29
Joined: Wed Jun 08, 2011 5:10 pm
Contact:

Re: After upgrade from 2.5 to 3.6.5 menu items return "500 JHtml Image not found"

Post by JonDePoe » Tue Jan 15, 2019 2:36 pm

Thanks to all who helped me solve this issue. I haven't coded since back in the late 60's in COBOL and FORTRAN IV so I'm a bit out of the loop these days. Hope I can muddle through getting one other site upgraded without a meltdown there. Thanks again to all.


Post Reply

Return to “Migrating and Upgrading to Joomla! 3.x”