contactform reply does not go to sender? Topic is solved

Need help with the Administration of your Joomla! 3.x site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
User avatar
carsten888
Joomla! Ace
Joomla! Ace
Posts: 1201
Joined: Sat Feb 11, 2006 8:32 am
Location: Tilburg, Holland
Contact:

contactform reply does not go to sender?

Post by carsten888 » Sun Jan 13, 2019 10:31 am

I'm using the normal Joomla contact form. When a user mails me, I hit reply and the mail would be send to myself, not to the sender. This used to work fine for many years.

But since a few weeks, the reply adress is the websites main adress. So now I have to copy-paste the email from the message. Such a hassle.

I checked the mail-settings for the contactform-menu-item. But 'custom reply' (whatever that means?) is turned off.

Image

Where to config this so the reply goes to the sender?
http://www.pages-and-items.com
Admin-Help-Pages, Dynamic-Menu-Links, Admin-Menu-Manager, Access-Manager, Redirect-on-Login, Pages-and-Items, module Admin-Messages, module Logged-in-Users, plugin load module in article, plugin pure css tooltip and more...

waarnemer
Joomla! Hero
Joomla! Hero
Posts: 2120
Joined: Sun May 04, 2008 12:37 pm

Re: contactform reply does not go to sender?

Post by waarnemer » Mon Jan 14, 2019 10:25 am

Hi Carsten,

I do not quit follow...
When a user mails me, I hit reply and the mail would be send to myself, not to the sender.
I believe the standard email contact form works as follows. Requestor fills out the form, requestor enters email address, requestor selects if he/she wants to recieve a copy, requestor hits "send email" (or submit).. and is redirected to a thank you page (if you created that).

Now you (or the one that is entered to receive) receive the message and requestor receives a copy.

Now.. what can be, is that your website is on another IP or host than your email server.
Anti-spoofing technology makes it impossible for mail servers to receive email from mail servers that are not 'assigned' in the originating domain (your domain).

So if your mail server is on another IP/host than your web server, it may be your mail will never make it to the requestor as on his end, it is checked if the mail is coming from the mail server(s) which are defined in your DNS. Your PHP mailer (site) may not be added.

Two options...
1. configure your site email settings to use SMTP
2. add your site host/ip to the TXT SPF record..

mxtoolbox "dot" com "dash" problem "dash" spf "dash" txt-record is a good read. Also a good site to test your setup..

User avatar
carsten888
Joomla! Ace
Joomla! Ace
Posts: 1201
Joined: Sat Feb 11, 2006 8:32 am
Location: Tilburg, Holland
Contact:

Re: contactform reply does not go to sender?

Post by carsten888 » Mon Jan 14, 2019 1:23 pm

I'm using smtp, sending email is not a problem.

The user enters email and message and I receive the email. So that works. But when I want to reply, the pre-filled reply adress is my own, not of the sender.
For years I could just hit return and the sender adress would become the 'send to' adress. But since a few weeks this is no longer the case. Seems as if Joomla does no longer parse the 'reply to adress' in the email from the form.
O crap! I just viewed the source and Joomla DOES parse the reply-to adress just fine.
I tested in webmail and that works like it used to, in gmail it behaves wrong, so I guess this is a gmail-issue.

Sorry to waste anyones time.

THIS IS NOT A JOOMLA ISSUE. sorry.

mod: I might want to delete this thread.
http://www.pages-and-items.com
Admin-Help-Pages, Dynamic-Menu-Links, Admin-Menu-Manager, Access-Manager, Redirect-on-Login, Pages-and-Items, module Admin-Messages, module Logged-in-Users, plugin load module in article, plugin pure css tooltip and more...


Post Reply

Return to “Administration Joomla! 3.x”