HTTP ERROR 500 after upgrading vers. 3.9.3 Topic is solved

Need help upgrading your Joomla! website or converting to Joomla! 3.x?

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
Donnicola
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Thu Feb 28, 2019 12:48 pm

HTTP ERROR 500 after upgrading vers. 3.9.3

Post by Donnicola » Thu Feb 28, 2019 1:03 pm

Hello, after updating to vers. 3.9.3 all my sites give me the HTTP ERROR 500 error.
I already tried some changes on the htaccess file and I even tried to delete it.
I also tried old version of htaccess file but without success.
I have also tried modifications of the web.config.txt file without success.
I tried to check the permissions of files and folders but they seem correct.
Does anyone have an idea of what it can be?
Thanks in advance.

User avatar
john-doe
Joomla! Guru
Joomla! Guru
Posts: 818
Joined: Tue Apr 19, 2011 7:39 pm
Location: Colombia
Contact:

Re: HTTP ERROR 500 after upgrading vers. 3.9.3

Post by john-doe » Thu Feb 28, 2019 1:59 pm

Hello.
Do you have a backup of the site to restore it?
What PHP version is set on the server / folder ?
htaccess and web config? What are you running on your server Apache or IIS?
Remains as Error 500?

Note to moderators: Can this be moved to Upgrade section?
www.aldemar-hernandez.com - Custom templates and design services.

Donnicola
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Thu Feb 28, 2019 12:48 pm

Re: HTTP ERROR 500 after upgrading vers. 3.9.3

Post by Donnicola » Thu Feb 28, 2019 2:42 pm

Thanks for replay.
Some news: I used Reinstall the files of the core of Joomla, and it happened that on Mac I can see my sites and everything is fine, but on Windows some modules are missing.

Now the problem is completely different: on Mac work, on Windows only partial.

My PHp vers. is 7.1
I use ".htaccess" file activate and last vers. of web.config file.
All run on Apache web server.

Thanks

User avatar
john-doe
Joomla! Guru
Joomla! Guru
Posts: 818
Joined: Tue Apr 19, 2011 7:39 pm
Location: Colombia
Contact:

Re: HTTP ERROR 500 after upgrading vers. 3.9.3

Post by john-doe » Thu Feb 28, 2019 2:46 pm

OK so if it runs apache web.config has nothing to do here (it is just for IIS when is on a windows server machine).

So if on mac works and windows does not might be that:

The module or component loads images that are pointed to localhost of the MAC, and you are having live the localhost. Turn off the MAMP and clean cache of the browser(s) and see if everything is right or missing.

Are you on multilingual?
www.aldemar-hernandez.com - Custom templates and design services.

Donnicola
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Thu Feb 28, 2019 12:48 pm

Re: HTTP ERROR 500 after upgrading vers. 3.9.3

Post by Donnicola » Thu Feb 28, 2019 3:01 pm

I have nothing on local Mac, all is on the server on my hosting.

Yes 1 is multilingual but on the other server in the same hosting and I have same problem.

User avatar
john-doe
Joomla! Guru
Joomla! Guru
Posts: 818
Joined: Tue Apr 19, 2011 7:39 pm
Location: Colombia
Contact:

Re: HTTP ERROR 500 after upgrading vers. 3.9.3

Post by john-doe » Thu Feb 28, 2019 3:05 pm

Sounds silly, but have you checked that the other module is properly sert to the correct language?
Sometimes happen that the exact module needs to be shown in separate languages and is only shown for a specific language. Unless the module is set to "All", might be the problem.

If is that case do a copy and set the original at main language and the copy(ies) to the other language(s).
www.aldemar-hernandez.com - Custom templates and design services.

Donnicola
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Thu Feb 28, 2019 12:48 pm

Re: HTTP ERROR 500 after upgrading vers. 3.9.3

Post by Donnicola » Thu Feb 28, 2019 3:16 pm

Only 1 of my sites is multilingual but the problem is the same for everyone. Some modules are not visible even on non-multilingual sites. Slideshow type modules and also dynamic menu modules.

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 19602
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: HTTP ERROR 500 after upgrading vers. 3.9.3

Post by leolam » Thu Feb 28, 2019 8:33 pm

Did you see the HEADLINES? (above this forum?)

Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.

Leo 8)
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
-> Joomla Webmaster Services: gws-webmaster.services

Donnicola
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Thu Feb 28, 2019 12:48 pm

Re: HTTP ERROR 500 after upgrading vers. 3.9.3

Post by Donnicola » Fri Mar 01, 2019 12:48 pm

leolam wrote:
Thu Feb 28, 2019 8:33 pm
Did you see the HEADLINES? (above this forum?)
Sorry, can you help me to understand what you mean? Thanks

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 11161
Joined: Thu Feb 15, 2007 5:48 am
Location: Oxford, UK

Re: HTTP ERROR 500 after upgrading vers. 3.9.3

Post by toivo » Fri Mar 01, 2019 12:55 pm

@leolam is guiding you to go to the link at the top, just above the first post, and requesting you to post the results of the Forum Post Assistant (FPA).
Toivo Talikka, Global Moderator

Donnicola
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Thu Feb 28, 2019 12:48 pm

Re: HTTP ERROR 500 after upgrading vers. 3.9.3

Post by Donnicola » Fri Mar 01, 2019 1:22 pm

toivo wrote:
Fri Mar 01, 2019 12:55 pm
@leolam is guiding you to go to the link at the top, just above the first post, and requesting you to post the results of the Forum Post Assistant (FPA).
Thanks for replay.
So I had download the script ForumPostAssistant-FPA.
What I do now? Upload the file fpa-en.php on my server, run it and result will be automatically published on forum assistance? And after immediatelly I delete this file from my server?
Forgive me for my inexperience.

User avatar
john-doe
Joomla! Guru
Joomla! Guru
Posts: 818
Joined: Tue Apr 19, 2011 7:39 pm
Location: Colombia
Contact:

Re: HTTP ERROR 500 after upgrading vers. 3.9.3

Post by john-doe » Fri Mar 01, 2019 1:26 pm

Donnicola wrote:
Fri Mar 01, 2019 1:22 pm
Thanks for replay.
So I had download the script ForumPostAssistant-FPA.
What I do now? Upload the file fpa-en.php on my server, run it and result will be automatically published on forum assistance? And after immediatelly I delete this file from my server?
Forgive me for my inexperience.
Run the FPA, copy the result, and then post it. FPA is formatted so you can just copy the result and paste it.
Since FPA does not post automatically, the other things you mentioned are right.
Last edited by john-doe on Fri Mar 01, 2019 1:28 pm, edited 1 time in total.
www.aldemar-hernandez.com - Custom templates and design services.

Donnicola
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Thu Feb 28, 2019 12:48 pm

Re: HTTP ERROR 500 after upgrading vers. 3.9.3

Post by Donnicola » Fri Mar 01, 2019 1:39 pm

Forum Post Assistant (v1.4.8 (koine)) : 1st March 2019 wrote:
Basic Environment :: wrote:Joomla! Instance :: Joomla! 3.9.3-Stable (Amani) 12-February-2019
Joomla! Platform :: Joomla Platform 13.1.0-Stable (Curiosity) 24-Apr-2013
Joomla! Configured :: Yes | Read-Only (444) | Owner: --protected-- . (uid: /gid: ) | Group: --protected-- (gid: ) | Valid For: 3.9
Configuration Options :: Offline: false | SEF: true | SEF Suffix: false | SEF ReWrite: false | .htaccess/web.config: Yes | GZip: false | Cache: true | CacheTime: 1 | CacheHandler: file | CachePlatformPrefix: false | FTP Layer: false | Proxy: false | LiveSite: | Session lifetime: 15 | Session handler: database | Shared sessions: false | SSL: 0 | Error Reporting: default | Site Debug: false | Language Debug: false | Default Access: 1 | Unicode Slugs: false | dbConnection Type: mysqli | PHP Supports J! 3.9.3: Yes | Database Supports J! 3.9.3: Yes | Database Credentials Present: Yes |

Host Configuration :: OS: Linux | OS Version: 4.8.11-hoststar | Technology: x86_64 | Web Server: Apache | Encoding: gzip, deflate | Doc Root: --protected-- | System TMP Writable: Yes | Free Disk Space : 204.78 GiB |

PHP Configuration :: Version: 7.1.1 | PHP API: cgi-fcgi | Session Path Writable: No | Display Errors: | Error Reporting: 1 | Log Errors To: | Last Known Error: | Register Globals: | Magic Quotes: | Safe Mode: | Open Base: /home/www/:/tmp:/usr/local/php71/lib/php/ | Uploads: 1 | Max. Upload Size: 100M | Max. POST Size: 100M | Max. Input Time: 60 | Max. Execution Time: 180 | Memory Limit: 128M

Database Configuration :: Version: 5.6.36 (Client:mysqlnd 5.0.12-dev - 20150407 - $Id: b396954eeb2d1d9ed7902b8bae237b287f21ad9e $) | Host: --protected-- (--protected--) | default Collation: utf8_general_ci (default Character Set: utf8) | Database Size: 11.20 MiB | #of Tables:  82
Detailed Environment :: wrote:PHP Extensions :: Core (7.1.1) | date (7.1.1) | libxml (7.1.1) | openssl (7.1.1) | pcre (7.1.1) | zlib (7.1.1) | bcmath (7.1.1) | bz2 (7.1.1) | calendar (7.1.1) | ctype (7.1.1) | curl (7.1.1) | dom (20031129) | hash (1.0) | fileinfo (1.0.5) | filter (7.1.1) | ftp (7.1.1) | gd (7.1.1) | gettext (7.1.1) | SPL (7.1.1) | iconv (7.1.1) | session (7.1.1) | intl (1.1.0) | json (1.5.0) | mbstring (7.1.1) | mcrypt (7.1.1) | standard (7.1.1) | mysqlnd (mysqlnd 5.0.12-dev - 20150407 - $Id: b396954eeb2d1d9ed7902b8bae237b287f21ad9e $) | pcntl (7.1.1) | mysqli (7.1.1) | Phar (2.0.2) | posix (7.1.1) | readline (7.1.1) | Reflection (7.1.1) | imap (7.1.1) | shmop (7.1.1) | SimpleXML (7.1.1) | soap (7.1.1) | sockets (7.1.1) | exif (1.4 $Id: 8bdc0c8f27c2c9dd1f7551f1f9fe3ab57a06a4b1 $) | sysvmsg (7.1.1) | sysvsem (7.1.1) | sysvshm (7.1.1) | tokenizer (7.1.1) | wddx (7.1.1) | xml (7.1.1) | xmlreader (7.1.1) | xmlrpc (7.1.1) | xmlwriter (7.1.1) | xsl (7.1.1) | zip (1.13.5) | cgi-fcgi () | PDO (7.1.1) | pdo_mysql (7.1.1) | pdo_sqlite (7.1.1) | sqlite3 (0.7-dev) | imagick (3.4.3) | ionCube Loader () | Zend Engine (3.1.0) |
Potential Missing Extensions ::
Disabled Functions :: apache_get_modules | apache_get_version | apache_getenv | apache_note | apache_setenv | define_syslog_variables | ini_alter | link | openlog | passthru | pfsockopen | posix_getpwuid | posix_kill | posix_mkfifo | posix_setpgid | posix_setsid | posix_setuid | posix_uname | proc_close | proc_get_status | proc_nice | proc_open | proc_terminate | shell_exec | show_source | syslog | system | virtual |

Switch User Environment (Experimental) :: PHP CGI: Yes | Server SU: Yes | PHP SU: Yes | Custom SU (LiteSpeed/Cloud/Grid): No
Potential Ownership Issues: Maybe
Folder Permissions :: wrote:Core Folders :: images/ (755) | components/ (755) | modules/ (755) | plugins/ (755) | language/ (755) | templates/ (755) | cache/ (755) | logs/ (---) | tmp/ (755) | administrator/components/ (755) | administrator/modules/ (755) | administrator/language/ (755) | administrator/templates/ (755) | administrator/logs/ (755) |

Elevated Permissions (First 10) ::
Database Information :: wrote:Database statistics :: Uptime: 193322 | Threads: 6 | Questions: 64911735 | Slow queries: 142 | Opens: 364086 | Flush tables: 1 | Open tables: 1024 | Queries per second avg: 335.770 |
Extensions Discovered :: wrote:Components :: SITE ::
Core :: com_wrapper (3.0.0) 1 | com_mailto (3.0.0) 1 |
3rd Party::

Components :: ADMIN ::
Core :: com_menus (3.0.0) 1 | com_admin (3.0.0) 1 | com_templates (3.0.0) 1 | com_cache (3.0.0) 1 | com_users (3.0.0) 1 | com_modules (3.0.0) 1 | com_languages (3.0.0) 1 | com_installer (3.0.0) 1 | com_actionlogs (3.9.0) 1 | com_tags (3.1.0) 1 | com_search (3.0.0) 1 | com_categories (3.0.0) 1 | com_config (3.0.0) 1 | com_joomlaupdate (3.6.2) 1 | com_media (3.0.0) 1 | com_plugins (3.0.0) 1 | com_messages (3.0.0) 1 | com_finder (3.0.0) 1 | com_fields (3.7.0) 1 | com_cpanel (3.0.0) 1 | com_ajax (3.2.0) 1 | com_redirect (3.0.0) 1 | com_associations (3.7.0) 1 | com_postinstall (3.2.0) 1 | com_login (3.0.0) 1 | com_contenthistory (3.2.0) 1 | com_content (3.0.0) 1 | com_newsfeeds (3.0.0) 1 | com_privacy (3.9.0) 1 | com_checkin (3.0.0) 1 | com_banners (3.0.0) 1 |
3rd Party:: COM_SIGPRO (3.1.0) 1 | com_jaextmanager (2.5.3) 1 | com_jaextmanager (2.6.3) 1 | com_jabuilder (1.0.7) 1 |

Modules :: SITE ::
Core :: mod_breadcrumbs (3.0.0) 1 | mod_whosonline (3.0.0) 1 | mod_articles_popular (3.0.0) 1 | mod_custom (3.0.0) 1 | mod_users_latest (3.0.0) 1 | mod_tags_popular (3.1.0) 1 | mod_wrapper (3.0.0) 1 | mod_articles_latest (3.0.0) 1 | mod_search (3.0.0) 1 | mod_articles_news (3.0.0) 1 | mod_articles_categories (3.0.0) 1 | mod_random_image (3.0.0) 1 | mod_related_items (3.0.0) 1 | mod_languages (3.5.0) 1 | mod_feed (3.0.0) 1 | mod_banners (3.0.0) 1 | mod_login (3.0.0) 1 | mod_articles_archive (3.0.0) 1 | mod_tags_similar (3.1.0) 1 | mod_syndicate (3.0.0) 1 | mod_menu (3.0.0) 1 | mod_finder (3.0.0) 1 | mod_footer (3.0.0) 1 | mod_stats (3.0.0) 1 | mod_articles_category (3.0.0) 1 |
3rd Party:: MOD_JA_ACM (2.1.4) 1 |

Modules :: ADMIN ::
Core :: mod_latest (3.0.0) 1 | mod_multilangstatus (3.0.0) 1 | mod_latestactions (3.9.0) 1 | mod_sampledata (3.8.0) 1 | mod_custom (3.0.0) 1 | mod_toolbar (3.0.0) 1 | mod_title (3.0.0) 1 | mod_logged (3.0.0) 1 | mod_feed (3.0.0) 1 | mod_version (3.0.0) 1 | mod_privacy_dashboard (3.9.0) 1 | mod_login (3.0.0) 1 | mod_status (3.0.0) 1 | mod_popular (3.0.0) 1 | mod_stats_admin (3.0.0) 1 | mod_quickicon (3.0.0) 1 | mod_menu (3.0.0) 1 | mod_submenu (3.0.0) 1 |
3rd Party:: JA Builder Quick Icons (1.0.2) 1 | JA Builder Admin Menu (1.0.0) 1 |

Libraries :: SITE ::
Core ::
3rd Party::

Plugins :: SITE ::
Core :: plg_content_vote (3.0.0) 1 | plg_content_joomla (3.0.0) 1 | plg_content_pagebreak (3.0.0) 1 | plg_content_fields (3.7.0) 1 | plg_content_loadmodule (3.0.0) 1 | plg_content_emailcloak (3.0.0) 1 | plg_content_confirmconsent (3.9.0) 1 | plg_content_pagenavigation (3.0.0) 1 | plg_content_finder (3.0.0) 1 | plg_fields_editor (3.7.0) 1 | plg_fields_list (3.7.0) 1 | plg_fields_sql (3.7.0) 1 | plg_fields_integer (3.7.0) 1 | plg_fields_checkboxes (3.7.0) 1 | plg_fields_repeatable (3.9.0) 1 | plg_fields_calendar (3.7.0) 1 | plg_fields_textarea (3.7.0) 1 | plg_fields_url (3.7.0) 1 | plg_fields_media (3.7.0) 1 | plg_fields_usergrouplist (3.7.0) 1 | plg_fields_user (3.7.0) 1 | plg_fields_imagelist (3.7.0) 1 | plg_fields_text (3.7.0) 1 | plg_fields_color (3.7.0) 1 | plg_fields_radio (3.7.0) 1 | PLG_ACTIONLOG_JOOMLA (3.9.0) 1 | plg_authentication_joomla (3.0.0) 1 | plg_authentication_cookie (3.0.0) 1 | plg_authentication_ldap (3.0.0) 0 | plg_authentication_gmail (3.0.0) 0 | plg_twofactorauth_yubikey (3.2.0) 0 | plg_twofactorauth_totp (3.2.0) 0 | plg_installer_packageinstaller (3.6.0) 1 | PLG_INSTALLER_URLINSTALLER (3.6.0) 1 | plg_installer_webinstaller (1.1.1) 1 | PLG_INSTALLER_FOLDERINSTALLER (3.6.0) 1 | plg_privacy_content (3.9.0) 1 | plg_privacy_actionlogs (3.9.0) 1 | plg_privacy_consents (3.9.0) 1 | plg_privacy_user (3.9.0) 1 | plg_privacy_message (3.9.0) 1 | plg_quickicon_phpversioncheck (3.7.0) 1 | plg_quickicon_privacycheck (3.9.0) 1 | plg_quickicon_extensionupdate (3.0.0) 1 | plg_quickicon_joomlaupdate (3.0.0) 1 | plg_extension_joomla (3.0.0) 1 | plg_search_content (3.0.0) 1 | plg_search_tags (3.0.0) 1 | plg_search_newsfeeds (3.0.0) 1 | plg_search_contacts (3.0.0) 1 | plg_search_categories (3.0.0) 1 | plg_system_remember (3.0.0) 1 | plg_system_fields (3.7.0) 1 | plg_system_updatenotification (3.5.0) 1 | plg_system_highlight (3.0.0) 1 | plg_system_stats (3.5.0) 1 | PLG_SYSTEM_ACTIONLOGS (3.9.0) 1 | plg_system_cache (3.0.0) 0 | plg_system_log (3.0.0) 1 | plg_system_logout (3.0.0) 1 | plg_system_debug (3.0.0) 1 | plg_system_sef (3.0.0) 1 | plg_system_privacyconsent (3.9.0) 1 | plg_system_languagecode (3.0.0) 0 | plg_system_logrotation (3.9.0) 1 | plg_system_redirect (3.0.0) 0 | plg_system_languagefilter (3.0.0) 0 | plg_system_p3p (3.0.0) 0 | plg_system_sessiongc (3.8.6) 1 | plg_user_joomla (3.0.0) 1 | plg_user_profile (3.0.0) 0 | plg_user_terms (3.9.0) 1 | plg_user_contactcreator (3.0.0) 0 | plg_finder_content (3.0.0) 1 | plg_finder_tags (3.0.0) 1 | plg_finder_newsfeeds (3.0.0) 1 | plg_finder_contacts (3.0.0) 1 | plg_finder_categories (3.0.0) 1 | plg_captcha_recaptcha_invisible (3.8) 0 | plg_captcha_recaptcha (3.4.0) 0 | plg_editors-xtd_readmore (3.0.0) 1 | plg_editors-xtd_pagebreak (3.0.0) 1 | plg_editors-xtd_fields (3.7.0) 1 | plg_editors-xtd_article (3.0.0) 1 | plg_editors-xtd_module (3.5.0) 1 | plg_editors-xtd_image (3.0.0) 1 | plg_editors-xtd_menu (3.7.0) 1 |
3rd Party:: Content - Simple Image Gallery Pro (3.1.0) ? | JUB (1.1.5) 1 | System - JA Google Map (2.6.5) 1 | T3 Framework (2.7.3) 1 | plg_editors_tinymce (4.5.9) 1 | plg_editors_codemirror (5.40.0) 1 | Button - Simple Image Gallery Pro (3.1.0) 1 | K2 - Simple Image Gallery Pro (3.1.0) 1 |
Templates Discovered :: wrote:Templates :: SITE :: protostar (1.0) 1 | JA_Builder (1.1.0) 1 | ja_smallbiz (1.0.1) 1 | beez3 (3.1.0) 1 |
Templates :: ADMIN :: isis (1.0) 1 | hathor (3.0.0) 1 |
Last edited by toivo on Fri Mar 01, 2019 1:44 pm, edited 1 time in total.
Reason: mod note: disabled smilies in post Options for readability

gws
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3837
Joined: Tue Aug 23, 2005 1:56 pm
Location: South coast, UK
Contact:

Re: HTTP ERROR 500 after upgrading vers. 3.9.3

Post by gws » Fri Mar 01, 2019 1:43 pm

session path writeable = No should be Yes,speak to your host to change it.

Donnicola
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Thu Feb 28, 2019 12:48 pm

Re: HTTP ERROR 500 after upgrading vers. 3.9.3

Post by Donnicola » Fri Mar 01, 2019 1:55 pm

gws wrote:
Fri Mar 01, 2019 1:43 pm
session path writeable = No should be Yes,speak to your host to change it.
Thanks, can you think this can be the problem for this issue?

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 19602
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: HTTP ERROR 500 after upgrading vers. 3.9.3

Post by leolam » Fri Mar 01, 2019 10:25 pm

No but it will influence uploading of extensions and content so it needs to be changed. I am pretty sure that your server's "open base directory" is causing this. Ask your host to disable this directive. It has no value in a proper configured (!) server

Leo 8)
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
-> Joomla Webmaster Services: gws-webmaster.services

Donnicola
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Thu Feb 28, 2019 12:48 pm

Re: HTTP ERROR 500 after upgrading vers. 3.9.3

Post by Donnicola » Sun Mar 03, 2019 2:44 pm

leolam wrote:
Fri Mar 01, 2019 10:25 pm
I am pretty sure that your server's "open base directory" is causing this.
Leo 8)
Thanks Leo, tomorrow I ask for it!
Nice day

Donnicola
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Thu Feb 28, 2019 12:48 pm

Re: HTTP ERROR 500 after upgrading vers. 3.9.3

Post by Donnicola » Fri Mar 08, 2019 12:35 am

Hi guys
I spoke to my hosting for the "open base directory" and they told me they can not change this setting for a security purposes. I can say that I agree with them because for years it has always worked well on my sites. The problem is updating to version 3.9.3 of joomla. I tried to reinstall old versions of my sites and update them. Up to version 3.9.2 everything works fine, when I upgrade to version 3.9.3 all my sites on windows systems do not work. I update also graphic templates from Joomlart and other components and plugin.
Thanks for your help

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 11161
Joined: Thu Feb 15, 2007 5:48 am
Location: Oxford, UK

Re: HTTP ERROR 500 after upgrading vers. 3.9.3

Post by toivo » Fri Mar 08, 2019 7:46 am

Donnicola wrote:I tried to reinstall old versions of my sites and update them.
Did you reinstall a copy of the site on a Windows localhost site or reinstall on the website itself?
Toivo Talikka, Global Moderator

Donnicola
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Thu Feb 28, 2019 12:48 pm

Re: HTTP ERROR 500 after upgrading vers. 3.9.3

Post by Donnicola » Fri Mar 08, 2019 11:45 am

toivo wrote:
Fri Mar 08, 2019 7:46 am
Did you reinstall a copy of the site on a Windows localhost site or reinstall on the website itself?
I havn^t installation on localhost, all is on my hosting.
I reinstall my old site in a subdomain and update them to vers. 3.9.2 and all work fine. When update to vers. 3.9.3 and whatch them for example with Opera browser with my iMac it work fine. But if I whatch it with Opera in my Pc windows I can't see many part of my site. Menu don't work, some module don't show, some images don't displayed.
I also noticed that if I do a resize of the browser window, some images appear.

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 11161
Joined: Thu Feb 15, 2007 5:48 am
Location: Oxford, UK

Re: HTTP ERROR 500 after upgrading vers. 3.9.3

Post by toivo » Fri Mar 08, 2019 12:40 pm

Have you cleared all temporary files from the browser cache and also from Joomla? Some templates have their own cache and your JoomlArt template probably has one, too.

Second point, use a browser, for example Google Chrome, that has a javascript console, where you can check if the page has javascript errors, which effectively stop all javascript functions.
Toivo Talikka, Global Moderator

Donnicola
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Thu Feb 28, 2019 12:48 pm

Re: HTTP ERROR 500 after upgrading vers. 3.9.3

Post by Donnicola » Fri Mar 08, 2019 1:18 pm

This is a part of the error found with Javascript Console in Google Chrome.

Refused to execute script from '<URL>' because its MIME type ('text/x-js') is not executable, and strict MIME type checking is enabled.
index.php?lang=it:1 Refused to execute script from 'http://therapie.therapieintegrative.ch/ ... 4678bf745b' because its MIME type ('text/x-js') is not executable, and strict MIME type checking is enabled.
index.php?lang=it:1 Refused to execute script from 'http://therapie.therapieintegrative.ch/ ... 4678bf745b' because its MIME type ('text/x-js') is not executable, and strict MIME type checking is enabled.

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 11161
Joined: Thu Feb 15, 2007 5:48 am
Location: Oxford, UK

Re: HTTP ERROR 500 after upgrading vers. 3.9.3

Post by toivo » Fri Mar 08, 2019 3:44 pm

The link in the error messages points to an instance of the jQuery file jquery.min.js in the cache. The MIME type 'text/x-js' should be the standard 'application/javascript', IMHO. The refusal of the browser to run javascript is probably a side effect from the recommendation in the Joomla 3.9.3 release to fix one of the low priority security issues, browser side MIME sniffing.

Edit the file .htaccess and comment out the new Header line, introduced in Joomla 3.9.3, and hopefully you will see the javascript errors disappear.

Before:

Code: Select all

## Suppress mime type detection in browsers for unknown types
<IfModule mod_headers.c>
Header always set X-Content-Type-Options "nosniff"
</IfModule>
After:

Code: Select all

## Suppress mime type detection in browsers for unknown types
<IfModule mod_headers.c>
# Header always set X-Content-Type-Options "nosniff"
</IfModule>
It would be interesting to know what sets the incorrect MIME type - the web server or the caching system of your template. If the above modification does not work, change the default template to Protostar, clean the cache in both Joomla and the browser and see if the javascript errors disappear.
Toivo Talikka, Global Moderator

Donnicola
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Thu Feb 28, 2019 12:48 pm

Re: HTTP ERROR 500 after upgrading vers. 3.9.3

Post by Donnicola » Fri Mar 08, 2019 10:42 pm

Thanks guys we have solved.
The problem was just that toivo, the new Header line introduced in Joomla 3.9.3 in the .htaccess file.
I comment out the new Header line and all work fine now, but I probably did not flush the cache well before.
What can I do to understand if is incorrect Mime type in the caching system of my template or in the web server?
Thanks to everyone

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 11161
Joined: Thu Feb 15, 2007 5:48 am
Location: Oxford, UK

Re: HTTP ERROR 500 after upgrading vers. 3.9.3

Post by toivo » Sat Mar 09, 2019 7:18 am

Glad to hear that it is now working.

It would be difficult to identify the root cause without the same paid template and its framework. Maybe others have a similar issue without those extensions. I will therefore post to 'Discuss Joomla! 3.9.3' in the Accouncement Discussions and refer to this topic.
Toivo Talikka, Global Moderator

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 11161
Joined: Thu Feb 15, 2007 5:48 am
Location: Oxford, UK

Re: HTTP ERROR 500 after upgrading vers. 3.9.3

Post by toivo » Sat Mar 09, 2019 9:23 am

If you upload the following script to the Joomla folder and save it as 'mime-check.php', it can help us to eliminate your template framework and focus on the MIME type configuration of the web server as the root cause of the original issue.

Browse to the script and it will display the MIME types of the different jQuery scripts in the media folder.

The URL of what I believe is the cached version comes from the error message you posted earlier. If the address has changed, the script will display a PHP warning. You can then view the HTML source code of the home page and get the new path from there. The MIME type may still be the same as the other two, though.

Code: Select all

<?php
$jquery		= 'media/jui/js/jquery.js';
$jquery_min = 'media/jui/js/jquery.min.js';
$cached		= 'media/jui/js/jquery.min.js?8d4c3bf397b2de679f7aa74678bf745b';
echo $jquery . ' MIME type = ' . mime_content_type($jquery) . ' -- ';
echo $jquery_min . ' MIME type = ' . mime_content_type($jquery_min) . ' -- ';
echo $cached . ' MIME type = ' . mime_content_type($cached);
Toivo Talikka, Global Moderator

Donnicola
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Thu Feb 28, 2019 12:48 pm

Re: HTTP ERROR 500 after upgrading vers. 3.9.3

Post by Donnicola » Sat Mar 09, 2019 9:59 am

toivo wrote:
Sat Mar 09, 2019 9:23 am
Browse to the script and it will display the MIME types of the different jQuery scripts in the media folder.
I do not know if I can follow you, maybe it's a bit difficult for me.
However I created the script and this is the result:

media/jui/js/jquery.js MIME type = text/plain -- media/jui/js/jquery.min.js MIME type = text/plain -- media/jui/js/jquery.min.js?8d4c3bf397b2de679f7aa74678bf745b MIME type =

what I can do now?

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 11161
Joined: Thu Feb 15, 2007 5:48 am
Location: Oxford, UK

Re: HTTP ERROR 500 after upgrading vers. 3.9.3

Post by toivo » Sat Mar 09, 2019 12:32 pm

Your server sent a normal response to the MIME types. Therefore it looks like the MIME type 'text/x-js' that browsers cannot execute comes from the template framework your site uses.

Do you know if your paid template has updates? The latest version of the JoomlArt T3 Framework or the JA T3v2 System Plugin is 2.7.6 and your site may be a couple of updates behind.

It is probably nothing to worry about because the new Header directive that we turned off was introduced due to only a low priority security issue.
Toivo Talikka, Global Moderator

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 11161
Joined: Thu Feb 15, 2007 5:48 am
Location: Oxford, UK

Re: HTTP ERROR 500 after upgrading vers. 3.9.3

Post by toivo » Sat Mar 09, 2019 2:01 pm

Apparently the prefix 'x-' in a MIME type means that it is non-standard and has not been registered with the 'Internet Assigned Numbers Authority' (IANA). No wonder browsers do not want to run those scripts when strict type checking is enabled.

Ref 1 https://www.freeformatter.com/mime-types-list.html

Ref 2 http://www.iana.org/assignments/media-t ... ypes.xhtml

According to the IANA document, the former MIME types are now known as Media Types.
Toivo Talikka, Global Moderator

Donnicola
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Thu Feb 28, 2019 12:48 pm

Re: HTTP ERROR 500 after upgrading vers. 3.9.3

Post by Donnicola » Sun Mar 10, 2019 12:32 am

toivo wrote:
Sat Mar 09, 2019 12:32 pm
Do you know if your paid template has updates? The latest version of the JoomlArt T3 Framework or the JA T3v2 System Plugin is 2.7.6 and your site may be a couple of updates behind.
I just update all yesterday tamplate e T3 Framework, but if I uncheck new Header in htaccess the issue reappears. This only in browser of Pc Windows system.


Post Reply

Return to “Migrating and Upgrading to Joomla! 3.x”