Menu links don't display top of the section

Joomla! Documentation Workgroup

Moderator: Documentation

Post Reply
User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 37022
Joined: Sat Apr 05, 2008 9:58 pm

Menu links don't display top of the section

Post by Webdongle » Sat Mar 23, 2019 5:34 pm

e.g. https://docs.joomla.org/Why_can%27t_you ... rom_ianmac clicking the link (from a google search) or from any source starts displaying about 3 lines into that section then auto scrolls to the top of the section

But clicking the menu in the docs page ... starts displaying about 3 lines into that section and stays there ?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

User avatar
sozzled
Joomla! Champion
Joomla! Champion
Posts: 7153
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: Menu links don't display top of the section

Post by sozzled » Sat Mar 23, 2019 5:58 pm

hashtag (#) in the URL explains the "autoscroll". OK? Not sure where the "menu in the docs page" is, so I can't comment on that.
https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 37022
Joined: Sat Apr 05, 2008 9:58 pm

Re: Menu links don't display top of the section

Post by Webdongle » Sat Mar 23, 2019 6:08 pm

Page menu is near top right. It also has a hash in the url
docs page 01.JPG
You do not have the required permissions to view the files attached to this post.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

User avatar
sozzled
Joomla! Champion
Joomla! Champion
Posts: 7153
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: Menu links don't display top of the section

Post by sozzled » Sat Mar 23, 2019 6:46 pm

I get it. Thanks for explaining.

Ah well, named anchors are curious little devils, aren't they? And wikiMedia's TOC "module" is also quaint. I vaguely remember (when I used to use wikiMedia as penance for my sins) that I spent more time wrestling with the vagaries of the application, in trying to get things to look "nice", than actually writing informative text. The example you've described could be found in hundreds (if not thousands) of other articles where a TOC "menu" appears.
https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?


Post Reply

Return to “docs.joomla.org - Feedback/Information”