Widget werkt niet zoals het hoort Topic is solved

Vragen over componenten, modules en plugins die op Joomla! 3.x draaien.

Moderator: pe7er

Forum rules
Forum Regels
Post Reply
HesterPr
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Thu Aug 01, 2019 6:40 pm

Widget werkt niet zoals het hoort

Post by HesterPr » Fri Aug 02, 2019 2:46 pm

Goedemiddag,

Onze vakantiewoning staat ingeschreven bij; “vakantiehuisnu.nl” Daar is het mogelijk om een widget van een beschikbaarheidskalender te plaatsen op je eigen site (www.vakantiehuisarcadia.nl). Als ik de onderstaande link plak aan de HTML kant van het artikel en ik dat dan opsla ……

<script type="text/javascript" src="https://www.ferienhausmiete.de/verwalte ... cript><div id="ferienhausmiete-de-widget4-236273"><a href="https://www.ferienhausmiete.de/236273.htm" target="_blank">Arcadia</a></div>

verandert de link in :

<div id="ferienhausmiete-de-widget4-236273"><a href="https://www.ferienhausmiete.de/236273.htm" target="_blank" rel="noopener noreferrer">Arcadia</a></div>
<div id="ferienhausmiete-de-widget4-236273">

het gevolg is dat op de voorkant van mijn website geen beschikbaarheidskalender te zien is maar een link naar ons huisje op de website van vakantiehuisnu.nl

Hoe komt het dat de geplakte link zichzelf omzet in iets anders?
Hoe kan ik er voor zorgen dat de beschikbaarheidskalender zichtbaar wordt ipv de link naar die andere website

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 22278
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, The Netherlands
Contact:

Re: Widget werkt niet zoals het hoort

Post by pe7er » Fri Aug 02, 2019 6:43 pm

Standaard kun je geen JavaScript in artikelen plaatsen. Joomla en/of je WYSIWYG editor voorkomen dat uit veiligheidsoogpunt.

Je kunt in Joomla via System > Global Configuration > [Text Filters] tab > het account type waar je JavaScript wilt toestaan (bijv Super Users) de Filtering op "No Filtering" zetten.

Als je JCE Editor als WYSIWYG editor gebruikt, dan dien je JCE te configureren dat JavaScript wordt toegestaan (en niet uit je artikel gestripped), zie https://www.joomlacontenteditor.net/sup ... -on-saving
Kind Regards,
Peter Martin, Global Moderator
https://db8.nl - Joomla specialist, Nijmegen, Nederland
Co-developer of d2 Content https://data2site.com/joomla-extensions/d2-content

User avatar
Rondeb
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 133
Joined: Mon Dec 02, 2013 12:14 pm
Location: Meschede - Germany
Contact:

Re: Widget werkt niet zoals het hoort

Post by Rondeb » Fri Aug 02, 2019 9:11 pm

Hallo Hester,

@pe7er zijn reactie en tip is helemaal goed en ook een oplossing.

Maar je kan ook met de plugin Sourcerer script in artikel plaatsen deze extensie is gratis maar is ook betaalde versie!
https://www.regularlabs.com/extensions/sourcerer

Vriendelijke groeten,

Ron

HesterPr
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Thu Aug 01, 2019 6:40 pm

Re: Widget werkt niet zoals het hoort

Post by HesterPr » Sat Aug 03, 2019 2:43 pm

Goedemiddag,
Bedankt voor het beantwoorden .
Ik heb op mijn site gekeken naar “Je kunt in Joomla via System > Global Configuration > [Text Filters] tab > het account type waar je JavaScript wilt toestaan (bijv Super Users) de Filtering op "No Filtering" zetten.”

Op mijn site stond de textfilter van de superuser al op ‘geen filter’, voor de zekerheid heb ik de administrator ook maar op ‘geen filter’ gezet en het nogmaals geprobeerd. Hetzelfde resultaat. De widget verandert in een link.
Daarna heb ik gekeken naar de ‘sourcerer’ plugin. Wat is uit de documentatie begrijp, zou ik na het installeren daarvan de code tussen {source}….en {/source} moeten zetten. Zie onder
{source} <script type="text/javascript" src="https://www.ferienhausmiete.de/verwalte ... cript><div id="ferienhausmiete-de-widget4-236273"><a href="https://www.ferienhausmiete.de/236273.htm" target="_blank">Arcadia</a></div>{/source}

Klopt dit? Zo niet dan wordt het te technisch voor me 

Zijn er anders nog andere oplossingen voor me?
Vriendelijke groet,
Hester

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 22278
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, The Netherlands
Contact:

Re: Widget werkt niet zoals het hoort

Post by pe7er » Sat Aug 03, 2019 7:05 pm

Ik zou eerlijk gezegd geen plugin gebruiken als het niet nodig is. Hoe minder 3rd party extensions je gebruikt, hoe minder je hoeft te updaten, hoe minder problemen je hebt tussen de andere plugins, en minder 3rd party plugins is ook beter voor de performance van de site.

Je kunt ook proberen in Site > Global Configuration de WYSIWYG editor op "None" te zetten,
dan de JavaScript toe te voegen,
en daarna de WYSIWYG editor weer op de oude setting te zetten (en het artikel niet meer te editen. Zet bijvoorbeeld bij de "Notes" een aantekening daarover).
Kind Regards,
Peter Martin, Global Moderator
https://db8.nl - Joomla specialist, Nijmegen, Nederland
Co-developer of d2 Content https://data2site.com/joomla-extensions/d2-content

HesterPr
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Thu Aug 01, 2019 6:40 pm

Re: Widget werkt niet zoals het hoort

Post by HesterPr » Sun Aug 04, 2019 12:42 pm

Ik heb geprobeerd bij de algemene instellingen WYSIWYG editor to vinden maar die ik kan dat nergens vinden!
Gevonden: TinyMCE is een platform-onafhankelijke web-gebaseerde JavaScript HTML WYSIWYG tekstverwerker.
Op TinyMCE staat wel een instelling ‘verboden elementen’ ( Moet altijd iets ingevuld worden staat er bij de popup, anders bv cms als je niets wilt invullen.) Daarachter in het invulgedeelte staat ; script,applet,iframe
Misschien is dit het probleem. Kan ik die ‘script,applet,iframe’, zonder problemen verwijderen en dan csm invullen? En dan kijken of het wel werkt?
Hester

HesterPr
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Thu Aug 01, 2019 6:40 pm

Re: Widget werkt niet zoals het hoort

Post by HesterPr » Sun Aug 04, 2019 7:14 pm

Goedenavond,

Ik heb ondertussen de instellingen aangepast en geprobeerd.
Ik heb bij TinyMCE de instellingen
-Verboden elementen verandert in cms en
- Geldige elementen: JavaScript

- Uitgebreide geldige elementen: JavaScript

Jammer genoeg gebeurt nog steeds hetzelfde; de beschikbaarheidskalender verschijnt niet, alleen een link naar ons huisje op de site van vakantiehuisnu.nl
Is het nu beter om de wijzigingen weer terug te zetten op de oude instellingen?

Groet,
Hester

User avatar
Rondeb
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 133
Joined: Mon Dec 02, 2013 12:14 pm
Location: Meschede - Germany
Contact:

Re: Widget werkt niet zoals het hoort

Post by Rondeb » Mon Aug 05, 2019 6:37 am

pe7er wrote:
Sat Aug 03, 2019 7:05 pm
Je kunt ook proberen in Site > Global Configuration de WYSIWYG editor op "None" te zetten,
dan de JavaScript toe te voegen,
en daarna de WYSIWYG editor weer op de oude setting te zetten (en het artikel niet meer te editen. Zet bijvoorbeeld bij de "Notes" een aantekening daarover).
Hallo Hester,

heb je bovenstaande wat @pe7er als oplossing aankaart al geprobeerd?

Groeten Ron

User avatar
Jaydot
Joomla! Explorer
Joomla! Explorer
Posts: 273
Joined: Sun Jun 04, 2017 12:11 pm
Location: The Netherlands
Contact:

Re: Widget werkt niet zoals het hoort

Post by Jaydot » Mon Aug 05, 2019 10:21 am

Beetje laat, maar toch even een aanvulling:
Je kunt Tiny prima gebruiken om code in te voeren, maar daarvoor moeten de instellingen aangepast worden. Dat kan makkelijker dan door gebruik van de verboden/toegestaan velden.
Zoals Peter al zei: ga éérst naar Global Config en de tab "Tekst Filters", en zorg dat het filter voor jouw Gebruikersgroep op "Geen Filters" staat.
Ga dan naar de instellingen van Tiny, kies de set waar jouw Gebruikersgroep onder valt (Tiny heeft drie "sets" waar je verschillende toestemmingen voor verschillende gebruikersgroep kunt instellen). In jouw set zet je "Gebruik Joomla Tekstfilters" aan.
(Ik doe dit altijd standaard voor alledrie de sets - dan hoef ik niet te rommelen in die verboden/toegestane velden, en ik kan in de Tekst Filters heel precies regelen wie wat mag invoeren.)
Overigens zou ik zo'n script altijd in een eigen module (type: aangepast) zetten, en niet in een artikel, gewoon om tekst en externe functionaliteit gescheiden te houden.
The fact that an opinion is widely held is no evidence whatsoever that it is not utterly absurd.
Personal website: https://jaydot.nl

HesterPr
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Thu Aug 01, 2019 6:40 pm

Re: Widget werkt niet zoals het hoort

Post by HesterPr » Mon Aug 05, 2019 2:35 pm

Goedemiddag,
Ik ben blij dat je nog reageerde want het probleem is nog steeds niet opgelost.
Ik heb precies gedaan wat jij voorstelde. Mijn groep; ‘super user’ heb ik vanaf het begin al op ’geen filter’ staan. Nu heb ik bij Tiny alle drie de sets ‘Gebruik Joomla tekstfilters’ op ‘aan’ gezet.
Ik heb een aangepaste module gemaakt en in de HTML kant dit geplakt’;

<script type="text/javascript" src="https://www.ferienhausmiete.de/verwalte ... cript><div id="ferienhausmiete-de-widget4-236273"><a href="https://www.ferienhausmiete.de/236273.htm" target="_blank">Arcadia</a></div>

Vervolgens heb ik op opslaan geklikt, ik schakel de tekstverwerker terug en dit is wat ik zie:
Arcadia
Als ik eerst opsla en dan wissel zie ik hetzelfde.
Schakel ik dan terug naar de tekstverwerker dan is de code ‘verandert’ in

<p>
<script type="text/javascript" src="https://www.ferienhausmiete.de/verwalte ... "></script>
</p>
<div id="ferienhausmiete-de-widget4-236273"><a href="https://www.ferienhausmiete.de/236273.htm" target="_blank" rel="noopener noreferrer">Arcadia</a></div>

Ik heb werkelijk geen idee meer hoe dit opgelost kan worden. De website www.Ferienhause.de
Gaf nog het volgende aan; Können Sie manuell rel=noopener entfernen?

Dat kan wel maar daar verandert niets door, als ik die woorden weghaal en opsla, staan ze direct weer terug.
Ik wordt hier een beetje moedeloos van. Juist deze widget is het belangrijkste onderdeel van mijn website, samen met het Chronoform6 formulier.
Op de een of andere manier is er ergens een instelling die voorkomt dat deze widget geplaatst wordt! Maar welke?? Ik heb een andere module geprobeerd te plaatsen (buienradar.nl) en die werkte wel gewoon.

Groet,
Hester

HesterPr
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Thu Aug 01, 2019 6:40 pm

Re: Widget werkt niet zoals het hoort

Post by HesterPr » Mon Aug 05, 2019 3:13 pm

Ik weet niet wat ik gedaan heb, maar hij staat erop!! Joepie :)
Allemaal heel erg bedankt voor alle geboden hulp!

Groet,
Hester

User avatar
Jaydot
Joomla! Explorer
Joomla! Explorer
Posts: 273
Joined: Sun Jun 04, 2017 12:11 pm
Location: The Netherlands
Contact:

Re: Widget werkt niet zoals het hoort

Post by Jaydot » Mon Aug 05, 2019 3:31 pm

Nee hoor, zo te zien werkt het bijna goed, maar:
Tiny is een invoerscherm, het kan géén javascript uitvoeren... daarvoor moet het script via de server lopen. Je kunt dus pas zien of het werkt als je je module publiceert en dan aan de voorkant van de site kijkt wat er gebeurt.
Verder: Tiny heeft een WYSIWYG scherm en een HTML scherm.
Code invoeren doe je altijd in het HTML scherm.
Als je vervolgens in het WYSIWYG scherm kijkt zie je alleen "Arcadia" en da's logisch, want de javascript code zie je daar niet.
De toegevoegde "rel" zou geen probleem moeten zijn.
Maar ik krijg dat scriptje ook niet werkend - weet je zeker dat het scriptje echt goed is? De link naar Ferienhause werkt niet, maar ik vermoed ook dat je ingelogd moet zijn om zulke scriptjes op te kunnen pakken...
The fact that an opinion is widely held is no evidence whatsoever that it is not utterly absurd.
Personal website: https://jaydot.nl

User avatar
Jaydot
Joomla! Explorer
Joomla! Explorer
Posts: 273
Joined: Sun Jun 04, 2017 12:11 pm
Location: The Netherlands
Contact:

Re: Widget werkt niet zoals het hoort

Post by Jaydot » Mon Aug 05, 2019 3:32 pm

Ha! Je bent me voor :).
Mooizo!
The fact that an opinion is widely held is no evidence whatsoever that it is not utterly absurd.
Personal website: https://jaydot.nl


Post Reply

Return to “Extensies 3.x”