Version php 7.0 a 7.1 Topic is solved

Para cualquier duda sobre Joomla! 3.x que no tenga cabida en alguno de los foros de más abajo.

Moderators: hefesto, carcam

Post Reply
joaovega
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Mon Aug 12, 2019 9:44 pm

Version php 7.0 a 7.1

Post by joaovega » Sun Aug 25, 2019 5:32 pm

Hola a todos, tengo mi sitio funcionando con la ultima version de Joomla pero no consigo poder usarlo con versiones de php posteriores a la 7.0
Cuando cambio a la 7.1 o posteriores me arroja el siguiente mensaje:

0 - [] operator not supported for strings


Dejo el informe del sitio con el fpa. Agradezco cualquier ayuda, no tengo idea de lo que esta sucediendo y no encuentro referencias al error.
Forum Post Assistant (v1.4.9 (lambrusca) : 25th August 2019 wrote:
Last PHP Error(s) Reported :: wrote:[25-Aug-2019 13:53:36 UTC] PHP Warning: Invalid argument supplied for foreach() in /home/rg3l07z14gr9/public_html/libraries/src/Plugin/PluginHelper.php on line 103
Basic Environment :: wrote:Joomla! Instance :: Joomla! 3.9.11-Stable (Amani) 13-August-2019
Joomla! Platform :: Joomla Platform 13.1.0-Stable (Curiosity) 24-Apr-2013
Joomla! Configured :: Yes | Read-Only (444) | Owner: --protected-- . (uid: 1/gid: 1) | Group: --protected-- (gid: 1) | Valid For: 3.9
Configuration Options :: Offline: false | SEF: true | SEF Suffix: false | SEF ReWrite: false | .htaccess/web.config: Yes | GZip: true | Cache: true | CacheTime: 5 | CacheHandler: file | CachePlatformPrefix: false | FTP Layer: false | Proxy: false | LiveSite: | Session lifetime: 15 | Session handler: database | Shared sessions: false | SSL: 0 | Error Reporting: simple | Site Debug: false | Language Debug: false | Default Access: 1 | Unicode Slugs: false | dbConnection Type: pdomysql | PHP Supports J! 3.9.11: Yes | Database Supports J! 3.9.11: Unknown | Database Credentials Present: Yes |

Host Configuration :: OS: Linux | OS Version: 2.6.32-954.3.5.lve1.4.66.el6.x86_64 | Technology: x86_64 | Web Server: Apache | Encoding: gzip, deflate | Doc Root: --protected-- | System TMP Writable: Yes | Free Disk Space : 1112.42 GiB |

PHP Configuration :: Version: 7.0.33 | PHP API: litespeed | Session Path Writable: Yes | Display Errors: | Error Reporting: 32767 | Log Errors To: error_log | Last Known Error: 25th August 2019 17:19:51. | Register Globals: | Magic Quotes: | Safe Mode: | Allow url fopen: 1 | Open Base: | Uploads: 1 | Max. Upload Size: 32M | Max. POST Size: 32M | Max. Input Time: -1 | Max. Execution Time: 30 | Memory Limit: 128M

Database Configuration :: Connection Error: : Database Credentials Present? in Configuration...
Detailed Environment :: wrote:PHP Extensions :: Core (7.0.33) | date (7.0.33) | libxml (7.0.33) | openssl (7.0.33) | pcre (7.0.33) | sqlite3 (7.0.33) | zlib (7.0.33) | bz2 (7.0.33) | calendar (7.0.33) | ctype (7.0.33) | curl (7.0.33) | hash (1.0) | filter (7.0.33) | ftp (7.0.33) | gettext (7.0.33) | gmp (7.0.33) | SPL (7.0.33) | iconv (7.0.33) | pcntl (7.0.33) | readline (7.0.33) | Reflection (7.0.33) | session (7.0.33) | standard (7.0.33) | shmop (7.0.33) | SimpleXML (7.0.33) | mbstring (7.0.33) | tokenizer (7.0.33) | xml (7.0.33) | litespeed () | bcmath (7.0.33) | dom (20031129) | fileinfo (1.0.5) | gd (7.0.33) | imagick (3.4.3) | imap (7.0.33) | inotify (2.0.0) | intl (1.1.0) | json (1.4.0) | exif (7.0.33) | mcrypt (7.0.33) | mysqli (7.0.33) | mysqlnd (mysqlnd 5.0.12-dev - 20150407 - $Id: b5c5906d452ec590732a93b051f3827e02749b83 $) | PDO (7.0.33) | pdo_mysql (7.0.33) | pdo_sqlite (7.0.33) | Phar (2.0.2) | posix (7.0.33) | soap (7.0.33) | xmlreader (7.0.33) | xmlrpc (7.0.33) | xmlwriter (7.0.33) | Zend Engine (3.0.0) |
Potential Missing Extensions :: zip |

Switch User Environment (Experimental) :: PHP CGI: No | Server SU: No | PHP SU: No | Custom SU (LiteSpeed/Cloud/Grid): Yes
Potential Ownership Issues: No
Folder Permissions :: wrote:Core Folders :: images/ (755) | components/ (755) | modules/ (755) | plugins/ (755) | language/ (755) | templates/ (755) | cache/ (755) | logs/ (755) | tmp/ (755) | administrator/components/ (755) | administrator/modules/ (755) | administrator/language/ (755) | administrator/templates/ (755) | administrator/logs/ (755) |

Elevated Permissions (First 10) ::
Extensions Discovered :: wrote:Components :: SITE ::
Core :: com_wrapper (3.0.0) ? | com_mailto (3.0.0) ? |
3rd Party:: kunena_tmpl_crypsis (5.1.14) ? | kunena_tmpl_crypsisb3 (5.1.14) ? |

Components :: ADMIN ::
Core :: com_ajax (3.2.0) ? | com_templates (3.0.0) ? | com_menus (3.0.0) ? | com_cpanel (3.0.0) ? | com_content (3.0.0) ? | com_categories (3.0.0) ? | com_login (3.0.0) ? | com_messages (3.0.0) ? | com_installer (3.0.0) ? | com_checkin (3.0.0) ? | com_config (3.0.0) ? | com_fields (3.7.0) ? | com_postinstall (3.2.0) ? | com_search (3.0.0) ? | com_newsfeeds (3.0.0) ? | com_plugins (3.0.0) ? | com_banners (3.0.0) ? | com_weblinks (3.6.0) ? | com_users (3.0.0) ? | com_cache (3.0.0) ? | com_admin (3.0.0) ? | com_tags (3.1.0) ? | com_associations (3.7.0) ? | com_contenthistory (3.2.0) ? | com_redirect (3.0.0) ? | com_finder (3.0.0) ? | com_media (3.0.0) ? | com_actionlogs (3.9.0) ? | com_modules (3.0.0) ? | com_privacy (3.9.0) ? | com_joomlaupdate (3.6.2) ? | com_languages (3.0.0) ? |
3rd Party:: RokSprocket (2.1.26) ? | com_jaextmanager (2.6.5) ? | com_jaextmanager (2.5.3) ? | JChat (2.7) ? | Akeeba (6.6.0) ? | mod_kunenamenu (4.0.12) ? | plg_kunena_community (5.1.14) ? | plg_kunena_comprofiler (5.1.14) ? | PLG_KUNENA_EASYPROFILE (5.1.14) ? | PLG_KUNENA_EASYBLOG (0.0.1) ? | plg_kunena_alphauserpoints (4.0.12) ? | plg_finder_kunena (5.1.14) ? | plg_kunena_easysocial (5.1.14) ? | plg_kunena_uddeim (5.1.14) ? | plg_kunena_kunena (5.1.14) ? | plg_kunena_finder (5.1.14) ? | plg_kunena_gravatar (5.1.14) ? | plg_kunena_joomla (5.1.14) ? | plg_kunena_altauserpoints (5.1.14) ? | com_kunena (5.1.14) ? | Facebook All (1.5) ? | com_form2content (5.6.0) ? | uddeIM (3.7) ? | AlphaUserPoints (2.0.4) ? | Editor Button - AlphaUserPoints Raf (1.6.0) ? | Content - AlphaUserPoints - Standar (1.9.0) ? | User - AlphaUserPoints - New user (2.0.3) ? | alphauserpointsicon (1.9.0) ? | System - AlphaUserPoints (1.9.0) ? | Content - AlphaUserPoints - Raffle (1.9.1) ? | AlphaUserPoints - Notification on u (1.9.0) ? | Content - AlphaUserPoints - Reader (1.9.0) ? | AlphaUserPoints - Example Plugin fo (1.9.0) ? | mod_joomstats (3.0 BETA) ? | JoomGallery (3.3.4) ? |

Modules :: SITE ::
Core :: mod_breadcrumbs (3.0.0) ? | mod_articles_popular (3.0.0) ? | mod_tags_similar (3.1.0) ? | mod_articles_latest (3.0.0) ? | mod_finder (3.0.0) ? | mod_whosonline (3.0.0) ? | mod_search (3.0.0) ? | mod_wrapper (3.0.0) ? | mod_articles_categories (3.0.0) ? | mod_custom (3.0.0) ? | mod_banners (3.0.0) ? | mod_menu (3.0.0) ? | mod_articles_archive (3.0.0) ? | mod_random_image (3.0.0) ? | mod_login (3.0.0) ? | mod_users_latest (3.0.0) ? | mod_articles_news (3.0.0) ? | mod_stats (3.0.0) ? | mod_tags_popular (3.1.0) ? | mod_footer (3.0.0) ? | mod_syndicate (3.0.0) ? | mod_weblinks (3.6.0) ? | mod_related_items (3.0.0) ? | mod_feed (3.0.0) ? | mod_languages (3.5.0) ? | mod_articles_category (3.0.0) ? |
3rd Party:: Lof Article Scroller Module (3.0) ? | AlphaUserPoints - Online Users (2.0.4) ? | AlphaUserPoints - Last points earne (2.0.4) ? | mod_ads_elite (4.5) ? | RokSprocket Module (2.1.26) ? | uddeIM Notifier (3.7) ? | JChatSocial Module (2.7) ? | Lof ArticlesSlideShow Module (2.2) ? | mod_kunenastats (5.1.1) ? | Sj Content Categories (2.0.0) ? | Thread Share for Kunena (1.0.2) ? | AlphaUserPoints - Points from Start (2.0.4) ? | mod_kunenalatest (5.1.1) ? | zKunenaLatest (2.0) ? | AlphaUserPoints - Most Active Users (2.0.4) ? | mod_kunenasearch (5.1.1) ? | mod_joomimg (3.3.0) ? | mod_joomstats (3.0 BETA) ? | uddeIM Statistics (3.7) ? | Mb2 Content (1.3.1) ? | mod_sw_kbirthday (1.9.0) ? | AlphaUserPoints - Actual Points (2.0.4) ? | AlphaUserPoints - Lastest activity (2.0.4) ? | FacebookAll Embedded Posts (1.5) ? | Facebookall Login (1.5) ? | AlphaUserPoints - Coupon Code (2.0.4) ? | uddeIM Mailbox (3.7) ? | AlphaUserPoints - Monthly statistic (2.0.4) ? | AlphaUserPoints - Most Referral Use (2.0.4) ? | FacebookAll Follow Button (1.5) ? | FacebookAll Page Plugin (1.5) ? |

Modules :: ADMIN ::
Core :: mod_title (3.0.0) ? | mod_toolbar (3.0.0) ? | mod_custom (3.0.0) ? | mod_menu (3.0.0) ? | mod_logged (3.0.0) ? | mod_login (3.0.0) ? | mod_latestactions (3.9.0) ? | mod_status (3.0.0) ? | mod_submenu (3.0.0) ? | mod_latest (3.0.0) ? | mod_quickicon (3.0.0) ? | mod_stats_admin (3.0.0) ? | mod_multilangstatus (3.0.0) ? | mod_sampledata (3.8.0) ? | mod_feed (3.0.0) ? | mod_version (3.0.0) ? | mod_popular (3.0.0) ? | mod_privacy_dashboard (3.9.0) ? |
3rd Party::

Libraries ::
Core ::
3rd Party:: file_fof30 (3.4.5) ? |

Plugins ::
Core :: plg_captcha_recaptcha (3.4.0) ? | plg_captcha_recaptcha_invisible (3.8) ? | plg_system_sessiongc (3.8.6) ? | plg_system_stats (3.5.0) ? | plg_system_cache (3.0.0) ? | plg_system_privacyconsent (3.9.0) ? | plg_system_remember (3.0.0) ? | plg_system_logrotation (3.9.0) ? | plg_system_updatenotification (3.5.0) ? | plg_system_sef (3.0.0) ? | plg_system_p3p (3.0.0) ? | plg_system_languagefilter (3.0.0) ? | PLG_SYSTEM_ACTIONLOGS (3.9.0) ? | plg_system_fields (3.7.0) ? | plg_system_debug (3.0.0) ? | plg_system_redirect (3.0.0) ? | plg_system_log (3.0.0) ? | plg_system_languagecode (3.0.0) ? | plg_system_highlight (3.0.0) ? | plg_system_logout (3.0.0) ? | plg_search_content (3.0.0) ? | plg_search_newsfeeds (3.0.0) ? | plg_search_tags (3.0.0) ? | plg_search_weblinks (3.6.0) ? | plg_search_contacts (3.0.0) ? | plg_search_categories (3.0.0) ? | plg_content_vote (3.0.0) ? | plg_content_joomla (3.0.0) ? | plg_content_confirmconsent (3.9.0) ? | plg_content_loadmodule (3.0.0) ? | plg_content_fields (3.7.0) ? | plg_content_pagenavigation (3.0.0) ? | plg_content_pagebreak (3.0.0) ? | plg_content_finder (3.0.0) ? | plg_content_emailcloak (3.0.0) ? | plg_installer_packageinstaller (3.6.0) ? | PLG_INSTALLER_URLINSTALLER (3.6.0) ? | PLG_INSTALLER_FOLDERINSTALLER (3.6.0) ? | plg_installer_webinstaller (2.0.1) ? | plg_authentication_cookie (3.0.0) ? | plg_authentication_joomla (3.0.0) ? | plg_authentication_ldap (3.0.0) ? | plg_authentication_gmail (3.0.0) ? | plg_editors-xtd_image (3.0.0) ? | plg_editors-xtd_module (3.5.0) ? | plg_editors-xtd_menu (3.7.0) ? | plg_editors-xtd_readmore (3.0.0) ? | plg_editors-xtd_article (3.0.0) ? | plg_editors-xtd_fields (3.7.0) ? | plg_editors-xtd_pagebreak (3.0.0) ? | PLG_ACTIONLOG_JOOMLA (3.9.0) ? | plg_extension_joomla (3.0.0) ? | plg_quickicon_joomlaupdate (3.0.0) ? | plg_quickicon_extensionupdate (3.0.0) ? | plg_quickicon_phpversioncheck (3.7.0) ? | plg_quickicon_privacycheck (3.9.0) ? | plg_user_joomla (3.0.0) ? | plg_user_contactcreator (3.0.0) ? | plg_user_terms (3.9.0) ? | plg_user_profile (3.0.0) ? | plg_fields_url (3.7.0) ? | plg_fields_calendar (3.7.0) ? | plg_fields_text (3.7.0) ? | plg_fields_color (3.7.0) ? | plg_fields_integer (3.7.0) ? | plg_fields_repeatable (3.9.0) ? | plg_fields_user (3.7.0) ? | plg_fields_imagelist (3.7.0) ? | plg_fields_usergrouplist (3.7.0) ? | plg_fields_textarea (3.7.0) ? | plg_fields_list (3.7.0) ? | plg_fields_media (3.7.0) ? | plg_fields_editor (3.7.0) ? | plg_fields_radio (3.7.0) ? | plg_fields_checkboxes (3.7.0) ? | plg_fields_sql (3.7.0) ? | plg_twofactorauth_totp (3.2.0) ? | plg_twofactorauth_yubikey (3.2.0) ? | plg_privacy_message (3.9.0) ? | plg_privacy_content (3.9.0) ? | plg_privacy_actionlogs (3.9.0) ? | plg_privacy_user (3.9.0) ? | plg_privacy_consents (3.9.0) ? | plg_finder_content (3.0.0) ? | plg_finder_newsfeeds (3.0.0) ? | plg_finder_tags (3.0.0) ? | plg_finder_weblinks (3.6.0) ? | plg_finder_contacts (3.0.0) ? | plg_finder_categories (3.0.0) ? |
3rd Party:: plg_editors_tinymce (4.5.11) ? | plg_editors_codemirror (5.40.0) ? | PLG_FORM2CONTENT_METADATAGENERATOR (1.2.0) ? | PLG_SYSTEM_AKEEBAUPDATECHECK (6.6.0) ? | T3 Framework (2.7.4) ? | PLG_SYSTEM_BACKUPONUPDATE (6.6.0) ? | uddeIM Hooks (3.7) ? | System - AlphaUserPoints (1.9.0) ? | Tapatalk Kunena Plugin (kn40_2.1.1) ? | System - JChatSocial login (2.7) ? | System - JChatSocial (2.7) ? | System - Facebookall Login (1.5) ? | plg_system_adsstarterelite (4.5) ? | System - RokSprocket (2.1.26) ? | plg_system_kunena (5.1.14) ? | System - RokCommon (3.2.7) ? | uddeIM Searchbot (3.7) ? | Content - RokInjectModule (2.1.26) ? | Content - AlphaUserPoints - Standar (1.9.0) ? | Content - AlphaUserPoints - Raffle (1.9.1) ? | uddeIM Content Link (3.7) ? | Content - Facebook All Comment and (1.5) ? | Content - Facebook-Twitter-Google+1 (3.2) ? | plg_content_kunenadiscuss (5.1.1) ? | Content - AlphaUserPoints - Reader (1.9.0) ? | plg_content_adselite (4.5) ? | AlphaUserPoints - Notification on u (1.9.0) ? | AlphaUserPoints - Example Plugin fo (1.9.0) ? | Editor Button - AlphaUserPoints Raf (1.6.0) ? | PLG_ACTIONLOG_AKEEBABACKUP (6.6.0) ? | alphauserpointsicon (1.9.0) ? | plg_quickicon_akeebabackup (6.6.0) ? | plg_quickicon_kunena (5.1.14) ? | User - AlphaUserPoints - New user (2.0.3) ? | PLG_JOOMAUTOCAT (3.0) ? | User - AlphaUserPoints - Rule to Lo (1.9.0) ? | User - AlphaUserPoints - Rule Happy (1.9.0) ? | plg_kunena_gravatar (5.1.14) ? | PLG_KUNENA_EASYPROFILE (5.1.14) ? | plg_kunena_comprofiler (5.1.14) ? | plg_kunena_uddeim (5.1.14) ? | plg_kunena_joomla (5.1.14) ? | plg_kunena_community (5.1.14) ? | plg_kunena_altauserpoints (5.1.14) ? | plg_kunena_kunena (5.1.14) ? | plg_kunena_easysocial (5.1.14) ? | plg_kunena_finder (5.1.14) ? | plg_finder_kunena (5.1.14) ? |
Templates Discovered :: wrote:Templates :: SITE :: protostar (1.0) ? | purity_III (1.2.5) ? | beez3 (3.1.0) ? |
Templates :: ADMIN :: isis (1.0) ? | hathor (3.0.0) ? |

User avatar
john-doe
Joomla! Guru
Joomla! Guru
Posts: 875
Joined: Tue Apr 19, 2011 7:39 pm
Location: Colombia
Contact:

Re: Version php 7.0 a 7.1

Post by john-doe » Mon Aug 26, 2019 3:51 pm

Hola. El sintoma parece incompatibilidad de un componente. Están todos al día?
www.aldemar-hernandez.com - Custom templates and design services.

joaovega
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Mon Aug 12, 2019 9:44 pm

Re: Version php 7.0 a 7.1

Post by joaovega » Mon Aug 26, 2019 6:23 pm

Hola! Están todos al día, tenia JChatsocial obsoleto pero lo desinstalé y el problema persiste. 😕

trabajodirect
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Sun Apr 30, 2017 10:08 am

Re: Version php 7.0 a 7.1

Post by trabajodirect » Tue Sep 03, 2019 11:26 am

Por si te puede dar una pista tu problema no es pasar de PHP 7.0 a 7.1, sino que el plugin (seguro que es un plugin o la plantilla) funcionaba con PHP 5.5 o 5.6 y en la versión 7.0 te andaba de milagro.

Mirate cualquier plugin que tenga fecha de última actualización más de 1 año.

joaovega
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Mon Aug 12, 2019 9:44 pm

Re: Version php 7.0 a 7.1

Post by joaovega » Mon Sep 09, 2019 1:30 pm

trabajodirect wrote:
Tue Sep 03, 2019 11:26 am
Por si te puede dar una pista tu problema no es pasar de PHP 7.0 a 7.1, sino que el plugin (seguro que es un plugin o la plantilla) funcionaba con PHP 5.5 o 5.6 y en la versión 7.0 te andaba de milagro.

Mirate cualquier plugin que tenga fecha de última actualización más de 1 año.
Efectivamente era un plugin viejo que ya no tiene soporte ni actualizacion, lo desinstalé y listo.
Muchas gracias!


Post Reply

Return to “Joomla! 3.x”