My back end template changed to Hathor Topic is solved

General questions relating to Joomla! 3.x.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
Post Reply
moozarkgrl
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Fri Jul 18, 2014 5:22 pm

My back end template changed to Hathor

Post by moozarkgrl » Sat Oct 05, 2019 8:53 pm

I have a 3.98 site and yesterday my backend template changed to Hathor. The option to change the backend template - not like before. How can I rectify this? I read that Hathor is deprecated in this version of Joomla.
Last edited by toivo on Sun Oct 06, 2019 12:11 am, edited 1 time in total.
Reason: mod note: split from 3.9.8 Discussion

User avatar
sozzled
Joomla! Exemplar
Joomla! Exemplar
Posts: 8009
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: Discuss Joomla! 3.9.8

Post by sozzled » Sat Oct 05, 2019 9:18 pm

Go to Extensions » Templates » Styles in the backend. Select "Administrator" in the pull-down. Notice that there is a gold star on the line for Hathor. Click the star on the line for Isis to make Isis the default administrator template.

You read correctly: Hathor is no longer supported by the J! development team.

Next: update to the latest version of J! which is J! 3.9.12. Hope that helps.
https://www.kuneze.com/blog
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

User avatar
AMurray
Joomla! Champion
Joomla! Champion
Posts: 5026
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: My back end template changed to Hathor

Post by AMurray » Sun Oct 06, 2019 10:47 pm

sozzled wrote:You read correctly: Hathor is no longer supported by the J! development team.
My question then, if Hathor is obsolete and no longer supported, shouldn't it be removed from the Joomla distribution downloads? Why is it still included in the distribution of Joomla if no longer supported?

Do we need to put in a change request (pull request, whatever programmers call it) on Github.....?

I suppose if anyone absolutely want it, it could be put on the JED, under the "official extensions" category (like has been done with Weblinks)?
Regards,
--------------------------------------------------------------
A Murray
Millennium Falcon - it's the ship that made the Kessel run in less than 12 parsecs! The fastest hunk of junk in the galaxy.

User avatar
sozzled
Joomla! Exemplar
Joomla! Exemplar
Posts: 8009
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: My back end template changed to Hathor

Post by sozzled » Sun Oct 06, 2019 10:58 pm

"Politically-speaking", I guess, because Hathor—a derivative of the old J! 2.x version—was included as part of the design of J! 3.x, it's difficult to remove it. Further, some people (I couldn't give you a number) still use it. Therefore, if it was abruptly removed now, after being a standard part of the CMS for seven years, there would be a clamour from those people who will ask, "Where did it go?"

Technically-speaking, it wouldn't be that difficult to pull Hathor from the distribution package.

This also goes to the heart of the argument surrounding the design of J! 4. Do you ship with one supported template or do you try to maintain a range of alternatives? Reading the comments posted on this forum from those who are up-to-their-armpits wrestling with this issue, I tend to agree that one supported template is "the go".

Some people like Hathor (or Beez3 for that matter) even though they're old, they're tired and they haven't been properly maintained for a couple of years. I remember when J! 3 was being designed and there were howls of disapproval about Protostar then. Today there are howls of disapproval about the J! 4 front- and backend templates. You just can't please everyone. 8)
https://www.kuneze.com/blog
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

moozarkgrl
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Fri Jul 18, 2014 5:22 pm

Re: My back end template changed to Hathor

Post by moozarkgrl » Tue Oct 08, 2019 4:00 am

I've never used Hathor and thought it was what the backend template was showing. I'm enclosing a screen shot of what I've got now.
Bad Admin Backend Template.png
I've downloaded the current Isis template as well as a 3rd party admin template. Changing any one of the admin templates only changes the back end login screen. After I log in, it always looks like this.

Anyone else have this problem?
You do not have the required permissions to view the files attached to this post.

moozarkgrl
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Fri Jul 18, 2014 5:22 pm

Re: My back end template changed to Hathor

Post by moozarkgrl » Tue Oct 08, 2019 4:01 am

I'll open up a new forum post as the problem has changed, LOL

User avatar
sozzled
Joomla! Exemplar
Joomla! Exemplar
Posts: 8009
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: My back end template changed to Hathor

Post by sozzled » Tue Oct 08, 2019 4:21 am

sozzled wrote:
Sat Oct 05, 2019 9:18 pm
Go to Extensions » Templates » Styles in the backend. Select "Administrator" in the pull-down. Notice that there is a gold star on the line for Hathor. Click the star on the line for Isis to make Isis the default administrator template.
The screen you showed is Hathor.
https://www.kuneze.com/blog
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 11455
Joined: Thu Feb 15, 2007 5:48 am
Location: Suzhou, China

Re: My back end template changed to Hathor

Post by toivo » Tue Oct 08, 2019 4:43 am

Cross post removed. Please observe the forum rules, available from viewtopic.php?f=8&t=65.

Please post the results from the Forum Post Assistant (FPA) by following the instructions at https://forumpostassistant.github.io/docs/.
Toivo Talikka, Global Moderator

User avatar
sozzled
Joomla! Exemplar
Joomla! Exemplar
Posts: 8009
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: My back end template changed to Hathor

Post by sozzled » Tue Oct 08, 2019 4:47 am

hathor2isis.png
You do not have the required permissions to view the files attached to this post.
https://www.kuneze.com/blog
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

moozarkgrl
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Fri Jul 18, 2014 5:22 pm

Re: My back end template changed to Hathor

Post by moozarkgrl » Tue Oct 08, 2019 2:11 pm

I know how to change default templates. The problem is regardless which one I choose, the admin template remains the same! I even downloaded a 3rd party admin template. All it changes is the login screen.

moozarkgrl
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Fri Jul 18, 2014 5:22 pm

Re: My back end template changed to Hathor

Post by moozarkgrl » Tue Oct 08, 2019 2:47 pm

No matter which template I choose as default, all that changes is the Login screen but not the template itself.

Isis default:

Selected :
Isis Selected as Default.png
Login screen:
Isis Login Screen.png
Hathor default:
Hathor Selected as Default.png
Login screen:
Hathor Login Screen.png
You do not have the required permissions to view the files attached to this post.

moozarkgrl
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Fri Jul 18, 2014 5:22 pm

Re: My back end template changed to Hathor

Post by moozarkgrl » Tue Oct 08, 2019 2:50 pm

This time I used a 3rd party template:

Adminim default:
Adminim Selected as Default.png
Adminim login:
Adminim Login Screen.png
You do not have the required permissions to view the files attached to this post.

User avatar
sozzled
Joomla! Exemplar
Joomla! Exemplar
Posts: 8009
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: My back end template changed to Hathor

Post by sozzled » Tue Oct 08, 2019 5:39 pm

I don't know anything about the templates called Isis3 or Adminim, sorry. It looks like your website needs some work. There is a feature in the Joomla! Update component that allows you to re-install the current version of Joomla you are using (and that may be something worth considering).

I don't know what is the problem here. It may be worth running the Forum Post Assistant and posting the report here on the forum.

It's very strange.
https://www.kuneze.com/blog
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

moozarkgrl
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Fri Jul 18, 2014 5:22 pm

Re: My back end template changed to Hathor

Post by moozarkgrl » Tue Oct 08, 2019 8:40 pm

Forum Post Assistant (v1.4.9 (lambrusca) : 8th October 2019 wrote:
Last PHP Error(s) Reported :: wrote:[08-Oct-2019 20:35:07 UTC] PHP Warning: PHP Startup: Unable to load dynamic library '/opt/php70/lib/php/extensions/no-debug-non-zts-20151012/ixed.7.1.lin' - /opt/php70/lib/php/extensions/no-debug-non-zts-20151012/ixed.7.1.lin: cannot open shared object file: No such file or directory in Unknown on line 0
Basic Environment :: wrote:Joomla! Instance :: Joomla! 3.9.8-Stable (Amani) 11-June-2019
Joomla! Platform :: Joomla Platform 13.1.0-Stable (Curiosity) 24-Apr-2013
Joomla! Configured :: Yes | Read-Only (444) | Owner: --protected-- . (uid: 1/gid: 1) | Group: --protected-- (gid: 1) | Valid For: 3.9
Configuration Options :: Offline: false | SEF: true | SEF Suffix: false | SEF ReWrite: false | .htaccess/web.config: Yes | GZip: false | Cache: true | CacheTime: 15 | CacheHandler: file | CachePlatformPrefix: false | FTP Layer: false | Proxy: false | LiveSite: | Session lifetime: 60 | Session handler: database | Shared sessions: false | SSL: 2 | Error Reporting: default | Site Debug: false | Language Debug: false | Default Access: 1 | Unicode Slugs: false | dbConnection Type: mysqli | PHP Supports J! 3.9.8: Yes | Database Supports J! 3.9.8: Yes | Database Credentials Present: Yes |

Host Configuration :: OS: Linux | OS Version: 3.10.0-693.11.6.1.ELK.el6.x86_64 | Technology: x86_64 | Web Server: Apache | Encoding: gzip, deflate, br | Doc Root: --protected-- | System TMP Writable: Yes | Free Disk Space : 259.56 GiB |

PHP Configuration :: Version: 7.1.14 | PHP API: cgi-fcgi | Session Path Writable: Yes | Display Errors: 1 | Error Reporting: 32759 | Log Errors To: error_log | Last Known Error: 08th October 2019 15:38:05. | Register Globals: | Magic Quotes: | Safe Mode: | Allow url fopen: 1 | Open Base: | Uploads: 1 | Max. Upload Size: 64M | Max. POST Size: 64M | Max. Input Time: 60 | Max. Execution Time: 30 | Memory Limit: 256M

Database Configuration :: Version: 5.6.41-84.1 (Client:5.6.41-84.1) | Host: --protected-- (--protected--) | default Collation: utf8_unicode_ci (default Character Set: utf8) | Database Size: 9.08 MiB | #of Tables:  124
Detailed Environment :: wrote:PHP Extensions :: Core (7.1.14) | date (7.1.14) | libxml (7.1.14) | openssl (7.1.14) | pcre (7.1.14) | sqlite3 (7.1.14) | zlib (7.1.14) | bcmath (7.1.14) | bz2 (7.1.14) | calendar (7.1.14) | ctype (7.1.14) | curl (7.1.14) | dom (20031129) | hash (1.0) | fileinfo (1.0.5) | filter (7.1.14) | ftp (7.1.14) | gd (7.1.14) | gettext (7.1.14) | gmp (7.1.14) | SPL (7.1.14) | iconv (7.1.14) | session (7.1.14) | intl (1.1.0) | json (1.5.0) | mbstring (7.1.14) | mcrypt (7.1.14) | mysqli (7.1.14) | odbc (7.1.14) | standard (7.1.14) | PDO (7.1.14) | pdo_mysql (7.1.14) | pdo_sqlite (7.1.14) | Phar (2.0.2) | posix (7.1.14) | pspell (7.1.14) | Reflection (7.1.14) | imap (7.1.14) | SimpleXML (7.1.14) | soap (7.1.14) | sockets (7.1.14) | exif (7.1.14) | tidy (7.1.14) | tokenizer (7.1.14) | wddx (7.1.14) | xml (7.1.14) | xmlreader (7.1.14) | xmlrpc (7.1.14) | xmlwriter (7.1.14) | xsl (7.1.14) | zip (1.13.5) | cgi-fcgi () | ionCube Loader () | Zend Engine (3.1.0) |
Potential Missing Extensions ::
Disabled Functions :: dl |

Switch User Environment (Experimental) :: PHP CGI: Yes | Server SU: Yes | PHP SU: Yes | Custom SU (LiteSpeed/Cloud/Grid): Yes
Potential Ownership Issues: No
Folder Permissions :: wrote:Core Folders :: images/ (755) | components/ (755) | modules/ (755) | plugins/ (755) | language/ (755) | templates/ (755) | cache/ (755) | logs/ (755) | tmp/ (755) | administrator/components/ (755) | administrator/modules/ (755) | administrator/language/ (755) | administrator/templates/ (755) | administrator/logs/ (755) |

Elevated Permissions (First 10) ::
Database Information :: wrote:Database statistics :: Uptime: 4632437 | Threads: 12 | Questions: 2792439035 | Slow queries: 4880 | Opens: 33047300 | Flush tables: 1 | Open tables: 16800 | Queries per second avg: 602.801 |
Extensions Discovered :: wrote:Components :: SITE ::
Core :: com_mailto (3.0.0) 1 | com_wrapper (3.0.0) 1 |
3rd Party::

Components :: ADMIN ::
Core :: com_newsfeeds (3.0.0) 1 | com_media (3.0.0) 1 | com_installer (3.0.0) 1 | com_banners (3.0.0) 1 | com_users (3.0.0) 1 | com_checkin (3.0.0) 1 | com_associations (3.7.0) 1 | com_modules (3.0.0) 1 | com_postinstall (3.2.0) 1 | com_messages (3.0.0) 1 | com_languages (3.0.0) 1 | com_categories (3.0.0) 1 | com_finder (3.0.0) 1 | com_search (3.0.0) 1 | com_cache (3.0.0) 1 | com_ajax (3.2.0) 1 | com_actionlogs (3.9.0) 1 | com_admin (3.0.0) 1 | com_privacy (3.9.0) 1 | com_content (3.0.0) 1 | com_login (3.0.0) 1 | com_config (3.0.0) 1 | com_cpanel (3.0.0) 1 | com_joomlaupdate (3.6.2) 1 | com_redirect (3.0.0) 1 | com_templates (3.0.0) 1 | com_tags (3.1.0) 1 | com_plugins (3.0.0) 1 | com_menus (3.0.0) 1 | com_contenthistory (3.2.0) 1 | com_fields (3.7.0) 1 |
3rd Party:: sysbreezingforms (1.0.0) 1 | COM_BREEZINGFORMS (1.9.0 Stable ) 1 | com_uniterevolution2 (4.8.1) 1 | SP Simple Portfolio (1.0.0) 1 | COM_K2 (2.9.0) 1 | com_advportfoliopro (3.8.2) 1 | Akeeba (6.6.0) 1 | SP Page Builder (3.4.9) 1 |

Modules :: SITE ::
Core :: mod_search (3.0.0) 1 | mod_related_items (3.0.0) 1 | mod_articles_archive (3.0.0) 1 | mod_finder (3.0.0) 1 | mod_whosonline (3.0.0) 1 | mod_articles_categories (3.0.0) 1 | mod_tags_similar (3.1.0) 1 | mod_tags_popular (3.1.0) 1 | mod_articles_news (3.0.0) 1 | mod_articles_latest (3.0.0) 1 | mod_articles_popular (3.0.0) 1 | mod_banners (3.0.0) 1 | mod_breadcrumbs (3.0.0) 1 | mod_login (3.0.0) 1 | mod_languages (3.5.0) 1 | mod_footer (3.0.0) 1 | mod_feed (3.0.0) 1 | mod_stats (3.0.0) 1 | mod_wrapper (3.0.0) 1 | mod_menu (3.0.0) 1 | mod_articles_category (3.0.0) 1 | mod_random_image (3.0.0) 1 | mod_custom (3.0.0) 1 | mod_syndicate (3.0.0) 1 | mod_users_latest (3.0.0) 1 |
3rd Party:: Responsive Slide Show (1.0) 1 | K2 Content (2.9.0) 1 | K2 Tools (2.9.0) 1 | K2 Users (2.9.0) 1 | K2 User (2.9.0) 1 | SP Page Builder (1.3) 1 | SP Simple Portfolio (1.0.0) 1 | Unite Slider 2 (4.7) 1 | Adv Portfolio Pro (3.8.2) 1 | K2 Comments (2.9.0) 1 |

Modules :: ADMIN ::
Core :: mod_popular (3.0.0) 1 | mod_status (3.0.0) 1 | mod_sampledata (3.8.0) 1 | mod_title (3.0.0) 1 | mod_submenu (3.0.0) 1 | mod_stats_admin (3.0.0) 1 | mod_privacy_dashboard (3.9.0) 1 | mod_latestactions (3.9.0) 1 | mod_login (3.0.0) 1 | mod_latest (3.0.0) 1 | mod_feed (3.0.0) 1 | mod_logged (3.0.0) 1 | mod_menu (3.0.0) 1 | mod_custom (3.0.0) 1 | mod_quickicon (3.0.0) 1 | mod_toolbar (3.0.0) 1 | mod_version (3.0.0) 1 | mod_multilangstatus (3.0.0) 1 |
3rd Party:: K2 Stats (admin) (2.9.0) 1 | mod_sppagebuilder_icons (1.0.2) 1 | K2 Quick Icons (admin) (2.9.0) 1 | mod_sppagebuilder_admin_menu (1.3) 1 |

Libraries ::
Core ::
3rd Party:: file_fof30 (3.4.4) ? |

Plugins ::
Core :: plg_extension_joomla (3.0.0) 1 | plg_privacy_actionlogs (3.9.0) 1 | plg_privacy_consents (3.9.0) 1 | plg_privacy_content (3.9.0) 1 | plg_privacy_user (3.9.0) 1 | plg_privacy_message (3.9.0) 1 | plg_quickicon_joomlaupdate (3.0.0) 1 | plg_quickicon_phpversioncheck (3.7.0) 1 | plg_quickicon_privacycheck (3.9.0) 1 | plg_quickicon_extensionupdate (3.0.0) 1 | plg_authentication_gmail (3.0.0) 0 | plg_authentication_ldap (3.0.0) 0 | plg_authentication_joomla (3.0.0) 1 | plg_authentication_cookie (3.0.0) 1 | plg_content_confirmconsent (3.9.0) 0 | plg_content_pagebreak (3.0.0) 1 | plg_content_loadmodule (3.0.0) 1 | plg_content_emailcloak (3.0.0) 1 | plg_content_joomla (3.0.0) 1 | plg_content_vote (3.0.0) 0 | plg_content_pagenavigation (3.0.0) 1 | plg_content_fields (3.7.0) 1 | plg_content_finder (3.0.0) 0 | PLG_ACTIONLOG_JOOMLA (3.9.0) 1 | plg_captcha_recaptcha_invisible (3.8) 0 | plg_captcha_recaptcha (3.4.0) 1 | plg_search_contacts (3.0.0) 1 | plg_search_content (3.0.0) 1 | plg_search_newsfeeds (3.0.0) 1 | plg_search_categories (3.0.0) 1 | plg_search_tags (3.0.0) 1 | plg_system_highlight (3.0.0) 1 | plg_system_sef (3.0.0) 1 | plg_system_debug (3.0.0) 1 | plg_system_cache (3.0.0) 0 | PLG_SYSTEM_ACTIONLOGS (3.9.0) 1 | plg_system_languagefilter (3.0.0) 0 | plg_system_stats (3.5.0) 1 | plg_system_sessiongc (3.8.6) 1 | plg_system_languagecode (3.0.0) 0 | plg_system_logrotation (3.9.0) 1 | plg_system_logout (3.0.0) 1 | plg_system_updatenotification (3.5.0) 1 | plg_system_log (3.0.0) 1 | plg_system_fields (3.7.0) 1 | plg_system_p3p (3.0.0) 1 | plg_system_redirect (3.0.0) 1 | plg_system_privacyconsent (3.9.0) 0 | plg_system_remember (3.0.0) 1 | plg_twofactorauth_totp (3.2.0) 0 | plg_twofactorauth_yubikey (3.2.0) 0 | plg_user_contactcreator (3.0.0) 0 | plg_user_terms (3.9.0) 0 | plg_user_profile (3.0.0) 0 | plg_user_joomla (3.0.0) 1 | plg_installer_webinstaller (2.0.1) 1 | plg_installer_packageinstaller (3.6.0) 1 | PLG_INSTALLER_URLINSTALLER (3.6.0) 1 | PLG_INSTALLER_FOLDERINSTALLER (3.6.0) 1 | plg_editors-xtd_pagebreak (3.0.0) 1 | plg_editors-xtd_menu (3.7.0) 1 | plg_editors-xtd_readmore (3.0.0) 1 | plg_editors-xtd_article (3.0.0) 1 | plg_editors-xtd_module (3.5.0) 1 | plg_editors-xtd_fields (3.7.0) 1 | plg_editors-xtd_image (3.0.0) 1 | plg_fields_integer (3.7.0) 1 | plg_fields_repeatable (3.9.0) 1 | plg_fields_textarea (3.7.0) 1 | plg_fields_editor (3.7.0) 1 | plg_fields_color (3.7.0) 1 | plg_fields_media (3.7.0) 1 | plg_fields_usergrouplist (3.7.0) 1 | plg_fields_imagelist (3.7.0) 1 | plg_fields_text (3.7.0) 1 | plg_fields_list (3.7.0) 1 | plg_fields_user (3.7.0) 1 | plg_fields_url (3.7.0) 1 | plg_fields_calendar (3.7.0) 1 | plg_fields_radio (3.7.0) 1 | plg_fields_checkboxes (3.7.0) 1 | plg_fields_sql (3.7.0) 1 | plg_finder_contacts (3.0.0) 1 | plg_finder_content (3.0.0) 1 | plg_finder_newsfeeds (3.0.0) 0 | plg_finder_categories (3.0.0) 1 | plg_finder_tags (3.0.0) 0 |
3rd Party:: plg_quickicon_akeebabackup (6.6.0) 1 | Josetta - K2 Items (2.6.9) 1 | Josetta - K2 Categories (2.6.9) 1 | plg_content_cdajaxvote (2.5.x.2.0.3) 1 | PLG_ACTIONLOG_AKEEBABACKUP (6.6.0) 1 | plg_editors_tinymce (4.5.11) 1 | plg_editors_codemirror (5.40.0) 1 | plg_search_sppagebuilder (1.5) 1 | plg_search_advportfoliopro (3.8.2) 0 | Search - K2 (2.9.0) 1 | sysbreezingforms (1.0.0) 1 | System - SP PageBuilder (1.3) 1 | System - Helix3 Framework (2.5.6) 1 | System - SP Cookie Consent (1.0.0) 0 | PLG_SYSTEM_AKEEBAUPDATECHECK (6.6.0) 1 | plg_system_extstore_update_helper (1.0.0) 1 | System - K2 (2.9.0) 1 | System - Helix Ultimate Framework (1.1.1) 1 | PLG_SYSTEM_BACKUPONUPDATE (6.6.0) 1 | System - SP Page Builder Pro Update (1.1) ? | User - K2 (2.9.0) 1 | Helix3 - Ajax (2.5.6) 1 | plg_finder_sppagebuilder (1.6) 1 | plg_finder_advportfoliopro (3.8.2) 0 | plg_finder_k2 (2.9.0) 0 |
Templates Discovered :: wrote:Templates :: SITE :: beez3 (3.1.0) ? | lt_start_up (1.0) 1 | protostar (1.0) ? | revised (1.1.1) 1 | beez3 (3.1.0) ? | shaper_helixultimate (1.1.1) 1 |
Templates :: ADMIN :: hathor (3.0.0) 1 | isis (1.0) 1 | isis3 (3.4.2) 1 | adminim (1.0) 1 |
Last edited by toivo on Wed Oct 09, 2019 1:15 am, edited 1 time in total.
Reason: mod note: disabled smilies in post Options for readability

moozarkgrl
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Fri Jul 18, 2014 5:22 pm

Re: My back end template changed to Hathor

Post by moozarkgrl » Tue Oct 08, 2019 8:42 pm

sozzled wrote:
Tue Oct 08, 2019 5:39 pm
I don't know anything about the templates called Isis3 or Adminim, sorry. It looks like your website needs some work. There is a feature in the Joomla! Update component that allows you to re-install the current version of Joomla you are using (and that may be something worth considering).

I don't know what is the problem here. It may be worth running the Forum Post Assistant and posting the report here on the forum.

It's very strange.
Isis3 is just another copy of the Isis template from Joomla installation files.
One day it just started appearing this way.

moozarkgrl
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Fri Jul 18, 2014 5:22 pm

Re: My back end template changed to Hathor

Post by moozarkgrl » Tue Oct 08, 2019 8:47 pm

I already have the current version 3.98 so I don't have the update option.

How would you reinstall the same version?

User avatar
sozzled
Joomla! Exemplar
Joomla! Exemplar
Posts: 8009
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: My back end template changed to Hathor

Post by sozzled » Tue Oct 08, 2019 8:47 pm

There are a few peculiarities here (as I suspected) and I'm not sure where to begin with them at the moment. Obviously, the PHP message "PHP Startup: Unable to load dynamic library ..." is something to look closer at. Someone else may have some clues for this. There's probably something odd going on with the database. If you could, I would uninistall the two templates you've added—the ones I know nothing about—and see what happens after that.

I would also suggest running Extensions » Discover to see what it detects.
https://www.kuneze.com/blog
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

User avatar
sozzled
Joomla! Exemplar
Joomla! Exemplar
Posts: 8009
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: My back end template changed to Hathor

Post by sozzled » Tue Oct 08, 2019 8:49 pm

moozarkgrl wrote:
Tue Oct 08, 2019 8:47 pm
I already have the current version 3.98 so I don't have the update option.
J! 3.9.12 is the current version. You can that question to your list of problems to resolve as well.
https://www.kuneze.com/blog
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

moozarkgrl
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Fri Jul 18, 2014 5:22 pm

Re: My back end template changed to Hathor

Post by moozarkgrl » Thu Oct 10, 2019 12:40 pm

Discover only shows the Beez and Protostar templates. However, when I checked the database tab it showed this:

Database schema version (3.9.8-2019-06-11) does not match CMS version (3.9.10-2019-07-09).
Table 'chdg4_template_styles' should not have index 'idx_home'. (From file 3.9.8-2019-06-15.sql.)
Table 'chdg4_template_styles' does not have index 'idx_client_id'. (From file 3.9.8-2019-06-15.sql.)
Table 'chdg4_template_styles' does not have index 'idx_client_id_home'. (From file 3.9.8-2019-06-15.sql.)

and More Information:

Database schema version (in #__schemas): 3.9.8-2019-06-11.
Update version (in #__extensions): 3.9.8.
Database driver: mysqli.
169 database changes were checked.
211 database changes did not alter table structure and were skipped.

Under Warnings:

The PHP temporary folder is the folder that PHP uses to store an uploaded file before Joomla can access this file. Whilst the folder not being set isn't always a problem, if you are having issues with manifest files not being detected or uploaded files not being detected, setting this in your php.ini file might fix the issue.

You're right, 3.9.12 is the latest, but not showing up as an update. It states that I have the current version.

This is a new client site I'm taking over. From my limited knowledge, it looks like they were at 3.9.10, had some problems and then restored a backup made at 3.9.8? The rest of the site is looking great.

Can you point me to a post that explains how I can upload a newer version. I've always used update.

This is a new client site I'm taking over. From my limited knowledge, it looks like they were at 3.9.10, had some problems and then restored a backup made at 3.9.8? The rest of the site is looking great.

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 11455
Joined: Thu Feb 15, 2007 5:48 am
Location: Suzhou, China

Re: My back end template changed to Hathor

Post by toivo » Thu Oct 10, 2019 3:28 pm

How did your client restore the backup made at 3.9.8? The correct way starts with deleting all the files from the main Joomla folder and dropping the database schema, and then restoring the file system and the database from a full backup. There are several ways to do that, but the Kickstart utility from Akeeba Backup is very popular with webmasters.

The difference in your database schema indicate that your client did not restore the site or run Joomla! Update.

Using the Joomla! Update is the correct way to update the site to a newer version. However, in this case it is best to restore the site first to a consistent version.
Toivo Talikka, Global Moderator

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 26121
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: My back end template changed to Hathor

Post by Per Yngve Berg » Thu Oct 10, 2019 4:52 pm

Back to the original issue: Have you checked that the user have not selected a specific admin template in it's user profile?

User avatar
sozzled
Joomla! Exemplar
Joomla! Exemplar
Posts: 8009
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: My back end template changed to Hathor

Post by sozzled » Thu Oct 10, 2019 5:23 pm

You're brilliant, @Per!

I never realised that you can define which backend template is used on a per-user basis! You learn something everyday.

The attached screenshot illustrates the setting. This could be the solution that has been eluding us! :)
You do not have the required permissions to view the files attached to this post.
https://www.kuneze.com/blog
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

moozarkgrl
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Fri Jul 18, 2014 5:22 pm

Re: My back end template changed to Hathor

Post by moozarkgrl » Thu Oct 10, 2019 5:34 pm

Per Yngve Berg wrote:
Thu Oct 10, 2019 4:52 pm
Back to the original issue: Have you checked that the user have not selected a specific admin template in it's user profile?
You are totally right. That rectified the backend template problem! Yeah, thank you!

In regard to the database issues and the fact that 3.9.12 upgrade available doesn't come up, would uploading the upgrade package fix those errors as well?

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 26121
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: My back end template changed to Hathor

Post by Per Yngve Berg » Thu Oct 10, 2019 5:57 pm

Use Components->Joomla Update->Upload and update

User avatar
AMurray
Joomla! Champion
Joomla! Champion
Posts: 5026
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: My back end template changed to Hathor

Post by AMurray » Thu Oct 10, 2019 11:14 pm

Clear the cache in joomla and your browser cache, and under JOomla update options, check you're using the "default" update channel, as there are several others available (e.g. one for testing Joomla 4.0 etc). "Default" is the one that should fetch the latest 3.9.x version.
Regards,
--------------------------------------------------------------
A Murray
Millennium Falcon - it's the ship that made the Kessel run in less than 12 parsecs! The fastest hunk of junk in the galaxy.

moozarkgrl
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Fri Jul 18, 2014 5:22 pm

Re: My back end template changed to Hathor

Post by moozarkgrl » Sat Oct 12, 2019 6:19 pm

Thank you to everyone who helped me with this! Even though it wasn't picking up the latest version on the update channel, I uploaded the upgrade and everything went very smoothly. Database problems are gone too.


Post Reply

Return to “General Questions/New to Joomla! 3.x”