Media Files Not Loading on Addon Website`

General questions relating to Joomla! 3.x.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10
Post Reply
MikeK223
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu Mar 26, 2020 1:23 am

Media Files Not Loading on Addon Website`

Post by MikeK223 » Thu Mar 26, 2020 10:23 pm

Hi,

I need some help pointing a video player placed in an article to load a video file in a folder on my website.

I have a Shape5 Joomla 3.9.16 template installed on an addon domain (www.addon.com) I use with my main account www.mainaccount.com.

I can’t get the S5 Media player in an article to load the video file.

S5 Media player instructions say to insert:

{s5_media_player media=[video] download=[disabled]
[video_mov=[http://www.mysite.com/media/video/video.mov]

This is from the Shape5 Media Player demo article in the template demo which I have added to my article which does load and play:
{s5_media_player media=[video] download=[disabled] video_mp4=[http://www.shape5.com/demo/media/video1.mp4]}

This is the CPanel folder location of my Addon website:

public_html/AddonCOM

This is the CPanel folder location of the video file I am trying to access:

public_html/AddonCOM/Sermons/2020-Video/2020-03-22-09-31-40-Live.MOV

This is the address of the article on my website: http://Addon.com/index.php/watchlisten/watch

I have tried many variations to get the player to point to the video file including:

{s5_media_player media=[video] download=[disabled] video_mov=[http://www.MainDomain.com/AddonCOM/Serm ... 0-Live.MOV]}

{s5_media_player media=[video] download=[disabled] video_mov=[http://www.Addon.com/Sermons/2020-video ... 0-Live.MOV]}

The video player appears in the article, but the video doesn't load.


How do I point the player to the video file?

Could there possibly be something at Hostmonster.com that prevents and addon domain from pointing at a video/audio file?

Mike

 
User avatar
AMurray
Joomla! Champion
Joomla! Champion
Posts: 5515
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Media Files Not Loading on Addon Website`

Post by AMurray » Fri Mar 27, 2020 9:49 am

Is www.addon.com or www.mainaccount.com your actual sites (or just "dummy" domain names for the purpose of your question) since both are actual live websites.....
Regards,
--------------------------------------------------------------
A Murray
Millennium Falcon - it's the ship that made the Kessel run in less than 12 parsecs! The fastest hunk of junk in the galaxy.

User avatar
AMurray
Joomla! Champion
Joomla! Champion
Posts: 5515
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Media Files Not Loading on Addon Website`

Post by AMurray » Fri Mar 27, 2020 9:52 am

www.mysite.com is also an actual site - for a web hosting company!.

When you are talking about your own sites, it's best to actually provide *your* site's domain name links.
Regards,
--------------------------------------------------------------
A Murray
Millennium Falcon - it's the ship that made the Kessel run in less than 12 parsecs! The fastest hunk of junk in the galaxy.

MikeK223
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu Mar 26, 2020 1:23 am

Re: Media Files Not Loading on Addon Website`

Post by MikeK223 » Fri Mar 27, 2020 2:34 pm

I'm new to this.

My Hostmonster main account is www.(myname).com

There is no website installed on www,(myname).com. I set up the Hostmoster account long ago with www.(myname).com but I don't run a website for that domain. I have created websites as addon domains on this account.

The addon site is www.fbcfalun.com. It's a new website that is up and running, except for loading video and audio files. (These are the only files I have tried to insert into articles so far).

CPanel folder location www,.fbcfalun.com website:
public_html/FBCFalunCOM

CPanel folder location of the video file:
public_html/FBCFalunCOM/Sermons/2020-Video/2020-03-22-09-31-40-Live.MOV

Article website address:
http://www.fbcfalun.com/index.php/watch ... aged-video

There are three videos in the article. The code for the first two are different ways I've tried to get the video to load. The the code for the third video points to another website and does load the video.

Video player code placed in the article:

{s5_media_player media=[video] download=[disabled] video_mov=[http://www.fbcfalun.com/Sermons/2020-vi ... 0-Live.MOV]}

{s5_media_player media=[video] download=[disabled] video_mov=[http://www.(myname).com/FBCFalunCOM/Sermons/2020-video/2020-03-22-09-31-40-Live.MOV]}

{s5_media_player media=[video] download=[disabled] video_mp4=[http://www.shape5.com/demo/media/video1.mp4]}


(The file from Shape5 is an .mp4 file. The files on my site are .mov files. I have tried loading .mp4 and .mp3 files from my site and they haven't worked.)

Mike

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 26611
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Media Files Not Loading on Addon Website`

Post by Per Yngve Berg » Fri Mar 27, 2020 2:41 pm

The All Videos Plugin usually works.

https://extensions.joomla.org/extension/allvideos/

Be aware that if the video is hosted on your site, the video in it's entire length have to be downloaded before play starts. Only a streaming server (not a web server) can stream.

MikeK223
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu Mar 26, 2020 1:23 am

Re: Media Files Not Loading on Addon Website`

Post by MikeK223 » Fri Mar 27, 2020 5:56 pm

I've done some experimenting.

1) I created a folder (videos) and placed it here: public_html/videos
2) Placed two mp4 videos in that folder.
3) Created a new article and added the code for the Shape5 video players as follows:

{s5_media_player media=[video] download=[disabled] video_mp4=[http://www.(myname).com/videos/2020-03-22-FBCFalun-Service-Strong, Secure, Engaged.mp4]}

{s5_media_player media=[video] download=[disabled] video_mp4=[https://www.(myname).com/videos/heaven_and_earth.mp4]}

And the video files load and play.

So they won't play when they are pointed at public_html/FBCFalunCOM/Sermons/2020-Video/
but they will play when they are pointed at public_html/videos

I could just place all my video and audio content there, but I want to keep my file better organized than that.

Mike

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 26611
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Media Files Not Loading on Addon Website`

Post by Per Yngve Berg » Sat Mar 28, 2020 8:08 am

I cannot see why is will not work if the letter casing is correct.

 

Post Reply

Return to “General Questions/New to Joomla! 3.x”