500 error on Joomla admin login

General questions relating to Joomla! 2.5. Note: All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5. There are other boards for more specific help on Joomla! features and extensions.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
Post Reply
DJNickAnnies
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Tue Jun 30, 2020 9:35 am

500 error on Joomla admin login

Post by DJNickAnnies » Tue Jun 30, 2020 9:52 am

We have some sites hosted with Siteground, and one of these sites has an issue with the admin login. The site in question is http://www.kingstown.uk.com/

When logging in the return simply goes to a 500 error page. I had read the forums and support notes to try and resolve this but nothing is working - folder permissions, changing the admin password via phpMyAdmin etc. It's a corporate site that I need to make urgent changes to but I simply cannot get access. Does anyone have any ideas?

Any help would be greatly appreciated.

Many Thanks

Nick

 
DJNickAnnies
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Tue Jun 30, 2020 9:35 am

Re: 500 error on Joomla admin login

Post by DJNickAnnies » Tue Jun 30, 2020 11:02 am

Quick update. After Siteground did some tweaking the login now just folds back to the blank login, in a loop. So it does not give a 500 error but still won't allow me to login still. Siteground say that because they feel it is not a server error but a software error they can offer no further support, which is just about as unhelpful as you can get - clearly not willing to help, even though they claim to be a good Joomla host. Support is support, not in their eyes I guess...

User avatar
abernyte
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3883
Joined: Fri May 15, 2009 2:01 pm
Location: Écosse - Scozia - Escocia - Škotija -स्कॉटलैंड

Re: 500 error on Joomla admin login

Post by abernyte » Tue Jun 30, 2020 1:25 pm

That URL is displaying fine for me on Brave, Firefox and Palemoon. Is the blank page after the admin login?
If yes that is probably a PHP error. Has the php version been changed recently? You do realise that you are running on Joomla 2.5.19. It is over 7 years old and will have very out of date extensions which can also be the cause.
What we obtain too cheap, we esteem too lightly…Thomas Paine

DJNickAnnies
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Tue Jun 30, 2020 9:35 am

Re: 500 error on Joomla admin login

Post by DJNickAnnies » Tue Jun 30, 2020 1:35 pm

Hi there,

It only happens when you enter the login details and try to login. I might just rebuild the site if it's on a really old version. Thanks for your help...

User avatar
sozzled
Joomla! Exemplar
Joomla! Exemplar
Posts: 9560
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: 500 error on Joomla admin login

Post by sozzled » Tue Jun 30, 2020 8:42 pm

We don't usually have a lot to say about websites built with J! 2.5. You can draw your own conclusions from that.
DJNickAnnies wrote:
Tue Jun 30, 2020 1:35 pm
I might just rebuild the site if it's on a really old version.
What do you mean if it's a really old version? Where have you been?

I suggest you read General help: HTTP 500 Internal Server Errors. Even though that item relates to J! 3.x, the advice in it is good for any version of Joomla. That's the first step in understanding a few things about your problem.

Apart from these things, good luck. 8)
https://www.kuneze.com/blog
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

DJNickAnnies
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Tue Jun 30, 2020 9:35 am

Re: 500 error on Joomla admin login

Post by DJNickAnnies » Wed Jul 01, 2020 10:45 am

Haha, sorry, I was one of the original members of the Mambo/Joomla team, but it's been EONs since I have used it, "power in simplicity" very quickly became "confusion in complexity" so I've never used it again. You can find me here in the roster: https://www.joomla.org/about-joomla/hon ... nnies.html

I actually came up with the original Mambo asterisk logo and worked on the icons for the CMS etc...now it just gives me headaches.

 

Post Reply

Return to “General Questions/New to Joomla! 2.5”