[Solved] WYSIWYG editor errors in Internet Explorer

Need help with a WYSIWYG-editor in Joomla! 1.0.x? This is the place to be.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
User avatar
chay
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 175
Joined: Wed Aug 17, 2005 11:20 pm
Location: Alaska
Contact:

[Solved] WYSIWYG editor errors in Internet Explorer

Post by chay » Sun Oct 02, 2005 4:13 am

I got mosCE working with Firefox, but encountered errors using Internet Explorer.  Couldn't figure it out, so tried Fck editor (gotta love that name!), and tinyMCe and mosCE 1.03.  With all of them I had variations of the same problem.  Styles didn't come up, the text area box wouldn't take my cursor, or in Fck editor the text area box wouldn't show, the page wouldn't save or cancel, and I was getting error messages from the browser.  Then, at http://www.netshinesoftware.com/mambo-t ... ooter.html I found this:
1) Problem:  HTML Editor (eg. TinyMCE) Unresponsive
Description:  Sometimes, you find that you cannot enter text into the HTML editor, or click on the HTML editor's toolbar buttons - you are locked out of editing your content!

Possible Cause(s):  This is usually a problem with javascript permissions.  Javascript can only work in a single 'domain', so if resources are required from more than 1 domain to do a job, javascript applications such as HTML editors can crash.  The most common reason why HTML editors in mambo try to access resources from more than one domain is that the user tries to access the page without using "www." before the domain name (or, it could be that you are trying to access the page with the "www." but shouldn't be).  For example, usually http://mydomain.com/administrator is wrong.  It should be http://www.mydomain.com/administrator.

Resolution:  Whether or not to use "www." depends on the settings in your configuration.php file.  Go to Site->Global Configuration (from the main menu in Mambo), click on the Server tab, and check the 'Live Site' setting.  If the live site setting includes www. then you must use www. when accessing mambo administrator.  If live site does not include www. then you must not use www. when accessing mambo administrator.

If this does not solve your problem, a good place to start troubleshooting is to check for javascript errors.  In IE6, a little yellow icon appears in the bottom left of your browser when a javascript error occurs - double-click on it to see the error message.  In Firefox, click on Tools->JavaScript Console for a list of the errors.
I changed my menu links to match config; problem solved.
Last edited by rjs on Sun Nov 27, 2005 6:57 pm, edited 1 time in total.

User avatar
Soren Jensen
Joomla! Explorer
Joomla! Explorer
Posts: 290
Joined: Fri Nov 11, 2005 8:53 am
Location: Granada, Spain
Contact:

Re: [Solved] WYSIWYG editor errors in Internet Explorer

Post by Soren Jensen » Fri Nov 25, 2005 9:41 am

Thank you for posting this!

I had this exact error on a clean Joomla install from Fantastico scripts.

$mosConfig_live_site is set to "domain.com" and not "www.domain.com" so this will potentially create this problem for all fantastico script users?
Soren Beck Jensenhttp://www.component-creator.com/ - Build Joomla Components fast and easy

eyerouge
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Fri Nov 25, 2005 5:24 pm

Re: [Solved] WYSIWYG editor errors in Internet Explorer

Post by eyerouge » Wed Nov 30, 2005 6:30 am

Had no idea about the lameness of the Java. So how am I supposed to solve my problem: I have my site hosted at http://y.com and get there by redirecting/url-forwarding users inside a frame from http://x.com?

Please tell me that I don't need to buy another host and all that, or that there's some editor that actualy can handle this.

*fingers crossed*

User avatar
PeterC
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Mon Oct 10, 2005 1:45 pm
Location: West Midlands
Contact:

Re: [Solved] WYSIWYG editor errors in Internet Explorer

Post by PeterC » Wed Nov 30, 2005 8:36 pm

How mad is that?

Strange thing is I used Fantastico to install Joomla, while I'm no expert I was thinking it was something to do with Fantastico and was preparing to kill my site and re-install!

I've just given it a quick try dropping the www. and hey presto everything works  :D

Thanks a million chay

What a nice Christmas present.
--
There is every excuse for not knowing
There is no excuse for not asking!

jeffhoneyager
Joomla! Intern
Joomla! Intern
Posts: 92
Joined: Fri Dec 16, 2005 12:16 am
Location: Michigan
Contact:

NOT Solved !!! - WYSIWYG editor errors in Internet Explorer

Post by jeffhoneyager » Fri Dec 16, 2005 12:22 pm

I've had the same problem and was delighted to see these posts.

I changed my configuration.php in the $mosConfig_live_site to include the www then expected to have joy.

No Joy.

It still has the same problem - no content, no editor in FE or BE.

What now?
Peace & Joy, Jeff Honeyager
http://ExpertWebProfessionals.com
http://Jeff.honeyager.com
"Test Everything, Hold On To The Good."

fulltilt
Joomla! Explorer
Joomla! Explorer
Posts: 425
Joined: Thu Sep 01, 2005 1:27 pm
Location: Sydney, Australia
Contact:

Re: [Solved] WYSIWYG editor errors in Internet Explorer

Post by fulltilt » Fri Dec 16, 2005 1:41 pm

Remember that the URL in your browser must match ;)

I had found that fix recently, although the problem dogged me for months, but I didn't realise that other people had the same problem and didn't know about a solution.

I just figured it out because sometimes it would work, and sometimes not.

jeffhoneyager
Joomla! Intern
Joomla! Intern
Posts: 92
Joined: Fri Dec 16, 2005 12:16 am
Location: Michigan
Contact:

Re: [Solved] WYSIWYG editor errors in Internet Explorer

Post by jeffhoneyager » Fri Dec 16, 2005 7:24 pm

Yup the FF url matches the live site config. variable... and still no content, now editor.

I'm really confused.  It was working for a while, then poof.  I'm about ready to make 3 sites live.

What do I do?

Why does this WYSIWYG editor work?

Look ma I can bold!

Can I use this editor?  Where is it?  Will it work?

---- interesting ----

I just created a wrapper type new main menu item and added the url http://www.mapbuilder.net to it.

In FF I went to the site and could use its editor without any problems.

When I added it as a wrapper menu item, the editor went away while in the FE of Joomla!

What is specific about Joomla that eradicates the editor?

Should I go back to Mambo?

Thanks
Jeff
Last edited by jeffhoneyager on Fri Dec 16, 2005 8:32 pm, edited 1 time in total.
Peace & Joy, Jeff Honeyager
http://ExpertWebProfessionals.com
http://Jeff.honeyager.com
"Test Everything, Hold On To The Good."

User avatar
netshine
Joomla! Explorer
Joomla! Explorer
Posts: 430
Joined: Thu Aug 18, 2005 9:19 am
Location: Peterborough, UK
Contact:

Re: [Solved] WYSIWYG editor errors in Internet Explorer

Post by netshine » Tue Dec 27, 2005 11:56 am

Hiya,

I'm the guy who wrote the troubleshooter page mentioned above - glad you found it helpful!  :D

I am now having the same problem as jeffhoneyager!  I upgraded two sites from mambo to joomla, and now wysiwyg editors do not appear at all - just a textarea instead.  Naturally I have checked that the correct mambot is published etc etc, and I have tried several different editors - none of them work.

I can only assume therefore that this is caused by upgrading from mambo to joomla (I just copied the joomla files over the top of the mambo ones - worked pretty well for most things).  Will post back here if I find a solution.

jeffhoneyager
Joomla! Intern
Joomla! Intern
Posts: 92
Joined: Fri Dec 16, 2005 12:16 am
Location: Michigan
Contact:

Re: [Solved] WYSIWYG editor errors in Internet Explorer

Post by jeffhoneyager » Tue Dec 27, 2005 12:09 pm

Understanding a application/system problem requires that the conditions and errors must be reproducible to locate a problem and fix them.  This problem seems to pop up :( randomly.

Latest - my wysiwyg editor is back - then its gone - then its back!  Fortunately, its more back than not...

When I cleared my FF cache and made is only 5mb, the problem seemed to occur less frequently.  Of course I putzed around with a lot of settings I thought might affect java, so it could have been something else.  In fact when I get the error, I usually clear all my settings in FF and restart it.

I think asking users to mess with their browser settings in order to join our Joomla site is a non-starter.

I have only experienced this type of problem within Joomla.  What is so unique?  How can it be changed to NOT be so unique?

Thanks for the discourse
Jeff
Peace & Joy, Jeff Honeyager
http://ExpertWebProfessionals.com
http://Jeff.honeyager.com
"Test Everything, Hold On To The Good."

User avatar
netshine
Joomla! Explorer
Joomla! Explorer
Posts: 430
Joined: Thu Aug 18, 2005 9:19 am
Location: Peterborough, UK
Contact:

Re: [Solved] WYSIWYG editor errors in Internet Explorer

Post by netshine » Tue Dec 27, 2005 12:12 pm

Ok, I have found the problem for my site.  There is a new line in configuration.php for Joomla which was not there for mambo.  I simply added the following line to the end of configuration.php, and hey presto:

$mosConfig_editor = 'tinymce';

I'm not convinced that this is the same problem as jeffhoneyager though, as for me it was consistent and reproducible.  If you have a debugger (eg. Zend development environment), try stepping through the code in editors/editor.php - that's what revealed the problem for me.

jeffhoneyager
Joomla! Intern
Joomla! Intern
Posts: 92
Joined: Fri Dec 16, 2005 12:16 am
Location: Michigan
Contact:

Re: [Solved] WYSIWYG editor errors in Internet Explorer

Post by jeffhoneyager » Tue Dec 27, 2005 12:30 pm

Here is an inconsistency:

From adimistrator | System | System Info

The Relevant PHP Settings reported
WYSIWYG Editor:  No WYSIWYG Editor

The Configuration File section displayed this
$mosConfig_editor = 'tmedit';

From administrator | Site
Default WYSIWYG Editor:  TMEdit

My configuration.php file has
$mosConfig_editor = 'tinymce'

I would think they should all have only one entry.  This seems like an inconsistency waiting to become a problem.

Which should I change - at this point I don't know which one is being used?  I'll try one and report back.
Peace & Joy, Jeff Honeyager
http://ExpertWebProfessionals.com
http://Jeff.honeyager.com
"Test Everything, Hold On To The Good."

User avatar
zoiudo
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Wed Nov 23, 2005 6:58 pm
Location: Valencia (Spain)
Contact:

Re: [Solved] WYSIWYG editor errors in Internet Explorer

Post by zoiudo » Thu Jan 26, 2006 9:35 am

netshine wrote: Ok, I have found the problem for my site.  There is a new line in configuration.php for Joomla which was not there for mambo.  I simply added the following line to the end of configuration.php, and hey presto:

$mosConfig_editor = 'tinymce';

I'm not convinced that this is the same problem as jeffhoneyager though, as for me it was consistent and reproducible.  If you have a debugger (eg. Zend development environment), try stepping through the code in editors/editor.php - that's what revealed the problem for me.
Same overall problem here: WSYIWYG editors not working, both in IE 6 and in FF 1.5, with Joomla 1.0.7
As superadmin, my editor setting in the user manager is the same as in Site > Global configuration > WYSIWYG editor and the same as in the config.php file. I have tried with mosCE, TinyMCE and JoomlaFCK
My Live Site says http://cnespana.com. However, when I access http://cnespana.com/administrator with my browser, I am redirected to http://www.cnespana.com/administrator. Thus, I cannot check for validity the solution proposed in this thread.
I have also tried to change my Live Site URL to http://www.cnespana.com, but for some reason changes are not kept in the configuration.php file.
What else can I try? I am determined to get it working!!! ;D
--
Miguel Tito Malone 'Zoi'

User avatar
zoiudo
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Wed Nov 23, 2005 6:58 pm
Location: Valencia (Spain)
Contact:

Re: [Solved] WYSIWYG editor errors in Internet Explorer

Post by zoiudo » Thu Jan 26, 2006 11:01 am

Well, you never cease to learn  :-[

My solution was as simple as: 1) make configuration.php writeable, 2) change live site configuration from mydomain.com to http://www.mydomain.com 3) have your (any) WYSIWYG editor working, both frontend and backend.

I was somehow scared that changing the live site configuration could have baad side effects, but for the moment it doesn't look like that.

Sorry for the trouble!

Zoi
--
Miguel Tito Malone 'Zoi'

guiguy
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Sep 02, 2005 7:49 am

Re: NOT Solved !!! - WYSIWYG editor errors in Internet Explorer

Post by guiguy » Thu Nov 23, 2006 7:49 pm

Another thing to look at is the virtual host settings, if you have access to that.

For me nothing worked until I looked at httpd.conf and saw that the primary virtual host was domain.com and the alias was http://www.domain.com


Reversed that and the problem seems to have gone away....  until next time


Locked

Return to “WYSIWYG Editors - 1.0.x”