Backend admin login leading to 404 error page Topic is solved

Need help with the Administration of your Joomla! 3.x site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
sino27
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Mon May 10, 2021 7:49 am

Backend admin login leading to 404 error page

Post by sino27 » Mon May 10, 2021 8:07 am

Hello everyone,

I tried usual suspects, googling and whatever I could find.

Also I have used search on this forum and tried some things but it didn't helped well at least for the topics that I have read. So I am hitting a wall here and decided that at this point it's best I ask experts.

The frontend of my website is working fine but when I enter my backend admin login address, I get directed to an 404 error page.

Here is what changed.

I changed from

https://mysite.com
to
http://subdomain.mysite.com

Then I moved all content from domain root folder (https://mysite.com ) to my custom folder named "joomla". Also I pointed my subdomain (http://subdomain.mysite.com) to that newly created folder (joomla).

On subdomain I don't have SSL and I don't need it. I wanted to keep my Joomla for archive purpose. And as I said, frontend is working normally I just can't access backend administrator

http://subdomain.mysite.com/administrator - is resulting in 404
http://subdomain.mysite.com/ - works fine, menus are working fine, articles are there. Everything appear as normal. Just backend is not working.

So I tried with editing configuration.php and by that I mean I changed "public $force_ssl" from value 2 to 0. But that didn't helped. Cache folder is empty.

I tried with removing .htaccess file but that didn't helped. I restored it back.

At this point I am stuck. I think it's something in my configuration.php or do I need to go to php.Myadmin and change something in database? I really need admin backend page to work again and I need to be able to login somehow.

I am attaching plugin folder structure screenshot, perhaps there is some extension I need to delete? At some point in time there was more people involved so perhaps someone installed something which need to be deleted?
plugins.jpg
EDIT: I forgot tot mention that every time I tried with FPA, after I upload it and try to access it I am getting this message:

As a security measure, this copy of FPA has been self-deleted due to the time it has been present on the server.
You will need to upload another copy of FPA to continue.


No matter how many times I reupload it, this is the message I am getting. I guess it's because I moved Joomla to another directory or something...
You do not have the required permissions to view the files attached to this post.
Last edited by sino27 on Mon May 10, 2021 8:14 am, edited 1 time in total.

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 10420
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Backend admin login leading to 404 error page

Post by sozzled » Mon May 10, 2021 10:27 pm

sino27 wrote:
Mon May 10, 2021 8:07 am
... every time I tried with FPA, after I upload it and try to access it I am getting this message:

As a security measure, this copy of FPA has been self-deleted due to the time it has been present on the server.
You will need to upload another copy of FPA to continue.


No matter how many times I reupload it, this is the message I am getting. I guess it's because I moved Joomla to another directory or something...
See viewtopic.php?f=806&p=3621748#p3621668 for the answer. :)
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)
Testing J! 3.10: https://sintranet.enduring.com.au

sino27
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Mon May 10, 2021 7:49 am

Re: Backend admin login leading to 404 error page

Post by sino27 » Tue May 11, 2021 6:20 am

sozzled wrote:
Mon May 10, 2021 10:27 pm
See viewtopic.php?f=806&p=3621748#p3621668 for the answer. :)
Yea it worked!! I will post screenshots here. Btw one user sent me an email asking to access. Saying this is .htaccess error. I don't think this is smart idea right? To provide him access.

Here is my .htaccess code - can anyone tell me is everything fine in .htaccess

Code: Select all


##
# @package    Joomla
# @copyright  Copyright (C) 2005 - 2016 Open Source Matters. All rights reserved.
# @license    GNU General Public License version 2 or later; see LICENSE.txt
##

##
# READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE!
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations.  It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that disallows changing it in
# your .htaccess file.  If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's.  If they work,
# it has been set by your server administrator and you do not need it set here.
##

## No directory listings
IndexIgnore *

## Can be commented out if causes errors, see notes above.
Options +FollowSymlinks
Options -Indexes

## Mod_rewrite in use.

RewriteEngine On

## Begin - Rewrite rules to block out some common exploits.
# If you experience problems on your site block out the operations listed below
# This attempts to block the most common type of exploit `attempts` to Joomla!
#
# Block out any script trying to base64_encode data within the URL.
RewriteCond %{QUERY_STRING} base64_encode[^(]*\([^)]*\) [OR]
# Block out any script that includes a <script> tag in URL.
RewriteCond %{QUERY_STRING} (<|%3C)([^s]*s)+cript.*(>|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL.
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL.
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
# Return 403 Forbidden header and show the content of the root homepage
RewriteRule .* index.php [F]
#
## End - Rewrite rules to block out some common exploits.

## Begin - Custom redirects
#
# If you need to redirect some pages, or set a canonical non-www to
# www redirect (or vice versa), place that code here. Ensure those
# redirects use the correct RewriteRule syntax and the [R=301,L] flags.
#
## End - Custom redirects

##
# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root).
##

RewriteBase /

## Begin - Joomla! core SEF Section.
#
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
#
# If the requested path and file is not /index.php and the request
# has not already been internally rewritten to the index.php script
RewriteCond %{REQUEST_URI} !^/index\.php
# and the requested path and file doesn't directly match a physical file
RewriteCond %{REQUEST_FILENAME} !-f
# and the requested path and file doesn't directly match a physical folder
RewriteCond %{REQUEST_FILENAME} !-d
# internally rewrite the request to the index.php script
RewriteRule .* index.php [L]
#
## End - Joomla! core SEF Section.



sino27
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Mon May 10, 2021 7:49 am

Re: Backend admin login leading to 404 error page

Post by sino27 » Tue May 11, 2021 6:21 am

Screenshots from FPA
01.jpg
02.jpg
03.jpg
04.jpg
05.jpg
You do not have the required permissions to view the files attached to this post.

User avatar
AMurray
Joomla! Champion
Joomla! Champion
Posts: 6876
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Backend admin login leading to 404 error page

Post by AMurray » Tue May 11, 2021 8:37 am

Sorry.....we can't read screenshots - please post the report's output as instructed on the FPA's website. It is formatted for this forum.

Your first screenshot, has a nice green button that says "Click here to general post"....so please do so :) :).
Regards - A Murray

sino27
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Mon May 10, 2021 7:49 am

Re: Backend admin login leading to 404 error page

Post by sino27 » Tue May 11, 2021 9:01 am

AMurray wrote:
Tue May 11, 2021 8:37 am
Sorry.....we can't read screenshots - please post the report's output as instructed on the FPA's website. It is formatted for this forum.

Your first screenshot, has a nice green button that says "Click here to general post"....so please do so :) :).
I don't understand why you can not read screenshots? They are screens with information on them. Not different then me writing info here.

And why you say "we?" You mean you have limited eyesight so device is reading for you or am I misunderstanding this (english is not my first language).

I checked all screenshots and they are readable.

Or perhaps my screenshots are disabled because I am new member here?

I am not that blind I saw that button and even generated report but I was afraid that it contain private data such as server hostname, IP address, usernames and so on. Is it safe to post report here? Genuinely asking before I do something stupid.

gws
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4309
Joined: Tue Aug 23, 2005 1:56 pm
Location: South coast, UK
Contact:

Re: Backend admin login leading to 404 error page

Post by gws » Tue May 11, 2021 9:39 am

Yes its safe,been done by thousands of users,when you post it properly you will see and understand the difference.

sino27
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Mon May 10, 2021 7:49 am

Re: Backend admin login leading to 404 error page

Post by sino27 » Tue May 11, 2021 10:10 am

gws wrote:
Tue May 11, 2021 9:39 am
Yes its safe,been done by thousands of users,when you post it properly you will see and understand the difference.
Ok then. I apologize for not posting it. I was reluctant because of many alerts on FPA page itself. Since I am new I thought better not to post it to not do something silly. Here is a result of my FPA:
Forum Post Assistant (v1.6.2) : 11-May-2021 wrote:
Basic Environment :: wrote:Joomla! Instance :: Joomla! 3.9.18-Stable (Amani) 21-April-2020
Joomla! Platform :: Joomla Platform 13.1.0-Stable (Curiosity) 24-Apr-2013
Joomla! Configured :: Yes | Writable (740) |
Configuration Options :: Offline: false | SEF: true | SEF Suffix: true | SEF ReWrite: true | .htaccess/web.config: Yes | GZip: false | Cache: false | CacheTime: 15 | CacheHandler: file | CachePlatformPrefix: false | FTP Layer: true | Proxy: false | LiveSite: | Session lifetime: 15 | Session handler: database | Shared sessions: false | SSL: 0 | Error Reporting: default | Site Debug: false | Language Debug: false | Default Access: 1 | Unicode Slugs: false | dbConnection Type: mysql | PHP Supports J! 3.9.18: Yes | Database Supports J! 3.9.18: Unknown | Database Credentials Present: Yes |

Host Configuration :: OS: Linux | OS Version: 3.18.114-pvops-xen-x64 | Technology: x86_64 | Web Server: Apache | Encoding: gzip, deflate | System TMP Writable: Yes | Free Disk Space : 111.86 GiB |

PHP Configuration :: Version: 7.3.23 | PHP API: cgi-fcgi | Session Path Writable: Yes | Display Errors: 1 | Error Reporting: 32759 | Log Errors To: | Last Known Error: | Register Globals: | Magic Quotes: | Safe Mode: | Allow url fopen: | Open Base: | Uploads: 1 | Max. Upload Size: 8M | Max. POST Size: 8M | Max. Input Time: -1 | Max. Execution Time: 300 | Memory Limit: 100M

Database Configuration :: Connection Error: User Privileges : Unknown
Detailed Environment :: wrote:PHP Extensions :: Core (7.3.23) | date (7.3.23) | libxml (7.3.23) | openssl (7.3.23) | pcre (7.3.23) | sqlite3 (7.3.23) | zlib (7.3.23) | bcmath (7.3.23) | bz2 (7.3.23) | calendar (7.3.23) | ctype (7.3.23) | curl (7.3.23) | dba (7.3.23) | dom (20031129) | hash (7.3.23) | fileinfo (7.3.23) | filter (7.3.23) | ftp (7.3.23) | gd (7.3.23) | gettext (7.3.23) | SPL (7.3.23) | iconv (7.3.23) | session (7.3.23) | intl (7.3.23) | json (1.7.0) | mbstring (7.3.23) | standard (7.3.23) | mysqlnd (mysqlnd 5.0.12-dev - 20150407 - $Id: 7cc7cc96e675f6d72e5cf0f267f48e167c2abb23 $) | pcntl (7.3.23) | mysqli (7.3.23) | PDO (7.3.23) | pdo_mysql (7.3.23) | pdo_sqlite (7.3.23) | pgsql (7.3.23) | Phar (7.3.23) | posix (7.3.23) | Reflection (7.3.23) | imap (7.3.23) | SimpleXML (7.3.23) | soap (7.3.23) | exif (7.3.23) | tokenizer (7.3.23) | wddx (7.3.23) | xml (7.3.23) | xmlreader (7.3.23) | xmlwriter (7.3.23) | xsl (7.3.23) | zip (1.15.4) | cgi-fcgi () | ionCube Loader () | Zend Engine (3.3.23) |
Potential Missing Extensions ::

Switch User Environment :: PHP CGI: Yes | Server SU: Yes | PHP SU: Yes | Potential Ownership Issues: No
Folder Permissions :: wrote:Core Folders :: images/ (755) | components/ (710) | modules/ (710) | plugins/ (710) | language/ (710) | templates/ (710) | cache/ (710) | logs/ (710) | tmp/ (710) | administrator/components/ (710) | administrator/modules/ (710) | administrator/language/ (710) | administrator/templates/ (710) | administrator/logs/ (---) |

Elevated Permissions (First 10) ::
Extensions Discovered :: wrote:Components :: Site ::
Core :: com_wrapper (3.0.0) ? | com_mailto (3.0.0) ? |
3rd Party::

Components :: Admin ::
Core :: com_config (3.0.0) ? | com_templates (3.0.0) ? | com_banners (3.0.0) ? | com_content (3.0.0) ? | com_checkin (3.0.0) ? | com_installer (3.0.0) ? | com_contenthistory (3.2.0) ? | com_actionlogs (3.9.0) ? | com_tags (3.1.0) ? | com_fields (3.7.0) ? | com_newsfeeds (3.0.0) ? | com_messages (3.0.0) ? | com_users (3.0.0) ? | com_menus (3.0.0) ? | com_cpanel (3.0.0) ? | com_cache (3.0.0) ? | com_finder (3.0.0) ? | com_media (3.0.0) ? | com_plugins (3.0.0) ? | com_associations (3.7.0) ? | com_privacy (3.9.0) ? | com_search (3.0.0) ? | com_admin (3.0.0) ? | com_ajax (3.2.0) ? | com_joomlaupdate (3.6.2) ? | com_modules (3.0.0) ? | com_redirect (3.0.0) ? | com_categories (3.0.0) ? | com_postinstall (3.2.0) ? | com_languages (3.0.0) ? | com_login (3.0.0) ? | com_weblinks (3.6.0) ? |
3rd Party:: com_xmap (2.3.4) ? |

Modules :: Site ::
Core :: mod_articles_archive (3.0.0) ? | mod_random_image (3.0.0) ? | mod_stats (3.0.0) ? | mod_feed (3.0.0) ? | mod_articles_categories (3.0.0) ? | mod_related_items (3.0.0) ? | mod_footer (3.0.0) ? | mod_breadcrumbs (3.0.0) ? | mod_menu (3.0.0) ? | mod_whosonline (3.0.0) ? | mod_tags_popular (3.1.0) ? | mod_search (3.0.0) ? | mod_custom (3.0.0) ? | mod_articles_popular (3.0.0) ? | mod_articles_category (3.0.0) ? | mod_syndicate (3.0.0) ? | mod_articles_latest (3.0.0) ? | mod_languages (3.5.0) ? | mod_wrapper (3.0.0) ? | mod_users_latest (3.0.0) ? | mod_articles_news (3.0.0) ? | mod_finder (3.0.0) ? | mod_tags_similar (3.1.0) ? | mod_weblinks (3.6.0) ? | mod_banners (3.0.0) ? | mod_login (3.0.0) ? |
3rd Party::

Modules :: Admin ::
Core :: mod_version (3.0.0) ? | mod_logged (3.0.0) ? | mod_feed (3.0.0) ? | mod_sampledata (3.8.0) ? | mod_status (3.0.0) ? | mod_privacy_dashboard (3.9.0) ? | mod_menu (3.0.0) ? | mod_custom (3.0.0) ? | mod_stats_admin (3.0.0) ? | mod_latestactions (3.9.0) ? | mod_latest (3.0.0) ? | mod_quickicon (3.0.0) ? | mod_toolbar (3.0.0) ? | mod_multilangstatus (3.0.0) ? | mod_title (3.0.0) ? | mod_popular (3.0.0) ? | mod_submenu (3.0.0) ? | mod_login (3.0.0) ? |
3rd Party::

Libraries ::
Core ::
3rd Party::

Plugins ::
Core :: PLG_INSTALLER_FOLDERINSTALLER (3.6.0) ? | plg_installer_packageinstaller (3.6.0) ? | PLG_INSTALLER_URLINSTALLER (3.6.0) ? | plg_system_languagefilter (3.0.0) ? | plg_system_cache (3.0.0) ? | plg_system_languagecode (3.0.0) ? | plg_system_updatenotification (3.5.0) ? | plg_system_logrotation (3.9.0) ? | plg_system_sef (3.0.0) ? | plg_system_sessiongc (3.8.6) ? | plg_system_log (3.0.0) ? | plg_system_p3p (3.0.0) ? | plg_system_stats (3.5.0) ? | plg_system_debug (3.0.0) ? | plg_system_privacyconsent (3.9.0) ? | plg_system_redirect (3.0.0) ? | plg_system_logout (3.0.0) ? | plg_system_remember (3.0.0) ? | plg_system_fields (3.7.0) ? | PLG_SYSTEM_ACTIONLOGS (3.9.0) ? | plg_system_highlight (3.0.0) ? | plg_user_profile (3.0.0) ? | plg_user_joomla (3.0.0) ? | plg_user_terms (3.9.0) ? | plg_user_contactcreator (3.0.0) ? | PLG_ACTIONLOG_JOOMLA (3.9.0) ? | plg_authentication_joomla (3.0.0) ? | plg_authentication_cookie (3.0.0) ? | plg_authentication_gmail (3.0.0) ? | plg_authentication_ldap (3.0.0) ? | plg_captcha_recaptcha (3.4.0) ? | plg_captcha_recaptcha_invisible (3.8) ? | plg_search_newsfeeds (3.0.0) ? | plg_search_categories (3.0.0) ? | plg_search_tags (3.0.0) ? | plg_search_content (3.0.0) ? | plg_search_contacts (3.0.0) ? | plg_search_weblinks (3.6.0) ? | plg_content_pagenavigation (3.0.0) ? | plg_content_joomla (3.0.0) ? | plg_content_confirmconsent (3.9.0) ? | plg_content_pagebreak (3.0.0) ? | plg_content_vote (3.0.0) ? | plg_content_emailcloak (3.0.0) ? | plg_content_fields (3.7.0) ? | plg_content_finder (3.0.0) ? | plg_content_loadmodule (3.0.0) ? | plg_editors-xtd_readmore (3.0.0) ? | plg_editors-xtd_pagebreak (3.0.0) ? | plg_editors-xtd_image (3.0.0) ? | plg_editors-xtd_menu (3.7.0) ? | plg_editors-xtd_module (3.5.0) ? | plg_editors-xtd_fields (3.7.0) ? | plg_editors-xtd_article (3.0.0) ? | plg_extension_joomla (3.0.0) ? | plg_quickicon_joomlaupdate (3.0.0) ? | plg_quickicon_phpversioncheck (3.7.0) ? | plg_quickicon_privacycheck (3.9.0) ? | plg_quickicon_extensionupdate (3.0.0) ? | plg_fields_imagelist (3.7.0) ? | plg_fields_textarea (3.7.0) ? | plg_fields_radio (3.7.0) ? | plg_fields_color (3.7.0) ? | plg_fields_integer (3.7.0) ? | plg_fields_user (3.7.0) ? | plg_fields_checkboxes (3.7.0) ? | plg_fields_list (3.7.0) ? | plg_fields_calendar (3.7.0) ? | plg_fields_repeatable (3.9.0) ? | plg_fields_media (3.7.0) ? | plg_fields_text (3.7.0) ? | plg_fields_editor (3.7.0) ? | plg_fields_usergrouplist (3.7.0) ? | plg_fields_url (3.7.0) ? | plg_fields_sql (3.7.0) ? | plg_finder_newsfeeds (3.0.0) ? | plg_finder_categories (3.0.0) ? | plg_finder_tags (3.0.0) ? | plg_finder_content (3.0.0) ? | plg_finder_contacts (3.0.0) ? | plg_finder_weblinks (3.6.0) ? | plg_twofactorauth_totp (3.2.0) ? | plg_twofactorauth_yubikey (3.2.0) ? | plg_privacy_consents (3.9.0) ? | plg_privacy_user (3.9.0) ? | plg_privacy_content (3.9.0) ? | plg_privacy_message (3.9.0) ? | plg_privacy_actionlogs (3.9.0) ? |
3rd Party:: plg_editors_codemirror (5.40.0) ? | plg_editors_tinymce (4.5.11) ? | Xmap - Content Plugin (2.0.4) ? | Xmap - Virtuemart Plugin (2.0.3) ? | Xmap - SobiPro Plugin (2.0.2) ? | XMAP_PLUGIN_K2 (1.3) ? | Xmap - Mosets Tree Plugin (2.0.2) ? | Xmap - Kunena Plugin (3.0.0) ? | Xmap - WebLinks Plugin (2.0.1) ? |
Templates Discovered :: wrote:Templates :: Site :: protostar (1.0) ? | ALLROUNDER-3 (1.1) ? | beez3 (3.1.0) ? |
Templates :: Admin :: isis (1.0) ? | hathor (3.0.0) ? |
Last edited by toivo on Tue May 11, 2021 1:36 pm, edited 1 time in total.
Reason: mod note: removed CODE tags, disabled smilies

User avatar
AMurray
Joomla! Champion
Joomla! Champion
Posts: 6876
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Backend admin login leading to 404 error page

Post by AMurray » Tue May 11, 2021 10:21 pm

Thanks for posting the report; from the FPA, I can observe several things, that need attention, but at this point I don't know if these will help resolve the 404 error.

* Joomla is out of date - 3.9.18 vs current version 3.9.26. Put that aside for the moment. There are other configuration issues you should be able to to fix with help from your web host:
dbConnection Type: mysql | PHP Supports J! 3.9.18: Yes | Database Supports J! 3.9.18: Unknown
The dbConnection Type should be mysqli. This may need to be enabled by your web host for the specific PHP version you're using.
Max. Upload Size: 8M | Max. POST Size: 8M | Max. Input Time: -1 | Max. Execution Time: 300 | Memory Limit: 100M
With assistance from your web host (or you may be able to adjust these values through your web hosting admin utility), you should increase the max upload size and max post size from 8M to at least 30M (left at the values they are will likely cause issues with any future CMS updates or extension installations).

I can't identify any backup component being used, are you able to restore the site to a point you know it was working correctly? The backup could possibly be restored from your web hosting admin area (cPanel or equivalent) or your web host can assist with this.

If https://subdomain.mysite.com points to https://mysite.com/joomla, can you try the URL https://mysite.com/joomla/administrator (without using the sub-domain)?
Regards - A Murray

User avatar
abernyte
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4003
Joined: Fri May 15, 2009 2:01 pm
Location: Écosse - Scozia - Escocia - Škotija -स्कॉटलैंड

Re: Backend admin login leading to 404 error page

Post by abernyte » Wed May 12, 2021 8:43 am

This might be one of the rare occasions when the live site variable is required.
Access configuration.php in the root of your site and edit

Code: Select all

public $live_site = '';
to include subdomain.mysite.com between the quotation marks and see if access is possible.
What we obtain too cheap, we esteem too lightly…Thomas Paine

sino27
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Mon May 10, 2021 7:49 am

Re: Backend admin login leading to 404 error page

Post by sino27 » Wed May 12, 2021 11:33 am

Thanks guys I really appreciate it. This is just a quick reply. I just wanted to express my gratitude for your time.

I'll try some of your tips later tonight when I reach my personal computer from which I can access Joomla.

sino27
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Mon May 10, 2021 7:49 am

Re: Backend admin login leading to 404 error page

Post by sino27 » Wed May 12, 2021 11:52 am

abernyte wrote:
Wed May 12, 2021 8:43 am
This might be one of the rare occasions when the live site variable is required.
Access configuration.php in the root of your site and edit

Code: Select all

public $live_site = '';
to include subdomain.mysite.com between the quotation marks and see if access is possible.
Found access to Joomla on my email and I just tried your suggestion. I added "subodmain.mydomain.com" between quotation marks (I mean I added my real subdomain and domain inside public $live_site = ''; ) - and this is now working. I can access admin panel however another issue appeared.

As soon as I add my value - Administrator is working but my site appear as broken. It's hard to explain, like all the data is there it's just that Menu is huge span across two pages, images are one below another, it's like whole structure is broken.

Is there anything else I should add?

User avatar
abernyte
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4003
Joined: Fri May 15, 2009 2:01 pm
Location: Écosse - Scozia - Escocia - Škotija -स्कॉटलैंड

Re: Backend admin login leading to 404 error page

Post by abernyte » Wed May 12, 2021 2:12 pm

Try switching off SEF urls and rename .htaccess to htaccess.txt also sort out your permissions. Directories 755 and files 644.
What we obtain too cheap, we esteem too lightly…Thomas Paine

sino27
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Mon May 10, 2021 7:49 am

Re: Backend admin login leading to 404 error page

Post by sino27 » Tue May 18, 2021 5:51 pm

Hi guys. I just wanted to report that I am running fine now. To be honest I don't know what fixed it. When I added my new path to:
public $live_site = '';
I was able to login to admin but front end was messed up. Then I simply logged out, removed my path from:
public $live_site = '';
to return fronted back again to normal.

And frontend was fixed. But for some reason I can now access administrator even though I didn't do anything else or saved anything in the backend. Nor did I deleted or renamed .htaccess.

It acts as if I only needed to login to admin once and it fixed itself.

So now administrator is working. Just in case I did turn off SEF today.

So thanks for your help from the bottom of my heart.


Post Reply

Return to “Administration Joomla! 3.x”