FPA auto delete Topic is solved

This Forum board is about discussions about the FPA tool.

Moderator: General Support Moderators

Post Reply
Pierre_
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Wed Sep 18, 2019 12:42 am

FPA auto delete

Post by Pierre_ » Mon May 30, 2022 11:56 am

Hi,

I have a problem with running the fpa-en.php file. On each attempt I get the page with the message 'As a security measure, this copy of FPA has been self-deleted due to the time it has been present on the server.' In the instructions it says 'WinSCP Users - uncheck/disable "Preserve Timestamp" in the session options to avoid auto-delete issues.'. Where do you find this option?

My site is installed on a Linux system (Ubuntu).

SELF SOLVED

I noticed that the fpa-en.php file was dated January 2022 when checked out and that this date was preserved when checked out and then copied to my site. The self-destruct routine seems to rely on this date! To thwart the auto-destruction routine, I simply wrote a change in the file (modify a comment by adding a single character) and thus force the current date as the update date of the fpa-en.php file. .

Pierre
Last edited by toivo on Mon May 30, 2022 12:30 pm, edited 1 time in total.
Reason: mod note: moved from 4.x Migrating and Upgrading

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 29301
Joined: Mon Oct 27, 2008 9:27 pm
Location: Romerike, Norway

Re: FPA auto delete

Post by Per Yngve Berg » Mon May 30, 2022 12:34 pm

The option is in your FTP Client. Never had that problem with Filezilla.

Pierre_
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Wed Sep 18, 2019 12:42 am

Re: FPA auto delete

Post by Pierre_ » Mon May 30, 2022 5:24 pm

I am using Dolphin (Kubuntu) with a network shortcut in sftp mode. That works well. The problem is that by unzipping the file, the original dates in the zipped file (here January 18, 2022) are preserved in Dolphin as well as on transfer (still with Dolphin). My solution from my original post is a bit complicated. I just saw that opening and saving the file updated the date to "At the moment".

I am not a Filezila user. So, I just installed it and configured it for an sftp connection with my server. I found the "Preserve Timestamp" option. By keeping it unchecked, the current date is automatically registered on the server.

Conclusion: I will use Filezila next time!

Thanks.

Rock


Post Reply

Return to “Forum Post Assistant (FPA)”